source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 6953

Revision 6953, 9.7 KB checked in by iwamoto, 12 years ago (diff)

update: zlib, libpng, xz, proftpd

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.7
6Release: 1%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.bz2
9# Patch0: zlib-1.2.5-lfs-decls.patch
10
11Requires(post): /sbin/ldconfig
12Requires(postun): /sbin/ldconfig
13
14URL: http://www.zlib.net/
15License: zlib and Boost
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18%description
19The zlib compression library provides in-memory compression and
20decompression functions, including integrity checks of the
21uncompressed data.  This version of the library supports only one
22compression method (deflation), but other algorithms may be added
23later, which will have the same stream interface.  The zlib library is
24used by many different system programs.
25
26%description -l ja
27zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
28のデータの整合性チェックを行う関数を提供します。今バージョンのラ
29イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
30ートしていますが、今後同じストリームインターフェースを持つ他の圧
31縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
32用されています。
33
34%package devel
35Summary: Header files and libraries for developing apps which will use zlib.
36Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
37Group: Development/Libraries
38Requires: %{name} = %{version}-%{release}
39
40%description devel
41The zlib-devel package contains the header files and libraries needed
42to develop programs that use the zlib compression and decompression
43library.
44
45%package static
46Summary: Static libraries for  %{name}
47Summary(ja): %{name} のスタティックライブラリ
48Group: Development/Libraries
49Requires: %{name}-devel = %{version}-%{release}
50
51%description static
52The zlib-static package contains the static library for %{name}
53
54## to build compat32 for x86_64 architecture support
55%package -n compat32-%{name}
56Summary: The zlib compression and decompression library.
57Summary(ja): zlib 圧縮/展開ライブラリ
58Group: System Environment/Libraries
59Requires: %{name} = %{version}-%{release}
60Requires(post): /sbin/ldconfig
61Requires(postun): /sbin/ldconfig
62
63%description -n compat32-%{name}
64The zlib compression library provides in-memory compression and
65decompression functions, including integrity checks of the
66uncompressed data.  This version of the library supports only one
67compression method (deflation), but other algorithms may be added
68later, which will have the same stream interface.  The zlib library is
69used by many different system programs.
70
71%description -n compat32-%{name} -l ja
72zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
73のデータの整合性チェックを行う関数を提供します。今バージョンのラ
74イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
75ートしていますが、今後同じストリームインターフェースを持つ他の圧
76縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
77用されています。
78
79%package -n compat32-%{name}-devel
80Summary: Header files and libraries for developing apps which will use zlib.
81Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
82Group: Development/Libraries
83Requires: %{name} = %{version}-%{release}
84Requires: %{name}-devel = %{version}-%{release}
85
86%description -n compat32-%{name}-devel
87The zlib-devel package contains the header files and libraries needed
88to develop programs that use the zlib compression and decompression
89library.
90
91Install the zlib-devel package if you want to develop applications that
92will use the zlib library.
93
94
95%prep
96%setup -q
97# %patch0 -p1
98
99%build
100mkdir static shared
101
102# build shared lib
103CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
104
105make %{?_smp_mflags}
106mv -f Makefile zconf.h *.o *.so* shared/
107
108# build static lib
109CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
110make %{?_smp_mflags}
111mv -f Makefile zconf.h *.o *.a static/
112
113
114%install
115rm -rf ${RPM_BUILD_ROOT}
116mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
117
118mv -f shared/* .
119make install prefix=${RPM_BUILD_ROOT}%{_prefix}
120
121mv -f Makefile zconf.h *.o *.so* shared/
122mv -f static/* .
123make install prefix=${RPM_BUILD_ROOT}%{_prefix}
124
125install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
126mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
127install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
128
129if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
130    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
131    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
132    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
133fi
134
135%clean
136rm -rf ${RPM_BUILD_ROOT}
137
138%post -p /sbin/ldconfig
139
140%postun -p /sbin/ldconfig
141
142%post -n compat32-%{name} -p /sbin/ldconfig
143
144%postun -n compat32-%{name} -p /sbin/ldconfig
145
146%files
147%defattr(-,root,root)
148%doc README
149%{_libdir}/libz.so.*
150
151%files devel
152%defattr(-,root,root)
153%doc ChangeLog doc/algorithm.txt minigzip.c example.c
154%{_libdir}/*.so
155%{_libdir}/pkgconfig/zlib.pc
156%{_includedir}/*
157%{_mandir}/man3/zlib.3*
158
159%files static
160%defattr(-,root,root)
161%{_libdir}/*.a
162
163%if %{build_compat32}
164%files -n compat32-%{name}
165%defattr(-,root,root)
166%{_libdir}/libz.so.*
167
168%files -n compat32-%{name}-devel
169%defattr(-,root,root)
170%{_libdir}/*.so
171%{_libdir}/pkgconfig/zlib.pc
172%endif
173
174%changelog
175* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
176- new upstream release
177- drop patch0 (resolved by upstream)
178- use smp flag in make section
179
180* Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
181- added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
182
183* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
184- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
185- changed License: BSD to zlib and Boost
186- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
187- fixed %%doc files in -devel package
188
189* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
190- add Requires(post,pre): /sbin/ldconfig
191
192* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
193- rebuilt with gcc-4.4.3-3 on ppc
194
195* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
196- rebuilt with new toolchain
197
198* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
199- split static library to zlib-static
200  - needed by tuxonice-userui
201
202* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
203- change spec into UTF-8
204
205* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
206- removed %%if !%%{build_compat32} case condition
207
208* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
209- applied new versioning policy
210- rebuilt with new toolchains
211
212* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
213- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
214
215* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
216- added compat32-* packages for x86_64 architecture support
217
218* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
219- added compat32- packages for x86_64 architecture support
220
221* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
222- clean up specfile (do not build twice..)
223
224* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
225- new upstream release
226
227* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
228- new upstream release
229- add Patch1 for CAN-2005-2096
230
231* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
232- new upstream version
233- add translated descriptions (thanks to spec file translation project)
234
235* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
236- fixed buffer overrun on gzprintf
237        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
238
239* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
240- changed URL to more preferable site
241
242* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
243- upstream release
244
245* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
246- 1.1.3-14vl1
247- based on 1.1.3-14 from Rawhide
248- added Japanese summary
249
250* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
251- add -fPIC for shared libs (patch by Fritz Elfert)
252
253* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
254- on 64bit systems, make sure libraries are located correctly.
255
256* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
257- summaries from specspo.
258
259* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
260- automatic rebuild
261
262* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
263- rebuild
264
265* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
266- FHS packaging to build on solaris2.5.1.
267
268* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
269- use %%{_mandir} and %%{_tmppath}
270
271* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
272- updated URL and source location
273- moved README to main package
274
275* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
276- compress man page.
277
278* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
279- auto rebuild in the new build environment (release 5)
280
281* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
282- link against glibc
283
284* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
285- upgrade to 1.1.3
286
287* Fri May 08 1998 Prospector System <bugs@redhat.com>
288- translations modified for de, fr, tr
289
290* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
291- upgraded to 1.1.2
292- buildroot
293
294* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
295- added URL tag (down at the moment so it may not be correct)
296- made zlib-devel require zlib
297
298* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
299- built against glibc
Note: See TracBrowser for help on using the repository browser.