source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 521

Revision 521, 8.9 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.3
6Release: 7%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.bz2
9
10Requires(post): /sbin/ldconfig
11Requires(postun): /sbin/ldconfig
12
13URL: http://www.zlib.net/
14License: BSD
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17%description
18The zlib compression library provides in-memory compression and
19decompression functions, including integrity checks of the
20uncompressed data.  This version of the library supports only one
21compression method (deflation), but other algorithms may be added
22later, which will have the same stream interface.  The zlib library is
23used by many different system programs.
24
25%description -l ja
26zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
27のデータの整合性チェックを行う関数を提供します。今バージョンのラ
28イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
29ートしていますが、今後同じストリームインターフェースを持つ他の圧
30縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
31用されています。
32
33%package devel
34Summary: Header files and libraries for developing apps which will use zlib.
35Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The zlib-devel package contains the header files and libraries needed
41to develop programs that use the zlib compression and decompression
42library.
43
44%package static
45Summary: Static libraries for  %{name}
46Summary(ja): %{name} のスタティックライブラリ
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description static
51The zlib-static package contains the static library for %{name}
52
53## to build compat32 for x86_64 architecture support
54%package -n compat32-%{name}
55Summary: The zlib compression and decompression library.
56Summary(ja): zlib 圧縮/展開ライブラリ
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires(post): /sbin/ldconfig
60Requires(postun): /sbin/ldconfig
61
62%description -n compat32-%{name}
63The zlib compression library provides in-memory compression and
64decompression functions, including integrity checks of the
65uncompressed data.  This version of the library supports only one
66compression method (deflation), but other algorithms may be added
67later, which will have the same stream interface.  The zlib library is
68used by many different system programs.
69
70%description -n compat32-%{name} -l ja
71zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
72のデータの整合性チェックを行う関数を提供します。今バージョンのラ
73イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
74ートしていますが、今後同じストリームインターフェースを持つ他の圧
75縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
76用されています。
77
78%package -n compat32-%{name}-devel
79Summary: Header files and libraries for developing apps which will use zlib.
80Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83Requires: %{name}-devel = %{version}-%{release}
84
85%description -n compat32-%{name}-devel
86The zlib-devel package contains the header files and libraries needed
87to develop programs that use the zlib compression and decompression
88library.
89
90Install the zlib-devel package if you want to develop applications that
91will use the zlib library.
92
93
94%prep
95%setup -q
96
97%build
98mkdir static shared
99
100# build shared lib
101CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
102
103make
104mv -f Makefile zconf.h *.o *.so* shared/
105
106# build static lib
107CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
108make
109mv -f Makefile zconf.h *.o *.a static/
110
111
112%install
113rm -rf ${RPM_BUILD_ROOT}
114mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
115
116mv -f shared/* .
117make install prefix=${RPM_BUILD_ROOT}%{_prefix}
118
119mv -f Makefile zconf.h *.o *.so* shared/
120mv -f static/* .
121make install prefix=${RPM_BUILD_ROOT}%{_prefix}
122
123install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
124mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
125install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
126
127if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
128    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
129    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
130    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
131fi
132
133%clean
134rm -rf ${RPM_BUILD_ROOT}
135
136%post -p /sbin/ldconfig
137
138%postun -p /sbin/ldconfig
139
140%post -n compat32-%{name} -p /sbin/ldconfig
141
142%postun -n compat32-%{name} -p /sbin/ldconfig
143
144%files
145%defattr(-,root,root)
146%doc README
147%{_libdir}/libz.so.*
148
149%files devel
150%defattr(-,root,root)
151%doc ChangeLog algorithm.txt minigzip.c example.c
152%{_libdir}/*.so
153%{_includedir}/*
154%{_mandir}/man3/zlib.3*
155
156%files static
157%defattr(-,root,root)
158%{_libdir}/*.a
159
160%if %{build_compat32}
161%files -n compat32-%{name}
162%defattr(-,root,root)
163%{_libdir}/libz.so.*
164
165%files -n compat32-%{name}-devel
166%defattr(-,root,root)
167%{_libdir}/*.so
168%endif
169
170%changelog
171* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
172- add Requires(post,pre): /sbin/ldconfig
173
174* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
175- rebuilt with gcc-4.4.3-3 on ppc
176
177* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
178- rebuilt with new toolchain
179
180* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
181- split static library to zlib-static
182  - needed by tuxonice-userui
183
184* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
185- change spec into UTF-8
186
187* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
188- removed %%if !%%{build_compat32} case condition
189
190* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
191- applied new versioning policy
192- rebuilt with new toolchains
193
194* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
195- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
196
197* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
198- added compat32-* packages for x86_64 architecture support
199
200* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
201- added compat32- packages for x86_64 architecture support
202
203* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
204- clean up specfile (do not build twice..)
205
206* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
207- new upstream release
208
209* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
210- new upstream release
211- add Patch1 for CAN-2005-2096
212
213* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
214- new upstream version
215- add translated descriptions (thanks to spec file translation project)
216
217* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
218- fixed buffer overrun on gzprintf
219        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
220
221* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
222- changed URL to more preferable site
223
224* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
225- upstream release
226
227* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
228- 1.1.3-14vl1
229- based on 1.1.3-14 from Rawhide
230- added Japanese summary
231
232* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
233- add -fPIC for shared libs (patch by Fritz Elfert)
234
235* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
236- on 64bit systems, make sure libraries are located correctly.
237
238* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
239- summaries from specspo.
240
241* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
242- automatic rebuild
243
244* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
245- rebuild
246
247* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
248- FHS packaging to build on solaris2.5.1.
249
250* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
251- use %%{_mandir} and %%{_tmppath}
252
253* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
254- updated URL and source location
255- moved README to main package
256
257* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
258- compress man page.
259
260* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
261- auto rebuild in the new build environment (release 5)
262
263* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
264- link against glibc
265
266* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
267- upgrade to 1.1.3
268
269* Fri May 08 1998 Prospector System <bugs@redhat.com>
270- translations modified for de, fr, tr
271
272* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
273- upgraded to 1.1.2
274- buildroot
275
276* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
277- added URL tag (down at the moment so it may not be correct)
278- made zlib-devel require zlib
279
280* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
281- built against glibc
Note: See TracBrowser for help on using the repository browser.