source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 1868

Revision 1868, 9.3 KB checked in by kudoh, 14 years ago (diff)
Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.5
6Release: 1%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.bz2
9
10Requires(post): /sbin/ldconfig
11Requires(postun): /sbin/ldconfig
12
13URL: http://www.zlib.net/
14License: zlib and Boost
15BuildRoot: %{_tmppath}/%{name}-%{version}-root
16
17%description
18The zlib compression library provides in-memory compression and
19decompression functions, including integrity checks of the
20uncompressed data.  This version of the library supports only one
21compression method (deflation), but other algorithms may be added
22later, which will have the same stream interface.  The zlib library is
23used by many different system programs.
24
25%description -l ja
26zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
27のデータの整合性チェックを行う関数を提供します。今バージョンのラ
28イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
29ートしていますが、今後同じストリームインターフェースを持つ他の圧
30縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
31用されています。
32
33%package devel
34Summary: Header files and libraries for developing apps which will use zlib.
35Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
36Group: Development/Libraries
37Requires: %{name} = %{version}-%{release}
38
39%description devel
40The zlib-devel package contains the header files and libraries needed
41to develop programs that use the zlib compression and decompression
42library.
43
44%package static
45Summary: Static libraries for  %{name}
46Summary(ja): %{name} のスタティックライブラリ
47Group: Development/Libraries
48Requires: %{name}-devel = %{version}-%{release}
49
50%description static
51The zlib-static package contains the static library for %{name}
52
53## to build compat32 for x86_64 architecture support
54%package -n compat32-%{name}
55Summary: The zlib compression and decompression library.
56Summary(ja): zlib 圧縮/展開ライブラリ
57Group: System Environment/Libraries
58Requires: %{name} = %{version}-%{release}
59Requires(post): /sbin/ldconfig
60Requires(postun): /sbin/ldconfig
61
62%description -n compat32-%{name}
63The zlib compression library provides in-memory compression and
64decompression functions, including integrity checks of the
65uncompressed data.  This version of the library supports only one
66compression method (deflation), but other algorithms may be added
67later, which will have the same stream interface.  The zlib library is
68used by many different system programs.
69
70%description -n compat32-%{name} -l ja
71zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
72のデータの整合性チェックを行う関数を提供します。今バージョンのラ
73イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
74ートしていますが、今後同じストリームインターフェースを持つ他の圧
75縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
76用されています。
77
78%package -n compat32-%{name}-devel
79Summary: Header files and libraries for developing apps which will use zlib.
80Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
81Group: Development/Libraries
82Requires: %{name} = %{version}-%{release}
83Requires: %{name}-devel = %{version}-%{release}
84
85%description -n compat32-%{name}-devel
86The zlib-devel package contains the header files and libraries needed
87to develop programs that use the zlib compression and decompression
88library.
89
90Install the zlib-devel package if you want to develop applications that
91will use the zlib library.
92
93
94%prep
95%setup -q
96
97%build
98mkdir static shared
99
100# build shared lib
101CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
102
103make
104mv -f Makefile zconf.h *.o *.so* shared/
105
106# build static lib
107CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
108make
109mv -f Makefile zconf.h *.o *.a static/
110
111
112%install
113rm -rf ${RPM_BUILD_ROOT}
114mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
115
116mv -f shared/* .
117make install prefix=${RPM_BUILD_ROOT}%{_prefix}
118
119mv -f Makefile zconf.h *.o *.so* shared/
120mv -f static/* .
121make install prefix=${RPM_BUILD_ROOT}%{_prefix}
122
123install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
124mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
125install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
126
127if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
128    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
129    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
130    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
131fi
132
133%clean
134rm -rf ${RPM_BUILD_ROOT}
135
136%post -p /sbin/ldconfig
137
138%postun -p /sbin/ldconfig
139
140%post -n compat32-%{name} -p /sbin/ldconfig
141
142%postun -n compat32-%{name} -p /sbin/ldconfig
143
144%files
145%defattr(-,root,root)
146%doc README
147%{_libdir}/libz.so.*
148
149%files devel
150%defattr(-,root,root)
151%doc ChangeLog doc/algorithm.txt minigzip.c example.c
152%{_libdir}/*.so
153%{_libdir}/pkgconfig/zlib.pc
154%{_includedir}/*
155%{_mandir}/man3/zlib.3*
156
157%files static
158%defattr(-,root,root)
159%{_libdir}/*.a
160
161%if %{build_compat32}
162%files -n compat32-%{name}
163%defattr(-,root,root)
164%{_libdir}/libz.so.*
165
166%files -n compat32-%{name}-devel
167%defattr(-,root,root)
168%{_libdir}/*.so
169%{_libdir}/pkgconfig/zlib.pc
170%endif
171
172%changelog
173* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
174- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
175- changed License: BSD to zlib and Boost
176- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
177- fixed %%doc files in -devel package
178
179* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
180- add Requires(post,pre): /sbin/ldconfig
181
182* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
183- rebuilt with gcc-4.4.3-3 on ppc
184
185* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
186- rebuilt with new toolchain
187
188* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
189- split static library to zlib-static
190  - needed by tuxonice-userui
191
192* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
193- change spec into UTF-8
194
195* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
196- removed %%if !%%{build_compat32} case condition
197
198* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
199- applied new versioning policy
200- rebuilt with new toolchains
201
202* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
203- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
204
205* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
206- added compat32-* packages for x86_64 architecture support
207
208* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
209- added compat32- packages for x86_64 architecture support
210
211* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
212- clean up specfile (do not build twice..)
213
214* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
215- new upstream release
216
217* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
218- new upstream release
219- add Patch1 for CAN-2005-2096
220
221* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
222- new upstream version
223- add translated descriptions (thanks to spec file translation project)
224
225* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
226- fixed buffer overrun on gzprintf
227        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
228
229* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
230- changed URL to more preferable site
231
232* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
233- upstream release
234
235* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
236- 1.1.3-14vl1
237- based on 1.1.3-14 from Rawhide
238- added Japanese summary
239
240* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
241- add -fPIC for shared libs (patch by Fritz Elfert)
242
243* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
244- on 64bit systems, make sure libraries are located correctly.
245
246* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
247- summaries from specspo.
248
249* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
250- automatic rebuild
251
252* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
253- rebuild
254
255* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
256- FHS packaging to build on solaris2.5.1.
257
258* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
259- use %%{_mandir} and %%{_tmppath}
260
261* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
262- updated URL and source location
263- moved README to main package
264
265* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
266- compress man page.
267
268* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
269- auto rebuild in the new build environment (release 5)
270
271* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
272- link against glibc
273
274* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
275- upgrade to 1.1.3
276
277* Fri May 08 1998 Prospector System <bugs@redhat.com>
278- translations modified for de, fr, tr
279
280* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
281- upgraded to 1.1.2
282- buildroot
283
284* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
285- added URL tag (down at the moment so it may not be correct)
286- made zlib-devel require zlib
287
288* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
289- built against glibc
Note: See TracBrowser for help on using the repository browser.