source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 12005

Revision 12005, 10.2 KB checked in by tomop, 5 years ago (diff)

Merge branch 'tomop'

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.11
6Release: 1%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.xz
9# Patch0: zlib-1.2.5-lfs-decls.patch
10
11Requires(post): /sbin/ldconfig
12Requires(postun): /sbin/ldconfig
13
14URL: http://www.zlib.net/
15License: zlib and Boost
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%description
22The zlib compression library provides in-memory compression and
23decompression functions, including integrity checks of the
24uncompressed data.  This version of the library supports only one
25compression method (deflation), but other algorithms may be added
26later, which will have the same stream interface.  The zlib library is
27used by many different system programs.
28
29%description -l ja
30zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
31のデータの整合性チェックを行う関数を提供します。今バージョンのラ
32イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
33ートしていますが、今後同じストリームインターフェースを持つ他の圧
34縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
35用されています。
36
37%package devel
38Summary: Header files and libraries for developing apps which will use zlib.
39Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
40Group: Development/Libraries
41Requires: %{name} = %{version}-%{release}
42
43%description devel
44The zlib-devel package contains the header files and libraries needed
45to develop programs that use the zlib compression and decompression
46library.
47
48%package static
49Summary: Static libraries for  %{name}
50Summary(ja): %{name} のスタティックライブラリ
51Group: Development/Libraries
52Requires: %{name}-devel = %{version}-%{release}
53
54%description static
55The zlib-static package contains the static library for %{name}
56
57## to build compat32 for x86_64 architecture support
58%package -n compat32-%{name}
59Summary: The zlib compression and decompression library.
60Summary(ja): zlib 圧縮/展開ライブラリ
61Group: System Environment/Libraries
62Requires: %{name} = %{version}-%{release}
63Requires(post): /sbin/ldconfig
64Requires(postun): /sbin/ldconfig
65
66%description -n compat32-%{name}
67The zlib compression library provides in-memory compression and
68decompression functions, including integrity checks of the
69uncompressed data.  This version of the library supports only one
70compression method (deflation), but other algorithms may be added
71later, which will have the same stream interface.  The zlib library is
72used by many different system programs.
73
74%description -n compat32-%{name} -l ja
75zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
76のデータの整合性チェックを行う関数を提供します。今バージョンのラ
77イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
78ートしていますが、今後同じストリームインターフェースを持つ他の圧
79縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
80用されています。
81
82%package -n compat32-%{name}-devel
83Summary: Header files and libraries for developing apps which will use zlib.
84Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
85Group: Development/Libraries
86Requires: %{name} = %{version}-%{release}
87Requires: %{name}-devel = %{version}-%{release}
88
89%description -n compat32-%{name}-devel
90The zlib-devel package contains the header files and libraries needed
91to develop programs that use the zlib compression and decompression
92library.
93
94Install the zlib-devel package if you want to develop applications that
95will use the zlib library.
96
97
98%prep
99%setup -q
100# %patch0 -p1
101
102%build
103mkdir static shared
104
105# build shared lib
106CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
107
108make %{?_smp_mflags}
109mv -f Makefile zconf.h *.o *.so* shared/
110
111# build static lib
112CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
113make %{?_smp_mflags}
114mv -f Makefile zconf.h *.o *.a static/
115
116
117%install
118rm -rf ${RPM_BUILD_ROOT}
119mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
120
121mv -f shared/* .
122make install prefix=${RPM_BUILD_ROOT}%{_prefix}
123
124mv -f Makefile zconf.h *.o *.so* shared/
125mv -f static/* .
126make install prefix=${RPM_BUILD_ROOT}%{_prefix}
127
128install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
129mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
130install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
131
132if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
133    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
134    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
135    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
136fi
137
138cat %{buildroot}/usr/include/zlib.h | sed -n '1,/*\//p' > LICENSE
139
140%clean
141rm -rf ${RPM_BUILD_ROOT}
142
143%post -p /sbin/ldconfig
144
145%postun -p /sbin/ldconfig
146
147%post -n compat32-%{name} -p /sbin/ldconfig
148
149%postun -n compat32-%{name} -p /sbin/ldconfig
150
151%files
152%defattr(-,root,root)
153%license LICENSE
154%doc README
155%{_libdir}/*.so
156%{_libdir}/libz.so.*
157
158%files devel
159%defattr(-,root,root)
160%doc ChangeLog doc/algorithm.txt
161%{_libdir}/pkgconfig/zlib.pc
162%{_includedir}/*
163%{_mandir}/man3/zlib.3*
164
165%files static
166%defattr(-,root,root)
167%{_libdir}/*.a
168
169%if %{build_compat32}
170%files -n compat32-%{name}
171%defattr(-,root,root)
172%{_libdir}/libz.so.*
173
174%files -n compat32-%{name}-devel
175%defattr(-,root,root)
176%{_libdir}/*.so
177%{_libdir}/pkgconfig/zlib.pc
178%endif
179
180%changelog
181* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-1
182- new upstream release.
183- added license text.
184- reverted moving libz.so for compat32 package.
185
186* Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
187- moved libz.so into the main package.
188
189* Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
190- new upstream release
191- changed archive type bz2 to xz
192
193* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
194- new upstream release
195- drop patch0 (resolved by upstream)
196- use smp flag in make section
197
198* Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
199- added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
200
201* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
202- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
203- changed License: BSD to zlib and Boost
204- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
205- fixed %%doc files in -devel package
206
207* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
208- add Requires(post,pre): /sbin/ldconfig
209
210* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
211- rebuilt with gcc-4.4.3-3 on ppc
212
213* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
214- rebuilt with new toolchain
215
216* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
217- split static library to zlib-static
218  - needed by tuxonice-userui
219
220* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
221- change spec into UTF-8
222
223* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
224- removed %%if !%%{build_compat32} case condition
225
226* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
227- applied new versioning policy
228- rebuilt with new toolchains
229
230* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
231- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
232
233* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
234- added compat32-* packages for x86_64 architecture support
235
236* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
237- added compat32- packages for x86_64 architecture support
238
239* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
240- clean up specfile (do not build twice..)
241
242* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
243- new upstream release
244
245* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
246- new upstream release
247- add Patch1 for CAN-2005-2096
248
249* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
250- new upstream version
251- add translated descriptions (thanks to spec file translation project)
252
253* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
254- fixed buffer overrun on gzprintf
255        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
256
257* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
258- changed URL to more preferable site
259
260* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
261- upstream release
262
263* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
264- 1.1.3-14vl1
265- based on 1.1.3-14 from Rawhide
266- added Japanese summary
267
268* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
269- add -fPIC for shared libs (patch by Fritz Elfert)
270
271* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
272- on 64bit systems, make sure libraries are located correctly.
273
274* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
275- summaries from specspo.
276
277* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
278- automatic rebuild
279
280* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
281- rebuild
282
283* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
284- FHS packaging to build on solaris2.5.1.
285
286* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
287- use %%{_mandir} and %%{_tmppath}
288
289* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
290- updated URL and source location
291- moved README to main package
292
293* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
294- compress man page.
295
296* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
297- auto rebuild in the new build environment (release 5)
298
299* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
300- link against glibc
301
302* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
303- upgrade to 1.1.3
304
305* Fri May 08 1998 Prospector System <bugs@redhat.com>
306- translations modified for de, fr, tr
307
308* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
309- upgraded to 1.1.2
310- buildroot
311
312* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
313- added URL tag (down at the moment so it may not be correct)
314- made zlib-devel require zlib
315
316* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
317- built against glibc
Note: See TracBrowser for help on using the repository browser.