source: projects/specs/trunk/z/zlib/zlib-vl.spec @ 12346

Revision 12346, 10.4 KB checked in by tomop, 4 years ago (diff)

updated 14 packages

ca-certificates-2020.2.40-1

dmidecode-3.2-1

dnsmasq-2.80-2

golang-1.14.1-1

gthumb-3.8.3-1

haveged-1.9.8-1

iw-5.4-1

liblockfile-1.14-6

libnl3-3.5.0-1

libvisio-0.1.7-2

mailx-8.1.2.20180807-1

strace-5.5-1

tzdata-2019c-1

zlib-1.2.11-2

Line 
1%define build_compat32 %{?_with_compat32:1}%{!?_with_compat32:0}
2Summary: The zlib compression and decompression library.
3Summary(ja): zlib 圧縮/展開ライブラリ
4Name: zlib
5Version: 1.2.11
6Release: 2%{?_dist_release}
7Group: System Environment/Libraries
8Source: http://www.zlib.net/zlib-%{version}.tar.xz
9# Patch0: zlib-1.2.5-lfs-decls.patch
10
11Requires(post): /sbin/ldconfig
12Requires(postun): /sbin/ldconfig
13
14URL: http://www.zlib.net/
15License: zlib and Boost
16BuildRoot: %{_tmppath}/%{name}-%{version}-root
17
18Vendor: Project Vine
19Distribution: Vine Linux
20
21%global __provides_exclude_from ^%{_libdir}/pkgconfig/.*$
22
23%description
24The zlib compression library provides in-memory compression and
25decompression functions, including integrity checks of the
26uncompressed data.  This version of the library supports only one
27compression method (deflation), but other algorithms may be added
28later, which will have the same stream interface.  The zlib library is
29used by many different system programs.
30
31%description -l ja
32zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
33のデータの整合性チェックを行う関数を提供します。今バージョンのラ
34イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
35ートしていますが、今後同じストリームインターフェースを持つ他の圧
36縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
37用されています。
38
39%package devel
40Summary: Header files and libraries for developing apps which will use zlib.
41Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
42Group: Development/Libraries
43Requires: %{name} = %{version}-%{release}
44Provides: pkgconfig(zlib)
45
46%description devel
47The zlib-devel package contains the header files and libraries needed
48to develop programs that use the zlib compression and decompression
49library.
50
51%package static
52Summary: Static libraries for  %{name}
53Summary(ja): %{name} のスタティックライブラリ
54Group: Development/Libraries
55Requires: %{name}-devel = %{version}-%{release}
56
57%description static
58The zlib-static package contains the static library for %{name}
59
60## to build compat32 for x86_64 architecture support
61%package -n compat32-%{name}
62Summary: The zlib compression and decompression library.
63Summary(ja): zlib 圧縮/展開ライブラリ
64Group: System Environment/Libraries
65Requires: %{name} = %{version}-%{release}
66Requires(post): /sbin/ldconfig
67Requires(postun): /sbin/ldconfig
68
69%description -n compat32-%{name}
70The zlib compression library provides in-memory compression and
71decompression functions, including integrity checks of the
72uncompressed data.  This version of the library supports only one
73compression method (deflation), but other algorithms may be added
74later, which will have the same stream interface.  The zlib library is
75used by many different system programs.
76
77%description -n compat32-%{name} -l ja
78zlib圧縮ライブラリーは、メモリ内で圧縮と解凍を行う関数や、解凍後
79のデータの整合性チェックを行う関数を提供します。今バージョンのラ
80イブラリは「デフレーション(deflation)」という圧縮方法のみをサポ
81ートしていますが、今後同じストリームインターフェースを持つ他の圧
82縮方法も追加する予定です。zlibライブラリーは多種のプログラムで使
83用されています。
84
85%package -n compat32-%{name}-devel
86Summary: Header files and libraries for developing apps which will use zlib.
87Summary(ja): zlib を使ったプログラム開発に必要なヘッダファイル/ライブラリ
88Group: Development/Libraries
89Requires: %{name} = %{version}-%{release}
90Requires: %{name}-devel = %{version}-%{release}
91
92%description -n compat32-%{name}-devel
93The zlib-devel package contains the header files and libraries needed
94to develop programs that use the zlib compression and decompression
95library.
96
97Install the zlib-devel package if you want to develop applications that
98will use the zlib library.
99
100
101%prep
102%setup -q
103# %patch0 -p1
104
105%build
106mkdir static shared
107
108# build shared lib
109CFLAGS="$RPM_OPT_FLAGS -fPIC" ./configure --shared --prefix=%{_prefix}
110
111make %{?_smp_mflags}
112mv -f Makefile zconf.h *.o *.so* shared/
113
114# build static lib
115CFLAGS="$RPM_OPT_FLAGS" ./configure --prefix=%{_prefix}
116make %{?_smp_mflags}
117mv -f Makefile zconf.h *.o *.a static/
118
119
120%install
121rm -rf ${RPM_BUILD_ROOT}
122mkdir -p ${RPM_BUILD_ROOT}%{_prefix}
123
124mv -f shared/* .
125make install prefix=${RPM_BUILD_ROOT}%{_prefix}
126
127mv -f Makefile zconf.h *.o *.so* shared/
128mv -f static/* .
129make install prefix=${RPM_BUILD_ROOT}%{_prefix}
130
131install -m644 zutil.h ${RPM_BUILD_ROOT}%{_includedir}/zutil.h
132mkdir -p ${RPM_BUILD_ROOT}%{_mandir}/man3
133install -m644 zlib.3 ${RPM_BUILD_ROOT}%{_mandir}/man3
134
135if [ "%{_prefix}/lib" != "%{_libdir}" ]; then
136    mkdir -p ${RPM_BUILD_ROOT}%{_libdir}
137    mv ${RPM_BUILD_ROOT}%{_prefix}/lib/* ${RPM_BUILD_ROOT}%{_libdir}
138    rmdir ${RPM_BUILD_ROOT}%{_prefix}/lib
139fi
140
141cat %{buildroot}/usr/include/zlib.h | sed -n '1,/*\//p' > LICENSE
142
143%clean
144rm -rf ${RPM_BUILD_ROOT}
145
146%post -p /sbin/ldconfig
147
148%postun -p /sbin/ldconfig
149
150%post -n compat32-%{name} -p /sbin/ldconfig
151
152%postun -n compat32-%{name} -p /sbin/ldconfig
153
154%files
155%defattr(-,root,root)
156%license LICENSE
157%doc README
158%{_libdir}/*.so
159%{_libdir}/libz.so.*
160
161%files devel
162%defattr(-,root,root)
163%doc ChangeLog doc/algorithm.txt
164%{_libdir}/pkgconfig/zlib.pc
165%{_includedir}/*
166%{_mandir}/man3/zlib.3*
167
168%files static
169%defattr(-,root,root)
170%{_libdir}/*.a
171
172%if %{build_compat32}
173%files -n compat32-%{name}
174%defattr(-,root,root)
175%{_libdir}/libz.so.*
176
177%files -n compat32-%{name}-devel
178%defattr(-,root,root)
179%{_libdir}/*.so
180%{_libdir}/pkgconfig/zlib.pc
181%endif
182
183%changelog
184* Sat Mar 21 2020 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-2
185- dropped "Provides:pkgconfig(zlib)" from compat32-zlib-devel.
186
187* Wed Jan 02 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.11-1
188- new upstream release.
189- added license text.
190- reverted moving libz.so for compat32 package.
191
192* Sat Mar 19 2016 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> - 1.2.8-2
193- moved libz.so into the main package.
194
195* Fri Mar 21 2014 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.8-1
196- new upstream release
197- changed archive type bz2 to xz
198
199* Fri Oct 19 2012 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> - 1.2.7-1
200- new upstream release
201- drop patch0 (resolved by upstream)
202- use smp flag in make section
203
204* Fri Oct 1 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-2
205- added patch0 from gentoo to fix zlib.h errors on i686 compiling some applications
206
207* Wed Sep 22 2010 Toshiharu Kudoh <toshi.kd2@gmail.com> - 1.2.5-1
208- new upstream release (built with rpm-4.8.1-1 for pkg-config file)
209- changed License: BSD to zlib and Boost
210- added %%{_libdir}/pkgconfig/zlib.pc in -devel package
211- fixed %%doc files in -devel package
212
213* Fri Mar 05 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-7
214- add Requires(post,pre): /sbin/ldconfig
215
216* Fri Feb 12 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-6
217- rebuilt with gcc-4.4.3-3 on ppc
218
219* Mon Feb  8 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.2.3-5
220- rebuilt with new toolchain
221
222* Fri Mar 27 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-4
223- split static library to zlib-static
224  - needed by tuxonice-userui
225
226* Wed Dec 17 2008 AKIYAMA Kazuhito <akiyama@yb3.so-net.ne.jp> 1.2.3-3
227- change spec into UTF-8
228
229* Sun May 18 2008 NAKAMURA Kenta <kenta@vinelinux.org> 1.2.3-2
230- removed %%if !%%{build_compat32} case condition
231
232* Sat May 17 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.3-1
233- applied new versioning policy
234- rebuilt with new toolchains
235
236* Mon Feb 06 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl5
237- moved macros _lib to /usr/lib/rpm/rpmrc or macros files
238
239* Fri Feb 03 2006 Shu KONNO <owa@bg.wakwak.com> 1.2.3-0vl4
240- added compat32-* packages for x86_64 architecture support
241
242* Tue Oct 25 2005 NAKAMURA Kenta <kenta@c.csce.kyushu-u.ac.jp> 1.2.3-0vl3
243- added compat32- packages for x86_64 architecture support
244
245* Tue Oct 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl2
246- clean up specfile (do not build twice..)
247
248* Tue Jul 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.3-0vl1
249- new upstream release
250
251* Sun Jul 10 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2.2-0vl1
252- new upstream release
253- add Patch1 for CAN-2005-2096
254
255* Fri Mar 25 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-0vl1
256- new upstream version
257- add translated descriptions (thanks to spec file translation project)
258
259* Sun Apr 06 2003 Satoshi MACHINO <machino@vinelinux.org> 1.1.4-0vl3
260- fixed buffer overrun on gzprintf
261        -- added zlib-1.1.4-vsnprintf.patch from http://archives.neohapsis.com/archives/bugtraq/2003-02/0290.html
262
263* Fri Sep 20 2002 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.1.4-0vl2
264- changed URL to more preferable site
265
266* Tue Mar 12 2002 IWAI Masaharu <iwaim@cc.mbn.or.jp> 1.1.4-0vl1
267- upstream release
268
269* Tue Dec 26 2000 MATSUBAYASHI 'Shaolin' Kohji <shaolin@rhythmaning.org>
270- 1.1.3-14vl1
271- based on 1.1.3-14 from Rawhide
272- added Japanese summary
273
274* Fri Sep 15 2000 Florian La Roche <Florian.LaRoche@redhat.de>
275- add -fPIC for shared libs (patch by Fritz Elfert)
276
277* Thu Sep  7 2000 Jeff Johnson <jbj@redhat.com>
278- on 64bit systems, make sure libraries are located correctly.
279
280* Thu Aug 17 2000 Jeff Johnson <jbj@redhat.com>
281- summaries from specspo.
282
283* Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
284- automatic rebuild
285
286* Sun Jul 02 2000 Trond Eivind Glomsr <teg@redhat.com>
287- rebuild
288
289* Tue Jun 13 2000 Jeff Johnson <jbj@redhat.com>
290- FHS packaging to build on solaris2.5.1.
291
292* Wed Jun 07 2000 Trond Eivind Glomsr <teg@redhat.com>
293- use %%{_mandir} and %%{_tmppath}
294
295* Fri May 12 2000 Trond Eivind Glomsr <teg@redhat.com>
296- updated URL and source location
297- moved README to main package
298
299* Mon Feb  7 2000 Jeff Johnson <jbj@redhat.com>
300- compress man page.
301
302* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
303- auto rebuild in the new build environment (release 5)
304
305* Wed Sep 09 1998 Cristian Gafton <gafton@redhat.com>
306- link against glibc
307
308* Mon Jul 27 1998 Jeff Johnson <jbj@redhat.com>
309- upgrade to 1.1.3
310
311* Fri May 08 1998 Prospector System <bugs@redhat.com>
312- translations modified for de, fr, tr
313
314* Wed Apr 08 1998 Cristian Gafton <gafton@redhat.com>
315- upgraded to 1.1.2
316- buildroot
317
318* Tue Oct 07 1997 Donnie Barnes <djb@redhat.com>
319- added URL tag (down at the moment so it may not be correct)
320- made zlib-devel require zlib
321
322* Thu Jun 19 1997 Erik Troan <ewt@redhat.com>
323- built against glibc
Note: See TracBrowser for help on using the repository browser.