source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 4650

Revision 4650, 11.4 KB checked in by Takemikaduchi, 13 years ago (diff)

GNOME-3.1.5

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define gnome_common_version 2.28.0
8
9Summary: A system documentation reader from the Gnome project.
10Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
11Name: yelp
12Version: 3.1.2
13Release: 1%{?_dist_release}
14
15URL: http://live.gnome.org/Yelp
16Source0: %{name}-%{version}.tar.xz
17Source10: man-convert-helper
18
19License: GPL
20Group: User Interface/Desktops
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: gtk3 >= %{gtk3_version}
23Requires: gnome-user-docs
24Requires: nkf
25Requires: yelp-xsl
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: pango-devel >= %{pango_version}
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel
30BuildRequires: libxml2-devel >= 2.6.5
31BuildRequires: libxslt-devel >= 1.1.4
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: bzip2-devel
35BuildRequires: startup-notification-devel >= 0.8
36BuildRequires: dbus-glib-devel
37BuildRequires: rarian-devel >= %{rarian_version}
38BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
39BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
40BuildRequires: gnome-common >= %{gnome_common_version}
41BuildRequires: yelp-xsl-devel
42BuildRequires: WebKit3-gtk-devel
43BuildRequires: sqlite3-devel
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: Takemikaduchi
48
49%description
50Yelp is the Gnome 2 help/documentation browser. It is designed
51to help you browse all the documentation on your system in
52one central tool.
53
54%description -l ja
55Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
56によってシステム内の全てのドキュメントを参照できることを目標に
57作られています。
58
59%package libs
60Summary: Libraries for yelp
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description libs
65This package contains libraries used by the yelp help browser.
66
67%package devel
68Summary: Development files for yelp-libs
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71
72%description devel
73This package contains header files and documentation for
74the libraries in the yelp-libs package.
75
76%prep
77%setup -q
78
79# autoreconf -f -i
80
81%build
82%configure \
83        --disable-static
84make
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
89make install DESTDIR=$RPM_BUILD_ROOT
90unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
91
92mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
93
94install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
95
96rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
97
98%find_lang %{name}
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%post
104update-desktop-database %{_datadir}/applications >& /dev/null ||:
105update-mime-database %{_datadir}/mime >& /dev/null ||:
106
107touch %{_datadir}/icons/hicolor
108#if [ -x /usr/bin/gtk-update-icon-cache ]; then
109#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
110#fi
111
112%postun
113update-desktop-database %{_datadir}/applications >& /dev/null ||:
114update-mime-database %{_datadir}/mime >& /dev/null ||:
115glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
116
117%posttrans
118glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
119
120%files -f %{name}.lang
121%defattr(-,root,root)
122%{_bindir}/*
123%{_datadir}/applications/*
124%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
125%dir %{_datadir}/gnome/help
126%{_datadir}/%{name}
127#%{_datadir}/icons/hicolor/*
128
129%files libs
130%defattr(-,root,root,-)
131%{_libdir}/libyelp.so.*
132
133%files devel
134%defattr(-,root,root,-)
135%{_libdir}/libyelp.so
136%{_includedir}/libyelp
137%{_datadir}/gtk-doc/html/libyelp
138
139
140
141%changelog
142* Sun Aug 21 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.2-1
143- new upstream release
144
145* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
146- new upstream release
147- create -libs and -devel sub package
148- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
149- remove BuildRequires: xulrunner-devel
150- change BuildRequires: gtk3-devel instead of gtk2-devel
151- change BuildRequires: xz-devel instead of lzma-devel
152- drop old Patches
153
154* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
155- update Patch2: yelp-2.30.2-add-mime-handling.patch
156
157* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
158- rebuild with xulrunner-2.0
159- add Patch11 to build with xulrunner-2.0
160
161* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
162- new upstream release
163
164* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
165- new upstream release
166
167* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
168- new upstream release
169- change Requires: gecko-libs -> xulrunner
170- change BuildRequires: gecko-devel -> xulrunner-devel
171- drop Patch11
172
173* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
174- new upstream release
175- build with xulrunner-1.9.2 (gecko-1.9.2)
176  - BR: gecko-devel instead of gecko-unstable-devel
177  - add patch11 to fix xulrunner-1.9.2 problem
178    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
179    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
180
181* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
182- new upstream release
183
184* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
185- convert manpages from euc to utf8
186
187* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
188- rebuild with gecko-1.9.1
189
190* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
191- new upstream release
192- remove BR: libgnomeprintui-devel
193
194* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
195- use xulrunner-1.9 for gecko libs instead of firefox
196- add Patch7,8,9 to build with xulrunner-1.9
197
198* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
199- new upstream release
200
201* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
202- new upstream release
203- added Patches from Fedora Core
204  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
205  - Disallow launchers when running under GDM.
206  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
207  - Add patch for RH bug #437328 (searching with Beagle broken).
208  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
209  - Handle .HP tags in man pages
210  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
211  - Actually apply the Pango patch
212  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
213  - Patched to include DocBook mimetype in desktop file, and added preun and
214    post hooks to update-desktop-database (#175880)
215  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
216    the documentation as reported by gnomevfs (also #175880)
217
218* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
219- new upstream release
220- added BuildRequires: rarian-devel
221
222* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
223- rebuild with new environment/toolchain
224
225* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
226- new upstream release
227- drop Patch20
228
229* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
230- added Patch20 (<BTS:0314>)
231- add BuildRequires: libgnomeprintui-devel
232
233* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
234- rebuild with firefox-2.0
235
236* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
237- updated to 2.14.3
238- changed Group to User Interface/Desktops
239
240* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
241- add Patch10 to fix corruption of help option message.
242- add Japanese summary and description
243
244* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
245- new upstream release
246
247* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
248- rebuild with firefox-1.5.0.2-0vl4
249
250* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
251- new upstream release
252- build with firefox-1.5.0.2
253
254* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
255- run gtk-update-icon-cache in %%post script.
256
257* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
258- new upstream release
259
260* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
261- new upstream release
262
263* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
264- rebuild with firefox-1.5.0.1
265
266* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
267- new upstream release
268- build with firefox-1.5
269
270* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
271- new upstream release
272- build with mozilla-1.7.12
273
274* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
275- new upstream release
276
277* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
278- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
279
280* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
281- rebuild with mozilla-1.7.8
282
283* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
284- new upstream release
285
286* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
287- rebuild with mozilla-1.7.7
288
289* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
290- add Requires/BuildRequires to gnome-doc-utils
291
292* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
293- include yelp.schemas
294- add versioned requires to mozilla
295
296* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
297- new upstream version
298- use mozilla's gecko engine, add Requires: mozilla
299
300* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
301- new upstream release
302
303* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
304- new upstream release
305- rebuild with new toolchains
306
307* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
308- new upstream release
309
310* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
311- new upstream release
312
313* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
314- new upstream release
315
316* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
317- new upstream release
318
319* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
320- new upstream release
321- build for Vine Linux
322
323* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
324- rebuild for all arches
325
326* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
327- Remove the strange copyright on the start page. Fixes #69106
328
329* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
330- 1.0.2
331- include libexecdir stuff
332
333* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
334- rebuild with new gail
335- 1.0.1
336
337* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
338- automated rebuild
339
340* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
341- put all the binaries in the file list... why is this package so hard?
342
343* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
344- put images in file list, this thing will be non-ugly yet
345
346* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
347- 1.0
348- use desktop-file-install to install/munge .desktop files
349- put the sgml stuff in file list
350
351* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
352- rebuild in different environment
353
354* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
355- 0.10
356
357* Sun May 26 2002 Tim Powers <timp@redhat.com>
358- automated rebuild
359
360* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
361- rebuild in different environment
362
363* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
364- 0.8
365
366* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
367- 0.6.1
368
369* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
370- 0.6
371
372* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
373- Rebuild for new gnome2 libraries
374
375* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
376- Initial build.
Note: See TracBrowser for help on using the repository browser.