source: projects/specs/trunk/y/yelp/yelp-vl.spec @ 4616

Revision 4616, 11.5 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define glib2_version 2.28.6
2%define pango_version 1.28.4
3%define gtk3_version 3.0.9
4%define desktop_file_utils_version 0.17
5%define gnome_doc_utils_version 0.20.0
6%define rarian_version 0.7.0
7%define gnome_common_version 2.28.0
8
9Summary: A system documentation reader from the Gnome project.
10Summary(ja): GNOME プロジェクトのシステムドキュメントリーダ
11Name: yelp
12Version: 3.1.1
13Release: 1%{?_dist_release}
14
15URL: http://live.gnome.org/Yelp
16Source0: %{name}-%{version}.tar.xz
17Source10: man-convert-helper
18
19License: GPL
20Group: User Interface/Desktops
21BuildRoot: %{_tmppath}/%{name}-%{version}-root
22Requires: gtk3 >= %{gtk3_version}
23Requires: gnome-user-docs
24Requires: nkf
25Requires: yelp-xsl
26BuildRequires: glib2-devel >= %{glib2_version}
27BuildRequires: pango-devel >= %{pango_version}
28BuildRequires: gtk3-devel >= %{gtk3_version}
29BuildRequires: GConf2-devel
30BuildRequires: libxml2-devel >= 2.6.5
31BuildRequires: libxslt-devel >= 1.1.4
32BuildRequires: zlib-devel
33BuildRequires: xz-devel
34BuildRequires: bzip2-devel
35BuildRequires: startup-notification-devel >= 0.8
36BuildRequires: dbus-glib-devel
37BuildRequires: rarian-devel >= %{rarian_version}
38BuildRequires: desktop-file-utils >= %{desktop_file_utils_version}
39BuildRequires: gnome-doc-utils >= %{gnome_doc_utils_version}
40BuildRequires: gnome-common >= %{gnome_common_version}
41BuildRequires: yelp-xsl-devel
42BuildRequires: WebKit3-gtk-devel
43BuildRequires: sqlite3-devel
44
45Vendor: Project Vine
46Distribution: Vine Linux
47Packager: Takemikaduchi
48
49%description
50Yelp is the Gnome 2 help/documentation browser. It is designed
51to help you browse all the documentation on your system in
52one central tool.
53
54%description -l ja
55Yelp は Gnome 2 のヘルプ/ドキュメントブラウザです。このツール
56によってシステム内の全てのドキュメントを参照できることを目標に
57作られています。
58
59%package libs
60Summary: Libraries for yelp
61Group: Development/Libraries
62Requires: %{name} = %{version}-%{release}
63
64%description libs
65This package contains libraries used by the yelp help browser.
66
67%package devel
68Summary: Development files for yelp-libs
69Group: Development/Libraries
70Requires: %{name}-libs = %{version}-%{release}
71
72%description devel
73This package contains header files and documentation for
74the libraries in the yelp-libs package.
75
76%prep
77%setup -q
78
79# autoreconf -f -i
80
81%build
82%configure \
83        --disable-static
84make
85
86%install
87rm -rf $RPM_BUILD_ROOT
88export GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
89make install DESTDIR=$RPM_BUILD_ROOT
90unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
91
92desktop-file-install --vendor=gnome --delete-original       \
93  --dir $RPM_BUILD_ROOT%{_datadir}/applications             \
94  --add-only-show-in GNOME                                  \
95  $RPM_BUILD_ROOT%{_datadir}/applications/*
96
97mkdir -p -m 755 $RPM_BUILD_ROOT/%{_datadir}/gnome/help
98
99install -m755 %{SOURCE10} $RPM_BUILD_ROOT%{_datadir}/yelp/
100
101rm -rf $RPM_BUILD_ROOT%{_libdir}/*.{la,a}
102
103%find_lang %{name}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post
109update-desktop-database %{_datadir}/applications >& /dev/null ||:
110update-mime-database %{_datadir}/mime >& /dev/null ||:
111
112touch %{_datadir}/icons/hicolor
113#if [ -x /usr/bin/gtk-update-icon-cache ]; then
114#  /usr/bin/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor ||:
115#fi
116
117%postun
118update-desktop-database %{_datadir}/applications >& /dev/null ||:
119update-mime-database %{_datadir}/mime >& /dev/null ||:
120glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
121
122%posttrans
123glib-compile-schemas %{_datadir}/glib-2.0/schemas ||:
124
125%files -f %{name}.lang
126%defattr(-,root,root)
127%{_bindir}/*
128%{_datadir}/applications/*
129%{_datadir}/glib-2.0/schemas/org.gnome.yelp.gschema.xml
130%dir %{_datadir}/gnome/help
131%{_datadir}/%{name}
132#%{_datadir}/icons/hicolor/*
133
134%files libs
135%defattr(-,root,root,-)
136%{_libdir}/libyelp.so.*
137
138%files devel
139%defattr(-,root,root,-)
140%{_libdir}/libyelp.so
141%{_includedir}/libyelp
142%{_datadir}/gtk-doc/html/libyelp
143
144
145
146%changelog
147* Mon Aug 15 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 3.1.1-1
148- new upstream release
149- create -libs and -devel sub package
150- add BuildRequires: yelp-xsl-devel, WebKit3-gtk-devel, sqlite3-devel
151- remove BuildRequires: xulrunner-devel
152- change BuildRequires: gtk3-devel instead of gtk2-devel
153- change BuildRequires: xz-devel instead of lzma-devel
154- drop old Patches
155
156* Sat Apr 09 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-3
157- update Patch2: yelp-2.30.2-add-mime-handling.patch
158
159* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.30.2-2
160- rebuild with xulrunner-2.0
161- add Patch11 to build with xulrunner-2.0
162
163* Sun Oct 03 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.2-1
164- new upstream release
165
166* Sat May 01 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.1-1
167- new upstream release
168
169* Sun Apr 04 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.30.0-1
170- new upstream release
171- change Requires: gecko-libs -> xulrunner
172- change BuildRequires: gecko-devel -> xulrunner-devel
173- drop Patch11
174
175* Mon Mar 01 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 2.28.1-1
176- new upstream release
177- build with xulrunner-1.9.2 (gecko-1.9.2)
178  - BR: gecko-devel instead of gecko-unstable-devel
179  - add patch11 to fix xulrunner-1.9.2 problem
180    - https://bugzilla.gnome.org/show_bug.cgi?id=603561
181    - http://git.gnome.org/browse/yelp/commit/?id=a5588114ed94d00ca64913aa5b248e09a5e13edc
182
183* Sun Nov  1 2009 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.28.0-1
184- new upstream release
185
186* Tue Aug 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-3
187- convert manpages from euc to utf8
188
189* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.26.0-1
190- rebuild with gecko-1.9.1
191
192* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.24.0-1
193- new upstream release
194- remove BR: libgnomeprintui-devel
195
196* Mon Jun 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.22.1-2
197- use xulrunner-1.9 for gecko libs instead of firefox
198- add Patch7,8,9 to build with xulrunner-1.9
199
200* Thu Apr 10 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.1-1vl5
201- new upstream release
202
203* Sun Apr  6 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.22.0-1vl5
204- new upstream release
205- added Patches from Fedora Core
206  * Mon Mar 31 2008 Jon McCann <jmccann@redhat.com> - 2.22.0-4
207  - Disallow launchers when running under GDM.
208  * Thu Mar 13 2008 Matthew Barnes <mbarnes@redhat.com> - 2.22.0-2
209  - Add patch for RH bug #437328 (searching with Beagle broken).
210  * Fri Nov 16 2007 Matthias Clasen <mclasen@redhat.com> - 2.20.0-7
211  - Handle .HP tags in man pages
212  * Wed Sep  6 2006 Matthias Clasen  <mclasen@redhat.com> - 2.16.0-2.fc6
213  - Actually apply the Pango patch
214  * Thu Dec 15 2005 David Malcolm <dmalcolm@redhat.com> - 2.13.2-2
215  - Patched to include DocBook mimetype in desktop file, and added preun and
216    post hooks to update-desktop-database (#175880)
217  - Patched to ensure that Yelp recognizes that it can handle the mimetype of
218    the documentation as reported by gnomevfs (also #175880)
219
220* Sat Jan 12 2008 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.20.0-0vl1
221- new upstream release
222- added BuildRequires: rarian-devel
223
224* Thu May 17 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl2
225- rebuild with new environment/toolchain
226
227* Sat Apr 28 2007 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.1-0vl1
228- new upstream release
229- drop Patch20
230
231* Thu Nov 16 2006 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.14.3-0vl3
232- added Patch20 (<BTS:0314>)
233- add BuildRequires: libgnomeprintui-devel
234
235* Wed Oct 25 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.3-0vl2
236- rebuild with firefox-2.0
237
238* Sun Oct 15 2006 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.14.3-0vl1
239- updated to 2.14.3
240- changed Group to User Interface/Desktops
241
242* Sat Jul 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl2
243- add Patch10 to fix corruption of help option message.
244- add Japanese summary and description
245
246* Sun Jun 04 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.2-0vl1
247- new upstream release
248
249* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl2
250- rebuild with firefox-1.5.0.2-0vl4
251
252* Fri Apr 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.1-0vl1
253- new upstream release
254- build with firefox-1.5.0.2
255
256* Sat Apr 01 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl2
257- run gtk-update-icon-cache in %%post script.
258
259* Tue Mar 14 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.14.0-0vl1
260- new upstream release
261
262* Wed Mar 08 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.13.6-0vl1
263- new upstream release
264
265* Thu Feb 02 2006 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl2
266- rebuild with firefox-1.5.0.1
267
268* Fri Dec 30 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.2-0vl1
269- new upstream release
270- build with firefox-1.5
271
272* Sat Sep 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.1-0vl1
273- new upstream release
274- build with mozilla-1.7.12
275
276* Mon Sep 19 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.12.0-0vl1
277- new upstream release
278
279* Sat Aug 20 2005 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 2.10.0-0vl4
280- rebuilt with mozilla-1.7.11 (doh! 0vl3 had stupid mistake in the changelog)
281
282* Fri May 13 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl2
283- rebuild with mozilla-1.7.8
284
285* Mon May 02 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.10.0-0vl1
286- new upstream release
287
288* Sun Apr 17 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl4
289- rebuild with mozilla-1.7.7
290
291* Thu Apr 14 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl3
292- add Requires/BuildRequires to gnome-doc-utils
293
294* Mon Mar 28 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl2
295- include yelp.schemas
296- add versioned requires to mozilla
297
298* Thu Mar 24 2005 Daisuke SUZUKI <daisuke@linux.or.jp> 2.9.3-0vl1
299- new upstream version
300- use mozilla's gecko engine, add Requires: mozilla
301
302* Mon Nov 22 2004 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.4-0vl1
303- new upstream release
304
305* Mon Dec 22 2003 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 2.4.2-0vl1
306- new upstream release
307- rebuild with new toolchains
308
309* Thu Sep 11 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-0vl1
310- new upstream release
311
312* Wed Sep 03 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.90-0vl1
313- new upstream release
314
315* Thu May 15 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.0-0vl1
316- new upstream release
317
318* Tue Jan 21 2003 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
319- new upstream release
320
321* Thu Dec 26 2002 Daisuke SUZUKI <daisuke@linux.or.jp> 2.1.3-0vl1
322- new upstream release
323- build for Vine Linux
324
325* Mon Nov 18 2002 Tim Powers <timp@redhat.com>
326- rebuild for all arches
327
328* Mon Aug 12 2002 Alexander Larsson <alexl@redhat.com>
329- Remove the strange copyright on the start page. Fixes #69106
330
331* Thu Aug  8 2002 Havoc Pennington <hp@redhat.com>
332- 1.0.2
333- include libexecdir stuff
334
335* Sat Jul 27 2002 Havoc Pennington <hp@redhat.com>
336- rebuild with new gail
337- 1.0.1
338
339* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
340- automated rebuild
341
342* Tue Jun 18 2002 Havoc Pennington <hp@redhat.com>
343- put all the binaries in the file list... why is this package so hard?
344
345* Mon Jun 17 2002 Havoc Pennington <hp@redhat.com>
346- put images in file list, this thing will be non-ugly yet
347
348* Sun Jun 16 2002 Havoc Pennington <hp@redhat.com>
349- 1.0
350- use desktop-file-install to install/munge .desktop files
351- put the sgml stuff in file list
352
353* Fri Jun 07 2002 Havoc Pennington <hp@redhat.com>
354- rebuild in different environment
355
356* Wed Jun  5 2002 Havoc Pennington <hp@redhat.com>
357- 0.10
358
359* Sun May 26 2002 Tim Powers <timp@redhat.com>
360- automated rebuild
361
362* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
363- rebuild in different environment
364
365* Tue May 21 2002 Havoc Pennington <hp@redhat.com>
366- 0.8
367
368* Fri May  3 2002 Havoc Pennington <hp@redhat.com>
369- 0.6.1
370
371* Fri Apr 19 2002 Havoc Pennington <hp@redhat.com>
372- 0.6
373
374* Wed Jan 30 2002 Owen Taylor <otaylor@redhat.com>
375- Rebuild for new gnome2 libraries
376
377* Mon Jan 28 2002 Alex Larsson <alexl@redhat.com>
378- Initial build.
Note: See TracBrowser for help on using the repository browser.