source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 1452

Revision 1452, 25.4 KB checked in by daisuke, 14 years ago (diff)

xulrunner: update to 1.9.2.8

Line 
1%define nspr_version 4.8
2%define nss_version 3.12
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.6.21
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24# Separated plugins are supported on x86(64) only
25%ifarch %{ix86} x86_64
26%define separated_plugins 1
27%else
28%define separated_plugins 0
29%endif
30
31Summary:        XUL Runtime for Gecko Applications
32Summary(ja):    Gecko アプリケーションのための XUL ランタイム
33Name:           xulrunner
34Version:        1.9.2.8
35Release:        1%{?_dist_release}
36URL:            http://www.mozilla.org/projects/xulrunner/
37License:        MPLv1.1 or GPLv2+ or LGPLv2+
38Group:          Applications/Internet
39Source0:        %{name}-%{version}-source.tar.bz2
40Source10:       %{name}-mozconfig
41Source11:       %{name}-mozconfig-vine5
42Source12:       %{name}-vine-default-prefs.js
43Source21:       %{name}.sh.in
44Source23:       %{name}.1
45
46# locale sources
47%define MOZ_BUILD_LOCALES "ja"
48Source1000:     xulrunner-%{version}-ja.tar.bz2
49
50# build patches
51Patch0:         xulrunner-version.patch
52Patch1:         mozilla-build.patch
53Patch3:         mozilla-jemalloc.patch
54Patch7:         xulrunner-1.9.2.1-build.patch
55Patch8:         mozilla-plugin.patch
56Patch9:         mozilla-build-sbrk.patch
57
58# patches from Fedora
59Patch100:       mozilla-192-pkgconfig.patch
60
61# Upstream patches
62Patch200:        mozilla-ps-pdf-simplify-operators.patch
63
64
65# ---------------------------------------------------
66
67BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
68BuildRequires:  nspr-devel >= %{nspr_version}
69BuildRequires:  nss-devel >= %{nss_version}
70BuildRequires:  cairo-devel >= %{cairo_version}
71BuildRequires:  libpng-devel
72BuildRequires:  libjpeg-devel
73BuildRequires:  bzip2-devel
74BuildRequires:  zlib-devel
75BuildRequires:  lcms-devel
76BuildRequires:  libIDL-devel
77BuildRequires:  gtk2-devel
78BuildRequires:  gnome-vfs2-devel
79BuildRequires:  libgnome-devel
80BuildRequires:  libgnomeui-devel
81BuildRequires:  pango-devel
82BuildRequires:  freetype2-devel >= 2.1.9
83BuildRequires:  libXt-devel
84BuildRequires:  libXrender-devel
85%if %{build_vine6}
86BuildRequires:  sqlite3-devel >= %{sqlite_version}
87%endif
88BuildRequires:  libnotify-devel >= %{libnotify_version}
89BuildRequires:  startup-notification-devel
90BuildRequires:  alsa-lib-devel
91BuildRequires:  lcms-devel
92BuildRequires:  zip
93# For -sqlite.patch
94BuildRequires:  autoconf213
95
96Requires:       nspr >= %{nspr_version}
97Requires:       nss >= %{nss_version}
98
99Provides:       gecko-libs = %{version}
100
101%description
102XULRunner provides the XUL Runtime environment for Gecko applications.
103
104%package devel
105Summary: Development files for Gecko
106Group: Development/Libraries
107
108Obsoletes: mozilla-devel
109Obsoletes: firefox-devel < 2.1
110Obsoletes: xulrunner-devel-unstable
111
112Provides: gecko-devel = %{version}
113Provides: gecko-devel-unstable = %{version}
114
115Requires: xulrunner = %{version}-%{release}
116Requires: nspr-devel >= %{nspr_version}
117Requires: nss-devel >= %{nss_version}
118Requires: cairo-devel >= %{cairo_version}
119Requires: libjpeg-devel
120Requires: zip
121Requires: bzip2-devel
122Requires: zlib-devel
123Requires: lcms-devel
124Requires: libIDL-devel
125Requires: gtk2-devel
126Requires: gnome-vfs2-devel
127Requires: libgnome-devel
128Requires: libgnomeui-devel
129Requires: pango-devel
130Requires: freetype2-devel >= 2.1.9
131Requires: libXt-devel
132Requires: libXrender-devel
133%if %{build_vine6}
134Requires: sqlite3-devel >= %{sqlite_version}
135%endif
136Requires: startup-notification-devel
137Requires: alsa-lib-devel
138
139%description devel
140Gecko development files.
141
142#---------------------------------------------------------------------
143
144%prep
145%setup -q -c -b 1000
146cd %{tarballdir}
147
148sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
149    %{P:%%PATCH0} > version.patch
150%{__patch} -p1 -b --suffix .version < version.patch
151
152%patch1  -p1 -b .build
153%patch3  -p1 -b .jemalloc
154%patch7  -p2 -b .del
155%patch8  -p1 -b .plugin
156%patch9  -p2 -b .sbrk
157
158%patch100 -p1 -b .pkgconfig
159
160%patch200 -p1 -b .ps-pdf-simplify-operators
161
162%{__rm} -f .mozconfig
163%if %{build_vine6}
164%{__cp} %{SOURCE10} .mozconfig
165%else
166%{__cp} %{SOURCE11} .mozconfig
167%endif
168
169%if !%{?separated_plugins}
170echo "ac_add_options --disable-ipc" >> .mozconfig
171%endif
172
173#---------------------------------------------------------------------
174
175%build
176cd %{tarballdir}
177
178INTERNAL_GECKO=%{version_internal}
179MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
180
181# Mozilla builds with -Wall with exception of a few warnings which show up
182# everywhere in the code; so, don't override that.
183MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
184export CFLAGS=$MOZ_OPT_FLAGS
185export CXXFLAGS=$MOZ_OPT_FLAGS
186
187export PREFIX='%{_prefix}'
188export LIBDIR='%{_libdir}'
189
190MOZ_SMP_FLAGS=-j1
191%ifnarch ppc ppc64 s390 s390x
192[ -z "$RPM_BUILD_NCPUS" ] && \
193     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
194[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
195%endif
196
197export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
198make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
199make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
200
201# build locales
202LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
203            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
204for dir in $LOCALEDIRS
205do
206  for lang in %{MOZ_BUILD_LOCALES} ; do
207    make -C $dir/locales AB_CD=$lang
208  done
209done
210
211#---------------------------------------------------------------------
212
213%install
214cd %{tarballdir}
215%{__rm} -rf $RPM_BUILD_ROOT
216
217INTERNAL_GECKO=%{version_internal}
218
219INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
220MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
221
222INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
223MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
224
225#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
226DESTDIR=$RPM_BUILD_ROOT make install
227
228%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
229             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
230             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
231%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
232
233%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
234
235# set up our default preferences
236%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
237%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
238%{__rm} vl-default-prefs
239
240# Start script install
241%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
242%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
243  $RPM_BUILD_ROOT%{_bindir}/%{name}
244%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
245
246%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
247
248cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
249find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
250cd -
251
252# install locales
253for lang in %{MOZ_BUILD_LOCALES} ; do
254  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
255done
256
257# Prepare our devel package
258%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
259%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
260%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
261
262%{__cp} -rL dist/include/* \
263  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
264
265# Copy pc files (for compatibility with 1.9.1)
266%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
267        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
268%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
269        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
270
271# Fix multilib devel conflicts...
272%ifarch x86_64 ia64 s390x ppc64
273%define mozbits 64
274%else
275%define mozbits 32
276%endif
277
278function install_file() {
279genheader=$*
280mv ${genheader}.h ${genheader}%{mozbits}.h
281cat > ${genheader}.h << EOF
282// This file exists to fix multilib conflicts
283#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
284#include "${genheader}64.h"
285#else
286#include "${genheader}32.h"
287#endif
288EOF
289}
290
291pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
292install_file "mozilla-config"
293popd
294
295pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
296install_file "jsautocfg"
297popd
298
299%{__install} -p -c -m 755 dist/bin/xpcshell \
300  dist/bin/xpidl \
301  dist/bin/xpt_dump \
302  dist/bin/xpt_link \
303  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
304
305%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
306%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
307
308%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
309ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
310       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
311
312%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
313ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
314       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
315
316%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
317ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
318       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
319
320%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
321ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
322       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
323
324find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
325find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
326
327%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
328pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
329for i in *.so; do
330    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
331done
332popd
333
334# GRE stuff
335%ifarch x86_64 ia64 ppc64 s390x
336%define gre_conf_file gre64.conf
337%else
338%define gre_conf_file gre.conf
339%endif
340
341MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
342%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
343        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
344chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
345
346# Library path
347%ifarch x86_64 ia64 ppc64 s390x
348%define ld_conf_file xulrunner-64.conf
349%else
350%define ld_conf_file xulrunner-32.conf
351%endif
352
353%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
354%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
355${MOZ_APP_DIR}
356EOF
357                       
358# Copy over the LICENSE
359%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
360
361# Use the system hunspell dictionaries
362%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
363ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
364
365# ghost files
366%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
367touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
368touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
369
370#---------------------------------------------------------------------
371
372%clean
373%{__rm} -rf $RPM_BUILD_ROOT
374
375#---------------------------------------------------------------------
376
377%post
378/sbin/ldconfig
379
380%postun
381/sbin/ldconfig
382
383%preun
384# is it a final removal?
385if [ $1 -eq 0 ]; then
386  %{__rm} -rf ${MOZ_APP_DIR}/components
387fi
388
389%files
390%defattr(-,root,root,-)
391%{_bindir}/xulrunner
392%dir /etc/gre.d
393/etc/gre.d/%{gre_conf_file}
394%dir %{mozappdir}
395%doc %attr(644, root, root) %{mozappdir}/LICENSE
396%doc %attr(644, root, root) %{mozappdir}/README.txt
397%{mozappdir}/chrome
398%{mozappdir}/dictionaries
399%dir %{mozappdir}/components
400%ghost %{mozappdir}/components/compreg.dat
401%ghost %{mozappdir}/components/xpti.dat
402%{mozappdir}/components/*.so
403%{mozappdir}/components/*.xpt
404%attr(644, root, root) %{mozappdir}/components/*.js
405%{mozappdir}/defaults
406%{mozappdir}/greprefs
407%dir %{mozappdir}/icons
408%attr(644, root, root) %{mozappdir}/icons/*
409%{mozappdir}/modules
410%{mozappdir}/plugins
411%{mozappdir}/res
412%{mozappdir}/*.so
413%{mozappdir}/mozilla-xremote-client
414%{mozappdir}/run-mozilla.sh
415%{mozappdir}/regxpcom
416%{mozappdir}/xulrunner
417%{mozappdir}/xulrunner-bin
418%{mozappdir}/xulrunner-stub
419%if %{?separated_plugins}
420%{mozappdir}/plugin-container
421%endif
422%{mozappdir}/platform.ini
423%{mozappdir}/dependentlibs.list
424%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
425
426# XXX See if these are needed still
427%{mozappdir}/updater*
428%exclude %{mozappdir}/update.locale
429%exclude %{mozappdir}/components/components.list
430
431%files devel
432%defattr(-,root,root,-)
433%dir %{_datadir}/idl/%{name}*%{version_internal}
434%{_datadir}/idl/%{name}*%{version_internal}/*
435%{_includedir}/%{name}*%{version_internal}
436%dir %{_libdir}/%{name}-sdk-*
437%dir %{_libdir}/%{name}-sdk-*/sdk
438%{_libdir}/%{name}-sdk-*/*
439%{_libdir}/%{name}-sdk-*/sdk/*
440%{_libdir}/pkgconfig/*.pc
441%{mozappdir}/xpcshell
442%{mozappdir}/xpidl
443%{mozappdir}/xpt_dump
444%{mozappdir}/xpt_link
445
446#---------------------------------------------------------------------
447
448%changelog
449* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
450- update tp 1.9.2.8 (sync with firefox-3.6.8)
451
452* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
453- update tp 1.9.2.7 (sync with firefox-3.6.7)
454
455* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
456- enable ipc only on ix86/x86_64 arches
457
458* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
459- update to 1.9.2.4 (sync with firefox-3.6.4)
460- add patch10 to fix build failure
461
462* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
463- update to 1.9.2.3 (sync with firefox-3.6.3)
464
465* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
466- update to 1.9.2.2 (sync with firefox-3.6.2)
467- add patch7,9 for fix build failure
468
469* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
470- enable libnotify support
471  - add ac_add_options --enable-libnotify
472- disable Necko wifi monitor
473  - add ac_add_options --disable-necko-wifi
474  - remove BR: wireless-tools-devel
475- fix %%files devel
476- add patch3,5 to fix jemalloc alignment assertion
477- add Patch8 to fix mozilla-plugin.pc
478
479* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
480- add BR: libnotify-devel, wireless-tools-devel
481
482* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
483- update to 1.9.2 (sync with firefox-3.6)
484- obsoletes xulrunner-devel-unstable
485
486* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
487- use internal sqlite3 on vine5
488
489* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
490- update to 1.9.1.7
491
492* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
493- update to 1.9.1.6
494- build with sqlite3-3.6.21
495
496* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
497- update to 1.9.1.5
498
499* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
500- update to 1.9.1.3
501
502* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
503- really update to 1.9.1.2 (<BTS:0748>)
504
505* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
506- update to 1.9.1.2 (sync with firefox-3.5.2)
507
508* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
509- update to 1.9.1.1 (sync with firefox-3.5.1)
510- add missing Requires to -devel
511- add missing BR
512
513* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
514- enable-system-cairo
515
516* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
517- update to 1.9.1 (based on firefox 3.5)
518
519* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
520- update to 1.9.1rc3 (sync with firefox 3.5rc3)
521
522* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
523- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
524- remove old patches
525- require nspr >= 4.8
526
527* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
528- new upstream release
529
530* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
531- update mozconfig
532  - disable-system-cairo for stability
533
534* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
535- new upstream release
536
537* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
538- new upstream release
539- add ja locale
540
541* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
542- new upstream release
543
544* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
545- new upstream release
546
547* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
548- add Patch3
549
550* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
551- update to xulrunner 1.9.0.2 byild 6
552- build with gnome-2.24
553
554* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
555- new upstream release
556
557* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
558- initial build for Vine Linux
559
560* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
561- Update to 1.9 final
562
563* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
564- Simplify PS/PDF operators
565
566* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
567- Upstream patch to fsync() less
568
569* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
570- Ensure we enable startup notification; add BR and modify config
571  (bug #445543)
572
573* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
574- Some files moved to mozilla-filesystem; kill them and add the Req
575
576* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
577- Clean up the %%files list and get rid of the executable bit on some files
578
579* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
580- Fix font scaling
581
582* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
583- Enabled phishing protection (#443403)
584
585* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
586- Changed "__ppc64__" to "__powerpc64__",
587  "__ppc64__" doesn't work anymore
588- Added fix for #443725 - Critical hanging bug with fix
589  available upstream (mozbz#429903)
590
591* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
592- Fixed multilib issues, added starting script instead of a symlink
593  to binary (#436393)
594
595* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
596- Add upstream patches for dpi, toolbar buttons, and invalid keys
597- Re-enable system cairo
598
599* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
600- Spec cleanups
601
602* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
603- Beta 5
604
605* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
606- Beta 5 RC2
607
608* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
609- Update to latest trunk (2008-03-27)
610
611* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
612- Update to latest trunk (2008-03-26)
613
614* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
615- Update to latest trunk (2008-03-25)
616
617* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
618- Update to latest trunk (2008-03-24)
619
620* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
621- Update to latest trunk (2008-03-20)
622
623* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
624- Update to latest trunk (2008-03-17)
625
626* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
627- Revert to trunk from the 15th to fix crashes on HTTPS sites
628
629* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
630- Update to latest trunk (2008-03-16)
631- Add patch to negate a11y slowdown on some pages (#431162)
632
633* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
634- Update to latest trunk (2008-03-15)
635
636* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
637- Avoid conflicts between gecko debuginfo packages
638
639* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
640- Update to latest trunk (2008-03-12)
641
642* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
643- Update to latest trunk (2008-03-11)
644
645* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
646- Update to latest trunk (2008-03-10)
647
648* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
649- Update to latest trunk (2008-03-09)
650
651* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
652- Update to latest trunk (2008-03-07)
653
654* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
655- Update to latest trunk (2008-03-06)
656
657* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
658- Update to latest trunk (2008-03-04)
659
660* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
661- Update to latest trunk (2008-03-02)
662
663* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
664- Update to latest trunk (2008-03-01)
665
666* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
667- Update to latest trunk (2008-02-29)
668
669* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
670- Update to latest trunk (2008-02-28)
671
672* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
673- Update to latest trunk (2008-02-27)
674
675* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
676- Update to latest trunk (2008-02-26)
677
678* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
679- Update to latest trunk (2008-02-23)
680
681* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
682- Update to latest trunk (2008-02-22)
683
684* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
685- Update to latest trunk (2008-02-21)
686
687* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
688- Update to latest trunk (2008-02-20)
689
690* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
691- Update to latest trunk (2008-02-17)
692
693* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
694- Update to latest trunk (2008-02-15)
695
696* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
697- Update to latest trunk (2008-02-14)
698- Use system hunspell
699
700* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
701- Update to latest trunk (2008-02-11)
702
703* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
704- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
705  you know, debuginfo.
706
707* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
708- Update to latest trunk (2008-02-10)
709
710* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
711- Update to latest trunk (2008-02-09)
712
713* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
714- Update to latest trunk (2008-02-06)
715
716* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
717- Update to latest trunk (2008-01-30)
718
719* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
720- rebuild agains new nss
721- enabled gnome vfs
722
723* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
724- fixed stable pkg-config files (#429654)
725- removed sqlite patch
726
727* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
728- Update to latest trunk (2008-01-21)
729
730* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
731- Update to latest trunk (2008-01-15)
732- Now with system extensions directory support
733
734* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
735- Update to latest trunk (2008-01-13)
736- Use CFLAGS instead of configure arguments
737- Random cleanups: BuildRequires, scriptlets, prefs, etc.
738
739* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
740- Provide gecko-devel-unstable as well
741
742* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
743- divided devel package to devel and devel-unstable
744
745* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
746- removed fedora specific pkg-config files
747- updated to the latest trunk (2008-01-07)
748- removed unnecessary patches
749- fixed idl dir (#427965)
750
751* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
752- Re-enable camellia256 support now that NSS supports it
753
754* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
755- updated to the latest trunk (2008-01-03)
756
757* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
758- Don't Provide webclient (xulrunner is not itself a webclient)
759- Don't Obsolete old firefox, only firefox-devel
760- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
761
762* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
763- added java and plugin subdirs to plugin includes
764
765* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
766- dependency fixes, obsoletes firefox < 3 and firefox-devel now
767
768* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
769- updated to Beta 2.
770- moved SDK to xulrunner-sdk
771
772* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
773- fixed mozilla-plugin.pc (#412971)
774
775* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
776- export /etc/gre.d/gre.conf (it's used by python gecko applications)
777
778* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
779- added xulrunner/js include dir to xulrunner-js
780
781* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
782- update to beta 1
783
784* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
785- packed all gecko libraries (#389391)
786
787* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
788- registered xulrunner libs system-wide
789- added xulrunner-gtkmozembed.pc
790
791* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
792- added proper nss/nspr dependencies
793
794* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
795- more build fixes, use system nss libraries
796
797* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
798- build fixes
799
800* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
801- updated to the latest trunk
802
803* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
804- build fixes for ppc/ppc64
805
806* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
807- removed conflicts with the current gecko-based apps
808- added updated ppc64 patch
809
810* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
811- build fixes
812
813* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
814- Initial cut at XULRunner 1.9 Alpha 7
815- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.