source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 1809

Revision 1809, 25.6 KB checked in by daisuke, 14 years ago (diff)

xulrunner: update to 1.9.2.9

Line 
1%define nspr_version 4.8.6
2%define nss_version 3.12
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.7.2
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24# Separated plugins are supported on x86(64) only
25%ifarch %{ix86} x86_64
26%define separated_plugins 1
27%else
28%define separated_plugins 0
29%endif
30
31Summary:        XUL Runtime for Gecko Applications
32Summary(ja):    Gecko アプリケーションのための XUL ランタイム
33Name:           xulrunner
34Version:        1.9.2.9
35Release:        1%{?_dist_release}
36URL:            http://www.mozilla.org/projects/xulrunner/
37License:        MPLv1.1 or GPLv2+ or LGPLv2+
38Group:          Applications/Internet
39Source0:        %{name}-%{version}.source.tar.bz2
40Source10:       %{name}-mozconfig
41Source11:       %{name}-mozconfig-vine5
42Source12:       %{name}-vine-default-prefs.js
43Source21:       %{name}.sh.in
44Source23:       %{name}.1
45
46# locale sources
47%define MOZ_BUILD_LOCALES "ja"
48Source1000:     xulrunner-%{version}-ja.tar.bz2
49
50# build patches
51Patch0:         xulrunner-version.patch
52Patch1:         mozilla-build.patch
53Patch3:         mozilla-jemalloc.patch
54Patch7:         xulrunner-1.9.2.1-build.patch
55Patch8:         mozilla-plugin.patch
56Patch9:         mozilla-build-sbrk.patch
57Patch10:        mozilla-libjpeg-turbo.patch
58
59# patches from Fedora
60Patch100:       mozilla-192-pkgconfig.patch
61
62# Upstream patches
63Patch200:        mozilla-ps-pdf-simplify-operators.patch
64
65
66# ---------------------------------------------------
67
68BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
69BuildRequires:  nspr-devel >= %{nspr_version}
70BuildRequires:  nss-devel >= %{nss_version}
71BuildRequires:  cairo-devel >= %{cairo_version}
72BuildRequires:  libpng-devel
73BuildRequires:  libjpeg-turbo-devel
74BuildRequires:  bzip2-devel
75BuildRequires:  zlib-devel
76BuildRequires:  lcms-devel
77BuildRequires:  libIDL-devel
78BuildRequires:  gtk2-devel
79BuildRequires:  gnome-vfs2-devel
80BuildRequires:  libgnome-devel
81BuildRequires:  libgnomeui-devel
82BuildRequires:  pango-devel
83BuildRequires:  freetype2-devel >= 2.1.9
84BuildRequires:  libXt-devel
85BuildRequires:  libXrender-devel
86%if %{build_vine6}
87BuildRequires:  sqlite3-devel >= %{sqlite_version}
88%endif
89BuildRequires:  libnotify-devel >= %{libnotify_version}
90BuildRequires:  startup-notification-devel
91BuildRequires:  alsa-lib-devel
92BuildRequires:  lcms-devel
93BuildRequires:  zip
94# For -sqlite.patch
95BuildRequires:  autoconf213
96
97Requires:       nspr >= %{nspr_version}
98Requires:       nss >= %{nss_version}
99
100Provides:       gecko-libs = %{version}
101
102%description
103XULRunner provides the XUL Runtime environment for Gecko applications.
104
105%package devel
106Summary: Development files for Gecko
107Group: Development/Libraries
108
109Obsoletes: mozilla-devel
110Obsoletes: firefox-devel < 2.1
111Obsoletes: xulrunner-devel-unstable
112
113Provides: gecko-devel = %{version}
114Provides: gecko-devel-unstable = %{version}
115
116Requires: xulrunner = %{version}-%{release}
117Requires: nspr-devel >= %{nspr_version}
118Requires: nss-devel >= %{nss_version}
119Requires: cairo-devel >= %{cairo_version}
120Requires: libjpeg-turbo-devel
121Requires: zip
122Requires: bzip2-devel
123Requires: zlib-devel
124Requires: lcms-devel
125Requires: libIDL-devel
126Requires: gtk2-devel
127Requires: gnome-vfs2-devel
128Requires: libgnome-devel
129Requires: libgnomeui-devel
130Requires: pango-devel
131Requires: freetype2-devel >= 2.1.9
132Requires: libXt-devel
133Requires: libXrender-devel
134%if %{build_vine6}
135Requires: sqlite3-devel >= %{sqlite_version}
136%endif
137Requires: startup-notification-devel
138Requires: alsa-lib-devel
139
140%description devel
141Gecko development files.
142
143#---------------------------------------------------------------------
144
145%prep
146%setup -q -c -b 1000
147cd %{tarballdir}
148
149sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
150    %{P:%%PATCH0} > version.patch
151%{__patch} -p1 -b --suffix .version < version.patch
152
153%patch1  -p1 -b .build
154%patch3  -p1 -b .jemalloc
155%patch7  -p2 -b .del
156%patch8  -p1 -b .plugin
157%patch9  -p2 -b .sbrk
158%patch10 -p1 -b .libjpeg-turbo
159
160%patch100 -p1 -b .pkgconfig
161
162%patch200 -p1 -b .ps-pdf-simplify-operators
163
164%{__rm} -f .mozconfig
165%if %{build_vine6}
166%{__cp} %{SOURCE10} .mozconfig
167%else
168%{__cp} %{SOURCE11} .mozconfig
169%endif
170
171%if !%{?separated_plugins}
172echo "ac_add_options --disable-ipc" >> .mozconfig
173%endif
174
175#---------------------------------------------------------------------
176
177%build
178cd %{tarballdir}
179
180INTERNAL_GECKO=%{version_internal}
181MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
182
183# Mozilla builds with -Wall with exception of a few warnings which show up
184# everywhere in the code; so, don't override that.
185MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
186export CFLAGS=$MOZ_OPT_FLAGS
187export CXXFLAGS=$MOZ_OPT_FLAGS
188
189export PREFIX='%{_prefix}'
190export LIBDIR='%{_libdir}'
191
192MOZ_SMP_FLAGS=-j1
193%ifnarch ppc ppc64 s390 s390x
194[ -z "$RPM_BUILD_NCPUS" ] && \
195     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
196[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
197%endif
198
199export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
200make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
201make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
202
203# build locales
204LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
205            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
206for dir in $LOCALEDIRS
207do
208  for lang in %{MOZ_BUILD_LOCALES} ; do
209    make -C $dir/locales AB_CD=$lang
210  done
211done
212
213#---------------------------------------------------------------------
214
215%install
216cd %{tarballdir}
217%{__rm} -rf $RPM_BUILD_ROOT
218
219INTERNAL_GECKO=%{version_internal}
220
221INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
222MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
223
224INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
225MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
226
227#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
228DESTDIR=$RPM_BUILD_ROOT make install
229
230%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
231             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
232             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
233%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
234
235%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
236
237# set up our default preferences
238%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
239%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
240%{__rm} vl-default-prefs
241
242# Start script install
243%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
244%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
245  $RPM_BUILD_ROOT%{_bindir}/%{name}
246%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
247
248%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
249
250cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
251find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
252cd -
253
254# install locales
255for lang in %{MOZ_BUILD_LOCALES} ; do
256  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
257done
258
259# Prepare our devel package
260%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
261%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
262%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
263
264%{__cp} -rL dist/include/* \
265  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
266
267# Copy pc files (for compatibility with 1.9.1)
268%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
269        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
270%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
271        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
272
273# Fix multilib devel conflicts...
274%ifarch x86_64 ia64 s390x ppc64
275%define mozbits 64
276%else
277%define mozbits 32
278%endif
279
280function install_file() {
281genheader=$*
282mv ${genheader}.h ${genheader}%{mozbits}.h
283cat > ${genheader}.h << EOF
284// This file exists to fix multilib conflicts
285#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
286#include "${genheader}64.h"
287#else
288#include "${genheader}32.h"
289#endif
290EOF
291}
292
293pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
294install_file "mozilla-config"
295popd
296
297pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
298install_file "jsautocfg"
299popd
300
301%{__install} -p -c -m 755 dist/bin/xpcshell \
302  dist/bin/xpidl \
303  dist/bin/xpt_dump \
304  dist/bin/xpt_link \
305  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
306
307%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
308%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
309
310%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
311ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
312       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
313
314%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
315ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
316       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
317
318%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
319ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
320       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
321
322%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
323ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
324       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
325
326find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
327find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
328
329%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
330pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
331for i in *.so; do
332    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
333done
334popd
335
336# GRE stuff
337%ifarch x86_64 ia64 ppc64 s390x
338%define gre_conf_file gre64.conf
339%else
340%define gre_conf_file gre.conf
341%endif
342
343MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
344%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
345        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
346chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
347
348# Library path
349%ifarch x86_64 ia64 ppc64 s390x
350%define ld_conf_file xulrunner-64.conf
351%else
352%define ld_conf_file xulrunner-32.conf
353%endif
354
355%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
356%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
357${MOZ_APP_DIR}
358EOF
359                       
360# Copy over the LICENSE
361%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
362
363# Use the system hunspell dictionaries
364%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
365ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
366
367# ghost files
368%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
369touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
370touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
371
372#---------------------------------------------------------------------
373
374%clean
375%{__rm} -rf $RPM_BUILD_ROOT
376
377#---------------------------------------------------------------------
378
379%post
380/sbin/ldconfig
381
382%postun
383/sbin/ldconfig
384
385%preun
386# is it a final removal?
387if [ $1 -eq 0 ]; then
388  %{__rm} -rf ${MOZ_APP_DIR}/components
389fi
390
391%files
392%defattr(-,root,root,-)
393%{_bindir}/xulrunner
394%dir /etc/gre.d
395/etc/gre.d/%{gre_conf_file}
396%dir %{mozappdir}
397%doc %attr(644, root, root) %{mozappdir}/LICENSE
398%doc %attr(644, root, root) %{mozappdir}/README.txt
399%{mozappdir}/chrome
400%{mozappdir}/dictionaries
401%dir %{mozappdir}/components
402%ghost %{mozappdir}/components/compreg.dat
403%ghost %{mozappdir}/components/xpti.dat
404%{mozappdir}/components/*.so
405%{mozappdir}/components/*.xpt
406%attr(644, root, root) %{mozappdir}/components/*.js
407%{mozappdir}/defaults
408%{mozappdir}/greprefs
409%dir %{mozappdir}/icons
410%attr(644, root, root) %{mozappdir}/icons/*
411%{mozappdir}/modules
412%{mozappdir}/plugins
413%{mozappdir}/res
414%{mozappdir}/*.so
415%{mozappdir}/mozilla-xremote-client
416%{mozappdir}/run-mozilla.sh
417%{mozappdir}/regxpcom
418%{mozappdir}/xulrunner
419%{mozappdir}/xulrunner-bin
420%{mozappdir}/xulrunner-stub
421%if %{?separated_plugins}
422%{mozappdir}/plugin-container
423%endif
424%{mozappdir}/platform.ini
425%{mozappdir}/dependentlibs.list
426%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
427
428# XXX See if these are needed still
429%{mozappdir}/updater*
430%exclude %{mozappdir}/update.locale
431%exclude %{mozappdir}/components/components.list
432
433%files devel
434%defattr(-,root,root,-)
435%dir %{_datadir}/idl/%{name}*%{version_internal}
436%{_datadir}/idl/%{name}*%{version_internal}/*
437%{_includedir}/%{name}*%{version_internal}
438%dir %{_libdir}/%{name}-sdk-*
439%dir %{_libdir}/%{name}-sdk-*/sdk
440%{_libdir}/%{name}-sdk-*/*
441%{_libdir}/%{name}-sdk-*/sdk/*
442%{_libdir}/pkgconfig/*.pc
443%{mozappdir}/xpcshell
444%{mozappdir}/xpidl
445%{mozappdir}/xpt_dump
446%{mozappdir}/xpt_link
447
448#---------------------------------------------------------------------
449
450%changelog
451* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
452- update to 1.9.2.9 (sync with firefox-3.6.9)
453- add patch10 to build with libjpeg-turbo
454- build with sqlite-3.7.2
455- BR: nspr >= 4.8.6
456
457* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
458- update tp 1.9.2.8 (sync with firefox-3.6.8)
459
460* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
461- update tp 1.9.2.7 (sync with firefox-3.6.7)
462
463* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
464- enable ipc only on ix86/x86_64 arches
465
466* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
467- update to 1.9.2.4 (sync with firefox-3.6.4)
468- add patch10 to fix build failure
469
470* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
471- update to 1.9.2.3 (sync with firefox-3.6.3)
472
473* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
474- update to 1.9.2.2 (sync with firefox-3.6.2)
475- add patch7,9 for fix build failure
476
477* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
478- enable libnotify support
479  - add ac_add_options --enable-libnotify
480- disable Necko wifi monitor
481  - add ac_add_options --disable-necko-wifi
482  - remove BR: wireless-tools-devel
483- fix %%files devel
484- add patch3,5 to fix jemalloc alignment assertion
485- add Patch8 to fix mozilla-plugin.pc
486
487* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
488- add BR: libnotify-devel, wireless-tools-devel
489
490* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
491- update to 1.9.2 (sync with firefox-3.6)
492- obsoletes xulrunner-devel-unstable
493
494* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
495- use internal sqlite3 on vine5
496
497* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
498- update to 1.9.1.7
499
500* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
501- update to 1.9.1.6
502- build with sqlite3-3.6.21
503
504* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
505- update to 1.9.1.5
506
507* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
508- update to 1.9.1.3
509
510* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
511- really update to 1.9.1.2 (<BTS:0748>)
512
513* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
514- update to 1.9.1.2 (sync with firefox-3.5.2)
515
516* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
517- update to 1.9.1.1 (sync with firefox-3.5.1)
518- add missing Requires to -devel
519- add missing BR
520
521* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
522- enable-system-cairo
523
524* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
525- update to 1.9.1 (based on firefox 3.5)
526
527* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
528- update to 1.9.1rc3 (sync with firefox 3.5rc3)
529
530* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
531- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
532- remove old patches
533- require nspr >= 4.8
534
535* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
536- new upstream release
537
538* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
539- update mozconfig
540  - disable-system-cairo for stability
541
542* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
543- new upstream release
544
545* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
546- new upstream release
547- add ja locale
548
549* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
550- new upstream release
551
552* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
553- new upstream release
554
555* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
556- add Patch3
557
558* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
559- update to xulrunner 1.9.0.2 byild 6
560- build with gnome-2.24
561
562* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
563- new upstream release
564
565* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
566- initial build for Vine Linux
567
568* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
569- Update to 1.9 final
570
571* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
572- Simplify PS/PDF operators
573
574* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
575- Upstream patch to fsync() less
576
577* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
578- Ensure we enable startup notification; add BR and modify config
579  (bug #445543)
580
581* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
582- Some files moved to mozilla-filesystem; kill them and add the Req
583
584* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
585- Clean up the %%files list and get rid of the executable bit on some files
586
587* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
588- Fix font scaling
589
590* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
591- Enabled phishing protection (#443403)
592
593* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
594- Changed "__ppc64__" to "__powerpc64__",
595  "__ppc64__" doesn't work anymore
596- Added fix for #443725 - Critical hanging bug with fix
597  available upstream (mozbz#429903)
598
599* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
600- Fixed multilib issues, added starting script instead of a symlink
601  to binary (#436393)
602
603* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
604- Add upstream patches for dpi, toolbar buttons, and invalid keys
605- Re-enable system cairo
606
607* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
608- Spec cleanups
609
610* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
611- Beta 5
612
613* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
614- Beta 5 RC2
615
616* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
617- Update to latest trunk (2008-03-27)
618
619* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
620- Update to latest trunk (2008-03-26)
621
622* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
623- Update to latest trunk (2008-03-25)
624
625* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
626- Update to latest trunk (2008-03-24)
627
628* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
629- Update to latest trunk (2008-03-20)
630
631* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
632- Update to latest trunk (2008-03-17)
633
634* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
635- Revert to trunk from the 15th to fix crashes on HTTPS sites
636
637* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
638- Update to latest trunk (2008-03-16)
639- Add patch to negate a11y slowdown on some pages (#431162)
640
641* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
642- Update to latest trunk (2008-03-15)
643
644* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
645- Avoid conflicts between gecko debuginfo packages
646
647* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
648- Update to latest trunk (2008-03-12)
649
650* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
651- Update to latest trunk (2008-03-11)
652
653* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
654- Update to latest trunk (2008-03-10)
655
656* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
657- Update to latest trunk (2008-03-09)
658
659* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
660- Update to latest trunk (2008-03-07)
661
662* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
663- Update to latest trunk (2008-03-06)
664
665* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
666- Update to latest trunk (2008-03-04)
667
668* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
669- Update to latest trunk (2008-03-02)
670
671* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
672- Update to latest trunk (2008-03-01)
673
674* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
675- Update to latest trunk (2008-02-29)
676
677* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
678- Update to latest trunk (2008-02-28)
679
680* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
681- Update to latest trunk (2008-02-27)
682
683* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
684- Update to latest trunk (2008-02-26)
685
686* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
687- Update to latest trunk (2008-02-23)
688
689* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
690- Update to latest trunk (2008-02-22)
691
692* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
693- Update to latest trunk (2008-02-21)
694
695* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
696- Update to latest trunk (2008-02-20)
697
698* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
699- Update to latest trunk (2008-02-17)
700
701* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
702- Update to latest trunk (2008-02-15)
703
704* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
705- Update to latest trunk (2008-02-14)
706- Use system hunspell
707
708* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
709- Update to latest trunk (2008-02-11)
710
711* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
712- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
713  you know, debuginfo.
714
715* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
716- Update to latest trunk (2008-02-10)
717
718* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
719- Update to latest trunk (2008-02-09)
720
721* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
722- Update to latest trunk (2008-02-06)
723
724* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
725- Update to latest trunk (2008-01-30)
726
727* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
728- rebuild agains new nss
729- enabled gnome vfs
730
731* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
732- fixed stable pkg-config files (#429654)
733- removed sqlite patch
734
735* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
736- Update to latest trunk (2008-01-21)
737
738* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
739- Update to latest trunk (2008-01-15)
740- Now with system extensions directory support
741
742* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
743- Update to latest trunk (2008-01-13)
744- Use CFLAGS instead of configure arguments
745- Random cleanups: BuildRequires, scriptlets, prefs, etc.
746
747* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
748- Provide gecko-devel-unstable as well
749
750* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
751- divided devel package to devel and devel-unstable
752
753* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
754- removed fedora specific pkg-config files
755- updated to the latest trunk (2008-01-07)
756- removed unnecessary patches
757- fixed idl dir (#427965)
758
759* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
760- Re-enable camellia256 support now that NSS supports it
761
762* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
763- updated to the latest trunk (2008-01-03)
764
765* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
766- Don't Provide webclient (xulrunner is not itself a webclient)
767- Don't Obsolete old firefox, only firefox-devel
768- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
769
770* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
771- added java and plugin subdirs to plugin includes
772
773* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
774- dependency fixes, obsoletes firefox < 3 and firefox-devel now
775
776* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
777- updated to Beta 2.
778- moved SDK to xulrunner-sdk
779
780* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
781- fixed mozilla-plugin.pc (#412971)
782
783* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
784- export /etc/gre.d/gre.conf (it's used by python gecko applications)
785
786* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
787- added xulrunner/js include dir to xulrunner-js
788
789* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
790- update to beta 1
791
792* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
793- packed all gecko libraries (#389391)
794
795* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
796- registered xulrunner libs system-wide
797- added xulrunner-gtkmozembed.pc
798
799* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
800- added proper nss/nspr dependencies
801
802* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
803- more build fixes, use system nss libraries
804
805* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
806- build fixes
807
808* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
809- updated to the latest trunk
810
811* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
812- build fixes for ppc/ppc64
813
814* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
815- removed conflicts with the current gecko-based apps
816- added updated ppc64 patch
817
818* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
819- build fixes
820
821* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
822- Initial cut at XULRunner 1.9 Alpha 7
823- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.