source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 1241

Revision 1241, 25.3 KB checked in by shaolin, 14 years ago (diff)
  • xulrunner-1.9.2.4-2
    • enable ipc only on ix86/x86_64 arches
Line 
1%define nspr_version 4.8
2%define nss_version 3.12
3%define cairo_version 1.8.6
4%define libnotify_version 0.4
5%define tarballdir mozilla-1.9.2
6
7%define build_vine6 0
8%define build_vine5 0
9%if "%{?_dist_release}" == "vl6"
10%define build_vine6 1
11%define build_vine5 1
12%endif
13%if "%{?_dist_release}" == "vl5"
14%define build_vine5 1
15%endif
16
17%if %build_vine6
18%define sqlite_version 3.6.21
19%endif
20
21%define version_internal  1.9.2
22%define mozappdir         %{_libdir}/%{name}-%{version_internal}
23
24# Separated plugins are supported on x86(64) only
25%ifarch %{ix86} x86_64
26%define separated_plugins 1
27%else
28%define separated_plugins 0
29%endif
30
31Summary:        XUL Runtime for Gecko Applications
32Summary(ja):    Gecko アプリケーションのための XUL ランタイム
33Name:           xulrunner
34Version:        1.9.2.4
35Release:        2%{?_dist_release}
36URL:            http://www.mozilla.org/projects/xulrunner/
37License:        MPLv1.1 or GPLv2+ or LGPLv2+
38Group:          Applications/Internet
39Source0:        %{name}-%{version}-source.tar.bz2
40Source10:       %{name}-mozconfig
41Source11:       %{name}-mozconfig-vine5
42Source12:       %{name}-vine-default-prefs.js
43Source21:       %{name}.sh.in
44Source23:       %{name}.1
45
46# locale sources
47%define MOZ_BUILD_LOCALES "ja"
48Source1000:     xulrunner-%{version}-ja.tar.bz2
49
50# build patches
51Patch0:         xulrunner-version.patch
52Patch1:         mozilla-build.patch
53Patch3:         mozilla-jemalloc.patch
54Patch5:         mozilla-jemalloc-526152.patch
55Patch7:         xulrunner-1.9.2.1-build.patch
56Patch8:         mozilla-plugin.patch
57Patch9:         mozilla-build-sbrk.patch
58Patch10:        firefox-3.6.4-ipc-chromium-nspr4.patch
59
60# patches from Fedora
61Patch100:       mozilla-192-pkgconfig.patch
62
63# Upstream patches
64Patch200:        mozilla-ps-pdf-simplify-operators.patch
65
66
67# ---------------------------------------------------
68
69BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
70BuildRequires:  nspr-devel >= %{nspr_version}
71BuildRequires:  nss-devel >= %{nss_version}
72BuildRequires:  cairo-devel >= %{cairo_version}
73BuildRequires:  libpng-devel
74BuildRequires:  libjpeg-devel
75BuildRequires:  bzip2-devel
76BuildRequires:  zlib-devel
77BuildRequires:  lcms-devel
78BuildRequires:  libIDL-devel
79BuildRequires:  gtk2-devel
80BuildRequires:  gnome-vfs2-devel
81BuildRequires:  libgnome-devel
82BuildRequires:  libgnomeui-devel
83BuildRequires:  pango-devel
84BuildRequires:  freetype2-devel >= 2.1.9
85BuildRequires:  libXt-devel
86BuildRequires:  libXrender-devel
87%if %{build_vine6}
88BuildRequires:  sqlite3-devel >= %{sqlite_version}
89%endif
90BuildRequires:  libnotify-devel >= %{libnotify_version}
91BuildRequires:  startup-notification-devel
92BuildRequires:  alsa-lib-devel
93BuildRequires:  lcms-devel
94BuildRequires:  zip
95# For -sqlite.patch
96BuildRequires:  autoconf213
97
98Requires:       nspr >= %{nspr_version}
99Requires:       nss >= %{nss_version}
100
101Provides:       gecko-libs = %{version}
102
103%description
104XULRunner provides the XUL Runtime environment for Gecko applications.
105
106%package devel
107Summary: Development files for Gecko
108Group: Development/Libraries
109
110Obsoletes: mozilla-devel
111Obsoletes: firefox-devel < 2.1
112Obsoletes: xulrunner-devel-unstable
113
114Provides: gecko-devel = %{version}
115Provides: gecko-devel-unstable = %{version}
116
117Requires: xulrunner = %{version}-%{release}
118Requires: nspr-devel >= %{nspr_version}
119Requires: nss-devel >= %{nss_version}
120Requires: cairo-devel >= %{cairo_version}
121Requires: libjpeg-devel
122Requires: zip
123Requires: bzip2-devel
124Requires: zlib-devel
125Requires: lcms-devel
126Requires: libIDL-devel
127Requires: gtk2-devel
128Requires: gnome-vfs2-devel
129Requires: libgnome-devel
130Requires: libgnomeui-devel
131Requires: pango-devel
132Requires: freetype2-devel >= 2.1.9
133Requires: libXt-devel
134Requires: libXrender-devel
135%if %{build_vine6}
136Requires: sqlite3-devel >= %{sqlite_version}
137%endif
138Requires: startup-notification-devel
139Requires: alsa-lib-devel
140
141%description devel
142Gecko development files.
143
144#---------------------------------------------------------------------
145
146%prep
147%setup -q -c -b 1000
148cd %{tarballdir}
149
150sed -e 's/__RPM_VERSION_INTERNAL__/%{version_internal}/' \
151    %{P:%%PATCH0} > version.patch
152%{__patch} -p1 -b --suffix .version < version.patch
153
154%patch1  -p1 -b .build
155%patch3  -p1 -b .jemalloc
156%patch5  -p1 -b .jemalloc-526152
157%patch7  -p2 -b .del
158%patch8  -p1 -b .plugin
159%patch9  -p2 -b .sbrk
160%patch10 -p1 -b .nspr4
161
162%patch100 -p1 -b .pkgconfig
163
164%patch200 -p1 -b .ps-pdf-simplify-operators
165
166%{__rm} -f .mozconfig
167%if %{build_vine6}
168%{__cp} %{SOURCE10} .mozconfig
169%else
170%{__cp} %{SOURCE11} .mozconfig
171%endif
172
173%if !%{?separated_plugins}
174echo "ac_add_options --disable-ipc" >> .mozconfig
175%endif
176
177#---------------------------------------------------------------------
178
179%build
180cd %{tarballdir}
181
182INTERNAL_GECKO=%{version_internal}
183MOZ_APP_DIR=%{_libdir}/%{name}-${INTERNAL_GECKO}
184
185# Mozilla builds with -Wall with exception of a few warnings which show up
186# everywhere in the code; so, don't override that.
187MOZ_OPT_FLAGS=$(echo $RPM_OPT_FLAGS | %{__sed} -e 's/-Wall//')
188export CFLAGS=$MOZ_OPT_FLAGS
189export CXXFLAGS=$MOZ_OPT_FLAGS
190
191export PREFIX='%{_prefix}'
192export LIBDIR='%{_libdir}'
193
194MOZ_SMP_FLAGS=-j1
195%ifnarch ppc ppc64 s390 s390x
196[ -z "$RPM_BUILD_NCPUS" ] && \
197     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
198[ "$RPM_BUILD_NCPUS" -gt 1 ] && MOZ_SMP_FLAGS=-j2
199%endif
200
201export LDFLAGS="-Wl,-rpath,${MOZ_APP_DIR}"
202make -f client.mk configure STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
203make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
204
205# build locales
206LOCALEDIRS=`find . -print | grep 'locales/Makefile$' | \
207            sed -e 's|\./\(.*\)/locales/.*|\1|g'`
208for dir in $LOCALEDIRS
209do
210  for lang in %{MOZ_BUILD_LOCALES} ; do
211    make -C $dir/locales AB_CD=$lang
212  done
213done
214
215#---------------------------------------------------------------------
216
217%install
218cd %{tarballdir}
219%{__rm} -rf $RPM_BUILD_ROOT
220
221INTERNAL_GECKO=%{version_internal}
222
223INTERNAL_APP_NAME=%{name}-${INTERNAL_GECKO}
224MOZ_APP_DIR=%{_libdir}/${INTERNAL_APP_NAME}
225
226INTERNAL_APP_SDK_NAME=%{name}-sdk-${INTERNAL_GECKO}
227MOZ_APP_SDK_DIR=%{_libdir}/${INTERNAL_APP_SDK_NAME}
228
229#DESTDIR=$RPM_BUILD_ROOT make -f client.mk install STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS"
230DESTDIR=$RPM_BUILD_ROOT make install
231
232%{__mkdir_p} $RPM_BUILD_ROOT/${MOZ_APP_DIR} \
233             $RPM_BUILD_ROOT%{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
234             $RPM_BUILD_ROOT%{_includedir}/${INTERNAL_APP_SDK_NAME}
235%{__install} -p dist/sdk/bin/regxpcom $RPM_BUILD_ROOT/$MOZ_APP_DIR
236
237%{__mkdir_p} $RPM_BUILD_ROOT{%{_libdir},%{_bindir},%{_datadir}/applications}
238
239# set up our default preferences
240%{__cat} %{SOURCE12} | %{__sed} -e 's,RPM_VERREL,%{version}-%{release},g' > vl-default-prefs
241%{__install} -p -D -m 644 vl-default-prefs $RPM_BUILD_ROOT/${MOZ_APP_DIR}/defaults/pref/all-vine.js
242%{__rm} vl-default-prefs
243
244# Start script install
245%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
246%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{version_internal},g' > \
247  $RPM_BUILD_ROOT%{_bindir}/%{name}
248%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
249
250%{__rm} -f $RPM_BUILD_ROOT${MOZ_APP_DIR}/%{name}-config
251
252cd $RPM_BUILD_ROOT${MOZ_APP_DIR}/chrome
253find . -name "*" -type d -maxdepth 1 -exec %{__rm} -rf {} \;
254cd -
255
256# install locales
257for lang in %{MOZ_BUILD_LOCALES} ; do
258  %{__install} -p -D -m 664 dist/bin/chrome/$lang.{jar,manifest} $RPM_BUILD_ROOT/${MOZ_APP_DIR}/chrome/
259done
260
261# Prepare our devel package
262%{__mkdir_p} $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
263%{__mkdir_p} $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_SDK_NAME}
264%{__mkdir_p} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig
265
266%{__cp} -rL dist/include/* \
267  $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
268
269# Copy pc files (for compatibility with 1.9.1)
270%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
271        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
272%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
273        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
274
275# Fix multilib devel conflicts...
276%ifarch x86_64 ia64 s390x ppc64
277%define mozbits 64
278%else
279%define mozbits 32
280%endif
281
282function install_file() {
283genheader=$*
284mv ${genheader}.h ${genheader}%{mozbits}.h
285cat > ${genheader}.h << EOF
286// This file exists to fix multilib conflicts
287#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__)
288#include "${genheader}64.h"
289#else
290#include "${genheader}32.h"
291#endif
292EOF
293}
294
295pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
296install_file "mozilla-config"
297popd
298
299pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_SDK_NAME}
300install_file "jsautocfg"
301popd
302
303%{__install} -p -c -m 755 dist/bin/xpcshell \
304  dist/bin/xpidl \
305  dist/bin/xpt_dump \
306  dist/bin/xpt_link \
307  $RPM_BUILD_ROOT/${MOZ_APP_DIR}
308
309%{__rm} -rf $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
310%{__rm} -rf $RPM_BUILD_ROOT/%{_datadir}/idl/${INTERNAL_APP_NAME}
311
312%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
313ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
314       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/include
315
316%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
317ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
318       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/idl
319
320%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
321ln -s  %{_includedir}/${INTERNAL_APP_SDK_NAME} \
322       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/include
323
324%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
325ln -s  %{_datadir}/idl/${INTERNAL_APP_SDK_NAME} \
326       $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/idl
327
328find $RPM_BUILD_ROOT/%{_includedir} -type f -name "*.h" | xargs chmod 644
329find $RPM_BUILD_ROOT/%{_datadir}/idl -type f -name "*.idl" | xargs chmod 644
330
331%{__rm} -rf $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/*.so
332pushd $RPM_BUILD_ROOT${MOZ_APP_DIR}
333for i in *.so; do
334    ln -s ${MOZ_APP_DIR}/$i $RPM_BUILD_ROOT${MOZ_APP_SDK_DIR}/sdk/lib/$i
335done
336popd
337
338# GRE stuff
339%ifarch x86_64 ia64 ppc64 s390x
340%define gre_conf_file gre64.conf
341%else
342%define gre_conf_file gre.conf
343%endif
344
345MOZILLA_GECKO_VERSION=`./config/milestone.pl --topsrcdir=.`
346%{__mv} $RPM_BUILD_ROOT/etc/gre.d/$MOZILLA_GECKO_VERSION".system.conf" \
347        $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
348chmod 644 $RPM_BUILD_ROOT/etc/gre.d/%{gre_conf_file}
349
350# Library path
351%ifarch x86_64 ia64 ppc64 s390x
352%define ld_conf_file xulrunner-64.conf
353%else
354%define ld_conf_file xulrunner-32.conf
355%endif
356
357%{__mkdir_p} $RPM_BUILD_ROOT/etc/ld.so.conf.d
358%{__cat} > $RPM_BUILD_ROOT/etc/ld.so.conf.d/%{ld_conf_file} << EOF
359${MOZ_APP_DIR}
360EOF
361                       
362# Copy over the LICENSE
363%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT${MOZ_APP_DIR}
364
365# Use the system hunspell dictionaries
366%{__rm} -rf ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
367ln -s %{_datadir}/myspell ${RPM_BUILD_ROOT}${MOZ_APP_DIR}/dictionaries
368
369# ghost files
370%{__mkdir_p} $RPM_BUILD_ROOT${MOZ_APP_DIR}/components
371touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/compreg.dat
372touch $RPM_BUILD_ROOT${MOZ_APP_DIR}/components/xpti.dat
373
374#---------------------------------------------------------------------
375
376%clean
377%{__rm} -rf $RPM_BUILD_ROOT
378
379#---------------------------------------------------------------------
380
381%post
382/sbin/ldconfig
383
384%postun
385/sbin/ldconfig
386
387%preun
388# is it a final removal?
389if [ $1 -eq 0 ]; then
390  %{__rm} -rf ${MOZ_APP_DIR}/components
391fi
392
393%files
394%defattr(-,root,root,-)
395%{_bindir}/xulrunner
396%dir /etc/gre.d
397/etc/gre.d/%{gre_conf_file}
398%dir %{mozappdir}
399%doc %attr(644, root, root) %{mozappdir}/LICENSE
400%doc %attr(644, root, root) %{mozappdir}/README.txt
401%{mozappdir}/chrome
402%{mozappdir}/dictionaries
403%dir %{mozappdir}/components
404%ghost %{mozappdir}/components/compreg.dat
405%ghost %{mozappdir}/components/xpti.dat
406%{mozappdir}/components/*.so
407%{mozappdir}/components/*.xpt
408%attr(644, root, root) %{mozappdir}/components/*.js
409%{mozappdir}/defaults
410%{mozappdir}/greprefs
411%dir %{mozappdir}/icons
412%attr(644, root, root) %{mozappdir}/icons/*
413%{mozappdir}/modules
414%{mozappdir}/plugins
415%{mozappdir}/res
416%{mozappdir}/*.so
417%{mozappdir}/mozilla-xremote-client
418%{mozappdir}/run-mozilla.sh
419%{mozappdir}/regxpcom
420%{mozappdir}/xulrunner
421%{mozappdir}/xulrunner-bin
422%{mozappdir}/xulrunner-stub
423%if %{?separated_plugins}
424%{mozappdir}/plugin-container
425%endif
426%{mozappdir}/platform.ini
427%{mozappdir}/dependentlibs.list
428%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
429
430# XXX See if these are needed still
431%{mozappdir}/updater*
432%exclude %{mozappdir}/update.locale
433%exclude %{mozappdir}/components/components.list
434
435%files devel
436%defattr(-,root,root,-)
437%dir %{_datadir}/idl/%{name}*%{version_internal}
438%{_datadir}/idl/%{name}*%{version_internal}/*
439%{_includedir}/%{name}*%{version_internal}
440%dir %{_libdir}/%{name}-sdk-*
441%dir %{_libdir}/%{name}-sdk-*/sdk
442%{_libdir}/%{name}-sdk-*/*
443%{_libdir}/%{name}-sdk-*/sdk/*
444%{_libdir}/pkgconfig/*.pc
445%{mozappdir}/xpcshell
446%{mozappdir}/xpidl
447%{mozappdir}/xpt_dump
448%{mozappdir}/xpt_link
449
450#---------------------------------------------------------------------
451
452%changelog
453* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
454- enable ipc only on ix86/x86_64 arches
455
456* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
457- update to 1.9.2.4 (sync with firefox-3.6.4)
458- add patch10 to fix build failure
459
460* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
461- update to 1.9.2.3 (sync with firefox-3.6.3)
462
463* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
464- update to 1.9.2.2 (sync with firefox-3.6.2)
465- add patch7,9 for fix build failure
466
467* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
468- enable libnotify support
469  - add ac_add_options --enable-libnotify
470- disable Necko wifi monitor
471  - add ac_add_options --disable-necko-wifi
472  - remove BR: wireless-tools-devel
473- fix %%files devel
474- add patch3,5 to fix jemalloc alignment assertion
475- add Patch8 to fix mozilla-plugin.pc
476
477* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
478- add BR: libnotify-devel, wireless-tools-devel
479
480* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
481- update to 1.9.2 (sync with firefox-3.6)
482- obsoletes xulrunner-devel-unstable
483
484* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
485- use internal sqlite3 on vine5
486
487* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
488- update to 1.9.1.7
489
490* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
491- update to 1.9.1.6
492- build with sqlite3-3.6.21
493
494* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
495- update to 1.9.1.5
496
497* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
498- update to 1.9.1.3
499
500* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
501- really update to 1.9.1.2 (<BTS:0748>)
502
503* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
504- update to 1.9.1.2 (sync with firefox-3.5.2)
505
506* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
507- update to 1.9.1.1 (sync with firefox-3.5.1)
508- add missing Requires to -devel
509- add missing BR
510
511* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
512- enable-system-cairo
513
514* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
515- update to 1.9.1 (based on firefox 3.5)
516
517* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
518- update to 1.9.1rc3 (sync with firefox 3.5rc3)
519
520* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
521- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
522- remove old patches
523- require nspr >= 4.8
524
525* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
526- new upstream release
527
528* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
529- update mozconfig
530  - disable-system-cairo for stability
531
532* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
533- new upstream release
534
535* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
536- new upstream release
537- add ja locale
538
539* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
540- new upstream release
541
542* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
543- new upstream release
544
545* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
546- add Patch3
547
548* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
549- update to xulrunner 1.9.0.2 byild 6
550- build with gnome-2.24
551
552* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
553- new upstream release
554
555* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
556- initial build for Vine Linux
557
558* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
559- Update to 1.9 final
560
561* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
562- Simplify PS/PDF operators
563
564* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
565- Upstream patch to fsync() less
566
567* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
568- Ensure we enable startup notification; add BR and modify config
569  (bug #445543)
570
571* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
572- Some files moved to mozilla-filesystem; kill them and add the Req
573
574* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
575- Clean up the %%files list and get rid of the executable bit on some files
576
577* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
578- Fix font scaling
579
580* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
581- Enabled phishing protection (#443403)
582
583* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
584- Changed "__ppc64__" to "__powerpc64__",
585  "__ppc64__" doesn't work anymore
586- Added fix for #443725 - Critical hanging bug with fix
587  available upstream (mozbz#429903)
588
589* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
590- Fixed multilib issues, added starting script instead of a symlink
591  to binary (#436393)
592
593* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
594- Add upstream patches for dpi, toolbar buttons, and invalid keys
595- Re-enable system cairo
596
597* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
598- Spec cleanups
599
600* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
601- Beta 5
602
603* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
604- Beta 5 RC2
605
606* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
607- Update to latest trunk (2008-03-27)
608
609* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
610- Update to latest trunk (2008-03-26)
611
612* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
613- Update to latest trunk (2008-03-25)
614
615* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
616- Update to latest trunk (2008-03-24)
617
618* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
619- Update to latest trunk (2008-03-20)
620
621* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
622- Update to latest trunk (2008-03-17)
623
624* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
625- Revert to trunk from the 15th to fix crashes on HTTPS sites
626
627* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
628- Update to latest trunk (2008-03-16)
629- Add patch to negate a11y slowdown on some pages (#431162)
630
631* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
632- Update to latest trunk (2008-03-15)
633
634* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
635- Avoid conflicts between gecko debuginfo packages
636
637* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
638- Update to latest trunk (2008-03-12)
639
640* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
641- Update to latest trunk (2008-03-11)
642
643* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
644- Update to latest trunk (2008-03-10)
645
646* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
647- Update to latest trunk (2008-03-09)
648
649* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
650- Update to latest trunk (2008-03-07)
651
652* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
653- Update to latest trunk (2008-03-06)
654
655* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
656- Update to latest trunk (2008-03-04)
657
658* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
659- Update to latest trunk (2008-03-02)
660
661* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
662- Update to latest trunk (2008-03-01)
663
664* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
665- Update to latest trunk (2008-02-29)
666
667* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
668- Update to latest trunk (2008-02-28)
669
670* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
671- Update to latest trunk (2008-02-27)
672
673* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
674- Update to latest trunk (2008-02-26)
675
676* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
677- Update to latest trunk (2008-02-23)
678
679* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
680- Update to latest trunk (2008-02-22)
681
682* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
683- Update to latest trunk (2008-02-21)
684
685* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
686- Update to latest trunk (2008-02-20)
687
688* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
689- Update to latest trunk (2008-02-17)
690
691* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
692- Update to latest trunk (2008-02-15)
693
694* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
695- Update to latest trunk (2008-02-14)
696- Use system hunspell
697
698* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
699- Update to latest trunk (2008-02-11)
700
701* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
702- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
703  you know, debuginfo.
704
705* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
706- Update to latest trunk (2008-02-10)
707
708* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
709- Update to latest trunk (2008-02-09)
710
711* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
712- Update to latest trunk (2008-02-06)
713
714* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
715- Update to latest trunk (2008-01-30)
716
717* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
718- rebuild agains new nss
719- enabled gnome vfs
720
721* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
722- fixed stable pkg-config files (#429654)
723- removed sqlite patch
724
725* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
726- Update to latest trunk (2008-01-21)
727
728* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
729- Update to latest trunk (2008-01-15)
730- Now with system extensions directory support
731
732* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
733- Update to latest trunk (2008-01-13)
734- Use CFLAGS instead of configure arguments
735- Random cleanups: BuildRequires, scriptlets, prefs, etc.
736
737* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
738- Provide gecko-devel-unstable as well
739
740* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
741- divided devel package to devel and devel-unstable
742
743* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
744- removed fedora specific pkg-config files
745- updated to the latest trunk (2008-01-07)
746- removed unnecessary patches
747- fixed idl dir (#427965)
748
749* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
750- Re-enable camellia256 support now that NSS supports it
751
752* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
753- updated to the latest trunk (2008-01-03)
754
755* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
756- Don't Provide webclient (xulrunner is not itself a webclient)
757- Don't Obsolete old firefox, only firefox-devel
758- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
759
760* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
761- added java and plugin subdirs to plugin includes
762
763* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
764- dependency fixes, obsoletes firefox < 3 and firefox-devel now
765
766* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
767- updated to Beta 2.
768- moved SDK to xulrunner-sdk
769
770* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
771- fixed mozilla-plugin.pc (#412971)
772
773* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
774- export /etc/gre.d/gre.conf (it's used by python gecko applications)
775
776* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
777- added xulrunner/js include dir to xulrunner-js
778
779* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
780- update to beta 1
781
782* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
783- packed all gecko libraries (#389391)
784
785* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
786- registered xulrunner libs system-wide
787- added xulrunner-gtkmozembed.pc
788
789* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
790- added proper nss/nspr dependencies
791
792* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
793- more build fixes, use system nss libraries
794
795* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
796- build fixes
797
798* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
799- updated to the latest trunk
800
801* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
802- build fixes for ppc/ppc64
803
804* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
805- removed conflicts with the current gecko-based apps
806- added updated ppc64 patch
807
808* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
809- build fixes
810
811* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
812- Initial cut at XULRunner 1.9 Alpha 7
813- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.