source: projects/specs/trunk/x/xulrunner/xulrunner-vl.spec @ 7314

Revision 7314, 24.5 KB checked in by daisuke, 11 years ago (diff)

xulrunner:

  • update to 17.0.2esr
  • remove /etc/ld.so.conf.d/xulrunner*.conf
Line 
1# Minimal required versions
2%global nspr_version 4.8.9
3%global nss_version 3.13.1
4%global cairo_version 1.10.2
5%global freetype_version 2.1.9
6%global libnotify_version 0.7.0
7
8# gecko_dir_ver should be set to the version in our directory names
9# alpha_version should be set to the alpha number if using an alpha, 0 otherwise
10# beta_version  should be set to the beta number if using a beta, 0 otherwise
11# rc_version    should be set to the RC number if using an RC, 0 otherwise
12%global gecko_dir_ver %{version}
13%global alpha_version 0
14%global beta_version  0
15%global rc_version    0
16
17%global mozappdir   %{_libdir}/%{name}
18%global tarballdir  mozilla-esr17
19
20Summary:        XUL Runtime for Gecko Applications
21Summary(ja):    Gecko アプリケーションのための XUL ランタイム
22Name:           xulrunner
23Version:        17.0.2
24Release:        1%{?_dist_release}
25URL:            http://developer.mozilla.org/En/XULRunner
26License:        MPLv1.1 or GPLv2+ or LGPLv2+
27Group:          Applications/Internet
28# You can get sources at ftp://ftp.mozilla.org/pub/firefox/releases/%{version}/source
29Source0:        %{name}-%{version}esr.source.tar.bz2
30Source10:       %{name}-mozconfig-vine
31Source12:       %{name}-redhat-default-prefs.js
32Source21:       %{name}.sh.in
33
34# build patches
35Patch1:         xulrunner-install-dir.patch
36Patch2:         mozilla-build.patch
37Patch14:        xulrunner-2.0-chromium-types.patch
38Patch17:        xulrunner-15.0-gcc47.patch
39# https://bugzilla.redhat.com/show_bug.cgi?id=814879#c3
40Patch18:        xulrunner-16.0-jemalloc-ppc.patch
41
42# Fedora specific patches
43Patch20:        mozilla-193-pkgconfig.patch
44
45# Upstream patches
46Patch49:        mozilla-746112.patch
47Patch50:        mozilla-813997.patch
48
49# ---------------------------------------------------
50
51BuildRequires:  nspr-devel >= %{nspr_version}
52BuildRequires:  nss-devel >= %{nss_version}
53BuildRequires:  cairo-devel >= %{cairo_version}
54BuildRequires:  libpng-devel
55BuildRequires:  libjpeg-turbo-devel
56BuildRequires:  zip
57BuildRequires:  bzip2-devel
58BuildRequires:  zlib-devel
59BuildRequires:  libIDL-devel
60BuildRequires:  gtk2-devel
61BuildRequires:  krb5-devel
62BuildRequires:  pango-devel
63BuildRequires:  freetype2-devel >= %{freetype_version}
64BuildRequires:  libXt-devel
65BuildRequires:  libXrender-devel
66BuildRequires:  startup-notification-devel
67BuildRequires:  alsa-lib-devel
68BuildRequires:  libnotify-devel >= %{libnotify_version}
69BuildRequires:  mesa-libGL-devel
70BuildRequires:  curl-devel
71BuildRequires:  yasm
72
73Requires:       nspr
74Requires:       nss
75Provides:       gecko-libs = %{gecko_verrel}
76Conflicts:      firefox < 3.6
77
78Vendor: Project Vine
79Distribution: Vine Linux
80Packager: daisuke
81
82%description
83XULRunner is a Mozilla runtime package that can be used to bootstrap XUL+XPCOM
84applications that are as rich as Firefox and Thunderbird. It provides mechanisms
85for installing, upgrading, and uninstalling these applications. XULRunner also
86provides libxul, a solution which allows the embedding of Mozilla technologies
87in other projects and products.
88
89%package devel
90Summary: Development files for Gecko
91Summary(ja):  Geckoの開発ファイル
92Group: Development/Libraries
93Obsoletes: mozilla-devel < 1.9
94Obsoletes: firefox-devel < 2.1
95Obsoletes: xulrunner-devel-unstable
96Provides: gecko-devel = %{gecko_verrel}
97Provides: gecko-devel-unstable = %{gecko_verrel}
98
99Requires: xulrunner = %{version}-%{release}
100Requires: nspr-devel
101Requires: nss-devel
102Requires: cairo-devel
103Requires: libjpeg-devel
104Requires: zip
105Requires: bzip2-devel
106Requires: zlib-devel
107Requires: libIDL-devel
108Requires: gtk2-devel
109Requires: krb5-devel
110Requires: pango-devel
111Requires: freetype-devel
112Requires: libXt-devel
113Requires: libXrender-devel
114Requires: startup-notification-devel
115Requires: alsa-lib-devel
116Requires: libnotify-devel
117Requires: mesa-libGL-devel
118
119%description devel
120This package contains the libraries amd header files that are needed
121for writing XUL+XPCOM applications with Mozilla XULRunner and Gecko.
122
123#---------------------------------------------------------------------
124
125%prep
126%setup -q -c
127cd %{tarballdir}
128
129%patch1  -p1
130%patch2  -p1 -b .build
131%patch14 -p2 -b .chromium-types
132%patch17 -p2 -b .gcc47
133%patch18 -p2 -b .jemalloc-ppc
134
135%patch20 -p2 -b .pk
136
137%patch49 -p2 -b .746112
138%patch50 -p1 -b .813997
139
140%{__rm} -f .mozconfig
141%{__cp} %{SOURCE10} .mozconfig
142
143echo "ac_add_options --disable-system-sqlite" >> .mozconfig
144
145%ifarch armv7hl
146echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
147echo "ac_add_options --with-float-abi=hard" >> .mozconfig
148echo "ac_add_options --with-fpu=vfpv3-d16" >> .mozconfig
149echo "ac_add_options --disable-elf-hack" >> .mozconfig
150%endif
151%ifarch armv7hnl
152echo "ac_add_options --with-arch=armv7-a" >> .mozconfig
153echo "ac_add_options --with-float-abi=hard" >> .mozconfig
154echo "ac_add_options --with-fpu=neon" >> .mozconfig
155echo "ac_add_options --disable-elf-hack" >> .mozconfig
156%endif
157%ifarch armv5tel
158echo "ac_add_options --with-arch=armv5te" >> .mozconfig
159echo "ac_add_options --with-float-abi=soft" >> .mozconfig
160echo "ac_add_options --disable-elf-hack" >> .mozconfig
161%endif
162
163%ifnarch %{ix86} x86_64
164echo "ac_add_options --disable-methodjit" >> .mozconfig
165echo "ac_add_options --disable-monoic" >> .mozconfig
166echo "ac_add_options --disable-polyic" >> .mozconfig
167echo "ac_add_options --disable-tracejit" >> .mozconfig
168%endif
169
170#---------------------------------------------------------------------
171
172%build
173cd %{tarballdir}
174
175# -fpermissive is needed to build with gcc 4.6+ which has become stricter
176#
177# Mozilla builds with -Wall with exception of a few warnings which show up
178# everywhere in the code; so, don't override that.
179#
180# Disable C++ exceptions since Mozilla code is not exception-safe
181#
182MOZ_OPT_FLAGS=$(echo "$RPM_OPT_FLAGS -fpermissive" | \
183                      %{__sed} -e 's/-Wall//' -e 's/-fexceptions/-fno-exceptions/g')
184export CFLAGS=$MOZ_OPT_FLAGS
185export CXXFLAGS=$MOZ_OPT_FLAGS
186
187export PREFIX='%{_prefix}'
188export LIBDIR='%{_libdir}'
189
190MOZ_SMP_FLAGS=-j1
191# On x86 architectures, Mozilla can build up to 4 jobs at once in parallel,
192# however builds tend to fail on other arches when building in parallel.
193%ifarch %{ix86} x86_64
194[ -z "$RPM_BUILD_NCPUS" ] && \
195     RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"
196[ "$RPM_BUILD_NCPUS" -ge 2 ] && MOZ_SMP_FLAGS=-j2
197[ "$RPM_BUILD_NCPUS" -ge 4 ] && MOZ_SMP_FLAGS=-j4
198%endif
199
200make -f client.mk build STRIP="/bin/true" MOZ_MAKE_FLAGS="$MOZ_SMP_FLAGS" MOZ_SERVICES_SYNC="1"
201
202#---------------------------------------------------------------------
203
204%install
205cd %{tarballdir}
206
207# set up our prefs before install, so it gets pulled in to omni.jar
208%{__cp} -p %{SOURCE12} dist/bin/defaults/pref/all-redhat.js
209
210DESTDIR=$RPM_BUILD_ROOT make install
211
212# Start script install
213%{__rm} -rf $RPM_BUILD_ROOT%{_bindir}/%{name}
214%{__cat} %{SOURCE21} | %{__sed} -e 's,XULRUNNER_VERSION,%{gecko_dir_ver},g' > \
215  $RPM_BUILD_ROOT%{_bindir}/%{name}
216%{__chmod} 755 $RPM_BUILD_ROOT%{_bindir}/%{name}
217
218%{__rm} -f $RPM_BUILD_ROOT%{mozappdir}/%{name}-config
219
220# Copy pc files (for compatibility with 1.9.1)
221%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul.pc \
222        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-unstable.pc
223%{__cp} $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding.pc \
224        $RPM_BUILD_ROOT/%{_libdir}/pkgconfig/libxul-embedding-unstable.pc
225
226# Fix multilib devel conflicts...
227function install_file() {
228genheader=$*
229mv ${genheader}.h ${genheader}%{__isa_bits}.h
230cat > ${genheader}.h << EOF
231/* This file exists to fix multilib conflicts */
232#if defined(__x86_64__) || defined(__ia64__) || defined(__s390x__) || defined(__powerpc64__) || (defined(__sparc__) && defined(__arch64__))
233#include "${genheader}64.h"
234#else
235#include "${genheader}32.h"
236#endif
237EOF
238}
239
240INTERNAL_APP_NAME=%{name}-%{gecko_dir_ver}
241
242pushd $RPM_BUILD_ROOT/%{_includedir}/${INTERNAL_APP_NAME}
243install_file "mozilla-config"
244install_file "js-config"
245popd
246
247# Link libraries in sdk directory instead of copying them:
248pushd $RPM_BUILD_ROOT%{_libdir}/%{name}-devel-%{gecko_dir_ver}/sdk/lib
249for i in *.so; do
250     rm $i
251     ln -s %{mozappdir}/$i $i
252done
253popd
254
255# Library path
256#LD_SO_CONF_D=%{_sysconfdir}/ld.so.conf.d
257#LD_CONF_FILE=xulrunner-%{__isa_bits}.conf
258
259#%{__mkdir_p} ${RPM_BUILD_ROOT}${LD_SO_CONF_D}
260#%{__cat} > ${RPM_BUILD_ROOT}${LD_SO_CONF_D}/${LD_CONF_FILE} << EOF
261#%{mozappdir}
262#EOF
263
264# Copy over the LICENSE
265%{__install} -p -c -m 644 LICENSE $RPM_BUILD_ROOT%{mozappdir}
266
267# Install xpcshell
268%{__cp} dist/bin/xpcshell $RPM_BUILD_ROOT/%{mozappdir}
269
270# Install run-mozilla.sh
271%{__cp} dist/bin/run-mozilla.sh $RPM_BUILD_ROOT/%{mozappdir}
272
273# ghost files
274%{__mkdir_p} $RPM_BUILD_ROOT%{mozappdir}/components
275touch $RPM_BUILD_ROOT%{mozappdir}/components/compreg.dat
276touch $RPM_BUILD_ROOT%{mozappdir}/components/xpti.dat
277
278#---------------------------------------------------------------------
279
280%post -p /sbin/ldconfig
281
282%postun -p /sbin/ldconfig
283
284%preun
285# is it a final removal?
286if [ $1 -eq 0 ]; then
287  %{__rm} -rf %{mozappdir}/components
288fi
289
290%files
291%defattr(-,root,root,-)
292%{_bindir}/xulrunner
293%dir %{mozappdir}
294%doc %attr(644, root, root) %{mozappdir}/LICENSE
295%doc %attr(644, root, root) %{mozappdir}/README.xulrunner
296%{mozappdir}/chrome
297%{mozappdir}/chrome.manifest
298%{mozappdir}/dictionaries
299%dir %{mozappdir}/components
300%ghost %{mozappdir}/components/compreg.dat
301%ghost %{mozappdir}/components/xpti.dat
302%{mozappdir}/components/*.so
303%{mozappdir}/components/*.manifest
304%{mozappdir}/omni.ja
305%{mozappdir}/plugins
306%{mozappdir}/*.so
307%{mozappdir}/mozilla-xremote-client
308%{mozappdir}/run-mozilla.sh
309%{mozappdir}/xulrunner
310%{mozappdir}/xulrunner-stub
311%{mozappdir}/platform.ini
312%{mozappdir}/dependentlibs.list
313#%{_sysconfdir}/ld.so.conf.d/xulrunner*.conf
314%{mozappdir}/plugin-container
315
316%files devel
317%defattr(-,root,root,-)
318%dir %{_libdir}/%{name}-devel-*
319%{_datadir}/idl/%{name}*%{gecko_dir_ver}
320%{_includedir}/%{name}*%{gecko_dir_ver}
321%{_libdir}/%{name}-devel-*/*
322%{_libdir}/pkgconfig/*.pc
323%{mozappdir}/xpcshell
324
325#---------------------------------------------------------------------
326
327%changelog
328* Fri Jan 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 17.0.2-1
329- update to 17.0.2esr
330- remove /etc/ld.so.conf.d/xulrunner*.conf
331
332* Wed Oct 10 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.8-1
333- update to 10.0.8esr
334
335* Sat Jul 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.6-1
336- update to 10.0.6 (based on firefox-10.0.6esr source)
337
338* Wed Mar 14 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 10.0.3-1
339- update to 10.0.3 (based on firefox-10.0.3esr source)
340- clean up spec
341
342* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.0.1-3
343- rebuild with libnotify-0.7
344
345* Tue May 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-2
346- modify gre.conf to promote internal gecko version.
347
348* Mon May 23 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0.1-1
349- update to 2.0.1 (sync with firefox-4.0.1)
350
351* Wed Mar 30 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.0-1
352- update to 2.0 (sync with firefox-4.0)
353- BR: libjpeg-turbo-devel >= 1.1.0
354- BR: nspr-devel >= 4.8.7
355- BR: nss-devel >= 3.12.9
356- BR: cairo-devel >= 1.10.2-2
357- add Patch130 to use omni.jar (upstream patch)
358
359* Thu Mar 10 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.15-1
360- update to 1.9.2.15 (sync with firefox-3.6.15)
361
362* Wed Mar 02 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.14-1
363- update to 1.9.2.14 (sync with firefox-3.6.14)
364
365* Sat Jan 08 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.13-1
366- update to 1.9.2.13 (sync with firefox-3.6.13)
367
368* Thu Oct 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.11-1
369- update to 1.9.2.11 (sync with firefox-3.6.11)
370
371* Thu Sep 23 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.9.2.9-2
372- rebuild with rpm-4.8.1 for pkg-config file
373
374* Mon Sep 13 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.9-1
375- update to 1.9.2.9 (sync with firefox-3.6.9)
376- add patch10 to build with libjpeg-turbo
377- build with sqlite-3.7.2
378- BR: nspr >= 4.8.6
379
380* Mon Jul 26 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.8-1
381- update tp 1.9.2.8 (sync with firefox-3.6.8)
382
383* Wed Jul 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.7-1
384- update tp 1.9.2.7 (sync with firefox-3.6.7)
385
386* Wed Jun 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.9.2.4-2
387- enable ipc only on ix86/x86_64 arches
388
389* Wed Jun 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.4-1
390- update to 1.9.2.4 (sync with firefox-3.6.4)
391- add patch10 to fix build failure
392
393* Sat Apr 03 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.3-1
394- update to 1.9.2.3 (sync with firefox-3.6.3)
395
396* Fri Apr 02 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2.2-1
397- update to 1.9.2.2 (sync with firefox-3.6.2)
398- add patch7,9 for fix build failure
399
400* Sat Jan 23 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-3
401- enable libnotify support
402  - add ac_add_options --enable-libnotify
403- disable Necko wifi monitor
404  - add ac_add_options --disable-necko-wifi
405  - remove BR: wireless-tools-devel
406- fix %%files devel
407- add patch3,5 to fix jemalloc alignment assertion
408- add Patch8 to fix mozilla-plugin.pc
409
410* Sat Jan 23 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1.9.2-2
411- add BR: libnotify-devel, wireless-tools-devel
412
413* Thu Jan 21 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.2-1
414- update to 1.9.2 (sync with firefox-3.6)
415- obsoletes xulrunner-devel-unstable
416
417* Sat Jan 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-2
418- use internal sqlite3 on vine5
419
420* Fri Jan 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.7-1
421- update to 1.9.1.7
422
423* Tue Jan 05 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.6-1
424- update to 1.9.1.6
425- build with sqlite3-3.6.21
426
427* Sat Nov 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.5-1
428- update to 1.9.1.5
429
430* Sun Oct 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.3-1
431- update to 1.9.1.3
432
433* Fri Aug 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-2
434- really update to 1.9.1.2 (<BTS:0748>)
435
436* Wed Aug 05 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.2-1
437- update to 1.9.1.2 (sync with firefox-3.5.2)
438
439* Sun Jul 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1.1-1
440- update to 1.9.1.1 (sync with firefox-3.5.1)
441- add missing Requires to -devel
442- add missing BR
443
444* Wed Jul 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-2
445- enable-system-cairo
446
447* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-1
448- update to 1.9.1 (based on firefox 3.5)
449
450* Tue Jun 30 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.2.rc3
451- update to 1.9.1rc3 (sync with firefox 3.5rc3)
452
453* Sun Jun 21 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.1-0.1.rc2
454- update to xulrunner 1.9.1rc2 (based on firefox 3.5rc2)
455- remove old patches
456- require nspr >= 4.8
457
458* Fri Jun 12 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.11-1
459- new upstream release
460
461* Sun May 03 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-2
462- update mozconfig
463  - disable-system-cairo for stability
464
465* Tue Apr 28 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.10-1
466- new upstream release
467
468* Sun Apr 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.9-1
469- new upstream release
470- add ja locale
471
472* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.7-1
473- new upstream release
474
475* Thu Oct 02 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.3-1
476- new upstream release
477
478* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-2
479- add Patch3
480
481* Fri Sep 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.2-1
482- update to xulrunner 1.9.0.2 byild 6
483- build with gnome-2.24
484
485* Fri Aug 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9.0.1-1
486- new upstream release
487
488* Sun Jun 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.9-1
489- initial build for Vine Linux
490
491* Tue Jun 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-1
492- Update to 1.9 final
493
494* Thu May 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.63
495- Simplify PS/PDF operators
496
497* Thu May 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.62
498- Upstream patch to fsync() less
499
500* Thu May 08 2008 Colin Walters <walters@redhat.com> 1.9-0.61
501- Ensure we enable startup notification; add BR and modify config
502  (bug #445543)
503
504* Wed Apr 30 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.60
505- Some files moved to mozilla-filesystem; kill them and add the Req
506
507* Mon Apr 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.59
508- Clean up the %%files list and get rid of the executable bit on some files
509
510* Sat Apr 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.58
511- Fix font scaling
512
513* Fri Apr 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.57
514- Enabled phishing protection (#443403)
515
516* Wed Apr 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.56
517- Changed "__ppc64__" to "__powerpc64__",
518  "__ppc64__" doesn't work anymore
519- Added fix for #443725 - Critical hanging bug with fix
520  available upstream (mozbz#429903)
521
522* Fri Apr 18 2008 Martin Stransky <stransky@redhat.com> 1.9-0.55
523- Fixed multilib issues, added starting script instead of a symlink
524  to binary (#436393)
525
526* Sat Apr 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.54
527- Add upstream patches for dpi, toolbar buttons, and invalid keys
528- Re-enable system cairo
529
530* Mon Apr  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.53
531- Spec cleanups
532
533* Wed Apr  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.52
534- Beta 5
535
536* Mon Mar 31 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.51
537- Beta 5 RC2
538
539* Thu Mar 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.50
540- Update to latest trunk (2008-03-27)
541
542* Wed Mar 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.49
543- Update to latest trunk (2008-03-26)
544
545* Tue Mar 25 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.48
546- Update to latest trunk (2008-03-25)
547
548* Mon Mar 24 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.47
549- Update to latest trunk (2008-03-24)
550
551* Thu Mar 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.46
552- Update to latest trunk (2008-03-20)
553
554* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.45
555- Update to latest trunk (2008-03-17)
556
557* Mon Mar 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.44
558- Revert to trunk from the 15th to fix crashes on HTTPS sites
559
560* Sun Mar 16 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.43
561- Update to latest trunk (2008-03-16)
562- Add patch to negate a11y slowdown on some pages (#431162)
563
564* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.42
565- Update to latest trunk (2008-03-15)
566
567* Sat Mar 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.41
568- Avoid conflicts between gecko debuginfo packages
569
570* Wed Mar 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.40
571- Update to latest trunk (2008-03-12)
572
573* Tue Mar 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.39
574- Update to latest trunk (2008-03-11)
575
576* Mon Mar 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.38
577- Update to latest trunk (2008-03-10)
578
579* Sun Mar  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.37
580- Update to latest trunk (2008-03-09)
581
582* Fri Mar  7 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.36
583- Update to latest trunk (2008-03-07)
584
585* Thu Mar  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.35
586- Update to latest trunk (2008-03-06)
587
588* Tue Mar  4 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta4.34
589- Update to latest trunk (2008-03-04)
590
591* Sun Mar  2 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.33
592- Update to latest trunk (2008-03-02)
593
594* Sat Mar  1 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.32
595- Update to latest trunk (2008-03-01)
596
597* Fri Feb 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.31
598- Update to latest trunk (2008-02-29)
599
600* Thu Feb 28 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.30
601- Update to latest trunk (2008-02-28)
602
603* Wed Feb 27 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.29
604- Update to latest trunk (2008-02-27)
605
606* Tue Feb 26 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.28
607- Update to latest trunk (2008-02-26)
608
609* Sat Feb 23 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.27
610- Update to latest trunk (2008-02-23)
611
612* Fri Feb 22 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.26
613- Update to latest trunk (2008-02-22)
614
615* Thu Feb 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.25
616- Update to latest trunk (2008-02-21)
617
618* Wed Feb 20 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.24
619- Update to latest trunk (2008-02-20)
620
621* Sun Feb 17 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.23
622- Update to latest trunk (2008-02-17)
623
624* Fri Feb 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.22
625- Update to latest trunk (2008-02-15)
626
627* Thu Feb 14 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta3.21
628- Update to latest trunk (2008-02-14)
629- Use system hunspell
630
631* Mon Feb 11 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.19
632- Update to latest trunk (2008-02-11)
633
634* Mon Feb 11 2008 Adam Jackson <ajax@redhat.com> 1.9-0.beta2.19
635- STRIP="/bin/true" on the %%make line so xulrunner-debuginfo contains,
636  you know, debuginfo.
637
638* Sun Feb 10 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.18
639- Update to latest trunk (2008-02-10)
640
641* Sat Feb  9 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.17
642- Update to latest trunk (2008-02-09)
643
644* Wed Feb  6 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.16
645- Update to latest trunk (2008-02-06)
646
647* Tue Jan 29 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.15
648- Update to latest trunk (2008-01-30)
649
650* Wed Jan 25 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.14
651- rebuild agains new nss
652- enabled gnome vfs
653
654* Wed Jan 23 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.13
655- fixed stable pkg-config files (#429654)
656- removed sqlite patch
657
658* Mon Jan 21 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.12
659- Update to latest trunk (2008-01-21)
660
661* Tue Jan 15 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.11
662- Update to latest trunk (2008-01-15)
663- Now with system extensions directory support
664
665* Sat Jan 13 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.10
666- Update to latest trunk (2008-01-13)
667- Use CFLAGS instead of configure arguments
668- Random cleanups: BuildRequires, scriptlets, prefs, etc.
669
670* Sat Jan 12 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.9
671- Provide gecko-devel-unstable as well
672
673* Wed Jan 9 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.8
674- divided devel package to devel and devel-unstable
675
676* Mon Jan 7 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.7
677- removed fedora specific pkg-config files
678- updated to the latest trunk (2008-01-07)
679- removed unnecessary patches
680- fixed idl dir (#427965)
681
682* Thu Jan 3 2008 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.6
683- Re-enable camellia256 support now that NSS supports it
684
685* Thu Jan 3 2008 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.5
686- updated to the latest trunk (2008-01-03)
687
688* Mon Dec 24 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.beta2.4
689- Don't Provide webclient (xulrunner is not itself a webclient)
690- Don't Obsolete old firefox, only firefox-devel
691- Kill legacy obsoletes (phoenix, etc) that were never in rawhide
692
693* Thu Dec 21 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.3
694- added java and plugin subdirs to plugin includes
695
696* Thu Dec 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.2
697- dependency fixes, obsoletes firefox < 3 and firefox-devel now
698
699* Wed Dec 12 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta2.1
700- updated to Beta 2.
701- moved SDK to xulrunner-sdk
702
703* Thu Dec 06 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.4
704- fixed mozilla-plugin.pc (#412971)
705
706* Tue Nov 27 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.3
707- export /etc/gre.d/gre.conf (it's used by python gecko applications)
708
709* Mon Nov 26 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.2
710- added xulrunner/js include dir to xulrunner-js
711
712* Tue Nov 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.beta1.1
713- update to beta 1
714
715* Mon Nov 19 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.6
716- packed all gecko libraries (#389391)
717
718* Thu Nov 15 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.5
719- registered xulrunner libs system-wide
720- added xulrunner-gtkmozembed.pc
721
722* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.4
723- added proper nss/nspr dependencies
724
725* Wed Nov 14 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.3
726- more build fixes, use system nss libraries
727
728* Tue Nov 6 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.2
729- build fixes
730
731* Tue Oct 30 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha9.1
732- updated to the latest trunk
733
734* Thu Sep 20 2007 David Woodhouse <dwmw2@infradead.org> 1.9-0.alpha7.4
735- build fixes for ppc/ppc64
736
737* Tue Sep 20 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.3
738- removed conflicts with the current gecko-based apps
739- added updated ppc64 patch
740
741* Tue Sep 18 2007 Martin Stransky <stransky@redhat.com> 1.9-0.alpha7.2
742- build fixes
743
744* Wed Sep  5 2007 Christopher Aillon <caillon@redhat.com> 1.9-0.alpha7.1
745- Initial cut at XULRunner 1.9 Alpha 7
746- Temporarily revert camellia 256 support since our nss doesn't support it yet
Note: See TracBrowser for help on using the repository browser.