source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 3285

Revision 3285, 6.6 KB checked in by owa, 13 years ago (diff)

mono-2.10.1

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.10
9Release: 1%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer2
62%{mono_dir}/gac/fastcgi-mono-server2
63%{mono_dir}/gac/fastcgi-mono-server4
64%{mono_dir}/gac/mod-mono-server2
65%{mono_dir}/gac/mod-mono-server4
66%{mono_dir}/gac/xsp2
67%{mono_dir}/gac/xsp4
68%{mono_dir}/2.0/Mono.WebServer2.dll
69%{mono_dir}/2.0/fastcgi-mono-server2.exe
70%{mono_dir}/2.0/mod-mono-server2.exe
71%{mono_dir}/2.0/xsp2.exe
72%{mono_dir}/4.0/Mono.WebServer2.dll
73%{mono_dir}/4.0/fastcgi-mono-server4.exe
74%{mono_dir}/4.0/mod-mono-server4.exe
75%{mono_dir}/4.0/xsp4.exe
76%{_prefix}/lib/monodoc/sources/Mono.WebServer.*
77%{_prefix}/lib/monodoc/sources/Mono.FastCGI.*
78%{_datadir}/pkgconfig/*
79%{_mandir}/*/*
80
81
82%changelog
83* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-1
84- updated xsp to 2.10
85
86* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
87- updated xsp to 2.8.2
88
89* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
90- updated xsp to 2.8.1
91
92* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
93- updated xsp to 2.8
94- rebuilt with mono-2.8
95- dropt BR: mono-jscript
96
97* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
98- rebuild with rpm-4.8.1 for pkg-config file
99
100* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
101- updated xsp to 2.6.5
102
103* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
104- updated xsp to 2.6.4
105
106* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
107- updated xsp to 2.6.3
108
109* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
110- updated to 2.6
111- rebuilt with new toolchain
112
113* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
114- updated to 2.4.3
115
116* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
117- changed Group to Applications/Internet
118
119* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
120- updated to 2.4
121
122* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
123- initial build for VineSeed
124        - updated xsp to 2.0
125        - added japanese summary
126        - applied vine versioning policy
127        - spec in utf-8
128
129* Tue Apr 22 2008 wberrier@suse.de
130- update to 1.9.1 (bugfix release)
131  - Output date header (instead of asp.net doing it)
132* Tue Mar 25 2008 wberrier@suse.de
133- update to 1.9
134  - minor test updates
135  - BaseRequestBroker fix: Check if the request ID is valid inside
136  the lock.
137* Mon Jan 14 2008 wberrier@suse.de
138- update to 1.2.6
139  - FastCGI support
140* Thu Aug 30 2007 wberrier@suse.de
141- xsp_1.2.5_p5_final.patch: Fix for regression in the request
142  broker
143* Fri Aug 17 2007 wberrier@suse.de
144- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
145  - bugs: 81699, 81906, 82379, 82057
146  - fixes ability to handle large (GB) uploads (needed for iFolder)
147* Fri Aug  3 2007 wberrier@suse.de
148- Update to 1.2.5
149  - More robust exception handling
150  - Fixed permissions bits for non executable scripts
151  - virtual host support
152  - New Documentation for Mono.WebServer
153  - Improved event handling
154* Tue Jun  5 2007 wberrier@novell.com
155- Remove unnecessary path defines (prefix, sysconfdir)
156- Update to 1.2.4
157  - fix some race conditions and crashes
158  - add tracing support
159* Fri Apr 13 2007 wberrier@novell.com
160- add %%debug_package so debug packages get created
161* Wed Apr 11 2007 wberrier@novell.com
162- Add mono dep/req for older distros
163* Thu Mar  1 2007 wberrier@suse.de
164- Update Update to 1.2.3
165  - Bug fix #80230 (prevents possible nullref)
166  - Support for response header encoding
167* Mon Jan 22 2007 ro@suse.de
168- drop requires for gnome-filesystem
169* Sat Dec  2 2006 wberrier@suse.de
170- Update to 1.2.1 (Fate #301111)
171  - Bugfixes:
172  - close the connection if there's an error reading the headers
173  (including assembly loading exceptions due to a bad installation).
174  - kill the warning that everyone is worried about.
175* Fri Oct 20 2006 wberrier@suse.de
176- Update to 1.1.18
177  - 2.0 updates
178* Thu Oct 19 2006 wberrier@suse.de
179- Add mono-devel to fix bnc #213576 (missing provides)
180* Tue Sep  5 2006 wberrier@suse.de
181- Update to 1.1.17.1 bugfix release
182- Read from the stream, not the socket as the socket data is
183  encrypted when using SSL.
184* Wed Aug 30 2006 wberrier@suse.de
185- Update to 1.1.17
186  - Added support for X.509 client certificates
187  - Update to handle newly created AppDomains
188* Mon Jul 31 2006 wberrier@suse.de
189- update to 1.1.16.1
190- better connection handling
191- fixes bugs: 77698,78034,78621
192* Tue Apr 25 2006 wberrier@suse.de
193- Security update (remove all the duplicated slashes
194  and don't do an extra Replace on non-windows.) and minor fix for
195  [#78034].
196* Wed Jan 25 2006 mls@suse.de
197- converted neededforbuild to BuildRequires
198* Fri Jan  6 2006 wberrier@suse.de
199- Update to 1.1.13, clean up deps
200* Thu Nov 10 2005 wberrier@suse.de
201- Update to 1.1.10, set libdir to lib/
202* Fri Oct  7 2005 wberrier@suse.de
203- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
204  libexec, so I disabled the patch)
205* Tue Jul 19 2005 sbrabec@suse.cz
206- Build as noarch (#81109).
207* Fri Jul 15 2005 sbrabec@suse.cz
208- Updated to version 1.0.9 (#96776).
209* Mon Feb 21 2005 clahey@suse.de
210- Updated to 1.0.6.
211* Sun Feb  6 2005 ro@suse.de
212- use /usr/lib/mono
213* Mon Dec 13 2004 clahey@suse.de
214- New package.
Note: See TracBrowser for help on using the repository browser.