source: projects/specs/trunk/x/xsp/xsp-vl.spec @ 3701

Revision 3701, 6.6 KB checked in by owa, 13 years ago (diff)

rebuilt with mono-2.10.1-3

Line 
1%define mono_dir %(/usr/bin/monodir)
2Summary: Small Web Server Hosting ASP.NET
3Summary(ja): ASP.NET を提供する小さなウェブサーバ
4Name: xsp
5URL: http://go-mono.com/
6License: GNU General Public License (GPL)
7Group: Applications/Internet
8Version: 2.10
9Release: 2%{?_dist_release}
10Source: http://mono.ximian.com/monobuild/preview/sources/xsp/xsp-%{version}.tar.bz2
11BuildRoot: %{_tmppath}/%{name}-%{version}-root
12BuildArch: noarch
13BuildRequires: mono-devel mono-web
14BuildRequires: mono-data-sqlite mono-data-oracle mono-extras mono-nunit
15BuildRequires: pkgconfig
16# One of the test runs requires this
17BuildRequires: sqlite
18# This must be manually entered according to xsp's protocol version
19# Since this package is currently noarch, and mod_mono's name is different
20# on different distros, we can't use this... yet
21#Requires: mod_mono >= %{version}
22
23%description
24The XSP server is a small Web server that hosts the Mono System.Web
25classes for running what is commonly known as ASP.NET.
26
27
28%prep
29%setup -q
30
31%build
32export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
33# Cannot use the configure macro because noarch-redhat-linux is not recognized by the auto tools in the tarball
34./configure \
35        --prefix=%{_prefix} \
36        --libexecdir=%{_prefix}/lib \
37    --libdir=%{_prefix}/lib \
38    --mandir=%{_prefix}/share/man \
39    --infodir=%{_prefix}/share/info \
40    --sysconfdir=%{_sysconfdir}
41make
42
43
44%install
45rm -rf $RPM_BUILD_ROOT
46export MONO_SHARED_DIR=%{_builddir}/%{?buildsubdir}
47make install DESTDIR=$RPM_BUILD_ROOT
48mkdir -p ${RPM_BUILD_ROOT}%{_datadir}
49mv ${RPM_BUILD_ROOT}%{_prefix}/lib/pkgconfig ${RPM_BUILD_ROOT}%{_datadir}
50
51
52%clean
53rm -rf $RPM_BUILD_ROOT
54
55
56%files
57%defattr(-,root,root)
58%doc NEWS README
59%{_bindir}/*
60%{_prefix}/lib/xsp
61%{mono_dir}/gac/Mono.WebServer2
62%{mono_dir}/gac/fastcgi-mono-server2
63%{mono_dir}/gac/fastcgi-mono-server4
64%{mono_dir}/gac/mod-mono-server2
65%{mono_dir}/gac/mod-mono-server4
66%{mono_dir}/gac/xsp2
67%{mono_dir}/gac/xsp4
68%{mono_dir}/2.0/Mono.WebServer2.dll
69%{mono_dir}/2.0/fastcgi-mono-server2.exe
70%{mono_dir}/2.0/mod-mono-server2.exe
71%{mono_dir}/2.0/xsp2.exe
72%{mono_dir}/4.0/Mono.WebServer2.dll
73%{mono_dir}/4.0/fastcgi-mono-server4.exe
74%{mono_dir}/4.0/mod-mono-server4.exe
75%{mono_dir}/4.0/xsp4.exe
76%{_prefix}/lib/monodoc/sources/Mono.WebServer.*
77%{_prefix}/lib/monodoc/sources/Mono.FastCGI.*
78%{_datadir}/pkgconfig/*
79%{_mandir}/*/*
80
81
82%changelog
83* Mon Apr 25 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-2
84- rebuilt with mono-2.10.1-3
85
86* Sun Apr 03 2011 Shu KONNO <owa@bg.wakwak.com> 2.10-1
87- updated xsp to 2.10
88
89* Sat Jan 08 2011 Shu KONNO <owa@bg.wakwak.com> 2.8.2-1
90- updated xsp to 2.8.2
91
92* Sun Nov 21 2010 Shu KONNO <owa@bg.wakwak.com> 2.8.1-1
93- updated xsp to 2.8.1
94
95* Fri Oct 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.8-1
96- updated xsp to 2.8
97- rebuilt with mono-2.8
98- dropt BR: mono-jscript
99
100* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.6.5-2
101- rebuild with rpm-4.8.1 for pkg-config file
102
103* Mon Jul 26 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.5-1
104- updated xsp to 2.6.5
105
106* Sat May 01 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.4-1
107- updated xsp to 2.6.4
108
109* Thu Apr 08 2010 Shu KONNO <owa@bg.wakwak.com> 2.6.3-1
110- updated xsp to 2.6.3
111
112* Tue Mar 02 2010 Shu KONNO <owa@bg.wakwak.com> 2.6-1
113- updated to 2.6
114- rebuilt with new toolchain
115
116* Tue Dec 15 2009 Shu KONNO <owa@bg.wakwak.com> 2.4.3-2
117- updated to 2.4.3
118
119* Sun Apr 19 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-2
120- changed Group to Applications/Internet
121
122* Sun Apr 05 2009 Shu KONNO <owa@bg.wakwak.com> 2.4-1
123- updated to 2.4
124
125* Wed Sep 17 2008 Shu KONNO <owa@bg.wakwak.com> 2.0-1
126- initial build for VineSeed
127        - updated xsp to 2.0
128        - added japanese summary
129        - applied vine versioning policy
130        - spec in utf-8
131
132* Tue Apr 22 2008 wberrier@suse.de
133- update to 1.9.1 (bugfix release)
134  - Output date header (instead of asp.net doing it)
135* Tue Mar 25 2008 wberrier@suse.de
136- update to 1.9
137  - minor test updates
138  - BaseRequestBroker fix: Check if the request ID is valid inside
139  the lock.
140* Mon Jan 14 2008 wberrier@suse.de
141- update to 1.2.6
142  - FastCGI support
143* Thu Aug 30 2007 wberrier@suse.de
144- xsp_1.2.5_p5_final.patch: Fix for regression in the request
145  broker
146* Fri Aug 17 2007 wberrier@suse.de
147- xsp_1.2.5_p4.patch.bz2: Bugfixes found in 1.2.5
148  - bugs: 81699, 81906, 82379, 82057
149  - fixes ability to handle large (GB) uploads (needed for iFolder)
150* Fri Aug  3 2007 wberrier@suse.de
151- Update to 1.2.5
152  - More robust exception handling
153  - Fixed permissions bits for non executable scripts
154  - virtual host support
155  - New Documentation for Mono.WebServer
156  - Improved event handling
157* Tue Jun  5 2007 wberrier@novell.com
158- Remove unnecessary path defines (prefix, sysconfdir)
159- Update to 1.2.4
160  - fix some race conditions and crashes
161  - add tracing support
162* Fri Apr 13 2007 wberrier@novell.com
163- add %%debug_package so debug packages get created
164* Wed Apr 11 2007 wberrier@novell.com
165- Add mono dep/req for older distros
166* Thu Mar  1 2007 wberrier@suse.de
167- Update Update to 1.2.3
168  - Bug fix #80230 (prevents possible nullref)
169  - Support for response header encoding
170* Mon Jan 22 2007 ro@suse.de
171- drop requires for gnome-filesystem
172* Sat Dec  2 2006 wberrier@suse.de
173- Update to 1.2.1 (Fate #301111)
174  - Bugfixes:
175  - close the connection if there's an error reading the headers
176  (including assembly loading exceptions due to a bad installation).
177  - kill the warning that everyone is worried about.
178* Fri Oct 20 2006 wberrier@suse.de
179- Update to 1.1.18
180  - 2.0 updates
181* Thu Oct 19 2006 wberrier@suse.de
182- Add mono-devel to fix bnc #213576 (missing provides)
183* Tue Sep  5 2006 wberrier@suse.de
184- Update to 1.1.17.1 bugfix release
185- Read from the stream, not the socket as the socket data is
186  encrypted when using SSL.
187* Wed Aug 30 2006 wberrier@suse.de
188- Update to 1.1.17
189  - Added support for X.509 client certificates
190  - Update to handle newly created AppDomains
191* Mon Jul 31 2006 wberrier@suse.de
192- update to 1.1.16.1
193- better connection handling
194- fixes bugs: 77698,78034,78621
195* Tue Apr 25 2006 wberrier@suse.de
196- Security update (remove all the duplicated slashes
197  and don't do an extra Replace on non-windows.) and minor fix for
198  [#78034].
199* Wed Jan 25 2006 mls@suse.de
200- converted neededforbuild to BuildRequires
201* Fri Jan  6 2006 wberrier@suse.de
202- Update to 1.1.13, clean up deps
203* Thu Nov 10 2005 wberrier@suse.de
204- Update to 1.1.10, set libdir to lib/
205* Fri Oct  7 2005 wberrier@suse.de
206- Update to 1.1.9.2 and cleanup (I Don't think noarch mono needs
207  libexec, so I disabled the patch)
208* Tue Jul 19 2005 sbrabec@suse.cz
209- Build as noarch (#81109).
210* Fri Jul 15 2005 sbrabec@suse.cz
211- Updated to version 1.0.9 (#96776).
212* Mon Feb 21 2005 clahey@suse.de
213- Updated to 1.0.6.
214* Sun Feb  6 2005 ro@suse.de
215- use /usr/lib/mono
216* Mon Dec 13 2004 clahey@suse.de
217- New package.
Note: See TracBrowser for help on using the repository browser.