source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 683

Revision 683, 11.1 KB checked in by inagaki, 14 years ago (diff)

updated: xorg-x11-xinit, xorg-x11-apps

Line 
1%define pkgname xinit
2
3Summary:     X.Org X11 X Window System xinit startup scripts
4Summary(ja): X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.2.1
7Release:   1%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source18: xinit-compat.desktop
23Source100: ck-xinit-session.c
24
25Patch1: xinit-1.0.2-client-session.patch
26Patch2: xinit-1.0.7-poke-ck.patch
27Patch3: xinit-1.0.9-unset.patch
28
29Patch10: xinit-1.0.7-vine.patch
30
31BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
32BuildRequires: pkgconfig
33BuildRequires: libX11-devel
34BuildRequires: ConsoleKit-devel
35BuildRequires: autoconf
36BuildRequires: automake
37BuildRequires: libtool
38BuildRequires: dbus-devel
39BuildRequires: xorg-x11-util-macros
40# NOTE: startx needs xauth in order to run, but that is not picked up
41#       automatically by rpm.  (Bug #173684)
42Requires: xauth
43# next two are for localuser.sh
44Requires: coreutils
45Requires: xorg-x11-server-utils
46Requires: ConsoleKit-x11
47Requires: ConsoleKit-libs
48Requires: dbus-x11
49
50# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
51# modularization.  These Obsoletes lines ensure upgrades work smoothly.
52Obsoletes: XFree86, XOrg
53
54# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
55# so the xinitrc package became unnecessary.  The xdm configs/scripts move
56# to the xdm package.
57Obsoletes: xinitrc
58Provides: xinitrc
59
60%description
61X.Org X11 X Window System xinit startup scripts
62
63%description -l ja
64X.Org X11 X Window System の xinit スタートアップ・スクリプト
65
66%package session
67Summary: Display manager support for ~/.xsession and ~/.Xclients
68Group: User Interface/X
69
70%description
71X.Org X11 X Window System xinit startup scripts
72
73%description session
74Allows legacy ~/.xsession and ~/.Xclients files to be used from display managers
75
76%prep
77%setup -q -n %{pkgname}-%{version}
78%patch1 -p1 -b .client-session
79#%patch2 -p1 -b .poke-ck
80%patch3 -p1 -b .unset
81%patch10 -p1 -b .vine
82
83%build
84autoreconf -i
85%configure
86# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
87# Makefile.am and submit it in a bug report or check into CVS.
88make XINITDIR=/etc/X11/xinit
89%{__cc} -o ck-xinit-session \
90        `pkg-config --cflags ck-connector dbus-1` $RPM_OPT_FLAGS \
91        $RPM_SOURCE_DIR/ck-xinit-session.c \
92        `pkg-config --libs ck-connector dbus-1`
93
94%install
95rm -rf $RPM_BUILD_ROOT
96# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
97# Makefile.am and submit it in a bug report or check into CVS.
98%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
99install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
100install -m644 -D $RPM_SOURCE_DIR/xinit-compat.desktop $RPM_BUILD_ROOT%{_datadir}/xsessions/xinit-compat.desktop
101
102# Install custom xinitrc, etc.
103{
104    install -m 644 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc-common
105
106    for script in %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
107        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
108    done
109
110    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
111    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
112
113    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
114    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
115
116    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
117}
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122%files
123%defattr(-,root,root,-)
124%doc COPYING README ChangeLog
125%{_bindir}/startx
126%{_bindir}/xinit
127%{_bindir}/ck-xinit-session
128%dir %{_sysconfdir}/X11
129%dir %{_sysconfdir}/X11/xinit
130%{_sysconfdir}/X11/xinit/xinitrc
131%{_sysconfdir}/X11/xinit/xinitrc-common
132%config(noreplace) %{_sysconfdir}/X11/Xmodmap
133%config(noreplace) %{_sysconfdir}/X11/Xresources
134%dir %{_sysconfdir}/X11/xinit/Xclients.d
135%{_sysconfdir}/X11/xinit/Xclients
136%{_sysconfdir}/X11/xinit/Xsession
137%dir %{_sysconfdir}/X11/xinit/xinitrc.d
138%{_sysconfdir}/X11/xinit/xinitrc.d/*
139#%dir %{_mandir}/man1
140%{_mandir}/man1/startx.1*
141%{_mandir}/man1/xinit.1*
142
143%files session
144%defattr(-, root, root)
145%{_datadir}/xsessions/xinit-compat.desktop
146
147%changelog
148* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 1.2.1-1
149- new upstream release
150- updated SOURCE12, SOURCE100
151- Install xinitrc-common non-executable.
152- added a new subpackage to add ~/.xsessions and ~/.Xclients
153  to session list
154
155* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
156- new upstream release
157
158* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
159- add Requires: dbus-x11
160
161* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
162- add LXDE to Xclients
163
164* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
165- new upstream release
166
167* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
168- fix typo in Xsession (<BTS:644>)
169
170* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
171- new upstream release
172
173* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
174- spec in UTF-8
175- modify Source16: add CK_XINIT_SESSION calls
176
177* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
178- add Patch10 to set display resolution.
179
180* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
181- initial build for Vine Linux
182
183* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
184- Try opening the console-kit session after the user's UID has already
185  been granted access to the server by localuser.sh, so that console-kit-daemon
186  can connect and ask the server for information just by having switch to the
187  user's UID (#287941).
188
189* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
190- xinit 1.0.7
191
192* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
193- Rebuild for build id
194
195* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
196- Bump release
197
198* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
199- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
200
201* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
202- Fix bug 212167, CVE-2006-5214
203
204* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
205- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
206  than the other way around. This preserves LD_LIBRARY_PRELOAD.
207        Patch from Stefan Becker, bug 164869.
208
209* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
210- Remove xinput.sh. Bug 244963.
211
212* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
213- localuser.sh: Run silently.
214
215* Sat Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
216- Don't install INSTALL
217
218* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
219- disable SCIM by default in non-Asian languages #237054
220  If you want to use SCIM, use im-chooser to enable it.
221
222* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
223- Man pages are now in section 1, not in section 1x
224
225* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
226- Also BR xorg-x11-util-macros since we autoreconf
227
228* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
229- Add ConsoleKit support (#233183)
230
231* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
232- Bump EVR to fix 6 to 7 updates.
233
234* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
235- start client in its own session with no controlling tty
236  (bug 214649)
237
238* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
239- Update Xsession to not use switchdesk for the hard coded kde and twm
240  cases.
241
242* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
243- rebuilt for unwind info generation, broken in gcc-4.1.1-21
244
245* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
246- Bump and rebuild.
247
248* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
249- Move hardcoded xsetroot background color to fallback cases (#205901).
250
251* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
252- Start ssh-agent for startx also (#169259).
253
254* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
255- Fix SourceN line for localuser.sh to not collide.
256
257* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
258- Added localuser.sh.
259
260* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
261- Added fix to Xclients script, based on patch from bug (#190799)
262
263* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
264- rebuild
265
266* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
267- Implemented changes to xinput.sh based on suggestions from (#194458)
268
269* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
270- Added documentation to doc macro.
271
272* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
273- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
274
275* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
276- Added "BuildRequires: pkgconfig" for bug (#194187)
277
278* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
279- Update xinit to 1.0.2
280
281* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
282- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
283
284* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
285- bump again for double-long bug on ppc(64)
286
287* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
288- rebuilt for new gcc4.1 snapshot and glibc changes
289
290* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
291- Updated to xinit 1.0.1 from X11R7.0
292
293* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
294- Updated to xinit 1.0.0 from X11R7 RC4.
295- Changed manpage dir from man1x to man1 to match upstream default.
296
297* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
298- Add "Requires: xauth" for startx, to fix bug (#173684)
299
300* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
301- Do not provide xinit anymore, gdm has been fixed and that breaks things
302  with the obsoletes
303
304* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
305- Added Xsession script from xinitrc, as it is very similar codebase, which
306  shares "xinitrc-common" anyway, and all of the display managers use it.
307
308* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
309- Updated to xinit 0.99.3 from X11R7 RC2.
310
311* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
312- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
313  monolithic and modular X.  This will be removed however for FC5.
314
315* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
316- Import custom Red Hat xinit scripts from xinitrc package.
317- Obsolete xinitrc package, as we include the scripts/configs here now.
318- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
319
320* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
321- Updated to xinit 0.99.2 from X11R7 RC1.
322- Change manpage location to 'man1x' in file manifest.
323
324* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
325- Use Fedora-Extras style BuildRoot tag.
326- Update BuildRequires to use new library package names.
327- Tidy up spec file a bit.
328
329* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
330- Initial build.
Note: See TracBrowser for help on using the repository browser.