source: projects/specs/trunk/x/xorg-x11-xinit/xorg-x11-xinit-vl.spec @ 521

Revision 521, 10.2 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkgname xinit
2
3Summary:   X.Org X11 X Window System xinit startup scripts
4Summary(ja):   X.Org X11 X ウィンドウシステム xinit スタートアップスクリプト
5Name:      xorg-x11-%{pkgname}
6Version:   1.2.0
7Release:   1%{?_dist_release}
8License:   MIT/X11
9Group:     User Interface/X
10URL:       http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/%{pkgname}-%{version}.tar.bz2
13Source10: xinitrc-common
14Source11: xinitrc
15Source12: Xclients
16Source13: Xmodmap
17Source14: Xresources
18# NOTE: Xsession is used by xdm/kdm/gdm and possibly others, so we keep it
19#       here instead of the xdm package.
20Source16: Xsession
21Source17: localuser.sh
22Source100: ck-xinit-session.c
23
24Patch1: xinit-1.0.2-client-session.patch
25
26Patch10: xinit-1.0.7-vine.patch
27
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: pkgconfig
30BuildRequires: libX11-devel
31BuildRequires: ConsoleKit-devel
32BuildRequires: autoconf
33BuildRequires: automake
34BuildRequires: libtool
35BuildRequires: xorg-x11-util-macros
36# NOTE: startx needs xauth in order to run, but that is not picked up
37#       automatically by rpm.  (Bug #173684)
38Requires: xauth
39# next two are for localuser.sh
40Requires: coreutils
41Requires: xorg-x11-server-utils
42Requires: ConsoleKit-x11
43Requires: ConsoleKit-libs
44Requires: dbus-x11
45
46# NOTE: xinit, startx moved to xorg-x11-xinit during the X.Org X11R7
47# modularization.  These Obsoletes lines ensure upgrades work smoothly.
48Obsoletes: XFree86, XOrg
49
50# NOTE: Most of the xinitrc scripts/config files are now in xorg-x11-xinit,
51# so the xinitrc package became unnecessary.  The xdm configs/scripts move
52# to the xdm package.
53Obsoletes: xinitrc
54Provides: xinitrc
55
56%description
57X.Org X11 X Window System xinit startup scripts
58
59%description -l ja
60X.Org X11 X Window System の xinit スタートアップ・スクリプト
61
62%prep
63%setup -q -n %{pkgname}-%{version}
64%patch1 -p1 -b .client-session
65%patch10 -p1 -b .vine
66
67%build
68autoreconf -i
69%configure
70# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
71# Makefile.am and submit it in a bug report or check into CVS.
72make XINITDIR=/etc/X11/xinit
73%{__cc} -o ck-xinit-session \
74        `pkg-config --cflags ck-connector` $RPM_OPT_FLAGS \
75        $RPM_SOURCE_DIR/ck-xinit-session.c \
76        `pkg-config --libs ck-connector`
77
78%install
79rm -rf $RPM_BUILD_ROOT
80# FIXME: Upstream should default to XINITDIR being this.  Make a patch to
81# Makefile.am and submit it in a bug report or check into CVS.
82%makeinstall XINITDIR=$RPM_BUILD_ROOT/etc/X11/xinit
83install -m755 ck-xinit-session $RPM_BUILD_ROOT/%{_bindir}
84
85# Install custom xinitrc, etc.
86{
87    for script in %{SOURCE10} %{SOURCE11} %{SOURCE12} %{SOURCE16} ; do
88        install -m 755 $script $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/${script##*/}
89    done
90
91    install -m 644 %{SOURCE13} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xmodmap
92    install -m 644 %{SOURCE14} $RPM_BUILD_ROOT%{_sysconfdir}/X11/Xresources
93
94    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d
95    install -m 755 %{SOURCE17} $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/xinitrc.d/localuser.sh
96
97    mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11/xinit/Xclients.d
98}
99
100%clean
101rm -rf $RPM_BUILD_ROOT
102
103%files
104%defattr(-,root,root,-)
105%doc AUTHORS COPYING README NEWS ChangeLog
106%{_bindir}/startx
107%{_bindir}/xinit
108%{_bindir}/ck-xinit-session
109%dir %{_sysconfdir}/X11
110%dir %{_sysconfdir}/X11/xinit
111%{_sysconfdir}/X11/xinit/xinitrc
112%{_sysconfdir}/X11/xinit/xinitrc-common
113%config(noreplace) %{_sysconfdir}/X11/Xmodmap
114%config(noreplace) %{_sysconfdir}/X11/Xresources
115%dir %{_sysconfdir}/X11/xinit/Xclients.d
116%{_sysconfdir}/X11/xinit/Xclients
117%{_sysconfdir}/X11/xinit/Xsession
118%dir %{_sysconfdir}/X11/xinit/xinitrc.d
119%{_sysconfdir}/X11/xinit/xinitrc.d/*
120#%dir %{_mandir}/man1
121%{_mandir}/man1/startx.1*
122%{_mandir}/man1/xinit.1*
123
124%changelog
125* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
126- new upstream release
127
128* Sun Jul 26 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-3
129- add Requires: dbus-x11
130
131* Mon Mar 23 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-2
132- add LXDE to Xclients
133
134* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.1-1
135- new upstream release
136
137* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-2
138- fix typo in Xsession (<BTS:644>)
139
140* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
141- new upstream release
142
143* Fri Jun 27 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 1.0.7-3
144- spec in UTF-8
145- modify Source16: add CK_XINIT_SESSION calls
146
147* Fri May 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-2
148- add Patch10 to set display resolution.
149
150* Thu May 08 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.7-1
151- initial build for Vine Linux
152
153* Fri Oct 12 2007 Nalin Dahyabhai <nalin@redhat.com> 1.0.7-2
154- Try opening the console-kit session after the user's UID has already
155  been granted access to the server by localuser.sh, so that console-kit-daemon
156  can connect and ask the server for information just by having switch to the
157  user's UID (#287941).
158
159* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 1.0.7-1
160- xinit 1.0.7
161
162* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1.0.2-27
163- Rebuild for build id
164
165* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-26
166- Bump release
167
168* Mon Aug 6 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-25
169- Fix typo: s/unask/umask/ - Bug 250882, Jan ONDREJ (ondrejj@salstar.sk)
170
171* Thu Aug 2 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-24
172- Fix bug 212167, CVE-2006-5214
173
174* Sun Jul 29 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-23
175- Fix Xsession to run the login shell inside the setgid ssh-agent, rather
176  than the other way around. This preserves LD_LIBRARY_PRELOAD.
177        Patch from Stefan Becker, bug 164869.
178
179* Fri Jul 27 2007 Soren Sandmann <sandmann@redhat.com> 1.0.2-22
180- Remove xinput.sh. Bug 244963.
181
182* Mon May 21 2007 Adam Jackson <ajax@redhat.com> 1.0.2-21
183- localuser.sh: Run silently.
184
185* Sat Apr 22 2007 Matthias Clasen <mclasen@redhat.com> 1.0.2-20
186- Don't install INSTALL
187
188* Thu Apr 19 2007 Warren Togami <wtogami@redhat.com> 1.0.2-19
189- disable SCIM by default in non-Asian languages #237054
190  If you want to use SCIM, use im-chooser to enable it.
191
192* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-18
193- Man pages are now in section 1, not in section 1x
194
195* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-17
196- Also BR xorg-x11-util-macros since we autoreconf
197
198* Mon Apr 02 2007 David Zeuthen <davidz@redhat.com> 1.0.2-16
199- Add ConsoleKit support (#233183)
200
201* Mon Nov 27 2006 Adam Jackson <ajax@redhat.com> 1.0.2-15
202- Bump EVR to fix 6 to 7 updates.
203
204* Fri Nov 10 2006 Ray Strode <rstrode@redhat.com> - 1.0.2-14
205- start client in its own session with no controlling tty
206  (bug 214649)
207
208* Mon Oct 23 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-13
209- Update Xsession to not use switchdesk for the hard coded kde and twm
210  cases.
211
212* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.0.2-12
213- rebuilt for unwind info generation, broken in gcc-4.1.1-21
214
215* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-11.fc6
216- Bump and rebuild.
217
218* Mon Sep 25 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-10.fc6
219- Move hardcoded xsetroot background color to fallback cases (#205901).
220
221* Thu Aug 17 2006 Kristian H淡gsberg <krh@redhat.com> - 1.0.2-9.fc6
222- Start ssh-agent for startx also (#169259).
223
224* Sat Jul 22 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-8.fc6
225- Fix SourceN line for localuser.sh to not collide.
226
227* Fri Jul 21 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-7.fc6
228- Added localuser.sh.
229
230* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-6.fc6
231- Added fix to Xclients script, based on patch from bug (#190799)
232
233* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.0.2-5.1.fc6
234- rebuild
235
236* Wed Jul 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-5.fc6
237- Implemented changes to xinput.sh based on suggestions from (#194458)
238
239* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-4
240- Added documentation to doc macro.
241
242* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-3
243- Added xinit-1.0.2-setuid.diff to fix potential security issue (#196094)
244
245* Tue Jun 06 2006 Mike A. Harris <mharris@redhat.com> 1.0.2-2
246- Added "BuildRequires: pkgconfig" for bug (#194187)
247
248* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
249- Update xinit to 1.0.2
250
251* Thu Feb 16 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
252- Change Conflicts to Obsoletes for xorg-x11 and XFree86 (#181414)
253
254* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
255- bump again for double-long bug on ppc(64)
256
257* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
258- rebuilt for new gcc4.1 snapshot and glibc changes
259
260* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
261- Updated to xinit 1.0.1 from X11R7.0
262
263* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
264- Updated to xinit 1.0.0 from X11R7 RC4.
265- Changed manpage dir from man1x to man1 to match upstream default.
266
267* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-6
268- Add "Requires: xauth" for startx, to fix bug (#173684)
269
270* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.3-5
271- Do not provide xinit anymore, gdm has been fixed and that breaks things
272  with the obsoletes
273
274* Sat Nov 12 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-4
275- Added Xsession script from xinitrc, as it is very similar codebase, which
276  shares "xinitrc-common" anyway, and all of the display managers use it.
277
278* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.3-3
279- Updated to xinit 0.99.3 from X11R7 RC2.
280
281* Mon Nov 07 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
282- Added "Provides: xinitrc = 5.0.0-1" for temporary compatibility between
283  monolithic and modular X.  This will be removed however for FC5.
284
285* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
286- Import custom Red Hat xinit scripts from xinitrc package.
287- Obsolete xinitrc package, as we include the scripts/configs here now.
288- Fix all scripts/configs to avoid the now obsolete /usr/X11R6 prefix.
289
290* Mon Oct 31 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
291- Updated to xinit 0.99.2 from X11R7 RC1.
292- Change manpage location to 'man1x' in file manifest.
293
294* Wed Oct 05 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-2
295- Use Fedora-Extras style BuildRoot tag.
296- Update BuildRequires to use new library package names.
297- Tidy up spec file a bit.
298
299* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 0.99.0-1
300- Initial build.
Note: See TracBrowser for help on using the repository browser.