source: projects/specs/trunk/x/xorg-x11-xfs/xorg-x11-xfs-vl.spec @ 9501

Revision 9501, 12.0 KB checked in by Takemikaduchi, 9 years ago (diff)

new upstream release

Line 
1Summary: X.Org X11 xfs font server
2Summary(ja): X.Org X11 xfs フォントサーバ
3Name: xorg-x11-xfs
4Version: 1.1.4
5Release: 2%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Daemons
8URL: http://www.x.org
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11Source0: ftp://ftp.x.org/pub/individual/app/xfs-%{version}.tar.bz2
12Source1: ftp://ftp.x.org/pub/individual/app/xfsinfo-1.0.5.tar.bz2
13Source2: ftp://ftp.x.org/pub/individual/app/fslsfonts-1.0.5.tar.bz2
14Source3: ftp://ftp.x.org/pub/individual/app/fstobdf-1.0.6.tar.bz2
15Source4: ftp://ftp.x.org/pub/individual/app/showfont-1.0.5.tar.bz2
16Source10:  xfs.init
17Source11:  xfs.config
18
19BuildRequires: pkgconfig
20# xfs needs 'fontsproto' to build, as indicated by ./configure
21BuildRequires: xorg-x11-proto-devel
22# FIXME: xfs needs xtrans to build, but autotools doesn't detect it missing
23BuildRequires: xorg-x11-xtrans-devel
24BuildRequires: xorg-x11-util-macros
25BuildRequires: libFS-devel
26BuildRequires: libXfont-devel
27BuildRequires: libX11-devel
28# FIXME: xfs needs freetype-devel to build, but autotools doesn't detect it missing
29BuildRequires: freetype2-devel
30BuildRequires: libfontenc-devel
31
32# Make sure libXfont provides the catalogue FPE.
33Requires: libXfont
34
35Obsoletes: XFree86-xfs, XOrg-xfs
36Provides: xfs
37Provides: XOrg-xfs = 7.0
38
39Requires(pre): util-linux, shadow-utils
40Requires(post): initscripts, grep, sed, coreutils
41Requires(preun): initscripts, chkconfig
42Requires(postun): initscripts
43
44# xfs initscript runtime dependencies
45Requires: initscripts, fontconfig, sed, findutils
46Requires: coreutils
47Requires: mkfontdir, mkfontscale, ttmkfdir
48# end of xfs initscript runtime dependencies
49
50%description
51X.Org X11 xfs font server
52
53%package utils
54Summary: X.Org X11 font server utilities
55Summary(ja): X.Org X11 フォントサーバユーティリティ
56Group: User Interface/X
57
58Conflicts: XOrg-xfs < 7.0
59
60%description utils
61X.Org X11 font server utilities
62
63%prep
64%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
65
66%build
67
68# Build xfs
69{
70   pushd xfs-*
71   %configure --disable-devel-docs
72   make configdir=%{_sysconfdir}/X11/fs
73   popd
74}
75
76for pkg in xfsinfo fslsfonts fstobdf showfont ; do
77   pushd ${pkg}-*
78   %configure
79   make
80   popd
81done
82
83%install
84rm -rf $RPM_BUILD_ROOT
85# Install xfs
86{
87   pushd xfs-*
88   %makeinstall configdir=$RPM_BUILD_ROOT%{_sysconfdir}/X11/fs
89   popd
90}
91
92for pkg in xfsinfo fslsfonts fstobdf showfont ; do
93   pushd ${pkg}-*
94   make install DESTDIR=$RPM_BUILD_ROOT
95   popd
96done
97
98# Install the modified xfs config file and initscript
99{
100   mkdir -p $RPM_BUILD_ROOT/etc/{X11/fs,rc.d/init.d}
101   install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/xfs
102   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fs/config
103}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%triggerpostun -- XFree86-xfs
109{
110  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
111  /sbin/chkconfig --add xfs
112  /sbin/service xfs condrestart || :
113} &> /dev/null || :
114
115%triggerpostun -- XOrg-xfs
116{
117  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
118  /sbin/chkconfig --add xfs
119  /sbin/service xfs condrestart || :
120} &> /dev/null || :
121
122%pre
123{
124  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
125  # Upgrade path:
126  if [ "$1" -gt "1" ] ; then
127    if [ -e "/usr/X11R6/lib/X11/fs/config" ] ; then
128      cat <<-EOF > "/etc/X11/fs/xfs-migrate"
129        On upgrades, we now must determine if we are upgrading from monolithic
130        xfs or modular xfs by checking for the existance of the old monolithic
131        xfs config file.  If found, we know it is a monolith->modular upgrade,
132        so we set this flag file in order for xfs.init to perform a "restart"
133        instead of a "reload" in the 'condrestart'.  See bug #173271 for
134        details.
135EOF
136    fi
137  fi
138} &> /dev/null || : # Silence output, and ignore errors (Bug #91822)
139
140%post
141{
142  # Install section
143  /sbin/chkconfig --add xfs
144  #------------------------------------------------------------------------
145  # Upgrade section
146  if [ "$1" -gt "1" ] ; then
147    XORG_CONFIG=/etc/X11/xorg.conf
148    XFSCONFIG=/etc/X11/fs/config
149
150    # XFS config file upgrade munging
151    if [ -f $XFSCONFIG ] ; then
152      # Remove Speedo font directories from xfs config if present to avoid
153      # bug reports about xfs complaining about empty directories in syslog.
154      perl -p -i -e 's#^.*/.*/Speedo.*\n##' $XFSCONFIG
155
156      # On upgrades, remove /usr/X11R6 font path elements from the XFS config file
157      if grep -q "/usr/X11R6/lib/X11/fonts" $XFSCONFIG &> /dev/null ; then
158        for fpe in misc:unscaled 75dpi:unscaled 100dpi:unscaled Type1 ; do
159          perl -p -i -e "s#/usr/X11R6/lib/X11/fonts/${fpe}#%{_x11fontdir}/${fpe}#g" $XFSCONFIG
160        done
161      fi
162    fi
163  fi ; # End Upgrade section
164}
165
166%preun
167{
168  if [ "$1" = "0" ]; then
169    /sbin/service xfs stop &> /dev/null || :
170    /sbin/chkconfig --del xfs || :
171  fi
172}
173
174%postun
175{
176  if [ "$1" -gt "1" ]; then
177    /sbin/service xfs condrestart &> /dev/null || :
178  fi
179}
180
181%files
182%defattr(-,root,root,-)
183%doc xfs-%{version}/AUTHORS xfs-%{version}/COPYING
184%doc xfs-%{version}/NEWS xfs-%{version}/README xfs-%{version}/ChangeLog
185%{_bindir}/xfs
186%dir %{_sysconfdir}/X11
187%dir %{_sysconfdir}/X11/fs
188%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/fs/config
189%{_mandir}/man1/xfs.1*
190%{_sysconfdir}/rc.d/init.d/xfs
191
192%files utils
193%{_bindir}/fslsfonts
194%{_bindir}/fstobdf
195%{_bindir}/showfont
196%{_bindir}/xfsinfo
197%{_mandir}/man1/fslsfonts.1*
198%{_mandir}/man1/fstobdf.1*
199%{_mandir}/man1/showfont.1*
200%{_mandir}/man1/xfsinfo.1*
201
202%changelog
203* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-2
204- xfsinfo-1.0.5
205- fslsfonts-1.0.5
206- fstobdf-1.0.6
207- showfont-1.0.5
208
209* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
210- update to 1.1.4
211
212* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-2
213- xfsinfo-1.0.4
214- showfont-1.0.4
215
216* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
217- update to 1.1.3
218
219* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
220- fslsfonts-1.0.3
221- fstobdf-1.0.4
222
223* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
224- xfs-1.1.2
225- add BuildRequires: xorg-x11-util-macros
226
227* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
228- xfs-1.1.1
229- xfsinfo-1.0.3
230- fslsfonts-1.0.3
231- fstobdf-1.0.4
232- showfont-1.0.3
233
234* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
235- xfs-1.1.0
236
237* Sun May 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-1
238- new upstream release
239  - xfs-1.0.8, xfsinfo-1.0.2, fslsfont-1.0.2,
240    fstobdf-1.0.3, showfont-1.0.2
241
242* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
243- add version-release to Obsoletes: XOrg-xfs
244
245* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
246- add version-release to Provides: XOrg-xfs
247
248* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
249- add Provides: XOrg-xfs for compatibility
250
251* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
252- initial build for Vine Linux
253
254* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.0.5-2
255- Autorebuild for GCC 4.3
256
257* Tue Oct 02 2007 Adam Jackson <ajax@redhat.com> 1:1.0.5-1
258- xfs 1.0.5
259
260* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.0.4-2
261- Rebuild for ppc toolchain bug
262
263* Fri Jul 27 2007 Bill Nottingham <notting@redhat.com> - 1:1.0.4-2
264- don't run by default any more, as it's not used by default
265- remove explicit restorecon dependency (#215142)
266
267* Fri Jun 22 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 1:1.0.4-1
268- Require catalogue capable libXfont.
269- Drop xfs.config.in, just use catalogue font path.
270- Stop xorg.conf munging madness.
271
272* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1:1.0.2-4
273- Don't install INSTALL
274
275* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.0.2-3.1
276- rebuild
277
278* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.2-3
279- Added xfs documentation to doc macro.
280- Use "make install" instead of makeinstall macro.
281- Clean up source file URLs.
282
283* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
284- Fix BuildRequires (#191856).
285
286* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-1
287- Update xfs and fstobdf
288
289* Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-4
290- Fix all rpm scriptlets "upgrade" tests to only execute on upgrades.
291
292* Sat Feb 25 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
293- Redirect output of "rm -rf fonts.dir" to /dev/null in xfs.init
294
295* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-2.1
296- bump again for double-long bug on ppc(64)
297
298* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
299- Removed invocation of fc-cache from xfs initscript for bug (#179362)
300- Redirect stderr to /dev/null to squelch an unwanted error xfs.init (#155349)
301- Replace "s#^/.*:[a-z]*$##g" with "s#:unscaled$##g" in xfs.init for (#179491)
302- Cosmetic cleanups to spec file to satiate the banshees.
303
304* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
305- rebuilt for new gcc4.1 snapshot and glibc changes
306
307* Mon Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
308- Updated all tarballs to version 1.0.1 from X11R7.0
309
310* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> 1:1.0.0-2
311- fix rpm post script (#176009, <ville.skytta@iki.fi>)
312
313* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
314- Updated all tarballs to version 1.0.0 from X11R7 RC4.
315- Get default X font directory with font-utils package 'fontdir' pkgconfig
316  variable.
317- Change manpage dir from man1x back to man1 to match upstream.
318
319* Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.2-4
320- require initscripts instead of /etc/init.d/functions
321
322* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
323- Updated xfs pre script to check for the existance of the old monolithic
324  /usr/X11R6/lib/X11/fs/config xfs config file, and set a migration flag
325  file.
326- Updated xfs.init to check for the existance of the migration flag file,
327  and perform an xfs 'restart' instead of a 'reload' if migrating.  Users
328  will now have to restart their X server, or reconnect the xfs server to
329  the X server after a migration to modular X.
330- Changed upgrade comparison typo from 2 to 1 in xfs post script.
331
332* Mon Nov 14 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
333- Added temporary "BuildRequires: libXfont-devel >= 0.99.2-3" and
334  "Requires: libXfont-devel >= 0.99.2-3" to ensure early-testers of
335  pre-rawhide modular X have installed the work around for (#172997).
336
337* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
338- Updated to xfs-0.99.2 and fstobdf-0.99.2 from X11R7 RC2
339- Added Epoch 1 to package, and set the version number to the xfs 0.99.2
340  version.
341
342* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
343- Added showfont-0.99.1 from X11R7 RC1 release.
344
345* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
346- Updated all packages to version 0.99.1 from X11R7 RC1.
347- Bump package version to 6.99.99.901 (the RC1 CVS tag).
348- Change manpage location to 'man1x' in file manifest.
349- Converted xfs.config to xfs.config.in, and added code to spec file to
350  generate xfs.config depending on what the system _x11fontdir is.
351- Complete and total rewrite of xfs postinstall script to use "sed -i"
352  and complete restructuring, which removed a lot of the super craptasticness
353  that had been sitting there for years.
354
355* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-4
356- Use Fedora-Extras style BuildRoot tag
357- Update BuildRequires to use new library package names
358- Remove unnecessary BuildRequires on 'install', and fix pkgconfig dep
359
360* Thu Aug 25 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-3
361- Install the initscript and xfs config file in the correct location as they
362  were inadvertently interchanged in previous builds.
363
364* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
365- Ported the xfs related rpm scripts over from monolithic packaging, and
366  added up to date Requires(*) dependencies for all of them.
367- Flagged xfs config file as config(noreplace)
368- Added build and runtime dependencies to xfs subpackage as best as could be
369  determined by analyzing ./configure output, and building in minimalized
370  build root environment.
371
372* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
373- Initial build.
Note: See TracBrowser for help on using the repository browser.