source: projects/specs/trunk/x/xorg-x11-xfs/xorg-x11-xfs-vl.spec @ 9108

Revision 9108, 11.9 KB checked in by Takemikaduchi, 9 years ago (diff)

xserver-1.16.2

Line 
1Summary: X.Org X11 xfs font server
2Summary(ja): X.Org X11 xfs フォントサーバ
3Name: xorg-x11-xfs
4Version: 1.1.4
5Release: 1%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Daemons
8URL: http://www.x.org
9BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
10
11Source0: ftp://ftp.x.org/pub/individual/app/xfs-%{version}.tar.bz2
12Source1: ftp://ftp.x.org/pub/individual/app/xfsinfo-1.0.4.tar.bz2
13Source2: ftp://ftp.x.org/pub/individual/app/fslsfonts-1.0.4.tar.bz2
14Source3: ftp://ftp.x.org/pub/individual/app/fstobdf-1.0.5.tar.bz2
15Source4: ftp://ftp.x.org/pub/individual/app/showfont-1.0.4.tar.bz2
16Source10:  xfs.init
17Source11:  xfs.config
18
19BuildRequires: pkgconfig
20# xfs needs 'fontsproto' to build, as indicated by ./configure
21BuildRequires: xorg-x11-proto-devel
22# FIXME: xfs needs xtrans to build, but autotools doesn't detect it missing
23BuildRequires: xorg-x11-xtrans-devel
24BuildRequires: xorg-x11-util-macros
25BuildRequires: libFS-devel
26BuildRequires: libXfont-devel
27BuildRequires: libX11-devel
28# FIXME: xfs needs freetype-devel to build, but autotools doesn't detect it missing
29BuildRequires: freetype2-devel
30BuildRequires: libfontenc-devel
31
32# Make sure libXfont provides the catalogue FPE.
33Requires: libXfont
34
35Obsoletes: XFree86-xfs, XOrg-xfs
36Provides: xfs
37Provides: XOrg-xfs = 7.0
38
39Requires(pre): util-linux, shadow-utils
40Requires(post): initscripts, grep, sed, coreutils
41Requires(preun): initscripts, chkconfig
42Requires(postun): initscripts
43
44# xfs initscript runtime dependencies
45Requires: initscripts, fontconfig, sed, findutils
46Requires: coreutils
47Requires: mkfontdir, mkfontscale, ttmkfdir
48# end of xfs initscript runtime dependencies
49
50%description
51X.Org X11 xfs font server
52
53%package utils
54Summary: X.Org X11 font server utilities
55Summary(ja): X.Org X11 フォントサーバユーティリティ
56Group: User Interface/X
57
58Conflicts: XOrg-xfs < 7.0
59
60%description utils
61X.Org X11 font server utilities
62
63%prep
64%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
65
66%build
67
68# Build xfs
69{
70   pushd xfs-*
71   %configure --disable-devel-docs
72   make configdir=%{_sysconfdir}/X11/fs
73   popd
74}
75
76for pkg in xfsinfo fslsfonts fstobdf showfont ; do
77   pushd ${pkg}-*
78   %configure
79   make
80   popd
81done
82
83%install
84rm -rf $RPM_BUILD_ROOT
85# Install xfs
86{
87   pushd xfs-*
88   %makeinstall configdir=$RPM_BUILD_ROOT%{_sysconfdir}/X11/fs
89   popd
90}
91
92for pkg in xfsinfo fslsfonts fstobdf showfont ; do
93   pushd ${pkg}-*
94   make install DESTDIR=$RPM_BUILD_ROOT
95   popd
96done
97
98# Install the modified xfs config file and initscript
99{
100   mkdir -p $RPM_BUILD_ROOT/etc/{X11/fs,rc.d/init.d}
101   install -c -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_sysconfdir}/rc.d/init.d/xfs
102   install -c -m 644 %{SOURCE11} $RPM_BUILD_ROOT%{_sysconfdir}/X11/fs/config
103}
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%triggerpostun -- XFree86-xfs
109{
110  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
111  /sbin/chkconfig --add xfs
112  /sbin/service xfs condrestart || :
113} &> /dev/null || :
114
115%triggerpostun -- XOrg-xfs
116{
117  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
118  /sbin/chkconfig --add xfs
119  /sbin/service xfs condrestart || :
120} &> /dev/null || :
121
122%pre
123{
124  /usr/sbin/useradd -c "X Font Server" -r -s /sbin/nologin -u 43 -d /etc/X11/fs xfs || :
125  # Upgrade path:
126  if [ "$1" -gt "1" ] ; then
127    if [ -e "/usr/X11R6/lib/X11/fs/config" ] ; then
128      cat <<-EOF > "/etc/X11/fs/xfs-migrate"
129        On upgrades, we now must determine if we are upgrading from monolithic
130        xfs or modular xfs by checking for the existance of the old monolithic
131        xfs config file.  If found, we know it is a monolith->modular upgrade,
132        so we set this flag file in order for xfs.init to perform a "restart"
133        instead of a "reload" in the 'condrestart'.  See bug #173271 for
134        details.
135EOF
136    fi
137  fi
138} &> /dev/null || : # Silence output, and ignore errors (Bug #91822)
139
140%post
141{
142  # Install section
143  /sbin/chkconfig --add xfs
144  #------------------------------------------------------------------------
145  # Upgrade section
146  if [ "$1" -gt "1" ] ; then
147    XORG_CONFIG=/etc/X11/xorg.conf
148    XFSCONFIG=/etc/X11/fs/config
149
150    # XFS config file upgrade munging
151    if [ -f $XFSCONFIG ] ; then
152      # Remove Speedo font directories from xfs config if present to avoid
153      # bug reports about xfs complaining about empty directories in syslog.
154      perl -p -i -e 's#^.*/.*/Speedo.*\n##' $XFSCONFIG
155
156      # On upgrades, remove /usr/X11R6 font path elements from the XFS config file
157      if grep -q "/usr/X11R6/lib/X11/fonts" $XFSCONFIG &> /dev/null ; then
158        for fpe in misc:unscaled 75dpi:unscaled 100dpi:unscaled Type1 ; do
159          perl -p -i -e "s#/usr/X11R6/lib/X11/fonts/${fpe}#%{_x11fontdir}/${fpe}#g" $XFSCONFIG
160        done
161      fi
162    fi
163  fi ; # End Upgrade section
164}
165
166%preun
167{
168  if [ "$1" = "0" ]; then
169    /sbin/service xfs stop &> /dev/null || :
170    /sbin/chkconfig --del xfs || :
171  fi
172}
173
174%postun
175{
176  if [ "$1" -gt "1" ]; then
177    /sbin/service xfs condrestart &> /dev/null || :
178  fi
179}
180
181%files
182%defattr(-,root,root,-)
183%doc xfs-%{version}/AUTHORS xfs-%{version}/COPYING
184%doc xfs-%{version}/NEWS xfs-%{version}/README xfs-%{version}/ChangeLog
185%{_bindir}/xfs
186%dir %{_sysconfdir}/X11
187%dir %{_sysconfdir}/X11/fs
188%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/fs/config
189%{_mandir}/man1/xfs.1*
190%{_sysconfdir}/rc.d/init.d/xfs
191
192%files utils
193%{_bindir}/fslsfonts
194%{_bindir}/fstobdf
195%{_bindir}/showfont
196%{_bindir}/xfsinfo
197%{_mandir}/man1/fslsfonts.1*
198%{_mandir}/man1/fstobdf.1*
199%{_mandir}/man1/showfont.1*
200%{_mandir}/man1/xfsinfo.1*
201
202%changelog
203* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.4-1
204- update to 1.1.4
205
206* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-2
207- xfsinfo-1.0.4
208- showfont-1.0.4
209
210* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.3-1
211- update to 1.1.3
212
213* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-2
214- fslsfonts-1.0.3
215- fstobdf-1.0.4
216
217* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.2-1
218- xfs-1.1.2
219- add BuildRequires: xorg-x11-util-macros
220
221* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.1.1-1
222- xfs-1.1.1
223- xfsinfo-1.0.3
224- fslsfonts-1.0.3
225- fstobdf-1.0.4
226- showfont-1.0.3
227
228* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
229- xfs-1.1.0
230
231* Sun May 25 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.8-1
232- new upstream release
233  - xfs-1.0.8, xfsinfo-1.0.2, fslsfont-1.0.2,
234    fstobdf-1.0.3, showfont-1.0.2
235
236* Mon May 19 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-4
237- add version-release to Obsoletes: XOrg-xfs
238
239* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-3
240- add version-release to Provides: XOrg-xfs
241
242* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-2
243- add Provides: XOrg-xfs for compatibility
244
245* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 1.0.5-1
246- initial build for Vine Linux
247
248* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1:1.0.5-2
249- Autorebuild for GCC 4.3
250
251* Tue Oct 02 2007 Adam Jackson <ajax@redhat.com> 1:1.0.5-1
252- xfs 1.0.5
253
254* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 1:1.0.4-2
255- Rebuild for ppc toolchain bug
256
257* Fri Jul 27 2007 Bill Nottingham <notting@redhat.com> - 1:1.0.4-2
258- don't run by default any more, as it's not used by default
259- remove explicit restorecon dependency (#215142)
260
261* Fri Jun 22 2007 Kristian H淡gsberg <krh@hinata.boston.redhat.com> - 1:1.0.4-1
262- Require catalogue capable libXfont.
263- Drop xfs.config.in, just use catalogue font path.
264- Stop xorg.conf munging madness.
265
266* Sat Apr 21 2007 Matthias Clasen <mclasen@redhat.com> - 1:1.0.2-4
267- Don't install INSTALL
268
269* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:1.0.2-3.1
270- rebuild
271
272* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.2-3
273- Added xfs documentation to doc macro.
274- Use "make install" instead of makeinstall macro.
275- Clean up source file URLs.
276
277* Tue May 30 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
278- Fix BuildRequires (#191856).
279
280* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-1
281- Update xfs and fstobdf
282
283* Wed Mar 01 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-4
284- Fix all rpm scriptlets "upgrade" tests to only execute on upgrades.
285
286* Sat Feb 25 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
287- Redirect output of "rm -rf fonts.dir" to /dev/null in xfs.init
288
289* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-2.1
290- bump again for double-long bug on ppc(64)
291
292* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
293- Removed invocation of fc-cache from xfs initscript for bug (#179362)
294- Redirect stderr to /dev/null to squelch an unwanted error xfs.init (#155349)
295- Replace "s#^/.*:[a-z]*$##g" with "s#:unscaled$##g" in xfs.init for (#179491)
296- Cosmetic cleanups to spec file to satiate the banshees.
297
298* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
299- rebuilt for new gcc4.1 snapshot and glibc changes
300
301* Mon Jan 16 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
302- Updated all tarballs to version 1.0.1 from X11R7.0
303
304* Tue Jan 10 2006 Bill Nottingham <notting@redhat.com> 1:1.0.0-2
305- fix rpm post script (#176009, <ville.skytta@iki.fi>)
306
307* Fri Dec 16 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
308- Updated all tarballs to version 1.0.0 from X11R7 RC4.
309- Get default X font directory with font-utils package 'fontdir' pkgconfig
310  variable.
311- Change manpage dir from man1x back to man1 to match upstream.
312
313* Tue Nov 15 2005 Jeremy Katz <katzj@redhat.com> 1:0.99.2-4
314- require initscripts instead of /etc/init.d/functions
315
316* Tue Nov 15 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
317- Updated xfs pre script to check for the existance of the old monolithic
318  /usr/X11R6/lib/X11/fs/config xfs config file, and set a migration flag
319  file.
320- Updated xfs.init to check for the existance of the migration flag file,
321  and perform an xfs 'restart' instead of a 'reload' if migrating.  Users
322  will now have to restart their X server, or reconnect the xfs server to
323  the X server after a migration to modular X.
324- Changed upgrade comparison typo from 2 to 1 in xfs post script.
325
326* Mon Nov 14 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
327- Added temporary "BuildRequires: libXfont-devel >= 0.99.2-3" and
328  "Requires: libXfont-devel >= 0.99.2-3" to ensure early-testers of
329  pre-rawhide modular X have installed the work around for (#172997).
330
331* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
332- Updated to xfs-0.99.2 and fstobdf-0.99.2 from X11R7 RC2
333- Added Epoch 1 to package, and set the version number to the xfs 0.99.2
334  version.
335
336* Thu Nov 10 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
337- Added showfont-0.99.1 from X11R7 RC1 release.
338
339* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
340- Updated all packages to version 0.99.1 from X11R7 RC1.
341- Bump package version to 6.99.99.901 (the RC1 CVS tag).
342- Change manpage location to 'man1x' in file manifest.
343- Converted xfs.config to xfs.config.in, and added code to spec file to
344  generate xfs.config depending on what the system _x11fontdir is.
345- Complete and total rewrite of xfs postinstall script to use "sed -i"
346  and complete restructuring, which removed a lot of the super craptasticness
347  that had been sitting there for years.
348
349* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-4
350- Use Fedora-Extras style BuildRoot tag
351- Update BuildRequires to use new library package names
352- Remove unnecessary BuildRequires on 'install', and fix pkgconfig dep
353
354* Thu Aug 25 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-3
355- Install the initscript and xfs config file in the correct location as they
356  were inadvertently interchanged in previous builds.
357
358* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-2
359- Ported the xfs related rpm scripts over from monolithic packaging, and
360  added up to date Requires(*) dependencies for all of them.
361- Flagged xfs config file as config(noreplace)
362- Added build and runtime dependencies to xfs subpackage as best as could be
363  determined by analyzing ./configure output, and building in minimalized
364  build root environment.
365
366* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
367- Initial build.
Note: See TracBrowser for help on using the repository browser.