source: projects/specs/trunk/x/xorg-x11-utils/xorg-x11-utils-vl.spec @ 578

Revision 578, 5.6 KB checked in by daisuke, 14 years ago (diff)

xorg-x11-utils-7.5-2
add edid-decode

Line 
1%define pkgname utils
2
3Summary: X.Org X11 X client utilities
4Summary(ja): X.Org X11 X クライアントユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0:  ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.1.0.tar.bz2
14Source1:  ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.3.tar.bz2
15Source2:  ftp://ftp.x.org/pub/individual/app/xev-1.0.4.tar.bz2
16Source3:  ftp://ftp.x.org/pub/individual/app/xfd-1.0.1.tar.bz2
17Source4:  ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.2.tar.bz2
18Source5:  ftp://ftp.x.org/pub/individual/app/xlsatoms-1.0.2.tar.bz2
19Source6:  ftp://ftp.x.org/pub/individual/app/xlsclients-1.0.2.tar.bz2
20Source7:  ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.2.tar.bz2
21Source8:  ftp://ftp.x.org/pub/individual/app/xprop-1.1.0.tar.bz2
22Source9:  ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.0.tar.bz2
23Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.0.5.tar.bz2
24
25Source100: edid-decode-20100205.tar.xz
26Source101: make-edid-decode-snapshot.sh
27
28BuildRequires: pkgconfig
29BuildRequires: libdmx-devel
30BuildRequires: libGL-devel
31BuildRequires: libXaw-devel >= 1.0.5
32BuildRequires: libXext-devel
33BuildRequires: libXft-devel
34BuildRequires: libXi-devel
35BuildRequires: libXinerama-devel
36BuildRequires: libXpm-devel
37BuildRequires: libXt-devel
38BuildRequires: libXtst-devel
39BuildRequires: libXv-devel
40BuildRequires: libXxf86dga-devel
41BuildRequires: libXxf86misc-devel
42BuildRequires: libXxf86vm-devel
43
44# FIXME: check if still needed for X11R7
45Requires(pre): filesystem
46
47Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
48
49%description
50A collection of client utilities which can be used to query the X server
51for various information, view and select fonts, etc.
52
53%prep
54%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a100
55
56%build
57# Build all apps
58{
59   for app in * ; do
60      pushd $app
61      if [ -e ./configure ]; then
62        %configure
63      fi
64      make
65      popd
66   done
67}
68
69%install
70rm -rf $RPM_BUILD_ROOT
71# Install all apps
72{
73   for app in * ; do
74      pushd $app
75      make install DESTDIR=$RPM_BUILD_ROOT
76      popd
77   done
78}
79
80%clean
81rm -rf $RPM_BUILD_ROOT
82
83%files
84%defattr(-,root,root,-)
85%doc
86%{_bindir}/edid-decode
87%{_bindir}/xdpyinfo
88%{_bindir}/xdriinfo
89%{_bindir}/xev
90%{_bindir}/xfd
91%{_bindir}/xfontsel
92%{_bindir}/xlsatoms
93%{_bindir}/xlsclients
94%{_bindir}/xlsfonts
95%{_bindir}/xprop
96%{_bindir}/xvinfo
97%{_bindir}/xwininfo
98%dir %{_datadir}/X11
99%{_datadir}/X11/app-defaults/XFontSel
100%{_datadir}/X11/app-defaults/Xfd
101%{_mandir}/man1/xdpyinfo.1*
102%{_mandir}/man1/xdriinfo.1*
103%{_mandir}/man1/xev.1*
104%{_mandir}/man1/xfd.1*
105%{_mandir}/man1/xfontsel.1*
106%{_mandir}/man1/xlsatoms.1*
107%{_mandir}/man1/xlsclients.1*
108%{_mandir}/man1/xlsfonts.1*
109%{_mandir}/man1/xprop.1*
110%{_mandir}/man1/xvinfo.1*
111%{_mandir}/man1/xwininfo.1*
112
113%changelog
114* Tue Mar 16 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-2
115- add edid-decode snapshot
116
117* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
118- xdpyinfo-1.1.0
119- xdriinfo-1.0.3
120- xev-1.0.4
121- xlsatoms-1.0.2
122- xlsclient-1.0.2
123- xprop-1.1.0
124- xvinfo-1.1.0
125- xwininfo-1.0.5
126
127* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
128- rebuild with libXaw.so.7 (libXaw-1.0.5)
129
130* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
131- xdpyinfo 1.0.3
132- xev 1.0.3
133- xprop 1.0.4
134- xwininfo 1.0.4
135
136* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
137- initial build for Vine Linux
138
139* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
140- Autorebuild for GCC 4.3
141
142* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
143- xdriinfo 1.0.2
144- xwininfo 1.0.3
145- Bump to 7.3
146
147* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
148- xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
149
150* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
151- xdpyinfo 1.0.2
152
153* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
154- Fix man page glob and rebuild for FC7.
155
156* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
157- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
158- Add 'dist' tag to package release string.
159
160* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
161- rebuild
162
163* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
164- Bump package version to 7.1 to reflect the X11 release the utilities
165  are aggregated from.
166- Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
167
168* Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
169- Fix BuildRequires (#191966)
170
171* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
172- Remove a spurious Xprint dependency from xdpyinfo.
173
174* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
175- bump again for double-long bug on ppc(64)
176
177* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
178- rebuilt for new gcc4.1 snapshot and glibc changes
179
180* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
181- Updated all tarballs to versions from X11R7.0
182
183* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
184- Updated all tarballs to version 1.0.0 from X11R7 RC4.
185- Changed manpage dir from man1x to man1 to match upstream RC4 default.
186- Moved all app-defaults files from _libdir to _datadir
187
188* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
189- require newer filesystem package (#172610)
190
191* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
192- rebuild
193
194* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
195- Initial build, with all apps taken from X11R7 RC2
196- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
197  some packages.
Note: See TracBrowser for help on using the repository browser.