source: projects/specs/trunk/x/xorg-x11-utils/xorg-x11-utils-vl.spec @ 521

Revision 521, 5.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define pkgname utils
2
3Summary: X.Org X11 X client utilities
4Summary(ja): X.Org X11 X クライアントユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.5
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
12
13Source0:  ftp://ftp.x.org/pub/individual/app/xdpyinfo-1.1.0.tar.bz2
14Source1:  ftp://ftp.x.org/pub/individual/app/xdriinfo-1.0.3.tar.bz2
15Source2:  ftp://ftp.x.org/pub/individual/app/xev-1.0.4.tar.bz2
16Source3:  ftp://ftp.x.org/pub/individual/app/xfd-1.0.1.tar.bz2
17Source4:  ftp://ftp.x.org/pub/individual/app/xfontsel-1.0.2.tar.bz2
18Source5:  ftp://ftp.x.org/pub/individual/app/xlsatoms-1.0.2.tar.bz2
19Source6:  ftp://ftp.x.org/pub/individual/app/xlsclients-1.0.2.tar.bz2
20Source7:  ftp://ftp.x.org/pub/individual/app/xlsfonts-1.0.2.tar.bz2
21Source8:  ftp://ftp.x.org/pub/individual/app/xprop-1.1.0.tar.bz2
22Source9:  ftp://ftp.x.org/pub/individual/app/xvinfo-1.1.0.tar.bz2
23Source10: ftp://ftp.x.org/pub/individual/app/xwininfo-1.0.5.tar.bz2
24
25BuildRequires: pkgconfig
26BuildRequires: libdmx-devel
27BuildRequires: libGL-devel
28BuildRequires: libXaw-devel >= 1.0.5
29BuildRequires: libXext-devel
30BuildRequires: libXft-devel
31BuildRequires: libXi-devel
32BuildRequires: libXinerama-devel
33BuildRequires: libXpm-devel
34BuildRequires: libXt-devel
35BuildRequires: libXtst-devel
36BuildRequires: libXv-devel
37BuildRequires: libXxf86dga-devel
38BuildRequires: libXxf86misc-devel
39BuildRequires: libXxf86vm-devel
40
41# FIXME: check if still needed for X11R7
42Requires(pre): filesystem
43
44Provides: xdpyinfo xdriinfo xev xfd xfontsel xlsatoms xlsclients xlsfonts xprop xvinfo xwininfo
45
46%description
47A collection of client utilities which can be used to query the X server
48for various information, view and select fonts, etc.
49
50%prep
51%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10
52
53%build
54# Build all apps
55{
56   for app in * ; do
57      pushd $app
58      %configure
59      make
60      popd
61   done
62}
63
64%install
65rm -rf $RPM_BUILD_ROOT
66# Install all apps
67{
68   for app in * ; do
69      pushd $app
70      make install DESTDIR=$RPM_BUILD_ROOT
71      popd
72   done
73}
74
75%clean
76rm -rf $RPM_BUILD_ROOT
77
78%files
79%defattr(-,root,root,-)
80%doc
81%{_bindir}/xdpyinfo
82%{_bindir}/xdriinfo
83%{_bindir}/xev
84%{_bindir}/xfd
85%{_bindir}/xfontsel
86%{_bindir}/xlsatoms
87%{_bindir}/xlsclients
88%{_bindir}/xlsfonts
89%{_bindir}/xprop
90%{_bindir}/xvinfo
91%{_bindir}/xwininfo
92%dir %{_datadir}/X11
93%{_datadir}/X11/app-defaults/XFontSel
94%{_datadir}/X11/app-defaults/Xfd
95%{_mandir}/man1/xdpyinfo.1*
96%{_mandir}/man1/xdriinfo.1*
97%{_mandir}/man1/xev.1*
98%{_mandir}/man1/xfd.1*
99%{_mandir}/man1/xfontsel.1*
100%{_mandir}/man1/xlsatoms.1*
101%{_mandir}/man1/xlsclients.1*
102%{_mandir}/man1/xlsfonts.1*
103%{_mandir}/man1/xprop.1*
104%{_mandir}/man1/xvinfo.1*
105%{_mandir}/man1/xwininfo.1*
106
107%changelog
108* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
109- xdpyinfo-1.1.0
110- xdriinfo-1.0.3
111- xev-1.0.4
112- xlsatoms-1.0.2
113- xlsclient-1.0.2
114- xprop-1.1.0
115- xvinfo-1.1.0
116- xwininfo-1.0.5
117
118* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
119- rebuild with libXaw.so.7 (libXaw-1.0.5)
120
121* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
122- xdpyinfo 1.0.3
123- xev 1.0.3
124- xprop 1.0.4
125- xwininfo 1.0.4
126
127* Wed Mar 26 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
128- initial build for Vine Linux
129
130* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 7.3-2
131- Autorebuild for GCC 4.3
132
133* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
134- xdriinfo 1.0.2
135- xwininfo 1.0.3
136- Bump to 7.3
137
138* Fri Aug 17 2007 Dave Airlie <airlied@redhat.com> 7.2-1
139- xfontsel 1.0.2, xlsfonts 1.0.2, xvinfo 1.0.2, xprop 1.0.3
140
141* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 7.1-4
142- xdpyinfo 1.0.2
143
144* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-3
145- Fix man page glob and rebuild for FC7.
146
147* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
148- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
149- Add 'dist' tag to package release string.
150
151* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
152- rebuild
153
154* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
155- Bump package version to 7.1 to reflect the X11 release the utilities
156  are aggregated from.
157- Updated to xdriinfo-1.0.1, xev-1.0.2, xwininfo-1.0.2 from X11R7.1
158
159* Wed May 31 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
160- Fix BuildRequires (#191966)
161
162* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
163- Remove a spurious Xprint dependency from xdpyinfo.
164
165* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
166- bump again for double-long bug on ppc(64)
167
168* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
169- rebuilt for new gcc4.1 snapshot and glibc changes
170
171* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
172- Updated all tarballs to versions from X11R7.0
173
174* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
175- Updated all tarballs to version 1.0.0 from X11R7 RC4.
176- Changed manpage dir from man1x to man1 to match upstream RC4 default.
177- Moved all app-defaults files from _libdir to _datadir
178
179* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
180- require newer filesystem package (#172610)
181
182* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-2
183- rebuild
184
185* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
186- Initial build, with all apps taken from X11R7 RC2
187- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
188  some packages.
Note: See TracBrowser for help on using the repository browser.