source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 5538

Revision 5538, 11.0 KB checked in by Takemikaduchi, 12 years ago (diff)

new upstream release

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 5%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.5.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.4.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.7.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.3.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.4.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.4.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.5.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.5.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.9.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.4.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.2.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.0.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.2.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.2.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80Vendor: Project Vine
81Distribution: Vine Linux
82
83%description
84A collection of utilities used to tweak and query the runtime configuration
85of the X server.
86
87%prep
88%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
89
90## %patch1100 -p0 -b .datadir-rgbpath-fix
91## %patch1700 -p1 -b .buffer-stomp
92## %patch1710 -p1 -b .xaw7
93
94
95%build
96
97# Build all apps
98{
99   for app in * ; do
100      pushd $app
101      case $app in
102         rgb-*)
103            # FIXME: run autotools junk to kick in our patch
104            aclocal --force
105            automake -f
106            autoconf
107            %configure ;# --with-rgb-db=%{_datadir}/X11
108            ;;
109         xset-*)
110            # FIXME: run autotools junk to kick in our patch
111            aclocal --force
112            automake -f
113            autoconf
114            %configure
115            ;;
116         xvidtune-*)
117            # FIXME: run autotools junk to kick in our patch
118            aclocal --force
119            automake -f
120            autoconf
121            %configure
122            ;;
123         *)
124            %configure
125            ;;
126      esac
127
128      make
129      popd
130   done
131}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135# Install all apps
136{
137   for app in * ; do
138      pushd $app
139      case $app in
140         *)
141            make install DESTDIR=$RPM_BUILD_ROOT
142            ;;
143      esac
144      popd
145   done
146}
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%files
152%defattr(-,root,root,-)
153%doc
154%{_bindir}/iceauth
155%{_bindir}/sessreg
156%{_bindir}/showrgb
157%{_bindir}/xcmsdb
158%{_bindir}/xgamma
159%{_bindir}/xhost
160%{_bindir}/xkeystone
161%{_bindir}/xmodmap
162%{_bindir}/xrandr
163%{_bindir}/xrdb
164%{_bindir}/xrefresh
165%{_bindir}/xset
166%{_bindir}/xsetmode
167%{_bindir}/xsetpointer
168%{_bindir}/xsetroot
169%{_bindir}/xstdcmap
170%{_bindir}/xvidtune
171%dir %{_datadir}/X11
172%{_datadir}/X11/rgb.txt
173%{_datadir}/X11/app-defaults/Xvidtune
174%{_mandir}/man1/iceauth.1*
175%{_mandir}/man1/sessreg.1*
176%{_mandir}/man1/showrgb.1*
177%{_mandir}/man1/xcmsdb.1*
178%{_mandir}/man1/xgamma.1*
179%{_mandir}/man1/xhost.1*
180%{_mandir}/man1/xmodmap.1*
181%{_mandir}/man1/xrandr.1*
182%{_mandir}/man1/xrdb.1*
183%{_mandir}/man1/xrefresh.1*
184%{_mandir}/man1/xset.1*
185%{_mandir}/man1/xsetmode.1*
186%{_mandir}/man1/xsetpointer.1*
187%{_mandir}/man1/xsetroot.1*
188%{_mandir}/man1/xstdcmap.1*
189%{_mandir}/man1/xvidtune.1*
190
191%changelog
192* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
193- sessreg-1.0.7
194
195* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
196- iceauth-1.0.5
197- xcmsdb-1.0.3
198- xrandr-1.3.5
199- xset-1.2.2
200
201* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
202- delete Obsoletes: xorg-x11
203
204* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
205- xrdb-1.0.9
206  (including security fix for CVE-2011-0465)
207
208* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
209- xrdb-1.0.8
210
211* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
212- xgamma-1.0.4
213- xrdb-1.0.7
214- xrefresh-1.0.4
215- xset-1.2.1
216
217* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
218- iceauth-1.0.4
219- rgb-1.0.4
220- sessreg-1.0.6
221- xcmsdb-1.0.3
222- xhost-1.0.4
223- xmodmap-1.0.5
224- xrandr-1.3.4
225- xset-1.2.0
226- xsetroot-1.1.0
227- xstdcmap-1.0.2
228- xvidtune-1.0.2
229- drop Patch1100,1700,1710
230- add BuildRequires: libXcursor-devel
231- fix %%files
232
233* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
234- iceauth-1.0.3
235- sessreg-1.0.5
236- xcmsdb-1.0.2
237- xgamma-1.0.3
238- xhost-1.0.3
239- xmodmap-1.0.4
240- xrandr-1.3.2
241- xrdb-1.0.6
242- xrefresh-1.0.3
243- xset-1.1.0
244- xsetroot-1.0.3
245- drop xtrap (deprecated upstream)
246
247* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
248- xrandr-1.3.0
249
250* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
251- xrandr-1.2.99.4
252
253* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
254- rebuild with libXaw.so.7 (libXaw-1.0.5)
255
256* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
257- rgb 1.0.3
258- sessreg 1.0.4
259- xhost 1.0.2
260- xrandr 1.2.3
261- xrdb 1.0.5
262- xset 1.0.4
263- xsetpointer 1.0.1
264
265* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
266- new versioning policy
267
268* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
269- initial build for Vine Linux
270
271* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
272- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
273- xrandr-1.2.2-verify-crtc-against-prev-config.patch
274- Patches from upstream to fix some bug in xrandr app
275
276* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
277- sessreg 1.0.3
278- xgamma 1.0.2
279- xmodmap 1.0.3
280- xrdb 1.0.4
281- xset 1.0.3
282- xsetroot 1.0.2
283- Bump to 7.3
284
285* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
286- Rebuild for ppc toolchain bug
287
288* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
289- rebuild for toolchain bug
290
291* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
292- iceauth 1.0.2
293
294* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
295- xrandr 1.2.2
296
297* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
298- xrandr 1.2.1
299
300* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
301- Superstition bump to 7.2
302- xrandr 1.2.0
303
304* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
305- Fix man page globs and rebuild for FC7.
306
307* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
308- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
309
310* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
311- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
312- Add 'dist' tag to package release string.
313
314* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
315- rebuild
316
317- Update to rgb-1.0.2 from X11R7.1
318
319* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
320- Bump the package version to 7.1 to have it match the X11 release that the
321  tarballs came from going forward.
322- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
323- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
324
325* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
326- Clean up Source lines in spec file, and other minor cleanups.
327
328* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
329- Added a whackload of BuildRequires for bug (#191987)
330
331* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
332- Updated xmodmap, xrandr, xrdb, and xset.
333
334* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
335- Eliminate a spurious Xprint dependency from xset.
336
337* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
338- Drop lbxproxy, LBX is deprecated upstream
339- Update to xhost 1.0.1
340
341* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
342- bump again for double-long bug on ppc(64)
343
344* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
345- rebuilt for new gcc4.1 snapshot and glibc changes
346
347* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
348- Updated all packages to the versions from X11R7.0
349
350* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
351- Updated all packages to version 1.0.0 from X11R7 RC4
352- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
353- Updated lbxproxy-datadir-AtomControl-fix.patch
354- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
355- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
356
357* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
358- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
359
360* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
361- Bump "filesystem" Requires(pre) to 2.3.7-1.
362
363* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
364- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
365  independent data files from libdir to datadir.
366- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
367  data files from libdir to datadir.
368- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
369  into datadir.
370
371* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
372- require newer filesystem package (#172610)
373
374* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
375- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
376- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
377
378* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
379- Initial build, with all apps taken from X11R7 RC2
380- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
381  some packages.
Note: See TracBrowser for help on using the repository browser.