source: projects/specs/trunk/x/xorg-x11-server-utils/xorg-x11-server-utils-vl.spec @ 4616

Revision 4616, 11.0 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkgname server-utils
2
3Summary: X.Org X11 X server utilities
4Summary(ja): X.Org X11 X サーバユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 4%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0:  ftp://ftp.x.org/pub/individual/app/iceauth-1.0.5.tar.bz2
13Source2:  ftp://ftp.x.org/pub/individual/app/rgb-1.0.4.tar.bz2
14Source3:  ftp://ftp.x.org/pub/individual/app/sessreg-1.0.6.tar.bz2
15Source4:  ftp://ftp.x.org/pub/individual/app/xcmsdb-1.0.3.tar.bz2
16Source5:  ftp://ftp.x.org/pub/individual/app/xgamma-1.0.4.tar.bz2
17Source6:  ftp://ftp.x.org/pub/individual/app/xhost-1.0.4.tar.bz2
18Source7:  ftp://ftp.x.org/pub/individual/app/xmodmap-1.0.5.tar.bz2
19Source8:  ftp://ftp.x.org/pub/individual/app/xrandr-1.3.5.tar.bz2
20Source9:  ftp://ftp.x.org/pub/individual/app/xrdb-1.0.9.tar.bz2
21Source10: ftp://ftp.x.org/pub/individual/app/xrefresh-1.0.4.tar.bz2
22Source11: ftp://ftp.x.org/pub/individual/app/xset-1.2.2.tar.bz2
23Source12: ftp://ftp.x.org/pub/individual/app/xsetmode-1.0.0.tar.bz2
24Source13: ftp://ftp.x.org/pub/individual/app/xsetpointer-1.0.1.tar.bz2
25Source14: ftp://ftp.x.org/pub/individual/app/xsetroot-1.1.0.tar.bz2
26Source15: ftp://ftp.x.org/pub/individual/app/xstdcmap-1.0.2.tar.bz2
27Source17: ftp://ftp.x.org/pub/individual/app/xvidtune-1.0.2.tar.bz2
28# NOTE: Each upstream tarball has its own "PatchN" section, taken from
29# multiplying the "SourceN" line times 100.  Please keep them in this
30# order.  Also, please keep each patch specific to a single upstream tarball,
31# so that they don't have to be split in half when submitting upstream.
32#
33# iceauth section
34#Patch0:
35
36# rgb section
37Patch1100: rgb-1.0.3-datadir-rgbpath-fix.patch
38# xvidtune section
39Patch1700: xvidtune-1.0.1-buffer-stomp.patch
40Patch1710: xvidtune-1.0.1-xaw7.patch
41
42# xrandr section
43
44BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
45# FIXME: Temporary build dep on automake, autoconf while they're still used
46# in the specfile.
47BuildRequires: autoconf, automake
48BuildRequires: pkgconfig
49# xsetroot requires xbitmaps-devel
50BuildRequires: xbitmaps-devel
51# xsetroot requires libX11-devel
52BuildRequires: libX11-devel
53# xsetroot requires libXmu-devel
54BuildRequires: libXmu-devel
55BuildRequires: xorg-x11-xtrans-devel libXext-devel
56BuildRequires: libXrandr-devel >= 1.2.0
57BuildRequires: xorg-x11-util-macros libXxf86vm-devel libXrandr-devel
58BuildRequires: libXrender-devel libXi-devel libXt-devel
59BuildRequires: libXaw-devel >= 1.0.5
60BuildRequires: libXpm-devel libXxf86misc-devel libXfontcache-devel
61BuildRequires: zlib-devel
62BuildRequires: libXcursor-devel
63# ENDNOTE
64
65# xrdb requires the C preprocessor to work properly
66Requires: cpp
67
68Requires: libXrandr
69
70Provides: iceauth rgb sessreg xcmsdb xgamma xhost
71Provides: xmodmap xrandr xrdb xrefresh xset xsetmode xsetpointer
72Provides: xsetroot xstdcmap xvidtune
73
74# NOTE: iceauth, rgb, sessreg, xcmsdb, xgamma, xhost, xmodmap,
75# xrandr, xrdb, xrefresh, xset, xsetmode, xsetpointer, xsetroot, xstdcmap,
76# xvidtune, were all in xorg-x11 and XFree86 packages, so we obsolete
77# them to ensure upgrades work.
78Obsoletes: XFree86
79
80Vendor: Project Vine
81Distribution: Vine Linux
82
83%description
84A collection of utilities used to tweak and query the runtime configuration
85of the X server.
86
87%prep
88%setup -q -c %{name}-%{version} -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a17
89
90## %patch1100 -p0 -b .datadir-rgbpath-fix
91## %patch1700 -p1 -b .buffer-stomp
92## %patch1710 -p1 -b .xaw7
93
94
95%build
96
97# Build all apps
98{
99   for app in * ; do
100      pushd $app
101      case $app in
102         rgb-*)
103            # FIXME: run autotools junk to kick in our patch
104            aclocal --force
105            automake -f
106            autoconf
107            %configure ;# --with-rgb-db=%{_datadir}/X11
108            ;;
109         xset-*)
110            # FIXME: run autotools junk to kick in our patch
111            aclocal --force
112            automake -f
113            autoconf
114            %configure
115            ;;
116         xvidtune-*)
117            # FIXME: run autotools junk to kick in our patch
118            aclocal --force
119            automake -f
120            autoconf
121            %configure
122            ;;
123         *)
124            %configure
125            ;;
126      esac
127
128      make
129      popd
130   done
131}
132
133%install
134rm -rf $RPM_BUILD_ROOT
135# Install all apps
136{
137   for app in * ; do
138      pushd $app
139      case $app in
140         *)
141            make install DESTDIR=$RPM_BUILD_ROOT
142            ;;
143      esac
144      popd
145   done
146}
147
148%clean
149rm -rf $RPM_BUILD_ROOT
150
151%files
152%defattr(-,root,root,-)
153%doc
154%{_bindir}/iceauth
155%{_bindir}/sessreg
156%{_bindir}/showrgb
157%{_bindir}/xcmsdb
158%{_bindir}/xgamma
159%{_bindir}/xhost
160%{_bindir}/xkeystone
161%{_bindir}/xmodmap
162%{_bindir}/xrandr
163%{_bindir}/xrdb
164%{_bindir}/xrefresh
165%{_bindir}/xset
166%{_bindir}/xsetmode
167%{_bindir}/xsetpointer
168%{_bindir}/xsetroot
169%{_bindir}/xstdcmap
170%{_bindir}/xvidtune
171%dir %{_datadir}/X11
172%{_datadir}/X11/rgb.txt
173%{_datadir}/X11/app-defaults/Xvidtune
174%{_mandir}/man1/iceauth.1*
175%{_mandir}/man1/sessreg.1*
176%{_mandir}/man1/showrgb.1*
177%{_mandir}/man1/xcmsdb.1*
178%{_mandir}/man1/xgamma.1*
179%{_mandir}/man1/xhost.1*
180%{_mandir}/man1/xmodmap.1*
181%{_mandir}/man1/xrandr.1*
182%{_mandir}/man1/xrdb.1*
183%{_mandir}/man1/xrefresh.1*
184%{_mandir}/man1/xset.1*
185%{_mandir}/man1/xsetmode.1*
186%{_mandir}/man1/xsetpointer.1*
187%{_mandir}/man1/xsetroot.1*
188%{_mandir}/man1/xstdcmap.1*
189%{_mandir}/man1/xvidtune.1*
190
191%changelog
192* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
193- iceauth-1.0.5
194- xcmsdb-1.0.3
195- xrandr-1.3.5
196- xset-1.2.2
197
198* Sun May 01 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
199- delete Obsoletes: xorg-x11
200
201* Thu Apr 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
202- xrdb-1.0.9
203  (including security fix for CVE-2011-0465)
204
205* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
206- xrdb-1.0.8
207
208* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
209- xgamma-1.0.4
210- xrdb-1.0.7
211- xrefresh-1.0.4
212- xset-1.2.1
213
214* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
215- iceauth-1.0.4
216- rgb-1.0.4
217- sessreg-1.0.6
218- xcmsdb-1.0.3
219- xhost-1.0.4
220- xmodmap-1.0.5
221- xrandr-1.3.4
222- xset-1.2.0
223- xsetroot-1.1.0
224- xstdcmap-1.0.2
225- xvidtune-1.0.2
226- drop Patch1100,1700,1710
227- add BuildRequires: libXcursor-devel
228- fix %%files
229
230* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
231- iceauth-1.0.3
232- sessreg-1.0.5
233- xcmsdb-1.0.2
234- xgamma-1.0.3
235- xhost-1.0.3
236- xmodmap-1.0.4
237- xrandr-1.3.2
238- xrdb-1.0.6
239- xrefresh-1.0.3
240- xset-1.1.0
241- xsetroot-1.0.3
242- drop xtrap (deprecated upstream)
243
244* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
245- xrandr-1.3.0
246
247* Wed Mar 18 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
248- xrandr-1.2.99.4
249
250* Sun Nov 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-3
251- rebuild with libXaw.so.7 (libXaw-1.0.5)
252
253* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
254- rgb 1.0.3
255- sessreg 1.0.4
256- xhost 1.0.2
257- xrandr 1.2.3
258- xrdb 1.0.5
259- xset 1.0.4
260- xsetpointer 1.0.1
261
262* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
263- new versioning policy
264
265* Sun Jan 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
266- initial build for Vine Linux
267
268* Thu Nov 29 2007 Dave Airlie <airlied@redhat.com> 7.3-2
269- xrandr-1.2.2-reset-other-outputs-using-best-crtc.patch
270- xrandr-1.2.2-verify-crtc-against-prev-config.patch
271- Patches from upstream to fix some bug in xrandr app
272
273* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
274- sessreg 1.0.3
275- xgamma 1.0.2
276- xmodmap 1.0.3
277- xrdb 1.0.4
278- xset 1.0.3
279- xsetroot 1.0.2
280- Bump to 7.3
281
282* Thu Aug 23 2007 Adam Jackson <ajax@redhat.com> - 7.2-6
283- Rebuild for ppc toolchain bug
284
285* Wed Jul 25 2007 Jeremy Katz <katzj@redhat.com> - 7.2-5
286- rebuild for toolchain bug
287
288* Tue Jul 24 2007 Adam Jackson <ajax@redhat.com> 7.2-4
289- iceauth 1.0.2
290
291* Wed Jul 11 2007 Adam Jackson <ajax@redhat.com> 7.2-3
292- xrandr 1.2.2
293
294* Wed Jun 27 2007 Adam Jackson <ajax@redhat.com> 7.2-2
295- xrandr 1.2.1
296
297* Wed Feb 28 2007 Adam Jackson <ajax@redhat.com> 7.2-1
298- Superstition bump to 7.2
299- xrandr 1.2.0
300
301* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-5
302- Fix man page globs and rebuild for FC7.
303
304* Fri Aug  4 2006 Adam Jackson <ajackson@redhat.com> 7.1-4.fc6
305- xvidtune-1.0.1-buffer-stomp.patch: Fix a heap smash. (#189146)
306
307* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-3.fc6
308- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
309- Add 'dist' tag to package release string.
310
311* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-2.1
312- rebuild
313
314- Update to rgb-1.0.2 from X11R7.1
315
316* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
317- Bump the package version to 7.1 to have it match the X11 release that the
318  tarballs came from going forward.
319- Update to xrefresh-1.0.2, xtrap-1.0.2 from X11R7.1
320- Remove build dependency on liblbxutil-devel, as LBX is no longer supported.
321
322* Mon Jun 05 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-6
323- Clean up Source lines in spec file, and other minor cleanups.
324
325* Wed May 17 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-5
326- Added a whackload of BuildRequires for bug (#191987)
327
328* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-4
329- Updated xmodmap, xrandr, xrdb, and xset.
330
331* Tue Apr 25 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-3
332- Eliminate a spurious Xprint dependency from xset.
333
334* Fri Apr 14 2006 Adam Jackson <ajackson@redhat.com> 1.0.1-2
335- Drop lbxproxy, LBX is deprecated upstream
336- Update to xhost 1.0.1
337
338* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
339- bump again for double-long bug on ppc(64)
340
341* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
342- rebuilt for new gcc4.1 snapshot and glibc changes
343
344* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
345- Updated all packages to the versions from X11R7.0
346
347* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
348- Updated all packages to version 1.0.0 from X11R7 RC4
349- Changed manpage dirs from man1x to man1 to match upstream RC4 default.
350- Updated lbxproxy-datadir-AtomControl-fix.patch
351- Updated rgb-1.0.0-datadir-rgbpath-fix.patch
352- Removed xvidtune-0.99.1-datadir-app-defaults-fix.patch, now unneeded.
353
354* Mon Nov 28 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-6
355- Added "Requires: cpp" as xrdb requires it for proper operation (#174302)
356
357* Wed Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-5
358- Bump "filesystem" Requires(pre) to 2.3.7-1.
359
360* Fri Nov 18 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
361- Added lbxproxy-0.99.2-datadir-AtomControl-fix.patch to move architecture
362  independent data files from libdir to datadir.
363- Added rgb-0.99.2-datadir-rgbpath-fix.patch to move architecture independent
364  data files from libdir to datadir.
365- Added xvidtune-0.99.1-datadir-app-defaults-fix.patch to move app-defaults
366  into datadir.
367
368* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
369- require newer filesystem package (#172610)
370
371* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
372- Added "Obsoletes: XFree86, xorg-x11", as these utilities came from there.
373- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
374
375* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
376- Initial build, with all apps taken from X11R7 RC2
377- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
378  some packages.
Note: See TracBrowser for help on using the repository browser.