source: projects/specs/trunk/x/xorg-x11-font-utils/xorg-x11-font-utils-vl.spec @ 8064

Revision 8064, 10.6 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define pkgname font-utils
2
3Summary: X.Org X11 font utilities
4Summary(ja): X.Org X11 font ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.7
7Release: 2%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.4.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.1.1.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.3.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20# xorg-x11-libXfont-devel needed for bdftopcf
21BuildRequires: libXfont-devel
22# xorg-x11-libX11-devel needed for fonttosfnt
23BuildRequires: libX11-devel
24# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
25BuildRequires: libfontenc-devel >= 0.99.2-2
26# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
27BuildRequires: freetype2-devel
28# zlib-devel needed for bdftopcf
29BuildRequires: zlib-devel
30# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
31# from it directly.
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: xorg-x11-util-macros
34BuildRequires: autoconf
35
36Requires(pre): xorg-x11-filesystem
37
38# NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
39# bug #173875 is installed in order for mkfontscale/mkfontdir to work
40# properly.  It is a "pre" dep, to ensure libfontenc gets installed before
41# xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
42# set, avoiding a possible race condition.
43Requires(pre): libfontenc
44
45Provides: %{pkgname}
46Provides: XOrg-%{pkgname} = %{version}
47Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
48# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
49# is needed for upgrades to work properly from OS releases that had XFree86
50Obsoletes: XFree86-font-utils, XOrg-font-utils
51# NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
52# this is needed for upgrades to work.
53Obsoletes: XFree86
54# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
55# xorg-x11-font-utils in 6.7.99.903-3
56Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
57# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
58Obsoletes: XOrg-tools <= 6.7.99.903-3
59
60Vendor: Project Vine
61Distribution: Vine Linux
62Packager: Takemikaduchi
63
64%description
65X.Org X11 font utilities required for font installation, conversion,
66and generation.
67
68%package -n bdftruncate
69Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
70Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
71Group:   Applications/System
72
73%description -n bdftruncate
74bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
75other ISO10646-1 BDF fonts in which all characters above a threshold
76code value are stored unencoded. This is often desirable because the
77Xlib API and X11 protocol data structures used for representing font
78metric information are extremely inefficient when handling sparsely
79populated fonts.
80
81%prep
82%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
83
84%build
85# Build all apps
86{
87   for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
88      pushd $app-*
89      # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
90      case $app in
91         font-util)
92            autoconf
93            ;;
94      esac
95      %configure
96      make
97      popd
98   done
99}
100
101%install
102rm -rf $RPM_BUILD_ROOT
103# Install all apps
104{
105    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
106        pushd $app-*
107        make install DESTDIR=$RPM_BUILD_ROOT
108        popd
109    done
110    for i in */README ; do
111        [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
112    done
113    for i in */COPYING ; do
114        grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
115    done
116}
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%files
122%defattr(-,root,root,-)
123%doc README-* COPYING-*
124%{_bindir}/bdftopcf
125%{_bindir}/fonttosfnt
126%{_bindir}/mkfontdir
127%{_bindir}/mkfontscale
128%{_bindir}/ucs2any
129# blech.  this one should be in -filesystem
130%dir %{_datadir}/fonts/X11
131%dir %{_datadir}/fonts/X11/util
132%{_datadir}/fonts/X11/util/map-*
133%{_datadir}/aclocal/fontutil.m4
134%{_libdir}/pkgconfig/fontutil.pc
135%{_mandir}/man1/bdftopcf.1*
136%{_mandir}/man1/fonttosfnt.1*
137%{_mandir}/man1/mkfontdir.1*
138%{_mandir}/man1/mkfontscale.1*
139%{_mandir}/man1/ucs2any.1*
140
141%files -n bdftruncate
142%defattr(-,root,root,-)
143%{_bindir}/bdftruncate
144%{_mandir}/man1/bdftruncate.1*
145
146
147%changelog
148* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
149- mkfontscale-1.1.1
150- font-util-1.3.0
151
152* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
153- bdftopcf-1.0.4
154
155* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
156- mkfontdir-1.0.7
157- mkfontscale-1.1.0
158- add BuildRequires: xorg-x11-util-macros
159
160* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
161- mkfontscale-1.0.9
162
163* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
164- mkfontdir-1.0.6
165
166* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
167- bdftopcf-1.0.3
168- mkfontscale-1.0.8
169- font-util-1.2.0
170
171* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
172- rebuild with rpm-4.8.1 for pkg-config file
173
174* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
175- bdftopcf-1.0.2
176- mkfontdir-1.0.5
177- mkfontscale-1.0.7
178- font-util-1.1.1
179
180* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
181- mkfontscale 1.0.6
182
183* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
184- fonttosfnt 1.0.4
185- mkfontdir 1.0.4
186- mkfontscale 1.0.5
187
188* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
189- new versioning policy
190
191* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
192- initial build for Vine Linux
193
194* Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
195- Move bdftruncate (and its perl dependency) to a subpackage.
196- %%doc for the non-empty READMEs and non-stub COPYINGs.
197
198* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
199- Rebuild for build id
200
201* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
202- bdftopcf 1.0.1
203- Superstition bump to 7.2-1
204
205* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
206- mkfontdir 1.0.3
207
208* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
209- fonttosfnt 1.0.3
210
211* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
212- Remove X11R6 symlinks.
213
214* Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
215- Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
216  with new freetype 2.2.
217
218* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
219- rebuild
220
221* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
222- Update to font-util-1.0.1 from X11R7.1
223- Set package version to X11 release the tarballs are based from.
224
225* Wed Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
226- Update mkfontdir
227
228* Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
229- Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
230  itself.  Leftover from the original package template it seems.  (#182439)
231
232* Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
233- Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
234  mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
235  binaries.  This will provide backward compatibilty for Fedora Core 5, however
236  3rd party developers and rpm package maintainers should update to using the
237  new X11R7 locations immediately, as these compatibility links are temporary,
238  and will be removed from a future OS release.
239- Remove system directories from file manifest to appease the banshees.
240
241* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
242- bump again for double-long bug on ppc(64)
243
244* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
245- rebuilt for new gcc4.1 snapshot and glibc changes
246
247* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
248- Updated all utilities to the versions shipped in X11R7.0.
249
250* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
251- Updated all utilities to version 1.0.0 from X11R7 RC4.
252- Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
253- Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
254  variable "fontdir" to the fontutil.pc file which all of the font packages
255  can autodetect and use instead of having to put manual fontdir overrides
256  in every single rpm package.
257
258* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
259- Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
260  and font-util to version 0.99.2 from X11R7 RC3.
261- Changed manpage dir from man1x back to man1 due to another upstream change.
262- Added fontutil.m4 to file manifest.
263
264* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
265- Changed package version to 0.99.1 to match the upstream font-util tarball
266  version, and added "Epoch: 1" to the package for upgrades.
267- Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
268  mapfiles data to install into datadir instead of libdir (#173943)
269- Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
270  libfontenc to be installed that fixes bug #173453, and to also force it
271  to be installed before xorg-x11-font-utils in a multi-package rpm
272  transaction, which will ensure that when font packages get installed
273  during upgrades via anaconda or yum, that the right libfontenc is being
274  used by mkfontscale/mkfontdir.
275- Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
276  people rebuilding xorg-x11-font-utils, as they'll need to install the new
277  libfontenc now anyway before they can install the font-utils package.
278
279* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
280- require newer filesystem (#172610)
281
282* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
283- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
284  X11R7 RC1.
285
286* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
287- Glob util/map-* files in file manifest.
288- Added missing "Obsoletes: xorg-x11-font-utils".
289- Added "BuildRequires: pkgconfig".
290
291* Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
292- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
293  ucs2any, bdftruncate.
294
295* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
296- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
297  X11R7 RC1.
298- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
299- Updated file manifest to to find the manpages in "man1x".
300
301* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
302- Initial build.
Note: See TracBrowser for help on using the repository browser.