source: projects/specs/trunk/x/xorg-x11-font-utils/xorg-x11-font-utils-vl.spec @ 12185

Revision 12185, 10.9 KB checked in by tomop, 5 years ago (diff)

updated X11 libs

Line 
1%define pkgname font-utils
2
3Summary: X.Org X11 font utilities
4Summary(ja): X.Org X11 font ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.7
7Release: 5%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.1.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.5.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.2.1.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.3.2.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20# xorg-x11-libXfont-devel needed for bdftopcf
21BuildRequires: libXfont-devel
22# xorg-x11-libX11-devel needed for fonttosfnt
23BuildRequires: libX11-devel
24# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
25BuildRequires: libfontenc-devel >= 0.99.2-2
26# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
27BuildRequires: freetype2-devel
28# zlib-devel needed for bdftopcf
29BuildRequires: zlib-devel
30# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
31# from it directly.
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: xorg-x11-util-macros
34BuildRequires: autoconf
35
36Requires(pre): xorg-x11-filesystem
37
38# NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
39# bug #173875 is installed in order for mkfontscale/mkfontdir to work
40# properly.  It is a "pre" dep, to ensure libfontenc gets installed before
41# xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
42# set, avoiding a possible race condition.
43Requires(pre): libfontenc
44
45Provides: %{pkgname}
46Provides: XOrg-%{pkgname} = %{version}
47Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
48# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
49# is needed for upgrades to work properly from OS releases that had XFree86
50Obsoletes: XFree86-font-utils, XOrg-font-utils
51# NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
52# this is needed for upgrades to work.
53Obsoletes: XFree86
54# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
55# xorg-x11-font-utils in 6.7.99.903-3
56Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
57# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
58Obsoletes: XOrg-tools <= 6.7.99.903-3
59
60Vendor: Project Vine
61Distribution: Vine Linux
62
63%description
64X.Org X11 font utilities required for font installation, conversion,
65and generation.
66
67%package -n bdftruncate
68Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
69Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
70Group:   Applications/System
71
72%description -n bdftruncate
73bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
74other ISO10646-1 BDF fonts in which all characters above a threshold
75code value are stored unencoded. This is often desirable because the
76Xlib API and X11 protocol data structures used for representing font
77metric information are extremely inefficient when handling sparsely
78populated fonts.
79
80%prep
81%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
82
83%build
84# Build all apps
85{
86   for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
87      pushd $app-*
88      # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
89      case $app in
90         font-util)
91            autoconf
92            ;;
93      esac
94      %configure
95      make
96      popd
97   done
98}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102# Install all apps
103{
104    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
105        pushd $app-*
106        make install DESTDIR=$RPM_BUILD_ROOT
107        popd
108    done
109    for i in */README ; do
110        [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
111    done
112    for i in */COPYING ; do
113        grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
114    done
115}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(-,root,root,-)
122%license COPYING-*
123%doc README-*
124%{_bindir}/bdftopcf
125%{_bindir}/fonttosfnt
126%{_bindir}/mkfontdir
127%{_bindir}/mkfontscale
128%{_bindir}/ucs2any
129# blech.  this one should be in -filesystem
130%dir %{_datadir}/fonts/X11
131%dir %{_datadir}/fonts/X11/util
132%{_datadir}/fonts/X11/util/map-*
133%{_datadir}/aclocal/fontutil.m4
134%{_libdir}/pkgconfig/fontutil.pc
135%{_mandir}/man1/bdftopcf.1*
136%{_mandir}/man1/fonttosfnt.1*
137%{_mandir}/man1/mkfontdir.1*
138%{_mandir}/man1/mkfontscale.1*
139%{_mandir}/man1/ucs2any.1*
140
141%files -n bdftruncate
142%defattr(-,root,root,-)
143%{_bindir}/bdftruncate
144%{_mandir}/man1/bdftruncate.1*
145
146
147%changelog
148* Fri Sep 06 2019 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 7.7-5
149- bdftopcf-1.1
150- fonttosfnt-1.0.5
151- mkfontscale-1.2.1
152- font-util-1.3.2
153
154* Sun Oct 25 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-4
155- font-util-1.3.1
156
157* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-3
158- bdftopcf-1.0.5
159- mkfontscale-1.1.2
160
161* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
162- mkfontscale-1.1.1
163- font-util-1.3.0
164
165* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
166- bdftopcf-1.0.4
167
168* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
169- mkfontdir-1.0.7
170- mkfontscale-1.1.0
171- add BuildRequires: xorg-x11-util-macros
172
173* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
174- mkfontscale-1.0.9
175
176* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
177- mkfontdir-1.0.6
178
179* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
180- bdftopcf-1.0.3
181- mkfontscale-1.0.8
182- font-util-1.2.0
183
184* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
185- rebuild with rpm-4.8.1 for pkg-config file
186
187* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
188- bdftopcf-1.0.2
189- mkfontdir-1.0.5
190- mkfontscale-1.0.7
191- font-util-1.1.1
192
193* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
194- mkfontscale 1.0.6
195
196* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
197- fonttosfnt 1.0.4
198- mkfontdir 1.0.4
199- mkfontscale 1.0.5
200
201* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
202- new versioning policy
203
204* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
205- initial build for Vine Linux
206
207* Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
208- Move bdftruncate (and its perl dependency) to a subpackage.
209- %%doc for the non-empty READMEs and non-stub COPYINGs.
210
211* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
212- Rebuild for build id
213
214* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
215- bdftopcf 1.0.1
216- Superstition bump to 7.2-1
217
218* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
219- mkfontdir 1.0.3
220
221* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
222- fonttosfnt 1.0.3
223
224* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
225- Remove X11R6 symlinks.
226
227* Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
228- Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
229  with new freetype 2.2.
230
231* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
232- rebuild
233
234* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
235- Update to font-util-1.0.1 from X11R7.1
236- Set package version to X11 release the tarballs are based from.
237
238* Wed Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
239- Update mkfontdir
240
241* Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
242- Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
243  itself.  Leftover from the original package template it seems.  (#182439)
244
245* Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
246- Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
247  mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
248  binaries.  This will provide backward compatibilty for Fedora Core 5, however
249  3rd party developers and rpm package maintainers should update to using the
250  new X11R7 locations immediately, as these compatibility links are temporary,
251  and will be removed from a future OS release.
252- Remove system directories from file manifest to appease the banshees.
253
254* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
255- bump again for double-long bug on ppc(64)
256
257* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
258- rebuilt for new gcc4.1 snapshot and glibc changes
259
260* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
261- Updated all utilities to the versions shipped in X11R7.0.
262
263* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
264- Updated all utilities to version 1.0.0 from X11R7 RC4.
265- Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
266- Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
267  variable "fontdir" to the fontutil.pc file which all of the font packages
268  can autodetect and use instead of having to put manual fontdir overrides
269  in every single rpm package.
270
271* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
272- Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
273  and font-util to version 0.99.2 from X11R7 RC3.
274- Changed manpage dir from man1x back to man1 due to another upstream change.
275- Added fontutil.m4 to file manifest.
276
277* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
278- Changed package version to 0.99.1 to match the upstream font-util tarball
279  version, and added "Epoch: 1" to the package for upgrades.
280- Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
281  mapfiles data to install into datadir instead of libdir (#173943)
282- Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
283  libfontenc to be installed that fixes bug #173453, and to also force it
284  to be installed before xorg-x11-font-utils in a multi-package rpm
285  transaction, which will ensure that when font packages get installed
286  during upgrades via anaconda or yum, that the right libfontenc is being
287  used by mkfontscale/mkfontdir.
288- Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
289  people rebuilding xorg-x11-font-utils, as they'll need to install the new
290  libfontenc now anyway before they can install the font-utils package.
291
292* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
293- require newer filesystem (#172610)
294
295* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
296- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
297  X11R7 RC1.
298
299* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
300- Glob util/map-* files in file manifest.
301- Added missing "Obsoletes: xorg-x11-font-utils".
302- Added "BuildRequires: pkgconfig".
303
304* Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
305- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
306  ucs2any, bdftruncate.
307
308* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
309- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
310  X11R7 RC1.
311- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
312- Updated file manifest to to find the manpages in "man1x".
313
314* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
315- Initial build.
Note: See TracBrowser for help on using the repository browser.