source: projects/specs/trunk/x/xorg-x11-font-utils/xorg-x11-font-utils-vl.spec @ 7648

Revision 7648, 10.4 KB checked in by Takemikaduchi, 11 years ago (diff)

xserver-1.14.1

Line 
1%define pkgname font-utils
2
3Summary: X.Org X11 font utilities
4Summary(ja): X.Org X11 font ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.7
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.4.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.1.0.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.2.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20# xorg-x11-libXfont-devel needed for bdftopcf
21BuildRequires: libXfont-devel
22# xorg-x11-libX11-devel needed for fonttosfnt
23BuildRequires: libX11-devel
24# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
25BuildRequires: libfontenc-devel >= 0.99.2-2
26# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
27BuildRequires: freetype2-devel
28# zlib-devel needed for bdftopcf
29BuildRequires: zlib-devel
30# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
31# from it directly.
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: xorg-x11-util-macros
34BuildRequires: autoconf
35
36Requires(pre): xorg-x11-filesystem
37
38# NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
39# bug #173875 is installed in order for mkfontscale/mkfontdir to work
40# properly.  It is a "pre" dep, to ensure libfontenc gets installed before
41# xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
42# set, avoiding a possible race condition.
43Requires(pre): libfontenc
44
45Provides: %{pkgname}
46Provides: XOrg-%{pkgname} = %{version}
47Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
48# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
49# is needed for upgrades to work properly from OS releases that had XFree86
50Obsoletes: XFree86-font-utils, XOrg-font-utils
51# NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
52# this is needed for upgrades to work.
53Obsoletes: XFree86
54# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
55# xorg-x11-font-utils in 6.7.99.903-3
56Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
57# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
58Obsoletes: XOrg-tools <= 6.7.99.903-3
59
60Vendor: Project Vine
61Distribution: Vine Linux
62
63%description
64X.Org X11 font utilities required for font installation, conversion,
65and generation.
66
67%package -n bdftruncate
68Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
69Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
70Group:   Applications/System
71
72%description -n bdftruncate
73bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
74other ISO10646-1 BDF fonts in which all characters above a threshold
75code value are stored unencoded. This is often desirable because the
76Xlib API and X11 protocol data structures used for representing font
77metric information are extremely inefficient when handling sparsely
78populated fonts.
79
80%prep
81%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
82
83%build
84# Build all apps
85{
86   for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
87      pushd $app-*
88      # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
89      case $app in
90         font-util)
91            autoconf
92            ;;
93      esac
94      %configure
95      make
96      popd
97   done
98}
99
100%install
101rm -rf $RPM_BUILD_ROOT
102# Install all apps
103{
104    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
105        pushd $app-*
106        make install DESTDIR=$RPM_BUILD_ROOT
107        popd
108    done
109    for i in */README ; do
110        [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
111    done
112    for i in */COPYING ; do
113        grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
114    done
115}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(-,root,root,-)
122%doc README-* COPYING-*
123%{_bindir}/bdftopcf
124%{_bindir}/fonttosfnt
125%{_bindir}/mkfontdir
126%{_bindir}/mkfontscale
127%{_bindir}/ucs2any
128# blech.  this one should be in -filesystem
129%dir %{_datadir}/fonts/X11
130%dir %{_datadir}/fonts/X11/util
131%{_datadir}/fonts/X11/util/map-*
132%{_datadir}/aclocal/fontutil.m4
133%{_libdir}/pkgconfig/fontutil.pc
134%{_mandir}/man1/bdftopcf.1*
135%{_mandir}/man1/fonttosfnt.1*
136%{_mandir}/man1/mkfontdir.1*
137%{_mandir}/man1/mkfontscale.1*
138%{_mandir}/man1/ucs2any.1*
139
140%files -n bdftruncate
141%defattr(-,root,root,-)
142%{_bindir}/bdftruncate
143%{_mandir}/man1/bdftruncate.1*
144
145
146%changelog
147* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
148- bdftopcf-1.0.4
149
150* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
151- mkfontdir-1.0.7
152- mkfontscale-1.1.0
153- add BuildRequires: xorg-x11-util-macros
154
155* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
156- mkfontscale-1.0.9
157
158* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
159- mkfontdir-1.0.6
160
161* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
162- bdftopcf-1.0.3
163- mkfontscale-1.0.8
164- font-util-1.2.0
165
166* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
167- rebuild with rpm-4.8.1 for pkg-config file
168
169* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
170- bdftopcf-1.0.2
171- mkfontdir-1.0.5
172- mkfontscale-1.0.7
173- font-util-1.1.1
174
175* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
176- mkfontscale 1.0.6
177
178* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
179- fonttosfnt 1.0.4
180- mkfontdir 1.0.4
181- mkfontscale 1.0.5
182
183* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
184- new versioning policy
185
186* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
187- initial build for Vine Linux
188
189* Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
190- Move bdftruncate (and its perl dependency) to a subpackage.
191- %%doc for the non-empty READMEs and non-stub COPYINGs.
192
193* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
194- Rebuild for build id
195
196* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
197- bdftopcf 1.0.1
198- Superstition bump to 7.2-1
199
200* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
201- mkfontdir 1.0.3
202
203* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
204- fonttosfnt 1.0.3
205
206* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
207- Remove X11R6 symlinks.
208
209* Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
210- Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
211  with new freetype 2.2.
212
213* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
214- rebuild
215
216* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
217- Update to font-util-1.0.1 from X11R7.1
218- Set package version to X11 release the tarballs are based from.
219
220* Wed Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
221- Update mkfontdir
222
223* Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
224- Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
225  itself.  Leftover from the original package template it seems.  (#182439)
226
227* Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
228- Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
229  mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
230  binaries.  This will provide backward compatibilty for Fedora Core 5, however
231  3rd party developers and rpm package maintainers should update to using the
232  new X11R7 locations immediately, as these compatibility links are temporary,
233  and will be removed from a future OS release.
234- Remove system directories from file manifest to appease the banshees.
235
236* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
237- bump again for double-long bug on ppc(64)
238
239* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
240- rebuilt for new gcc4.1 snapshot and glibc changes
241
242* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
243- Updated all utilities to the versions shipped in X11R7.0.
244
245* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
246- Updated all utilities to version 1.0.0 from X11R7 RC4.
247- Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
248- Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
249  variable "fontdir" to the fontutil.pc file which all of the font packages
250  can autodetect and use instead of having to put manual fontdir overrides
251  in every single rpm package.
252
253* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
254- Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
255  and font-util to version 0.99.2 from X11R7 RC3.
256- Changed manpage dir from man1x back to man1 due to another upstream change.
257- Added fontutil.m4 to file manifest.
258
259* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
260- Changed package version to 0.99.1 to match the upstream font-util tarball
261  version, and added "Epoch: 1" to the package for upgrades.
262- Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
263  mapfiles data to install into datadir instead of libdir (#173943)
264- Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
265  libfontenc to be installed that fixes bug #173453, and to also force it
266  to be installed before xorg-x11-font-utils in a multi-package rpm
267  transaction, which will ensure that when font packages get installed
268  during upgrades via anaconda or yum, that the right libfontenc is being
269  used by mkfontscale/mkfontdir.
270- Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
271  people rebuilding xorg-x11-font-utils, as they'll need to install the new
272  libfontenc now anyway before they can install the font-utils package.
273
274* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
275- require newer filesystem (#172610)
276
277* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
278- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
279  X11R7 RC1.
280
281* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
282- Glob util/map-* files in file manifest.
283- Added missing "Obsoletes: xorg-x11-font-utils".
284- Added "BuildRequires: pkgconfig".
285
286* Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
287- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
288  ucs2any, bdftruncate.
289
290* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
291- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
292  X11R7 RC1.
293- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
294- Updated file manifest to to find the manpages in "man1x".
295
296* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
297- Initial build.
Note: See TracBrowser for help on using the repository browser.