source: projects/specs/trunk/x/xorg-x11-font-utils/xorg-x11-font-utils-vl.spec @ 4616

Revision 4616, 10.2 KB checked in by Takemikaduchi, 13 years ago (diff)

X.Org, compiz, GNOME3, etc...

Line 
1%define pkgname font-utils
2
3Summary: X.Org X11 font utilities
4Summary(ja): X.Org X11 font ユーティリティ
5Name: xorg-x11-%{pkgname}
6Version: 7.6
7Release: 1%{?_dist_release}
8License: MIT/X11
9Group: User Interface/X
10URL: http://www.x.org
11
12Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.3.tar.bz2
13Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
14Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.6.tar.bz2
15Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-1.0.9.tar.bz2
16Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.2.0.tar.bz2
17
18BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
19BuildRequires: pkgconfig
20# xorg-x11-libXfont-devel needed for bdftopcf
21BuildRequires: libXfont-devel
22# xorg-x11-libX11-devel needed for fonttosfnt
23BuildRequires: libX11-devel
24# xorg-x11-libfontenc-devel needed for fonttosfnt, mkfontscale
25BuildRequires: libfontenc-devel >= 0.99.2-2
26# freetype-devel needed for bdftopcf, fonttosfnt, mkfontscale
27BuildRequires: freetype2-devel
28# zlib-devel needed for bdftopcf
29BuildRequires: zlib-devel
30# xorg-x11-proto-devel is needed for mkfontscale, which includes headers
31# from it directly.
32BuildRequires: xorg-x11-proto-devel
33BuildRequires: autoconf
34
35Requires(pre): xorg-x11-filesystem
36
37# NOTE: This versioned pre-dependency is needed to ensure that the bugfix for
38# bug #173875 is installed in order for mkfontscale/mkfontdir to work
39# properly.  It is a "pre" dep, to ensure libfontenc gets installed before
40# xorg-font-utils, before any fonts in an rpm upgrade or multi-transaction
41# set, avoiding a possible race condition.
42Requires(pre): libfontenc
43
44Provides: %{pkgname}
45Provides: XOrg-%{pkgname} = %{version}
46Provides: bdftopcf, fonttosfnt, mkfontdir, mkfontscale, ucs2any
47# NOTE: XFree86-font-utils package contains mkfontdir, mkfontscale, so this
48# is needed for upgrades to work properly from OS releases that had XFree86
49Obsoletes: XFree86-font-utils, XOrg-font-utils
50# NOTE: XFree86 package used to contain bdftopcf, mkfontdir, mkfontscale so
51# this is needed for upgrades to work.
52Obsoletes: XFree86
53# NOTE: The fonts/util subdir moved from xorg-x11-base-fonts to
54# xorg-x11-font-utils in 6.7.99.903-3
55Obsoletes: XOrg-base-fonts <= 6.7.99.903-3
56# NOTE: ucs2any moved from xorg-x11-tools to xorg-x11-font-utils in 6.7.99.903-3
57Obsoletes: XOrg-tools <= 6.7.99.903-3
58
59Vendor: Project Vine
60Distribution: Vine Linux
61
62%description
63X.Org X11 font utilities required for font installation, conversion,
64and generation.
65
66%package -n bdftruncate
67Summary: Generate truncated BDF font from ISO 10646-1 encoded BDF font
68Summary(ja): Generate truncated BDF font from ISO 10646-1 encoded BDF font
69Group:   Applications/System
70
71%description -n bdftruncate
72bdftruncate allows one to generate from an ISO10646-1 encoded BDF font
73other ISO10646-1 BDF fonts in which all characters above a threshold
74code value are stored unencoded. This is often desirable because the
75Xlib API and X11 protocol data structures used for representing font
76metric information are extremely inefficient when handling sparsely
77populated fonts.
78
79%prep
80%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4
81
82%build
83# Build all apps
84{
85   for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
86      pushd $app-*
87      # FIXME: We run autoconf to activate font-util-0.99.1-mapdir-use-datadir-fix.patch
88      case $app in
89         font-util)
90            autoconf
91            ;;
92      esac
93      %configure
94      make
95      popd
96   done
97}
98
99%install
100rm -rf $RPM_BUILD_ROOT
101# Install all apps
102{
103    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util; do
104        pushd $app-*
105        make install DESTDIR=$RPM_BUILD_ROOT
106        popd
107    done
108    for i in */README ; do
109        [ -s $i ] && cp $i README-$(echo $i | sed 's/-[0-9].*//')
110    done
111    for i in */COPYING ; do
112        grep -q stub $i || cp $i COPYING-$(echo $i | sed 's/-[0-9].*//')
113    done
114}
115
116%clean
117rm -rf $RPM_BUILD_ROOT
118
119%files
120%defattr(-,root,root,-)
121%doc README-* COPYING-*
122%{_bindir}/bdftopcf
123%{_bindir}/fonttosfnt
124%{_bindir}/mkfontdir
125%{_bindir}/mkfontscale
126%{_bindir}/ucs2any
127# blech.  this one should be in -filesystem
128%dir %{_datadir}/fonts/X11
129%dir %{_datadir}/fonts/X11/util
130%{_datadir}/fonts/X11/util/map-*
131%{_datadir}/aclocal/fontutil.m4
132%{_libdir}/pkgconfig/fontutil.pc
133%{_mandir}/man1/bdftopcf.1*
134%{_mandir}/man1/fonttosfnt.1*
135%{_mandir}/man1/mkfontdir.1*
136%{_mandir}/man1/mkfontscale.1*
137%{_mandir}/man1/ucs2any.1*
138
139%files -n bdftruncate
140%defattr(-,root,root,-)
141%{_bindir}/bdftruncate
142%{_mandir}/man1/bdftruncate.1*
143
144
145%changelog
146* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
147- mkfontscale-1.0.9
148
149* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
150- mkfontdir-1.0.6
151
152* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
153- bdftopcf-1.0.3
154- mkfontscale-1.0.8
155- font-util-1.2.0
156
157* Sun Sep 26 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-2
158- rebuild with rpm-4.8.1 for pkg-config file
159
160* Fri Nov 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
161- bdftopcf-1.0.2
162- mkfontdir-1.0.5
163- mkfontscale-1.0.7
164- font-util-1.1.1
165
166* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
167- mkfontscale 1.0.6
168
169* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
170- fonttosfnt 1.0.4
171- mkfontdir 1.0.4
172- mkfontscale 1.0.5
173
174* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-1
175- new versioning policy
176
177* Mon Jan 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.2-0vl1
178- initial build for Vine Linux
179
180* Mon Dec 10 2007 Adam Jackson <ajax@redhat.com> 1:7.2-3
181- Move bdftruncate (and its perl dependency) to a subpackage.
182- %%doc for the non-empty READMEs and non-stub COPYINGs.
183
184* Tue Aug 21 2007 Adam Jackson <ajax@redhat.com> - 1:7.2-2
185- Rebuild for build id
186
187* Thu Apr 26 2007 Adam Jackson <ajax@redhat.com> 1:7.2-1
188- bdftopcf 1.0.1
189- Superstition bump to 7.2-1
190
191* Mon Mar 26 2007 Adam Jackson <ajax@redhat.com> 1:7.1-5
192- mkfontdir 1.0.3
193
194* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 1:7.1-4.fc7
195- fonttosfnt 1.0.3
196
197* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-3
198- Remove X11R6 symlinks.
199
200* Fri Jul 14 2006 Adam Jackson <ajackson@redhat.com> 1:7.1-2
201- Added fonttosfnt-1.0.1-freetype22-build-fix.patch to fix a build failure
202  with new freetype 2.2.
203
204* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1:7.1-1.1
205- rebuild
206
207* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 1:7.1-1
208- Update to font-util-1.0.1 from X11R7.1
209- Set package version to X11 release the tarballs are based from.
210
211* Thu Apr 26 2006 Adam Jackson <ajackson@redhat.com> 1:1.0.2-2
212- Update mkfontdir
213
214* Wed Feb 22 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-3
215- Remove "Obsoletes: xorg-x11-font-utils" as the package should not obsolete
216  itself.  Leftover from the original package template it seems.  (#182439)
217
218* Fri Feb 17 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-2
219- Added with_X11R6_compat macro to conditionalize inclusion of mkfontdir and
220  mkfontscale symlinks in the old X11R6 locations, pointing to the X11R7
221  binaries.  This will provide backward compatibilty for Fedora Core 5, however
222  3rd party developers and rpm package maintainers should update to using the
223  new X11R7 locations immediately, as these compatibility links are temporary,
224  and will be removed from a future OS release.
225- Remove system directories from file manifest to appease the banshees.
226
227* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.2
228- bump again for double-long bug on ppc(64)
229
230* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1:1.0.1-1.1
231- rebuilt for new gcc4.1 snapshot and glibc changes
232
233* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1:1.0.1-1
234- Updated all utilities to the versions shipped in X11R7.0.
235
236* Thu Dec 15 2005 Mike A. Harris <mharris@redhat.com> 1:1.0.0-1
237- Updated all utilities to version 1.0.0 from X11R7 RC4.
238- Updated font-util-1.0.0-mapdir-use-datadir-fix.patch to work with RC4.
239- Added font-util-1.0.0-autoconf-add-with-fontdir-option.patch to add a new
240  variable "fontdir" to the fontutil.pc file which all of the font packages
241  can autodetect and use instead of having to put manual fontdir overrides
242  in every single rpm package.
243
244* Tue Dec 13 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.2-1
245- Updated bdftopcf, fonttosfnt to version 0.99.3, and mkfontdir, mkfontscale,
246  and font-util to version 0.99.2 from X11R7 RC3.
247- Changed manpage dir from man1x back to man1 due to another upstream change.
248- Added fontutil.m4 to file manifest.
249
250* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 1:0.99.1-1
251- Changed package version to 0.99.1 to match the upstream font-util tarball
252  version, and added "Epoch: 1" to the package for upgrades.
253- Added font-util-0.99.1-mapdir-use-datadir-fix.patch to fix the font-util
254  mapfiles data to install into datadir instead of libdir (#173943)
255- Added "Requires(pre): libfontenc >= 0.99.2-2" to force a version of
256  libfontenc to be installed that fixes bug #173453, and to also force it
257  to be installed before xorg-x11-font-utils in a multi-package rpm
258  transaction, which will ensure that when font packages get installed
259  during upgrades via anaconda or yum, that the right libfontenc is being
260  used by mkfontscale/mkfontdir.
261- Added ">= 0.99.2-2" to BuildRequires for libfontenc, as a convenience to
262  people rebuilding xorg-x11-font-utils, as they'll need to install the new
263  libfontenc now anyway before they can install the font-utils package.
264
265* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 6.99.99.902-2
266- require newer filesystem (#172610)
267
268* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.902-1
269- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
270  X11R7 RC1.
271
272* Wed Nov 09 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-3
273- Glob util/map-* files in file manifest.
274- Added missing "Obsoletes: xorg-x11-font-utils".
275- Added "BuildRequires: pkgconfig".
276
277* Sun Nov 06 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-2
278- Added font-util-0.99.1 to package, from X11R7 RC1 release, which provides
279  ucs2any, bdftruncate.
280
281* Wed Oct 26 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.901-1
282- Updated bdftopcf, fonttosfnt, mkfontdir, mkfontscale to version 0.99.1 from
283  X11R7 RC1.
284- Bumped package version to 6.99.99.901, the X11R7 RC1 release version tag.
285- Updated file manifest to to find the manpages in "man1x".
286
287* Wed Aug 24 2005 Mike A. Harris <mharris@redhat.com> 6.99.99.0-1
288- Initial build.
Note: See TracBrowser for help on using the repository browser.