source: projects/specs/trunk/x/xorg-x11-filesystem/xorg-x11-filesystem-vl.spec @ 521

Revision 521, 5.1 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1Summary: X.Org X11 filesystem layout
2Summary(ja): X.Org X11 ファイルシステムレイアウト
3Name: xorg-x11-filesystem
4Version: 7.4
5Release: 1%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Base
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9
10BuildArch: noarch
11
12Requires(pre): filesystem >= 2.4
13Obsoletes: XOrg-devel < 7.0
14
15%description
16This package provides some directories which are required by other
17packages which comprise the modularized X.Org X11R7 X Window System
18release.  This package must be installed during OS installation
19or upgrade, in order to force the creation of these directories,
20and replace any legacy symbolic links that might be present in old
21locations, which could result in upgrade failures.
22
23%prep
24%install
25rm -rf $RPM_BUILD_ROOT
26
27# NOTE: Do not replace these with _libdir or _includedir macros, they are
28#       intentionally explicit.
29mkdir -p "$RPM_BUILD_ROOT/usr/lib/X11"
30mkdir -p "$RPM_BUILD_ROOT/usr/include/X11"
31mkdir -p "$RPM_BUILD_ROOT%{_datadir}/X11"
32mkdir -p "$RPM_BUILD_ROOT%{_bindir}"
33
34UPGRADE_CMD="%{_bindir}/xorg-x11-filesystem-upgrade"
35
36# NOTE: The quoted 'EOF' is required to disable variable interpolation
37cat > "$RPM_BUILD_ROOT/${UPGRADE_CMD}" <<'EOF'
38#!/bin/bash
39#
40# Modular X.Org X11R7 filesystem upgrade script.
41#
42# If any of the following dirs are symlinks, remove them and create a dir
43# in its place.  This is required, so that modular X packages get installed
44# into a real directory, and do not follow old compatibility symlinks
45# provided in previous releases of the operating system.
46#
47# NOTE: Do not replace these with _libdir or _includedir macros, they are
48#       intentionally explicit.
49for dir in /usr/include/X11 /usr/lib/X11 ; do
50    [ -L "$dir" ] && rm -f -- "$dir" &> /dev/null
51done
52for dir in /usr/include/X11 /usr/lib/X11 ; do
53    [ ! -d "$dir" ] && mkdir -p "$dir" &> /dev/null
54done
55exit 0
56EOF
57
58chmod 0755 "$RPM_BUILD_ROOT/${UPGRADE_CMD}"
59
60
61%clean
62rm -rf $RPM_BUILD_ROOT
63
64%pre
65# NOTE: Do not replace these with _libdir or _includedir macros, they are
66#       intentionally explicit.
67# Remove old symlinks if present, and replace them with directories.
68for dir in /usr/include/X11 /usr/lib/X11 ; do
69    [ -L "$dir" ] && rm -f -- "$dir" &> /dev/null
70done
71for dir in /usr/include/X11 /usr/lib/X11 ; do
72    [ ! -d "$dir" ] && mkdir -p "$dir" &> /dev/null
73done
74exit 0
75
76%files
77%defattr(-,root,root,-)
78# NOTE: These are explicitly listed intentionally, instead of using rpm
79#       macros, as these exact locations are required for compatibility
80#       regardless of what _libdir or _includedir point to.
81%dir /usr/lib/X11
82%dir /usr/include/X11
83%dir %{_datadir}/X11
84%dir %{_bindir}/xorg-x11-filesystem-upgrade
85%{_bindir}/xorg-x11-filesystem-upgrade
86
87%changelog
88* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
89- spec in utf-8
90- bump version to 7.4-1
91
92* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
93- own %%{_datadir}/X11
94- Obsoletes: XOrg-devel < 7.0
95
96* Sat Jan 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.1-0vl1
97- initial build for Vine Linux based on fodora package.
98
99* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
100- Reword package description for (#189648)
101
102* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
103- Bumped version to 7.1-1 and rebuilt for X11R7.1.
104
105* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 7.0-1
106- Bumped version to 7.0-1 and rebuilt.
107
108* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
109- Ok, even though I _tested_ it, and it worked..  the previous build had a
110  broken post, preun, and postun script, due to copy and paste error.  Ugh.
111  Also, the script in /usr/bin was broken due to heredoc variable
112  interpolation, which I turned off this time so it is generated correctly.
113  I removed the post, preun, postun scripts as they are overkill anyway.
114  The bug in 0.99.2-2 might cause upgrade or uninstall of the package to
115  fail and require manual uninstallation with --noscripts.  Oops.  This
116  is what "rawhide" means boys and girls.
117- Added "Requires(pre): filesystem >= 2.3.7-1", to avoid problems with older
118  versions of it, and to allow packages that need this workaround to only
119  have to set a dependency on xorg-x11-filesystem instead of both packages.
120 
121* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
122- Updated scripts so that they create the directory even if the symlink was
123  not present, to ensure that the dir exists first and avoid theoretical
124  case in which, in a single transaction, xorg-x11-filesystem gets installed,
125  no symlink or dir is present causing the symlink test to fail, so no dir
126  gets created, then another package in the transaction set installs a
127  symlink, then a package tries to install a dir and fails.  This should
128  guarantee now that these two dirs are really really dirs, not symlinks
129  for sure for sure.
130
131* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
132- Initial build.
133- Package creates the directories /usr/lib/X11 and /usr/include/X11 and owns
134  them as properly flagged dirs in the file manifest.
135- Added identical pre/post/preun/postun scripts which test to see if any of
136  of each of /usr/include/X11 /usr/lib/X11 /usr/lib64/X11
Note: See TracBrowser for help on using the repository browser.