source: projects/specs/trunk/x/xorg-x11-filesystem/xorg-x11-filesystem-vl.spec @ 8064

Revision 8064, 5.3 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1Summary: X.Org X11 filesystem layout
2Summary(ja): X.Org X11 ファイルシステムレイアウト
3Name: xorg-x11-filesystem
4Version: 7.7
5Release: 1%{?_dist_release}
6License: MIT/X11
7Group: System Environment/Base
8BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9
10Requires(pre): filesystem >= 2.4
11Obsoletes: XOrg-devel < 7.0
12
13Vendor: Project Vine
14Distribution: Vine Linux
15Packager: Takemikaduchi
16
17%description
18This package provides some directories which are required by other
19packages which comprise the modularized X.Org X11R7 X Window System
20release.  This package must be installed during OS installation
21or upgrade, in order to force the creation of these directories,
22and replace any legacy symbolic links that might be present in old
23locations, which could result in upgrade failures.
24
25%prep
26%install
27rm -rf $RPM_BUILD_ROOT
28
29# NOTE: Do not replace these with _libdir or _includedir macros, they are
30#       intentionally explicit.
31mkdir -p "$RPM_BUILD_ROOT%{_libdir}/X11"
32mkdir -p "$RPM_BUILD_ROOT%{_includedir}/X11"
33mkdir -p "$RPM_BUILD_ROOT%{_datadir}/X11"
34mkdir -p "$RPM_BUILD_ROOT%{_bindir}"
35
36UPGRADE_CMD="%{_bindir}/xorg-x11-filesystem-upgrade"
37
38# NOTE: The quoted 'EOF' is required to disable variable interpolation
39cat > "$RPM_BUILD_ROOT/${UPGRADE_CMD}" <<'EOF'
40#!/bin/bash
41#
42# Modular X.Org X11R7 filesystem upgrade script.
43#
44# If any of the following dirs are symlinks, remove them and create a dir
45# in its place.  This is required, so that modular X packages get installed
46# into a real directory, and do not follow old compatibility symlinks
47# provided in previous releases of the operating system.
48#
49# NOTE: Do not replace these with _libdir or _includedir macros, they are
50#       intentionally explicit.
51for dir in %{_includedir}/X11 %{_libdir}/X11 ; do
52    [ -L "$dir" ] && rm -f -- "$dir" &> /dev/null
53done
54for dir in %{_includedir}/X11 %{_libdir}/X11 ; do
55    [ ! -d "$dir" ] && mkdir -p "$dir" &> /dev/null
56done
57exit 0
58EOF
59
60chmod 0755 "$RPM_BUILD_ROOT/${UPGRADE_CMD}"
61
62
63%clean
64rm -rf $RPM_BUILD_ROOT
65
66%pre
67# NOTE: Do not replace these with _libdir or _includedir macros, they are
68#       intentionally explicit.
69# Remove old symlinks if present, and replace them with directories.
70for dir in %{_includedir}/X11 %{_libdir}/X11 ; do
71    [ -L "$dir" ] && rm -f -- "$dir" &> /dev/null
72done
73for dir in %{_includedir}/X11 %{_libdir}/X11 ; do
74    [ ! -d "$dir" ] && mkdir -p "$dir" &> /dev/null
75done
76exit 0
77
78%files
79%defattr(-,root,root,-)
80# NOTE: These are explicitly listed intentionally, instead of using rpm
81#       macros, as these exact locations are required for compatibility
82#       regardless of what _libdir or _includedir point to.
83%dir %{_libdir}/X11
84%dir %{_includedir}/X11
85%dir %{_datadir}/X11
86%{_bindir}/xorg-x11-filesystem-upgrade
87
88%changelog
89* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
90- bump version to 7.7-1
91
92* Sun Apr 17 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
93- remove BuildArch: noarch
94- bump version to 7.6-1
95
96* Tue Apr 07 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
97- spec in utf-8
98- bump version to 7.4-1
99
100* Thu Apr 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
101- own %%{_datadir}/X11
102- Obsoletes: XOrg-devel < 7.0
103
104* Sat Jan 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.1-0vl1
105- initial build for Vine Linux based on fodora package.
106
107* Mon Jul 10 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
108- Reword package description for (#189648)
109
110* Wed Jun 21 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
111- Bumped version to 7.1-1 and rebuilt for X11R7.1.
112
113* Thu Feb 09 2006 Mike A. Harris <mharris@redhat.com> 7.0-1
114- Bumped version to 7.0-1 and rebuilt.
115
116* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-3
117- Ok, even though I _tested_ it, and it worked..  the previous build had a
118  broken post, preun, and postun script, due to copy and paste error.  Ugh.
119  Also, the script in /usr/bin was broken due to heredoc variable
120  interpolation, which I turned off this time so it is generated correctly.
121  I removed the post, preun, postun scripts as they are overkill anyway.
122  The bug in 0.99.2-2 might cause upgrade or uninstall of the package to
123  fail and require manual uninstallation with --noscripts.  Oops.  This
124  is what "rawhide" means boys and girls.
125- Added "Requires(pre): filesystem >= 2.3.7-1", to avoid problems with older
126  versions of it, and to allow packages that need this workaround to only
127  have to set a dependency on xorg-x11-filesystem instead of both packages.
128 
129* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
130- Updated scripts so that they create the directory even if the symlink was
131  not present, to ensure that the dir exists first and avoid theoretical
132  case in which, in a single transaction, xorg-x11-filesystem gets installed,
133  no symlink or dir is present causing the symlink test to fail, so no dir
134  gets created, then another package in the transaction set installs a
135  symlink, then a package tries to install a dir and fails.  This should
136  guarantee now that these two dirs are really really dirs, not symlinks
137  for sure for sure.
138
139* Mon Nov 21 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
140- Initial build.
141- Package creates the directories /usr/lib/X11 and /usr/include/X11 and owns
142  them as properly flagged dirs in the file manifest.
143- Added identical pre/post/preun/postun scripts which test to see if any of
144  of each of /usr/include/X11 /usr/lib/X11 /usr/lib64/X11
Note: See TracBrowser for help on using the repository browser.