source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 843

Revision 843, 7.8 KB checked in by daisuke, 14 years ago (diff)

xorg-x11-server:

  • add patch to import xorg.conf.d changes from upstream
    • /etc/xorg.conf.d -> /etc/X11/xorg.conf.d and /usr/share/X11/xorg.conf.d

xorg-x11-drv-{synaptics,fpit}:

  • move xorg.conf snippet to /usr/share/X11/xorg.conf.d

system-setup-keyboard:

  • new upstream release
  • move xorg.conf snippet to /etc/X11/xorg.conf.d
Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.2.2
9Release:        2%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        50-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  xorg-x11-util-macros >= 1.3.0
24Requires:       xorg-x11-server-Xorg
25
26Provides:       synaptics = %{version}-%{release}
27Obsoletes:      synaptics < 0.15.0
28
29
30%description
31This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
32default operates in compatibility mode by emulating a standard mouse. However,
33by using a dedicated driver, more advanced features of the touchpad becomes
34available.
35
36Features:
37
38    * Movement with adjustable, non-linear acceleration and speed.
39    * Button events through short touching of the touchpad.
40    * Double-Button events through double short touching of the touchpad.
41    * Dragging through short touching and holding down the finger on the
42      touchpad.
43    * Middle and right button events on the upper and lower corner of the
44      touchpad.
45    * Vertical scrolling (button four and five events) through moving the
46      finger on the right side of the touchpad.
47    * The up/down button sends button four/five events.
48    * Horizontal scrolling (button six and seven events) through moving the
49      finger on the lower side of the touchpad.
50    * The multi-buttons send button four/five events, and six/seven events for
51      horizontal scrolling.
52    * Adjustable finger detection.
53      Multifinger taps: two finger for middle button and three finger for
54      right button events. (Needs hardware support. Not all models implement
55      this feature.)
56    * Run-time configuration using shared memory. This means you can change
57      parameter settings without restarting the X server.
58
59%description -l ja
60Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
61パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
62しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
63ます。
64
65機能:
66    * スピードと加速の調整が可能。
67    * タッチパッドに短く触れたらクリック。
68    * タッチパッドに2度短く触れたらダブルクリック。
69    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
70    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
71    * タッチパッドの右端を上下になぞる事で縦スクロール。
72      (ボタン4及びボタン5として動作)
73    * 上下ボタンをボタン4及びボタン5として動作。
74    * タッチパッドの下端を左右になぞることで横スクロール。
75      (ボタン6及びボタン7として動作)
76    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
77    * 感度の調整が可能。
78    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
79      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
80    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
81      設定を変更することができる。
82
83%prep
84%setup -q -n %{tarball}-%{version}
85
86%build
87autoreconf -v --install --force || exit 1
88%configure --disable-static
89make %{?_smp_mflags}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94make install DESTDIR=$RPM_BUILD_ROOT
95
96# FIXME: Remove all libtool archives (*.la) from modules directory.  This
97# should be fixed in upstream Makefile.am or whatever.
98find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
99
100# install xorg.conf snippet
101install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
102install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/
103
104
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%files
109%defattr(-,root,root,-)
110%doc COPYING README
111%{_datadir}/X11/xorg.conf.d/*.conf
112%{driverdir}/synaptics_drv.so
113%{_bindir}/synclient
114%{_bindir}/syndaemon
115%{_mandir}/man4/synaptics.4*
116%{_mandir}/man1/synclient.1*
117%{_mandir}/man1/syndaemon.1*
118%{_includedir}/xorg/synaptics-properties.h
119%{_includedir}/xorg/synaptics.h
120%{_libdir}/pkgconfig/xorg-synaptics.pc
121
122%changelog
123* Sat Apr 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-2
124- move xorg.conf snippet to /usr/share/X11/xorg.conf.d
125
126* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
127- update to 1.2.2
128- drop hal support
129  - drop hal fdi policy
130  - remove R: hal
131- add xorg.conf snippet
132
133* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
134- rebuild with xserver-1.8rc (x86_64)
135
136* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
137- rebuild with xserver-1.8rc
138
139* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
140- new upstream release
141
142* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
143- new upstream release
144- add BR: xorg-x11-util-macros >= 1.3.0
145
146* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
147- new upstream release
148- remove Patch10: SHMconfig is not needed
149
150* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
151- new upstream release
152
153* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
154- new upstream release
155
156* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
157- new upstream release
158
159* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
160- use bundled fdi
161- add patch10 to enable SHMConfig on all synaptics devices.
162
163* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
164- new upstream release
165
166* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
167- new upstream version released from x.org
168- rename to xorg-x11-drv-synaptics
169- add Obsoletes/Provides synaptics
170- add patch1,2 from fedora
171  - patch1: reserve 5% on each side for edge detection.
172  - patch2: force a click if middle button emulation times out during ReadInput cycle.
173
174* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
175- fixed synaptics_drv.so path by using %%{_libdir}
176
177* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
178- add Patch0; add BuildRequires: libpciaccess-devel
179- built with xorg-x11-server-1.4.99.905
180
181* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
182- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
183- built with xorg-x11
184- spec encoding converted to UTF-8
185
186* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
187- source update.
188- build for VineSeed (4.0) Plus.
189
190* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
191- build for Vine Plus/3.0.
192
193* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
194- source update.
195- build for VineSeed Plus.
196
197* Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
198- add man page synaptics.5.
199- build for VineSeed Plus.
200
201* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
202- build for Vine Plus/3.0.
203
204* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
205- source update.
206- build for VineSeed Plus.
207
208* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
209- build for Vine Plus/3.0.
210
211* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
212- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.