source: projects/specs/trunk/x/xorg-x11-drv-synaptics/xorg-x11-drv-synaptics-vl.spec @ 707

Revision 707, 7.9 KB checked in by daisuke, 14 years ago (diff)

update to 1.2.2
drop hal support, add xorg.conf snippet

Line 
1%define tarball xf86-input-synaptics
2%define moduledir %(pkg-config xorg-server --variable=moduledir )
3%define driverdir %{moduledir}/input
4
5Name:           xorg-x11-drv-synaptics
6Summary:        Xorg X11 synaptics input driver
7Summary(ja):    Xorg X11 synaptics 入力ドライバ
8Version:        1.2.2
9Release:        1%{?_dist_release}
10URL:            http://www.x.org
11License:        MIT
12Group:          User Interface/X Hardware Support
13
14Source0:        ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
15
16Source1:        10-synaptics.conf
17
18BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root
19ExcludeArch:    s390 s390x
20BuildRequires:  libtool, pkgconfig
21BuildRequires:  xorg-x11-server-sdk >= 1.6.0
22BuildRequires:  libX11-devel, libXi-devel, libXext-devel
23BuildRequires:  xorg-x11-util-macros >= 1.3.0
24Requires:       xorg-x11-server-Xorg
25
26Provides:       synaptics = %{version}-%{release}
27Obsoletes:      synaptics < 0.15.0
28
29
30%description
31This is a driver for the Synaptics TouchPad for X.Org. A Synaptics touchpad by
32default operates in compatibility mode by emulating a standard mouse. However,
33by using a dedicated driver, more advanced features of the touchpad becomes
34available.
35
36Features:
37
38    * Movement with adjustable, non-linear acceleration and speed.
39    * Button events through short touching of the touchpad.
40    * Double-Button events through double short touching of the touchpad.
41    * Dragging through short touching and holding down the finger on the
42      touchpad.
43    * Middle and right button events on the upper and lower corner of the
44      touchpad.
45    * Vertical scrolling (button four and five events) through moving the
46      finger on the right side of the touchpad.
47    * The up/down button sends button four/five events.
48    * Horizontal scrolling (button six and seven events) through moving the
49      finger on the lower side of the touchpad.
50    * The multi-buttons send button four/five events, and six/seven events for
51      horizontal scrolling.
52    * Adjustable finger detection.
53      Multifinger taps: two finger for middle button and three finger for
54      right button events. (Needs hardware support. Not all models implement
55      this feature.)
56    * Run-time configuration using shared memory. This means you can change
57      parameter settings without restarting the X server.
58
59%description -l ja
60Synaptics は XOrg 用の Synaptics タッチパッドドライバです。Synaptics タッチ
61パッドはデフォルトでは標準マウスをエミュレートし互換モードで動作します。
62しかしこの専用ドライバを使用することで、より多くの機能が使用できるようになり
63ます。
64
65機能:
66    * スピードと加速の調整が可能。
67    * タッチパッドに短く触れたらクリック。
68    * タッチパッドに2度短く触れたらダブルクリック。
69    * タッチパッドに短く触れた後、指を下ろしたまま移動させたらドラッグ。
70    * タッチパッドの上下のコーナーに中ボタンと右ボタンを割り当て。
71    * タッチパッドの右端を上下になぞる事で縦スクロール。
72      (ボタン4及びボタン5として動作)
73    * 上下ボタンをボタン4及びボタン5として動作。
74    * タッチパッドの下端を左右になぞることで横スクロール。
75      (ボタン6及びボタン7として動作)
76    * 複数ボタンがある場合は横スクロール用にボタン4/5とボタン6/7として動作。
77    * 感度の調整が可能。
78    * 複数の指によるタップ: 二本指を中ボタン、三本指を右ボタンに割り当て。
79      (ハードウェアのサポートが必要。全てのタッチパッドで動作する訳では無い)
80    * 共有メモリによる実行中の設定変更が可能。これにより X の再起動無しに
81      設定を変更することができる。
82
83%prep
84%setup -q -n %{tarball}-%{version}
85
86%build
87autoreconf -v --install --force || exit 1
88%configure --disable-static
89make %{?_smp_mflags}
90
91%install
92rm -rf $RPM_BUILD_ROOT
93
94make install DESTDIR=$RPM_BUILD_ROOT
95
96# FIXME: Remove all libtool archives (*.la) from modules directory.  This
97# should be fixed in upstream Makefile.am or whatever.
98find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
99
100# install xorg.conf snippet
101install -d $RPM_BUILD_ROOT%{_sysconfdir}/xorg.conf.d/
102install -m644 %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/xorg.conf.d/
103
104#install -d $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
105#install -m644 fdi/11-x11-synaptics.fdi $RPM_BUILD_ROOT%{_datadir}/hal/fdi/policy/10osvendor
106
107
108%clean
109rm -rf $RPM_BUILD_ROOT
110
111%files
112%defattr(-,root,root,-)
113%doc COPYING README
114#%{_datadir}/hal/fdi/policy/10osvendor/*
115%{_sysconfdir}/xorg.conf.d/*.conf
116%{driverdir}/synaptics_drv.so
117%{_bindir}/synclient
118%{_bindir}/syndaemon
119%{_mandir}/man4/synaptics.4*
120%{_mandir}/man1/synclient.1*
121%{_mandir}/man1/syndaemon.1*
122%{_includedir}/xorg/synaptics-properties.h
123%{_includedir}/xorg/synaptics.h
124%{_libdir}/pkgconfig/xorg-synaptics.pc
125
126%changelog
127* Mon Mar 29 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.2-1
128- update to 1.2.2
129- drop hal support
130  - drop hal fdi policy
131  - remove R: hal
132- add xorg.conf snippet
133
134* Sun Mar 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-3
135- rebuild with xserver-1.8rc (x86_64)
136
137* Wed Mar 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.1-2
138- rebuild with xserver-1.8rc
139
140* Sun Feb 28 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1.2.1-1
141- new upstream release
142
143* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.2.0-1
144- new upstream release
145- add BR: xorg-x11-util-macros >= 1.3.0
146
147* Sat Jun 06 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.2-1
148- new upstream release
149- remove Patch10: SHMconfig is not needed
150
151* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1.1.0-1
152- new upstream release
153
154* Sun Dec 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.3-1
155- new upstream release
156
157* Mon Nov 24 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.99.1-1
158- new upstream release
159
160* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-2
161- use bundled fdi
162- add patch10 to enable SHMConfig on all synaptics devices.
163
164* Sat Sep 20 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.2-1
165- new upstream release
166
167* Tue Sep 09 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 0.15.1-1
168- new upstream version released from x.org
169- rename to xorg-x11-drv-synaptics
170- add Obsoletes/Provides synaptics
171- add patch1,2 from fedora
172  - patch1: reserve 5% on each side for edge detection.
173  - patch2: force a click if middle button emulation times out during ReadInput cycle.
174
175* Tue Jul  8 2008 Shu KONNO <owa@bg.wakwak.com> 0.14.6.20070706-3
176- fixed synaptics_drv.so path by using %%{_libdir}
177
178* Sun Jul  6 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-2
179- add Patch0; add BuildRequires: libpciaccess-devel
180- built with xorg-x11-server-1.4.99.905
181
182* Fri May 23 2008 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 0.14.6.20070706-1
183- updated to newest git upstream (cd6a1225ec319cad9788e8fba158d9792b55de23)
184- built with xorg-x11
185- spec encoding converted to UTF-8
186
187* Wed Jul 19 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.6-0vl1
188- source update.
189- build for VineSeed (4.0) Plus.
190
191* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl0
192- build for Vine Plus/3.0.
193
194* Sun Jun 18 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.5-0vl1
195- source update.
196- build for VineSeed Plus.
197
198* Sat Jan 23 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl3
199- add man page synaptics.5.
200- build for VineSeed Plus.
201
202* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl0
203- build for Vine Plus/3.0.
204
205* Sat Jan 21 2006 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.4-0vl1
206- source update.
207- build for VineSeed Plus.
208
209* Sun Apr 03 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl0
210- build for Vine Plus/3.0.
211
212* Thu Mar 31 2005 Kazutaka HARADA <kazutaka@dc4.so-net.ne.jp> 0.14.1-0vl1
213- initial build for VineSeed Plus.
Note: See TracBrowser for help on using the repository browser.