source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 9113

Revision 9113, 21.9 KB checked in by Takemikaduchi, 9 years ago (diff)

add patch

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8#%define gputoolsdate 20130611
9%define gputoolsdate 1.8
10%else
11%define accel sna
12%define gputoolsdate 20110817
13%endif
14
15Summary:   Xorg X11 Intel video driver
16Summary(ja):   Xorg X11 Intel ビデオドライバ
17Name:      xorg-x11-drv-intel
18Epoch:     1
19Version:   2.99.916
20Release:   2%{?_dist_release}
21URL:       http://intellinuxgraphics.org/
22License:   MIT
23Group:     User Interface/X Hardware Support
24
25Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
26Source2:   intel.xinf
27#Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
28Source3:   intel-gpu-tools-1.8.tar.bz2
29Source4:   intel-gpu-tools-%{gputoolsdate2}.tar.bz2
30
31# vine patch
32Patch0:    xf86-video-intel-2.99.916-git20141120.patch
33
34
35ExclusiveArch: %{ix86} x86_64 ia64
36BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
37BuildRequires: autoconf, automake, libtool
38BuildRequires: xorg-x11-server-sdk >= 1.7.99
39BuildRequires: libXvMC-devel
40BuildRequires: libGL-devel >= 7.10
41BuildRequires: libdrm-devel >= 2.4.25
42BuildRequires: kernel-headers >= 2.6.33
43BuildRequires: eudev-libudev-devel
44BuildRequires: libxcb-devel >= 1.5
45BuildRequires: xcb-util-devel
46BuildRequires: cairo-devel
47
48Requires:  hwdata
49Requires:  xorg-x11-server-Xorg
50Requires:  xcb-util
51
52Obsoletes: xorg-x11-drv-i810
53Provides: xorg-x11-drv-i810
54
55#Conflicts:  kudzu < 1.2.42-1
56
57Vendor: Project Vine
58Distribution: Vine Linux
59Packager: daisuke
60
61%description
62X.Org X11 Intel video driver.
63
64%package devel
65Summary:   Xorg X11 Intel video driver XvMC development package
66Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
67Group:     Development/System
68Requires:  %{name} = %{epoch}:%{version}-%{release}
69Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
70
71%description devel
72X.Org X11 Intel video driver XvMC development package.
73
74%package -n intel-gpu-tools
75Summary:    Debugging tools for Intel graphics chips
76Group:      Development/Tools
77
78%description -n intel-gpu-tools
79Debugging tools for Intel graphics chips
80
81
82%prep
83%setup -q -n xf86-video-intel-%{version} -b3 -b4
84%patch0 -p1
85
86%build
87autoreconf -vi
88
89%if "%{?_dist_release}" < "vl7"
90export CFLAGS="-I/usr/include/X11/dri"
91%endif
92
93%configure \
94  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
95  --enable-dri --enable-xvmc \
96  --enable-sna --enable-uxa \
97  --with-default-accel=%{accel} \
98  --enable-xaa=no
99make
100
101pushd ../intel-gpu-tools-%{gputoolsdate}
102autoreconf -v --install
103%configure --disable-nouveau --disable-dumper
104make
105popd
106
107
108%install
109rm -rf $RPM_BUILD_ROOT
110
111make install DESTDIR=$RPM_BUILD_ROOT
112mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
113install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
114
115pushd ../intel-gpu-tools-%{gputoolsdate}
116make install DESTDIR=$RPM_BUILD_ROOT
117popd
118
119
120find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
121
122%clean
123rm -rf $RPM_BUILD_ROOT
124
125%triggerpostun -- XOrg < 7.0
126if (grep -q i810 /etc/X11/xorg.conf)
127then
128  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
129  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
130fi ||:
131
132%files
133%defattr(-,root,root,-)
134%{driverdir}/intel_drv.so
135%{_datadir}/hwdata/videoaliases/intel.xinf
136%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
137%{_libdir}/libI810XvMC.so.*
138%{_libdir}/libIntelXvMC.so.*
139%{_libexecdir}/xf86-video-intel-backlight-helper
140%{_mandir}/man4/i*
141
142%files devel
143%defattr(-,root,root,-)
144%{_libdir}/libI810XvMC.so
145%{_libdir}/libIntelXvMC.so
146
147%files -n intel-gpu-tools
148%defattr(-,root,root,-)
149%{_bindir}/*
150%{_mandir}/man1/intel_*.1*
151
152
153%changelog
154* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
155- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
156- update Source3 (intel-gpu-tools-1.8.tar.bz2)
157
158* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
159- update to 2.99.916
160
161* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
162- update to 2.99.912
163
164* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
165- change BuildRequires: eudev-libudev-devel instead of libudev-devel
166
167* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
168- rebuild with VineSeed environment
169
170* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
171- new upstream release
172
173* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
174- new upstream release
175- change default accel method to sna.
176
177* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
178- new upstream release
179
180* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
181- new upstream release
182
183* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
184- new upstream release
185
186* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
187- new upstream release
188
189* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
190- new upstream release
191
192* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
193- new upstream release
194
195* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
196- new upstream release
197
198* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
199- new upstream release
200
201* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
202- new upstream release
203
204* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
205- new upstream release
206
207* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
208- rebuild with xcb-util-0.3.9
209
210* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
211- disable sna, enable uxa
212
213* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
214- new upstream release
215
216* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
217- rebuild with xserver-1.12.0
218
219* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
220- new upstream release
221- enable sna
222
223* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
224- disable sna/vmap
225
226* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
227- new upstram release
228- disable copy-fb patch
229
230* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
231- rebuild with xserver-1.11.1.902
232
233* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
234- add --enable-sna --enable-vmap
235
236* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
237- new upstream release
238
239* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
240- rebuild with xcb-util-0.3.8
241- drop Patch200
242
243* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
244- update to disable copy_fb on sandybridge/ivybridge
245
246* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
247- update intel.xinf
248- add patch10 from fedora
249  - Clamp VGA pixel clock to 250MHz,
250    anything higher's going to look awful anyway. (#559426)
251
252* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
253- drop patch1-3 and replaced with new patch1 from git master
254- add Patch200 to disable DRI on SandyBridge/IvyBridge
255- update intel-gpu-tools
256
257* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
258- add Patch1-3 from upstream
259
260* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
261- new upstream release
262- drop upstream patches: 107-115
263- temporary disabled patch101
264- BR: libdrm >= 2.4.25
265
266* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
267- add Patch101-115 from ubuntu/debian package
268  - Patch101: Plymouth integration patch
269  - Patch107: Check null return from uxa_acquire_solid()
270  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
271  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
272  - Patch110,114: Cherry picks to fix a large number of build warnings.
273  - Patch111: Fix clipped window plane offset
274  - Patch112: Fix issue where vertical green line and strange colors
275              shows up when playing gstreamer with certain videos,
276              when dragged.  (LP 460677)
277  - Patch113: Fixes GPU lockup during login with
278              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
279              error messages listed in the gpu dump text. (LP 710321)
280  - Patch115: Don't fill up Xorg.0.log with
281              "get vblank counter failed: Invalid argument" warnings.
282   
283* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
284- rebuild with xserver-1.10.0
285
286* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
287- new upstream release
288
289* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
290- new upstream release
291
292* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
293- rebuild with xserver-1.9.2
294
295* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
296- new upstream release
297- add Patch40: fix uxa planemask (backported)
298- add Patch61: add support for backlight on macbooks
299- add Patch62: disable page flipping for stability
300
301* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
302- new upstream release
303- drop patch70
304
305* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
306- rebuild again with xserver-1.8rc
307
308* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
309- add intel-gpu-tools as sub-package
310- rebuild with libdrm-2.4.18
311
312* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
313- new upstream release
314- import Patch1,2,60,70 from fedora
315- add BR: kernel-headers >= 2.6.33 (new drm header required)
316- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
317- add BR; libudev-devel and autoreconf for Patch60
318
319* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
320- rebuild with libdrm-2.4.17
321
322* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
323- new upstream release
324
325* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
326- new upstream release (hopefully fixes severe issues w/ efifb)
327- drop all patches already upstreamed; import Patch20/21 from Fedora
328
329* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
330- import Patch121,122 from ubuntu
331- build with libdrm-2.4.12 which fixes vt switch crash
332
333* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
334- apply patch114 to fix Xv with non-GEM kernel
335
336* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
337- update to 2.6.3
338- add patch106,107,115,118,119,120 from ubuntu
339  - add Patch106: remove triple buffering
340  - add Patch107: remove page flipping
341  - add Patch115: fix crash Xv overlay
342  - add Patch118: drop legacy3d
343  - add Patch119: fix crashes in drm bo
344  - add Patch120: fix vt switch
345- add patch130-134 from upstream git
346  - add Patch130: fix another vt switch leak
347  - add Patch131: Create known output configuration at EnterVT time
348  - add Patch132: fix leak of some 965 render state on VT switch
349  - add Patch133: fix crash with fake bufmgr and UXA
350  - add Patch134: fix EnterVT/LeaveVT
351  - add Patch135: add new chip supoprt
352
353
354* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
355- revert to 2.6.1, add Epoch
356- add Patch103-121 from ubuntu
357
358* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
359- new upstream release
360
361* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
362- new upstream release
363
364* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
365- new upstream release
366
367* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
368- add Patch5 - Dont die on irq handler failure
369
370* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
371- new upstream release
372- add BR: libdrm-devel >= 2.4.0-3
373
374* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
375- import Patch10,11,12 from ubuntu
376
377* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
378- new upstream release
379- add triggerpostun script to replace i810 driver to intel driver
380
381* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
382- new upstream release
383
384* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
385- new upstream release
386- rename i810.xinf to intel.xinf
387- update intel.xinf (add Intel 4 series)
388
389* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
390- rebuild with new xserver
391
392* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
393- new upstream release
394
395* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
396- new upstream release
397
398* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
399- new upstream release
400
401* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
402- initial build for Vine Linux
403
404* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
405- Rebuild for new server ABI.
406- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
407
408* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
409- hook up ch7017 (bz#408471)
410
411* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
412- xf86-video-intel 2.2.0
413
414* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
415- xf86-video-intel 2.1.99.
416- Drop the i810 driver.  Time to move on.
417- Require xserver 1.4.99.1
418
419* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
420- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
421
422* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
423- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
424  for textured Xv to use as an offscreen pixmap so xv actually works under
425  compiz - granted it may be unusably slow but at least stuff shows up.
426
427* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
428- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
429- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
430
431* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
432- intel-2.1.1-quirk-update.patch - update quirks from master
433
434* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
435- i810.xinf: Flip everything over to -intel by default now.  Still install
436  i810 driver just in case.
437
438* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
439- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
440
441* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
442- xf86-video-intel 2.1.1.
443
444* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
445- xf86-video-intel 2.1.0.
446
447* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
448- Update Requires and BuildRequires.
449
450* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
451- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
452  965GME, G33, Q33, and Q35 chips.
453
454* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
455- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
456  DRI clients are active, for better battery life.
457
458* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
459- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
460
461* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
462- xf86-video-intel 2.0.0.  Change the version number to match, why not.
463- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
464  rename this at some point.
465
466* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
467- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
468  915GM.
469
470* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
471- i810.xinf: More intel whitelisting (#214011, #234877)
472
473* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
474- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
475- i810.xinf: Point 965GM support at the intel driver since it's not present
476  in old i810.
477
478* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
479- xf86-video-intel-1.9.93 (RC3).
480
481* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
482- fix typo with 945GM pci id from my laptop
483
484* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
485- xf86-video-intel 1.9.92 (RC2).
486
487* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
488- Updated modesetting driver to one that will actually work with a 1.3 server.
489
490* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
491- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
492- Remove ivch and ch7017 from the install since they aren't hooked up to the
493  code anywhere
494- Disown the module
495
496* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
497- update modesetting driver to git snapshot from today
498
499* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
500- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
501
502* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
503- rebuilt for unwind info generation, broken in gcc-4.1.1-21
504
505* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
506- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
507  actually require kudzu to run.
508
509* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
510- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
511
512* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
513- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
514- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
515  driver match the corresponding terrible heuristic in the server.
516
517* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
518- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
519  correctly distinguish between Mac Mini and Macbook Pro.
520
521* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
522- i810.xinf: PCI IDs for i965.
523
524* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
525- i810.xinf: Uppercase PCI IDs.
526
527* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
528- Update i810 to 1.6.5, should fix DRI.
529- Add kuzdu requires.
530- i810.xinf: Start whitelisting devices over to intel.
531
532* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
533- intel-driver-rename.patch: Fix the driver name in more places so it'll,
534  you know, load.
535
536* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
537- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
538  LFP special casing in favor of the blacklist.
539
540* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
541- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
542  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
543  and is selected with Driver "intel" in xorg.conf.  Individual devices will
544  whitelist over to "intel" until that branch gets merged into head.
545- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
546- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
547  the BIOS is known to lie.
548
549* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
550- Today's snapshot: I2C bus creation fix.
551
552* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
553- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
554  clock when computing the modes list.
555- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
556  in centimeters as the size of the display in pixels.
557
558* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
559- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
560  probing.
561
562* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
563- Update again for a mode comparison bugfix.
564
565* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
566- Update to today's git; crash fixes, better pre-915 support, slightly better
567  autoconfigurability.
568
569* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
570- rebuild
571
572* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
573- Fix Revision number to match naming policy.
574
575* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
576- Add back modesetting changes.
577
578* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
579- Roll back modesetting changes and build for fc5 aiglx repo.
580
581* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
582- Snapshot of the git modesetting branch.
583
584* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
585- Update i810.xinf to include entries for E7221 and 945GM.
586
587* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
588- Add with_dri macro to spec file, and conditionalize build time DRI support
589
590* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
591- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
592  to pick up proto-devel as well.
593
594* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
595- Rebuild for 7.1 ABI fix.
596
597* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
598- Bump for fc5-bling build.
599
600* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
601- Update to 1.6.0 from 7.1RC1.
602
603* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
604- Add patch to add missing #include's, specifically assert.h.
605
606* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
607- Update to CVS snapshot of 20060322.
608
609* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
610- rebuilt for new gcc4.1 snapshot and glibc changes
611
612* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
613- Added 8086:2772 mapping to i810.xinf for bug (#178451)
614
615* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
616- Added 8086:2592 mapping to i810.xinf for bug (#172884)
617
618* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
619- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
620
621* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
622- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
623- Removed 'x' suffix from manpage dirs to match RC4 upstream.
624
625* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
626- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
627
628* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
629- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
630- Fix *.la file removal.
631- Added 'devel' subpackage for XvMC .so
632- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
633
634* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
635- Update BuildRoot to use Fedora Packaging Guidelines.
636- Deglob file manifest.
637- Limit "ExclusiveArch" to x86, x86_64, ia64
638
639* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
640- Initial spec file for i810 video driver generated automatically
641  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.