source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 8784

Revision 8784, 21.5 KB checked in by Takemikaduchi, 10 years ago (diff)

xserver-1.15.2

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8%define gputoolsdate 20130611
9%else
10%define accel sna
11%define gputoolsdate 20110817
12%endif
13
14Summary:   Xorg X11 Intel video driver
15Summary(ja):   Xorg X11 Intel ビデオドライバ
16Name:      xorg-x11-drv-intel
17Epoch:     1
18Version:   2.99.912
19Release:   1%{?_dist_release}
20URL:       http://intellinuxgraphics.org/
21License:   MIT
22Group:     User Interface/X Hardware Support
23
24Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
25Source2:   intel.xinf
26Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
27Source4:   intel-gpu-tools-%{gputoolsdate2}.tar.bz2
28
29# vine patch
30
31
32ExclusiveArch: %{ix86} x86_64 ia64
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34BuildRequires: autoconf, automake, libtool
35BuildRequires: xorg-x11-server-sdk >= 1.7.99
36BuildRequires: libXvMC-devel
37BuildRequires: libGL-devel >= 7.10
38BuildRequires: libdrm-devel >= 2.4.25
39BuildRequires: kernel-headers >= 2.6.33
40BuildRequires: eudev-libudev-devel
41BuildRequires: libxcb-devel >= 1.5
42BuildRequires: xcb-util-devel
43BuildRequires: cairo-devel
44
45Requires:  hwdata
46Requires:  xorg-x11-server-Xorg
47Requires:  xcb-util
48
49Obsoletes: xorg-x11-drv-i810
50Provides: xorg-x11-drv-i810
51
52#Conflicts:  kudzu < 1.2.42-1
53
54Vendor: Project Vine
55Distribution: Vine Linux
56Packager: daisuke
57
58%description
59X.Org X11 Intel video driver.
60
61%package devel
62Summary:   Xorg X11 Intel video driver XvMC development package
63Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
64Group:     Development/System
65Requires:  %{name} = %{epoch}:%{version}-%{release}
66Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
67
68%description devel
69X.Org X11 Intel video driver XvMC development package.
70
71%package -n intel-gpu-tools
72Summary:    Debugging tools for Intel graphics chips
73Group:      Development/Tools
74
75%description -n intel-gpu-tools
76Debugging tools for Intel graphics chips
77
78
79%prep
80%setup -q -n xf86-video-intel-%{version} -b3 -b4
81
82%build
83autoreconf -vi
84
85%if "%{?_dist_release}" < "vl7"
86export CFLAGS="-I/usr/include/X11/dri"
87%endif
88
89%configure \
90  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
91  --enable-dri --enable-xvmc \
92  --enable-sna --enable-uxa \
93  --with-default-accel=%{accel} \
94  --enable-xaa=no
95make
96
97pushd ../intel-gpu-tools-%{gputoolsdate}
98autoreconf -v --install
99%configure --disable-nouveau --disable-dumper
100make
101popd
102
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107make install DESTDIR=$RPM_BUILD_ROOT
108mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
109install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
110
111pushd ../intel-gpu-tools-%{gputoolsdate}
112make install DESTDIR=$RPM_BUILD_ROOT
113popd
114
115
116find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%triggerpostun -- XOrg < 7.0
122if (grep -q i810 /etc/X11/xorg.conf)
123then
124  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
125  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
126fi ||:
127
128%files
129%defattr(-,root,root,-)
130%{driverdir}/intel_drv.so
131%{_datadir}/hwdata/videoaliases/intel.xinf
132%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
133%{_libdir}/libI810XvMC.so.*
134%{_libdir}/libIntelXvMC.so.*
135%{_libexecdir}/xf86-video-intel-backlight-helper
136%{_mandir}/man4/i*
137
138%files devel
139%defattr(-,root,root,-)
140%{_libdir}/libI810XvMC.so
141%{_libdir}/libIntelXvMC.so
142
143%files -n intel-gpu-tools
144%defattr(-,root,root,-)
145%{_bindir}/*
146%{_mandir}/man1/intel_*.1*
147
148
149%changelog
150* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
151- update to 2.99.912
152
153* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
154- change BuildRequires: eudev-libudev-devel instead of libudev-devel
155
156* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
157- rebuild with VineSeed environment
158
159* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
160- new upstream release
161
162* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
163- new upstream release
164- change default accel method to sna.
165
166* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
167- new upstream release
168
169* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
170- new upstream release
171
172* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
173- new upstream release
174
175* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
176- new upstream release
177
178* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
179- new upstream release
180
181* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
182- new upstream release
183
184* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
185- new upstream release
186
187* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
188- new upstream release
189
190* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
191- new upstream release
192
193* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
194- new upstream release
195
196* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
197- rebuild with xcb-util-0.3.9
198
199* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
200- disable sna, enable uxa
201
202* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
203- new upstream release
204
205* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
206- rebuild with xserver-1.12.0
207
208* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
209- new upstream release
210- enable sna
211
212* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
213- disable sna/vmap
214
215* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
216- new upstram release
217- disable copy-fb patch
218
219* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
220- rebuild with xserver-1.11.1.902
221
222* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
223- add --enable-sna --enable-vmap
224
225* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
226- new upstream release
227
228* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
229- rebuild with xcb-util-0.3.8
230- drop Patch200
231
232* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
233- update to disable copy_fb on sandybridge/ivybridge
234
235* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
236- update intel.xinf
237- add patch10 from fedora
238  - Clamp VGA pixel clock to 250MHz,
239    anything higher's going to look awful anyway. (#559426)
240
241* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
242- drop patch1-3 and replaced with new patch1 from git master
243- add Patch200 to disable DRI on SandyBridge/IvyBridge
244- update intel-gpu-tools
245
246* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
247- add Patch1-3 from upstream
248
249* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
250- new upstream release
251- drop upstream patches: 107-115
252- temporary disabled patch101
253- BR: libdrm >= 2.4.25
254
255* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
256- add Patch101-115 from ubuntu/debian package
257  - Patch101: Plymouth integration patch
258  - Patch107: Check null return from uxa_acquire_solid()
259  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
260  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
261  - Patch110,114: Cherry picks to fix a large number of build warnings.
262  - Patch111: Fix clipped window plane offset
263  - Patch112: Fix issue where vertical green line and strange colors
264              shows up when playing gstreamer with certain videos,
265              when dragged.  (LP 460677)
266  - Patch113: Fixes GPU lockup during login with
267              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
268              error messages listed in the gpu dump text. (LP 710321)
269  - Patch115: Don't fill up Xorg.0.log with
270              "get vblank counter failed: Invalid argument" warnings.
271   
272* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
273- rebuild with xserver-1.10.0
274
275* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
276- new upstream release
277
278* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
279- new upstream release
280
281* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
282- rebuild with xserver-1.9.2
283
284* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
285- new upstream release
286- add Patch40: fix uxa planemask (backported)
287- add Patch61: add support for backlight on macbooks
288- add Patch62: disable page flipping for stability
289
290* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
291- new upstream release
292- drop patch70
293
294* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
295- rebuild again with xserver-1.8rc
296
297* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
298- add intel-gpu-tools as sub-package
299- rebuild with libdrm-2.4.18
300
301* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
302- new upstream release
303- import Patch1,2,60,70 from fedora
304- add BR: kernel-headers >= 2.6.33 (new drm header required)
305- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
306- add BR; libudev-devel and autoreconf for Patch60
307
308* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
309- rebuild with libdrm-2.4.17
310
311* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
312- new upstream release
313
314* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
315- new upstream release (hopefully fixes severe issues w/ efifb)
316- drop all patches already upstreamed; import Patch20/21 from Fedora
317
318* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
319- import Patch121,122 from ubuntu
320- build with libdrm-2.4.12 which fixes vt switch crash
321
322* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
323- apply patch114 to fix Xv with non-GEM kernel
324
325* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
326- update to 2.6.3
327- add patch106,107,115,118,119,120 from ubuntu
328  - add Patch106: remove triple buffering
329  - add Patch107: remove page flipping
330  - add Patch115: fix crash Xv overlay
331  - add Patch118: drop legacy3d
332  - add Patch119: fix crashes in drm bo
333  - add Patch120: fix vt switch
334- add patch130-134 from upstream git
335  - add Patch130: fix another vt switch leak
336  - add Patch131: Create known output configuration at EnterVT time
337  - add Patch132: fix leak of some 965 render state on VT switch
338  - add Patch133: fix crash with fake bufmgr and UXA
339  - add Patch134: fix EnterVT/LeaveVT
340  - add Patch135: add new chip supoprt
341
342
343* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
344- revert to 2.6.1, add Epoch
345- add Patch103-121 from ubuntu
346
347* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
348- new upstream release
349
350* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
351- new upstream release
352
353* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
354- new upstream release
355
356* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
357- add Patch5 - Dont die on irq handler failure
358
359* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
360- new upstream release
361- add BR: libdrm-devel >= 2.4.0-3
362
363* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
364- import Patch10,11,12 from ubuntu
365
366* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
367- new upstream release
368- add triggerpostun script to replace i810 driver to intel driver
369
370* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
371- new upstream release
372
373* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
374- new upstream release
375- rename i810.xinf to intel.xinf
376- update intel.xinf (add Intel 4 series)
377
378* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
379- rebuild with new xserver
380
381* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
382- new upstream release
383
384* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
385- new upstream release
386
387* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
388- new upstream release
389
390* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
391- initial build for Vine Linux
392
393* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
394- Rebuild for new server ABI.
395- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
396
397* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
398- hook up ch7017 (bz#408471)
399
400* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
401- xf86-video-intel 2.2.0
402
403* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
404- xf86-video-intel 2.1.99.
405- Drop the i810 driver.  Time to move on.
406- Require xserver 1.4.99.1
407
408* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
409- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
410
411* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
412- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
413  for textured Xv to use as an offscreen pixmap so xv actually works under
414  compiz - granted it may be unusably slow but at least stuff shows up.
415
416* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
417- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
418- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
419
420* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
421- intel-2.1.1-quirk-update.patch - update quirks from master
422
423* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
424- i810.xinf: Flip everything over to -intel by default now.  Still install
425  i810 driver just in case.
426
427* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
428- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
429
430* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
431- xf86-video-intel 2.1.1.
432
433* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
434- xf86-video-intel 2.1.0.
435
436* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
437- Update Requires and BuildRequires.
438
439* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
440- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
441  965GME, G33, Q33, and Q35 chips.
442
443* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
444- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
445  DRI clients are active, for better battery life.
446
447* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
448- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
449
450* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
451- xf86-video-intel 2.0.0.  Change the version number to match, why not.
452- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
453  rename this at some point.
454
455* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
456- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
457  915GM.
458
459* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
460- i810.xinf: More intel whitelisting (#214011, #234877)
461
462* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
463- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
464- i810.xinf: Point 965GM support at the intel driver since it's not present
465  in old i810.
466
467* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
468- xf86-video-intel-1.9.93 (RC3).
469
470* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
471- fix typo with 945GM pci id from my laptop
472
473* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
474- xf86-video-intel 1.9.92 (RC2).
475
476* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
477- Updated modesetting driver to one that will actually work with a 1.3 server.
478
479* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
480- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
481- Remove ivch and ch7017 from the install since they aren't hooked up to the
482  code anywhere
483- Disown the module
484
485* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
486- update modesetting driver to git snapshot from today
487
488* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
489- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
490
491* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
492- rebuilt for unwind info generation, broken in gcc-4.1.1-21
493
494* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
495- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
496  actually require kudzu to run.
497
498* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
499- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
500
501* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
502- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
503- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
504  driver match the corresponding terrible heuristic in the server.
505
506* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
507- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
508  correctly distinguish between Mac Mini and Macbook Pro.
509
510* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
511- i810.xinf: PCI IDs for i965.
512
513* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
514- i810.xinf: Uppercase PCI IDs.
515
516* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
517- Update i810 to 1.6.5, should fix DRI.
518- Add kuzdu requires.
519- i810.xinf: Start whitelisting devices over to intel.
520
521* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
522- intel-driver-rename.patch: Fix the driver name in more places so it'll,
523  you know, load.
524
525* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
526- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
527  LFP special casing in favor of the blacklist.
528
529* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
530- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
531  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
532  and is selected with Driver "intel" in xorg.conf.  Individual devices will
533  whitelist over to "intel" until that branch gets merged into head.
534- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
535- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
536  the BIOS is known to lie.
537
538* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
539- Today's snapshot: I2C bus creation fix.
540
541* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
542- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
543  clock when computing the modes list.
544- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
545  in centimeters as the size of the display in pixels.
546
547* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
548- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
549  probing.
550
551* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
552- Update again for a mode comparison bugfix.
553
554* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
555- Update to today's git; crash fixes, better pre-915 support, slightly better
556  autoconfigurability.
557
558* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
559- rebuild
560
561* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
562- Fix Revision number to match naming policy.
563
564* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
565- Add back modesetting changes.
566
567* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
568- Roll back modesetting changes and build for fc5 aiglx repo.
569
570* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
571- Snapshot of the git modesetting branch.
572
573* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
574- Update i810.xinf to include entries for E7221 and 945GM.
575
576* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
577- Add with_dri macro to spec file, and conditionalize build time DRI support
578
579* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
580- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
581  to pick up proto-devel as well.
582
583* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
584- Rebuild for 7.1 ABI fix.
585
586* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
587- Bump for fc5-bling build.
588
589* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
590- Update to 1.6.0 from 7.1RC1.
591
592* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
593- Add patch to add missing #include's, specifically assert.h.
594
595* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
596- Update to CVS snapshot of 20060322.
597
598* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
599- rebuilt for new gcc4.1 snapshot and glibc changes
600
601* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
602- Added 8086:2772 mapping to i810.xinf for bug (#178451)
603
604* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
605- Added 8086:2592 mapping to i810.xinf for bug (#172884)
606
607* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
608- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
609
610* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
611- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
612- Removed 'x' suffix from manpage dirs to match RC4 upstream.
613
614* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
615- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
616
617* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
618- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
619- Fix *.la file removal.
620- Added 'devel' subpackage for XvMC .so
621- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
622
623* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
624- Update BuildRoot to use Fedora Packaging Guidelines.
625- Deglob file manifest.
626- Limit "ExclusiveArch" to x86, x86_64, ia64
627
628* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
629- Initial spec file for i810 video driver generated automatically
630  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.