source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 8607

Revision 8607, 21.3 KB checked in by Takemikaduchi, 10 years ago (diff)

NEW: eudev
rtmpdump: add R: gmp-devel
gpac: remove Requires
others: rebuild with eudev

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8%define gputoolsdate 20130611
9%else
10%define accel sna
11%define gputoolsdate 20110817
12%endif
13
14Summary:   Xorg X11 Intel video driver
15Summary(ja):   Xorg X11 Intel ビデオドライバ
16Name:      xorg-x11-drv-intel
17Epoch:     1
18Version:   2.21.15
19Release:   3%{?_dist_release}
20URL:       http://intellinuxgraphics.org/
21License:   MIT
22Group:     User Interface/X Hardware Support
23
24Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
25Source2:   intel.xinf
26Source3:   intel-gpu-tools-%{gputoolsdate1}.tar.bz2
27Source4:   intel-gpu-tools-%{gputoolsdate2}.tar.bz2
28
29# vine patch
30
31
32ExclusiveArch: %{ix86} x86_64 ia64
33BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
34BuildRequires: autoconf, automake, libtool
35BuildRequires: xorg-x11-server-sdk >= 1.7.99
36BuildRequires: libXvMC-devel
37BuildRequires: libGL-devel >= 7.10
38BuildRequires: libdrm-devel >= 2.4.25
39BuildRequires: kernel-headers >= 2.6.33
40BuildRequires: eudev-libudev-devel
41BuildRequires: libxcb-devel >= 1.5
42BuildRequires: xcb-util-devel
43BuildRequires: cairo-devel
44
45Requires:  hwdata
46Requires:  xorg-x11-server-Xorg
47Requires:  xcb-util
48
49Obsoletes: xorg-x11-drv-i810
50Provides: xorg-x11-drv-i810
51
52#Conflicts:  kudzu < 1.2.42-1
53
54Vendor: Project Vine
55Distribution: Vine Linux
56Packager: daisuke
57
58%description
59X.Org X11 Intel video driver.
60
61%package devel
62Summary:   Xorg X11 Intel video driver XvMC development package
63Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
64Group:     Development/System
65Requires:  %{name} = %{epoch}:%{version}-%{release}
66Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
67
68%description devel
69X.Org X11 Intel video driver XvMC development package.
70
71%package -n intel-gpu-tools
72Summary:    Debugging tools for Intel graphics chips
73Group:      Development/Tools
74
75%description -n intel-gpu-tools
76Debugging tools for Intel graphics chips
77
78
79%prep
80%setup -q -n xf86-video-intel-%{version} -b3 -b4
81
82%build
83autoreconf -vi
84
85%if "%{?_dist_release}" < "vl7"
86export CFLAGS="-I/usr/include/X11/dri"
87%endif
88
89%configure \
90  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
91  --enable-dri --enable-xvmc \
92  --enable-sna --enable-uxa \
93  --with-default-accel=%{accel} \
94  --enable-xaa=no
95make
96
97pushd ../intel-gpu-tools-%{gputoolsdate}
98autoreconf -v --install
99%configure --disable-nouveau --disable-dumper
100make
101popd
102
103
104%install
105rm -rf $RPM_BUILD_ROOT
106
107make install DESTDIR=$RPM_BUILD_ROOT
108mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
109install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
110
111pushd ../intel-gpu-tools-%{gputoolsdate}
112make install DESTDIR=$RPM_BUILD_ROOT
113popd
114
115
116find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
117
118%clean
119rm -rf $RPM_BUILD_ROOT
120
121%triggerpostun -- XOrg < 7.0
122if (grep -q i810 /etc/X11/xorg.conf)
123then
124  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
125  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
126fi ||:
127
128%files
129%defattr(-,root,root,-)
130%{driverdir}/intel_drv.so
131%{_datadir}/hwdata/videoaliases/intel.xinf
132%{_libdir}/libI810XvMC.so.*
133%{_libdir}/libIntelXvMC.so.*
134%{_mandir}/man4/i*
135
136%files devel
137%defattr(-,root,root,-)
138%{_libdir}/libI810XvMC.so
139%{_libdir}/libIntelXvMC.so
140
141%files -n intel-gpu-tools
142%defattr(-,root,root,-)
143%{_bindir}/*
144%{_mandir}/man1/intel_*.1*
145
146
147%changelog
148* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
149- change BuildRequires: eudev-libudev-devel instead of libudev-devel
150
151* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
152- rebuild with VineSeed environment
153
154* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
155- new upstream release
156
157* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
158- new upstream release
159- change default accel method to sna.
160
161* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
162- new upstream release
163
164* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
165- new upstream release
166
167* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
168- new upstream release
169
170* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
171- new upstream release
172
173* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
174- new upstream release
175
176* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
177- new upstream release
178
179* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
180- new upstream release
181
182* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
183- new upstream release
184
185* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
186- new upstream release
187
188* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
189- new upstream release
190
191* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
192- rebuild with xcb-util-0.3.9
193
194* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
195- disable sna, enable uxa
196
197* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
198- new upstream release
199
200* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
201- rebuild with xserver-1.12.0
202
203* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
204- new upstream release
205- enable sna
206
207* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
208- disable sna/vmap
209
210* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
211- new upstram release
212- disable copy-fb patch
213
214* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
215- rebuild with xserver-1.11.1.902
216
217* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
218- add --enable-sna --enable-vmap
219
220* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
221- new upstream release
222
223* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
224- rebuild with xcb-util-0.3.8
225- drop Patch200
226
227* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
228- update to disable copy_fb on sandybridge/ivybridge
229
230* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
231- update intel.xinf
232- add patch10 from fedora
233  - Clamp VGA pixel clock to 250MHz,
234    anything higher's going to look awful anyway. (#559426)
235
236* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
237- drop patch1-3 and replaced with new patch1 from git master
238- add Patch200 to disable DRI on SandyBridge/IvyBridge
239- update intel-gpu-tools
240
241* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
242- add Patch1-3 from upstream
243
244* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
245- new upstream release
246- drop upstream patches: 107-115
247- temporary disabled patch101
248- BR: libdrm >= 2.4.25
249
250* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
251- add Patch101-115 from ubuntu/debian package
252  - Patch101: Plymouth integration patch
253  - Patch107: Check null return from uxa_acquire_solid()
254  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
255  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
256  - Patch110,114: Cherry picks to fix a large number of build warnings.
257  - Patch111: Fix clipped window plane offset
258  - Patch112: Fix issue where vertical green line and strange colors
259              shows up when playing gstreamer with certain videos,
260              when dragged.  (LP 460677)
261  - Patch113: Fixes GPU lockup during login with
262              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
263              error messages listed in the gpu dump text. (LP 710321)
264  - Patch115: Don't fill up Xorg.0.log with
265              "get vblank counter failed: Invalid argument" warnings.
266   
267* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
268- rebuild with xserver-1.10.0
269
270* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
271- new upstream release
272
273* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
274- new upstream release
275
276* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
277- rebuild with xserver-1.9.2
278
279* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
280- new upstream release
281- add Patch40: fix uxa planemask (backported)
282- add Patch61: add support for backlight on macbooks
283- add Patch62: disable page flipping for stability
284
285* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
286- new upstream release
287- drop patch70
288
289* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
290- rebuild again with xserver-1.8rc
291
292* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
293- add intel-gpu-tools as sub-package
294- rebuild with libdrm-2.4.18
295
296* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
297- new upstream release
298- import Patch1,2,60,70 from fedora
299- add BR: kernel-headers >= 2.6.33 (new drm header required)
300- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
301- add BR; libudev-devel and autoreconf for Patch60
302
303* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
304- rebuild with libdrm-2.4.17
305
306* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
307- new upstream release
308
309* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
310- new upstream release (hopefully fixes severe issues w/ efifb)
311- drop all patches already upstreamed; import Patch20/21 from Fedora
312
313* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
314- import Patch121,122 from ubuntu
315- build with libdrm-2.4.12 which fixes vt switch crash
316
317* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
318- apply patch114 to fix Xv with non-GEM kernel
319
320* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
321- update to 2.6.3
322- add patch106,107,115,118,119,120 from ubuntu
323  - add Patch106: remove triple buffering
324  - add Patch107: remove page flipping
325  - add Patch115: fix crash Xv overlay
326  - add Patch118: drop legacy3d
327  - add Patch119: fix crashes in drm bo
328  - add Patch120: fix vt switch
329- add patch130-134 from upstream git
330  - add Patch130: fix another vt switch leak
331  - add Patch131: Create known output configuration at EnterVT time
332  - add Patch132: fix leak of some 965 render state on VT switch
333  - add Patch133: fix crash with fake bufmgr and UXA
334  - add Patch134: fix EnterVT/LeaveVT
335  - add Patch135: add new chip supoprt
336
337
338* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
339- revert to 2.6.1, add Epoch
340- add Patch103-121 from ubuntu
341
342* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
343- new upstream release
344
345* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
346- new upstream release
347
348* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
349- new upstream release
350
351* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
352- add Patch5 - Dont die on irq handler failure
353
354* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
355- new upstream release
356- add BR: libdrm-devel >= 2.4.0-3
357
358* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
359- import Patch10,11,12 from ubuntu
360
361* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
362- new upstream release
363- add triggerpostun script to replace i810 driver to intel driver
364
365* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
366- new upstream release
367
368* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
369- new upstream release
370- rename i810.xinf to intel.xinf
371- update intel.xinf (add Intel 4 series)
372
373* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
374- rebuild with new xserver
375
376* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
377- new upstream release
378
379* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
380- new upstream release
381
382* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
383- new upstream release
384
385* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
386- initial build for Vine Linux
387
388* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
389- Rebuild for new server ABI.
390- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
391
392* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
393- hook up ch7017 (bz#408471)
394
395* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
396- xf86-video-intel 2.2.0
397
398* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
399- xf86-video-intel 2.1.99.
400- Drop the i810 driver.  Time to move on.
401- Require xserver 1.4.99.1
402
403* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
404- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
405
406* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
407- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
408  for textured Xv to use as an offscreen pixmap so xv actually works under
409  compiz - granted it may be unusably slow but at least stuff shows up.
410
411* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
412- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
413- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
414
415* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
416- intel-2.1.1-quirk-update.patch - update quirks from master
417
418* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
419- i810.xinf: Flip everything over to -intel by default now.  Still install
420  i810 driver just in case.
421
422* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
423- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
424
425* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
426- xf86-video-intel 2.1.1.
427
428* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
429- xf86-video-intel 2.1.0.
430
431* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
432- Update Requires and BuildRequires.
433
434* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
435- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
436  965GME, G33, Q33, and Q35 chips.
437
438* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
439- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
440  DRI clients are active, for better battery life.
441
442* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
443- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
444
445* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
446- xf86-video-intel 2.0.0.  Change the version number to match, why not.
447- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
448  rename this at some point.
449
450* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
451- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
452  915GM.
453
454* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
455- i810.xinf: More intel whitelisting (#214011, #234877)
456
457* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
458- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
459- i810.xinf: Point 965GM support at the intel driver since it's not present
460  in old i810.
461
462* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
463- xf86-video-intel-1.9.93 (RC3).
464
465* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
466- fix typo with 945GM pci id from my laptop
467
468* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
469- xf86-video-intel 1.9.92 (RC2).
470
471* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
472- Updated modesetting driver to one that will actually work with a 1.3 server.
473
474* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
475- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
476- Remove ivch and ch7017 from the install since they aren't hooked up to the
477  code anywhere
478- Disown the module
479
480* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
481- update modesetting driver to git snapshot from today
482
483* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
484- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
485
486* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
487- rebuilt for unwind info generation, broken in gcc-4.1.1-21
488
489* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
490- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
491  actually require kudzu to run.
492
493* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
494- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
495
496* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
497- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
498- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
499  driver match the corresponding terrible heuristic in the server.
500
501* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
502- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
503  correctly distinguish between Mac Mini and Macbook Pro.
504
505* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
506- i810.xinf: PCI IDs for i965.
507
508* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
509- i810.xinf: Uppercase PCI IDs.
510
511* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
512- Update i810 to 1.6.5, should fix DRI.
513- Add kuzdu requires.
514- i810.xinf: Start whitelisting devices over to intel.
515
516* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
517- intel-driver-rename.patch: Fix the driver name in more places so it'll,
518  you know, load.
519
520* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
521- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
522  LFP special casing in favor of the blacklist.
523
524* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
525- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
526  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
527  and is selected with Driver "intel" in xorg.conf.  Individual devices will
528  whitelist over to "intel" until that branch gets merged into head.
529- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
530- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
531  the BIOS is known to lie.
532
533* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
534- Today's snapshot: I2C bus creation fix.
535
536* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
537- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
538  clock when computing the modes list.
539- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
540  in centimeters as the size of the display in pixels.
541
542* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
543- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
544  probing.
545
546* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
547- Update again for a mode comparison bugfix.
548
549* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
550- Update to today's git; crash fixes, better pre-915 support, slightly better
551  autoconfigurability.
552
553* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
554- rebuild
555
556* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
557- Fix Revision number to match naming policy.
558
559* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
560- Add back modesetting changes.
561
562* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
563- Roll back modesetting changes and build for fc5 aiglx repo.
564
565* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
566- Snapshot of the git modesetting branch.
567
568* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
569- Update i810.xinf to include entries for E7221 and 945GM.
570
571* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
572- Add with_dri macro to spec file, and conditionalize build time DRI support
573
574* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
575- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
576  to pick up proto-devel as well.
577
578* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
579- Rebuild for 7.1 ABI fix.
580
581* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
582- Bump for fc5-bling build.
583
584* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
585- Update to 1.6.0 from 7.1RC1.
586
587* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
588- Add patch to add missing #include's, specifically assert.h.
589
590* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
591- Update to CVS snapshot of 20060322.
592
593* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
594- rebuilt for new gcc4.1 snapshot and glibc changes
595
596* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
597- Added 8086:2772 mapping to i810.xinf for bug (#178451)
598
599* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
600- Added 8086:2592 mapping to i810.xinf for bug (#172884)
601
602* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
603- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
604
605* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
606- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
607- Removed 'x' suffix from manpage dirs to match RC4 upstream.
608
609* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
610- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
611
612* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
613- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
614- Fix *.la file removal.
615- Added 'devel' subpackage for XvMC .so
616- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
617
618* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
619- Update BuildRoot to use Fedora Packaging Guidelines.
620- Deglob file manifest.
621- Limit "ExclusiveArch" to x86, x86_64, ia64
622
623* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
624- Initial spec file for i810 video driver generated automatically
625  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.