source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 5203

Revision 5203, 19.4 KB checked in by daisuke, 12 years ago (diff)

xorg-x11-drv-intel: disable sna/vmap.

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20100625
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.17.0
10Release:   2%{?_dist_release}
11URL:       http://intellinuxgraphics.org/
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19# Clamp VGA pixel clock to 250MHz,
20# anything higher's going to look awful anyway. (#559426)
21Patch10: intel-2.11.0-vga-clock-max.patch
22
23# import from ubuntu/debian package
24Patch101: intel-2.15.0-copy-fb.patch
25
26# vine patch
27
28
29ExclusiveArch: %{ix86} x86_64 ia64
30BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
31BuildRequires: autoconf, automake, libtool
32BuildRequires: xorg-x11-server-sdk >= 1.7.99
33BuildRequires: libXvMC-devel
34BuildRequires: libGL-devel >= 7.10
35BuildRequires: libdrm-devel >= 2.4.25
36BuildRequires: kernel-headers >= 2.6.33
37BuildRequires: libudev-devel
38BuildRequires: libxcb-devel >= 1.5
39BuildRequires: xcb-util-devel
40
41Requires:  hwdata
42Requires:  xorg-x11-server-Xorg
43Requires:  xcb-util
44
45Obsoletes: xorg-x11-drv-i810
46Provides: xorg-x11-drv-i810
47
48#Conflicts:  kudzu < 1.2.42-1
49
50Vendor: Project Vine
51Distribution: Vine Linux
52
53%description
54X.Org X11 Intel video driver.
55
56%package devel
57Summary:   Xorg X11 Intel video driver XvMC development package
58Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
59Group:     Development/System
60Requires:  %{name} = %{epoch}:%{version}-%{release}
61Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
62
63%description devel
64X.Org X11 Intel video driver XvMC development package.
65
66%package -n intel-gpu-tools
67Summary:    Debugging tools for Intel graphics chips
68Group:      Development/Tools
69
70%description -n intel-gpu-tools
71Debugging tools for Intel graphics chips
72
73
74%prep
75%setup -q -n xf86-video-intel-%{version} -b3
76
77%patch10 -p1 -b .vga-clock
78
79#%patch101 -p1 -b .copy-fb
80
81%build
82autoreconf -vi
83
84%configure \
85  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
86  --enable-dri --enable-xvmc
87  # --enable-sna --enable-vmap
88make
89
90pushd ../intel-gpu-tools-%{gputoolsdate}
91autoreconf -v --install
92%configure
93make
94popd
95
96
97%install
98rm -rf $RPM_BUILD_ROOT
99
100make install DESTDIR=$RPM_BUILD_ROOT
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
102install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
103
104pushd ../intel-gpu-tools-%{gputoolsdate}
105make install DESTDIR=$RPM_BUILD_ROOT
106popd
107
108
109find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
110
111%clean
112rm -rf $RPM_BUILD_ROOT
113
114%triggerpostun -- XOrg < 7.0
115if (grep -q i810 /etc/X11/xorg.conf)
116then
117  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
118  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
119fi ||:
120
121%files
122%defattr(-,root,root,-)
123%{driverdir}/intel_drv.so
124%{_datadir}/hwdata/videoaliases/intel.xinf
125%{_libdir}/libI810XvMC.so.*
126%{_libdir}/libIntelXvMC.so.*
127%{_mandir}/man4/i*
128
129%files devel
130%defattr(-,root,root,-)
131%{_libdir}/libI810XvMC.so
132%{_libdir}/libIntelXvMC.so
133
134%files -n intel-gpu-tools
135%defattr(-,root,root,-)
136%{_bindir}/intel_*
137%{_mandir}/man1/intel_*.1*
138
139
140%changelog
141* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
142- disable sna/vmap
143
144* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
145- new upstram release
146- disable copy-fb patch
147
148* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
149- rebuild with xserver-1.11.1.902
150
151* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
152- add --enable-sna --enable-vmap
153
154* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
155- new upstream release
156
157* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
158- rebuild with xcb-util-0.3.8
159- drop Patch200
160
161* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
162- update to disable copy_fb on sandybridge/ivybridge
163
164* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
165- update intel.xinf
166- add patch10 from fedora
167  - Clamp VGA pixel clock to 250MHz,
168    anything higher's going to look awful anyway. (#559426)
169
170* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
171- drop patch1-3 and replaced with new patch1 from git master
172- add Patch200 to disable DRI on SandyBridge/IvyBridge
173- update intel-gpu-tools
174
175* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
176- add Patch1-3 from upstream
177
178* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
179- new upstream release
180- drop upstream patches: 107-115
181- temporary disabled patch101
182- BR: libdrm >= 2.4.25
183
184* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
185- add Patch101-115 from ubuntu/debian package
186  - Patch101: Plymouth integration patch
187  - Patch107: Check null return from uxa_acquire_solid()
188  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
189  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
190  - Patch110,114: Cherry picks to fix a large number of build warnings.
191  - Patch111: Fix clipped window plane offset
192  - Patch112: Fix issue where vertical green line and strange colors
193              shows up when playing gstreamer with certain videos,
194              when dragged.  (LP 460677)
195  - Patch113: Fixes GPU lockup during login with
196              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
197              error messages listed in the gpu dump text. (LP 710321)
198  - Patch115: Don't fill up Xorg.0.log with
199              "get vblank counter failed: Invalid argument" warnings.
200   
201* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
202- rebuild with xserver-1.10.0
203
204* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
205- new upstream release
206
207* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
208- new upstream release
209
210* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
211- rebuild with xserver-1.9.2
212
213* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
214- new upstream release
215- add Patch40: fix uxa planemask (backported)
216- add Patch61: add support for backlight on macbooks
217- add Patch62: disable page flipping for stability
218
219* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
220- new upstream release
221- drop patch70
222
223* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
224- rebuild again with xserver-1.8rc
225
226* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
227- add intel-gpu-tools as sub-package
228- rebuild with libdrm-2.4.18
229
230* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
231- new upstream release
232- import Patch1,2,60,70 from fedora
233- add BR: kernel-headers >= 2.6.33 (new drm header required)
234- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
235- add BR; libudev-devel and autoreconf for Patch60
236
237* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
238- rebuild with libdrm-2.4.17
239
240* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
241- new upstream release
242
243* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
244- new upstream release (hopefully fixes severe issues w/ efifb)
245- drop all patches already upstreamed; import Patch20/21 from Fedora
246
247* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
248- import Patch121,122 from ubuntu
249- build with libdrm-2.4.12 which fixes vt switch crash
250
251* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
252- apply patch114 to fix Xv with non-GEM kernel
253
254* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
255- update to 2.6.3
256- add patch106,107,115,118,119,120 from ubuntu
257  - add Patch106: remove triple buffering
258  - add Patch107: remove page flipping
259  - add Patch115: fix crash Xv overlay
260  - add Patch118: drop legacy3d
261  - add Patch119: fix crashes in drm bo
262  - add Patch120: fix vt switch
263- add patch130-134 from upstream git
264  - add Patch130: fix another vt switch leak
265  - add Patch131: Create known output configuration at EnterVT time
266  - add Patch132: fix leak of some 965 render state on VT switch
267  - add Patch133: fix crash with fake bufmgr and UXA
268  - add Patch134: fix EnterVT/LeaveVT
269  - add Patch135: add new chip supoprt
270
271
272* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
273- revert to 2.6.1, add Epoch
274- add Patch103-121 from ubuntu
275
276* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
277- new upstream release
278
279* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
280- new upstream release
281
282* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
283- new upstream release
284
285* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
286- add Patch5 - Dont die on irq handler failure
287
288* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
289- new upstream release
290- add BR: libdrm-devel >= 2.4.0-3
291
292* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
293- import Patch10,11,12 from ubuntu
294
295* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
296- new upstream release
297- add triggerpostun script to replace i810 driver to intel driver
298
299* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
300- new upstream release
301
302* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
303- new upstream release
304- rename i810.xinf to intel.xinf
305- update intel.xinf (add Intel 4 series)
306
307* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
308- rebuild with new xserver
309
310* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
311- new upstream release
312
313* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
314- new upstream release
315
316* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
317- new upstream release
318
319* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
320- initial build for Vine Linux
321
322* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
323- Rebuild for new server ABI.
324- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
325
326* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
327- hook up ch7017 (bz#408471)
328
329* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
330- xf86-video-intel 2.2.0
331
332* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
333- xf86-video-intel 2.1.99.
334- Drop the i810 driver.  Time to move on.
335- Require xserver 1.4.99.1
336
337* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
338- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
339
340* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
341- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
342  for textured Xv to use as an offscreen pixmap so xv actually works under
343  compiz - granted it may be unusably slow but at least stuff shows up.
344
345* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
346- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
347- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
348
349* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
350- intel-2.1.1-quirk-update.patch - update quirks from master
351
352* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
353- i810.xinf: Flip everything over to -intel by default now.  Still install
354  i810 driver just in case.
355
356* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
357- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
358
359* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
360- xf86-video-intel 2.1.1.
361
362* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
363- xf86-video-intel 2.1.0.
364
365* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
366- Update Requires and BuildRequires.
367
368* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
369- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
370  965GME, G33, Q33, and Q35 chips.
371
372* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
373- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
374  DRI clients are active, for better battery life.
375
376* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
377- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
378
379* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
380- xf86-video-intel 2.0.0.  Change the version number to match, why not.
381- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
382  rename this at some point.
383
384* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
385- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
386  915GM.
387
388* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
389- i810.xinf: More intel whitelisting (#214011, #234877)
390
391* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
392- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
393- i810.xinf: Point 965GM support at the intel driver since it's not present
394  in old i810.
395
396* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
397- xf86-video-intel-1.9.93 (RC3).
398
399* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
400- fix typo with 945GM pci id from my laptop
401
402* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
403- xf86-video-intel 1.9.92 (RC2).
404
405* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
406- Updated modesetting driver to one that will actually work with a 1.3 server.
407
408* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
409- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
410- Remove ivch and ch7017 from the install since they aren't hooked up to the
411  code anywhere
412- Disown the module
413
414* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
415- update modesetting driver to git snapshot from today
416
417* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
418- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
419
420* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
421- rebuilt for unwind info generation, broken in gcc-4.1.1-21
422
423* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
424- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
425  actually require kudzu to run.
426
427* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
428- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
429
430* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
431- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
432- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
433  driver match the corresponding terrible heuristic in the server.
434
435* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
436- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
437  correctly distinguish between Mac Mini and Macbook Pro.
438
439* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
440- i810.xinf: PCI IDs for i965.
441
442* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
443- i810.xinf: Uppercase PCI IDs.
444
445* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
446- Update i810 to 1.6.5, should fix DRI.
447- Add kuzdu requires.
448- i810.xinf: Start whitelisting devices over to intel.
449
450* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
451- intel-driver-rename.patch: Fix the driver name in more places so it'll,
452  you know, load.
453
454* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
455- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
456  LFP special casing in favor of the blacklist.
457
458* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
459- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
460  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
461  and is selected with Driver "intel" in xorg.conf.  Individual devices will
462  whitelist over to "intel" until that branch gets merged into head.
463- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
464- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
465  the BIOS is known to lie.
466
467* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
468- Today's snapshot: I2C bus creation fix.
469
470* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
471- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
472  clock when computing the modes list.
473- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
474  in centimeters as the size of the display in pixels.
475
476* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
477- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
478  probing.
479
480* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
481- Update again for a mode comparison bugfix.
482
483* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
484- Update to today's git; crash fixes, better pre-915 support, slightly better
485  autoconfigurability.
486
487* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
488- rebuild
489
490* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
491- Fix Revision number to match naming policy.
492
493* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
494- Add back modesetting changes.
495
496* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
497- Roll back modesetting changes and build for fc5 aiglx repo.
498
499* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
500- Snapshot of the git modesetting branch.
501
502* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
503- Update i810.xinf to include entries for E7221 and 945GM.
504
505* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
506- Add with_dri macro to spec file, and conditionalize build time DRI support
507
508* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
509- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
510  to pick up proto-devel as well.
511
512* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
513- Rebuild for 7.1 ABI fix.
514
515* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
516- Bump for fc5-bling build.
517
518* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
519- Update to 1.6.0 from 7.1RC1.
520
521* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
522- Add patch to add missing #include's, specifically assert.h.
523
524* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
525- Update to CVS snapshot of 20060322.
526
527* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
528- rebuilt for new gcc4.1 snapshot and glibc changes
529
530* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
531- Added 8086:2772 mapping to i810.xinf for bug (#178451)
532
533* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
534- Added 8086:2592 mapping to i810.xinf for bug (#172884)
535
536* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
537- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
538
539* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
540- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
541- Removed 'x' suffix from manpage dirs to match RC4 upstream.
542
543* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
544- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
545
546* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
547- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
548- Fix *.la file removal.
549- Added 'devel' subpackage for XvMC .so
550- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
551
552* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
553- Update BuildRoot to use Fedora Packaging Guidelines.
554- Deglob file manifest.
555- Limit "ExclusiveArch" to x86, x86_64, ia64
556
557* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
558- Initial spec file for i810 video driver generated automatically
559  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.