source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 2231

Revision 2231, 16.7 KB checked in by daisuke, 14 years ago (diff)

xorg-x11-drv-intel: udpate to 2.13.0

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.13.0
10Release:   1%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19#Patch1: kill-svideo.patch
20
21#Patch2: intel-2.11.0-copy-fb.patch
22
23# patches from fedora - needs to be upstreamed
24
25# backported
26
27ExclusiveArch: %{ix86} x86_64 ia64
28BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
29BuildRequires: autoconf, automake, libtool
30BuildRequires: xorg-x11-server-sdk >= 1.7.99
31BuildRequires: libXvMC-devel
32BuildRequires: mesa-libGL-devel
33BuildRequires: libdrm-devel >= 2.4.22
34BuildRequires: kernel-headers >= 2.6.33
35BuildRequires: libudev-devel
36BuildRequires: libxcb-devel >= 1.5
37BuildRequires: xcb-util-devel
38
39Requires:  hwdata
40Requires:  xorg-x11-server-Xorg
41Requires:  xcb-util
42
43Obsoletes: xorg-x11-drv-i810
44Provides: xorg-x11-drv-i810
45
46#Conflicts:  kudzu < 1.2.42-1
47
48%description
49X.Org X11 Intel video driver.
50
51%package devel
52Summary:   Xorg X11 Intel video driver XvMC development package
53Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
54Group:     Development/System
55Requires:  %{name} = %{epoch}:%{version}-%{release}
56Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
57
58%description devel
59X.Org X11 Intel video driver XvMC development package.
60
61%package -n intel-gpu-tools
62Summary:    Debugging tools for Intel graphics chips
63Group:      Development/Tools
64
65%description -n intel-gpu-tools
66Debugging tools for Intel graphics chips
67
68
69%prep
70%setup -q -n xf86-video-intel-%{version} -b3
71
72#%patch1 -p1 -b .svideo
73#patch2 -p1 -b .copy-fb
74
75%build
76autoreconf -vi
77
78%configure \
79  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
80  --enable-dri --enable-xvmc
81make
82
83pushd ../intel-gpu-tools-%{gputoolsdate}
84autoreconf -v --install
85%configure
86make
87popd
88
89
90%install
91rm -rf $RPM_BUILD_ROOT
92
93make install DESTDIR=$RPM_BUILD_ROOT
94mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
95install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
96
97pushd ../intel-gpu-tools-%{gputoolsdate}
98make install DESTDIR=$RPM_BUILD_ROOT
99popd
100
101
102find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
103
104%clean
105rm -rf $RPM_BUILD_ROOT
106
107%triggerpostun -- XOrg < 7.0
108if (grep -q i810 /etc/X11/xorg.conf)
109then
110  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
111  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
112fi ||:
113
114%files
115%defattr(-,root,root,-)
116%{driverdir}/intel_drv.so
117%{_datadir}/hwdata/videoaliases/intel.xinf
118%{_libdir}/libI810XvMC.so.*
119%{_libdir}/libIntelXvMC.so.*
120%{_mandir}/man4/i*
121
122%files devel
123%defattr(-,root,root,-)
124%{_libdir}/libI810XvMC.so
125%{_libdir}/libIntelXvMC.so
126
127%files -n intel-gpu-tools
128%defattr(-,root,root,-)
129%{_bindir}/intel_*
130%{_mandir}/man1/intel_*.1*
131
132
133%changelog
134* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
135- new upstream release
136
137* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
138- rebuild with xserver-1.9.2
139
140* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
141- new upstream release
142- add Patch40: fix uxa planemask (backported)
143- add Patch61: add support for backlight on macbooks
144- add Patch62: disable page flipping for stability
145
146* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
147- new upstream release
148- drop patch70
149
150* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
151- rebuild again with xserver-1.8rc
152
153* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
154- add intel-gpu-tools as sub-package
155- rebuild with libdrm-2.4.18
156
157* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
158- new upstream release
159- import Patch1,2,60,70 from fedora
160- add BR: kernel-headers >= 2.6.33 (new drm header required)
161- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
162- add BR; libudev-devel and autoreconf for Patch60
163
164* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
165- rebuild with libdrm-2.4.17
166
167* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
168- new upstream release
169
170* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
171- new upstream release (hopefully fixes severe issues w/ efifb)
172- drop all patches already upstreamed; import Patch20/21 from Fedora
173
174* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
175- import Patch121,122 from ubuntu
176- build with libdrm-2.4.12 which fixes vt switch crash
177
178* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
179- apply patch114 to fix Xv with non-GEM kernel
180
181* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
182- update to 2.6.3
183- add patch106,107,115,118,119,120 from ubuntu
184  - add Patch106: remove triple buffering
185  - add Patch107: remove page flipping
186  - add Patch115: fix crash Xv overlay
187  - add Patch118: drop legacy3d
188  - add Patch119: fix crashes in drm bo
189  - add Patch120: fix vt switch
190- add patch130-134 from upstream git
191  - add Patch130: fix another vt switch leak
192  - add Patch131: Create known output configuration at EnterVT time
193  - add Patch132: fix leak of some 965 render state on VT switch
194  - add Patch133: fix crash with fake bufmgr and UXA
195  - add Patch134: fix EnterVT/LeaveVT
196  - add Patch135: add new chip supoprt
197
198
199* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
200- revert to 2.6.1, add Epoch
201- add Patch103-121 from ubuntu
202
203* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
204- new upstream release
205
206* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
207- new upstream release
208
209* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
210- new upstream release
211
212* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
213- add Patch5 - Dont die on irq handler failure
214
215* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
216- new upstream release
217- add BR: libdrm-devel >= 2.4.0-3
218
219* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
220- import Patch10,11,12 from ubuntu
221
222* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
223- new upstream release
224- add triggerpostun script to replace i810 driver to intel driver
225
226* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
227- new upstream release
228
229* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
230- new upstream release
231- rename i810.xinf to intel.xinf
232- update intel.xinf (add Intel 4 series)
233
234* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
235- rebuild with new xserver
236
237* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
238- new upstream release
239
240* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
241- new upstream release
242
243* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
244- new upstream release
245
246* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
247- initial build for Vine Linux
248
249* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
250- Rebuild for new server ABI.
251- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
252
253* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
254- hook up ch7017 (bz#408471)
255
256* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
257- xf86-video-intel 2.2.0
258
259* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
260- xf86-video-intel 2.1.99.
261- Drop the i810 driver.  Time to move on.
262- Require xserver 1.4.99.1
263
264* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
265- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
266
267* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
268- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
269  for textured Xv to use as an offscreen pixmap so xv actually works under
270  compiz - granted it may be unusably slow but at least stuff shows up.
271
272* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
273- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
274- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
275
276* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
277- intel-2.1.1-quirk-update.patch - update quirks from master
278
279* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
280- i810.xinf: Flip everything over to -intel by default now.  Still install
281  i810 driver just in case.
282
283* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
284- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
285
286* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
287- xf86-video-intel 2.1.1.
288
289* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
290- xf86-video-intel 2.1.0.
291
292* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
293- Update Requires and BuildRequires.
294
295* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
296- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
297  965GME, G33, Q33, and Q35 chips.
298
299* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
300- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
301  DRI clients are active, for better battery life.
302
303* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
304- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
305
306* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
307- xf86-video-intel 2.0.0.  Change the version number to match, why not.
308- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
309  rename this at some point.
310
311* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
312- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
313  915GM.
314
315* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
316- i810.xinf: More intel whitelisting (#214011, #234877)
317
318* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
319- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
320- i810.xinf: Point 965GM support at the intel driver since it's not present
321  in old i810.
322
323* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
324- xf86-video-intel-1.9.93 (RC3).
325
326* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
327- fix typo with 945GM pci id from my laptop
328
329* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
330- xf86-video-intel 1.9.92 (RC2).
331
332* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
333- Updated modesetting driver to one that will actually work with a 1.3 server.
334
335* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
336- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
337- Remove ivch and ch7017 from the install since they aren't hooked up to the
338  code anywhere
339- Disown the module
340
341* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
342- update modesetting driver to git snapshot from today
343
344* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
345- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
346
347* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
348- rebuilt for unwind info generation, broken in gcc-4.1.1-21
349
350* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
351- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
352  actually require kudzu to run.
353
354* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
355- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
356
357* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
358- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
359- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
360  driver match the corresponding terrible heuristic in the server.
361
362* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
363- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
364  correctly distinguish between Mac Mini and Macbook Pro.
365
366* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
367- i810.xinf: PCI IDs for i965.
368
369* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
370- i810.xinf: Uppercase PCI IDs.
371
372* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
373- Update i810 to 1.6.5, should fix DRI.
374- Add kuzdu requires.
375- i810.xinf: Start whitelisting devices over to intel.
376
377* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
378- intel-driver-rename.patch: Fix the driver name in more places so it'll,
379  you know, load.
380
381* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
382- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
383  LFP special casing in favor of the blacklist.
384
385* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
386- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
387  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
388  and is selected with Driver "intel" in xorg.conf.  Individual devices will
389  whitelist over to "intel" until that branch gets merged into head.
390- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
391- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
392  the BIOS is known to lie.
393
394* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
395- Today's snapshot: I2C bus creation fix.
396
397* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
398- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
399  clock when computing the modes list.
400- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
401  in centimeters as the size of the display in pixels.
402
403* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
404- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
405  probing.
406
407* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
408- Update again for a mode comparison bugfix.
409
410* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
411- Update to today's git; crash fixes, better pre-915 support, slightly better
412  autoconfigurability.
413
414* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
415- rebuild
416
417* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
418- Fix Revision number to match naming policy.
419
420* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
421- Add back modesetting changes.
422
423* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
424- Roll back modesetting changes and build for fc5 aiglx repo.
425
426* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
427- Snapshot of the git modesetting branch.
428
429* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
430- Update i810.xinf to include entries for E7221 and 945GM.
431
432* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
433- Add with_dri macro to spec file, and conditionalize build time DRI support
434
435* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
436- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
437  to pick up proto-devel as well.
438
439* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
440- Rebuild for 7.1 ABI fix.
441
442* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
443- Bump for fc5-bling build.
444
445* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
446- Update to 1.6.0 from 7.1RC1.
447
448* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
449- Add patch to add missing #include's, specifically assert.h.
450
451* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
452- Update to CVS snapshot of 20060322.
453
454* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
455- rebuilt for new gcc4.1 snapshot and glibc changes
456
457* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
458- Added 8086:2772 mapping to i810.xinf for bug (#178451)
459
460* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
461- Added 8086:2592 mapping to i810.xinf for bug (#172884)
462
463* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
464- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
465
466* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
467- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
468- Removed 'x' suffix from manpage dirs to match RC4 upstream.
469
470* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
471- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
472
473* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
474- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
475- Fix *.la file removal.
476- Added 'devel' subpackage for XvMC .so
477- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
478
479* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
480- Update BuildRoot to use Fedora Packaging Guidelines.
481- Deglob file manifest.
482- Limit "ExclusiveArch" to x86, x86_64, ia64
483
484* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
485- Initial spec file for i810 video driver generated automatically
486  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.