source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 2203

Revision 2203, 17.1 KB checked in by Takemikaduchi, 14 years ago (diff)

update Xorg libraries and xserver, and rebuild driver

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate 20090908
4
5Summary:   Xorg X11 Intel video driver
6Summary(ja):   Xorg X11 Intel ビデオドライバ
7Name:      xorg-x11-drv-intel
8Epoch:     1
9Version:   2.12.0
10Release:   2%{?_dist_release}
11URL:       http://www.x.org
12License:   MIT
13Group:     User Interface/X Hardware Support
14
15Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
16Source2:   intel.xinf
17Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
18
19Patch1: kill-svideo.patch
20
21#Patch2: intel-2.11.0-copy-fb.patch
22
23# patches from fedora - needs to be upstreamed
24Patch20: intel-2.8.0-kms-get-crtc.patch
25Patch30: intel-2.11.0-lvds-first.patch
26
27# backported
28Patch40: intel-2.12-fix-uxa-planemask.patch
29
30Patch60: uevent.patch
31
32# https://bugs.freedesktop.org/show_bug.cgi?id=27885
33Patch61: intel-2.10.0-add-mbp-backlight.patch
34
35# https://bugzilla.redhat.com/588421
36Patch62: intel-2.11-no-pageflipping.patch
37
38ExclusiveArch: %{ix86} x86_64 ia64
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake, libtool
41BuildRequires: xorg-x11-server-sdk >= 1.7.99
42BuildRequires: libXvMC-devel
43BuildRequires: mesa-libGL-devel
44BuildRequires: libdrm-devel >= 2.4.16
45BuildRequires: kernel-headers >= 2.6.33
46BuildRequires: libudev-devel
47BuildRequires: libxcb-devel >= 1.5
48BuildRequires: xcb-util-devel
49
50Requires:  hwdata
51Requires:  xorg-x11-server-Xorg
52Requires:  xcb-util
53
54Obsoletes: xorg-x11-drv-i810
55Provides: xorg-x11-drv-i810
56
57#Conflicts:  kudzu < 1.2.42-1
58
59%description
60X.Org X11 Intel video driver.
61
62%package devel
63Summary:   Xorg X11 Intel video driver XvMC development package
64Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
65Group:     Development/System
66Requires:  %{name} = %{epoch}:%{version}-%{release}
67Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
68
69%description devel
70X.Org X11 Intel video driver XvMC development package.
71
72%package -n intel-gpu-tools
73Summary:    Debugging tools for Intel graphics chips
74Group:      Development/Tools
75
76%description -n intel-gpu-tools
77Debugging tools for Intel graphics chips
78
79
80%prep
81%setup -q -n xf86-video-intel-%{version} -b3
82
83%patch1 -p1 -b .svideo
84#patch2 -p1 -b .copy-fb
85%patch20 -p1 -b .get-crtc
86%patch30 -p1 -b .lvds-first
87%patch40 -p1 -b .fix-uxa-planepask
88%patch60 -p1 -b .uevent
89%patch61 -p1 -b .add-mbp-backlight
90%patch62 -p1 -b .no-pageflipping
91
92%build
93autoreconf -vi
94
95%configure \
96  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
97  --enable-dri --enable-xvmc
98make
99
100pushd ../intel-gpu-tools-%{gputoolsdate}
101autoreconf -v --install
102%configure
103make
104popd
105
106
107%install
108rm -rf $RPM_BUILD_ROOT
109
110make install DESTDIR=$RPM_BUILD_ROOT
111mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
112install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
113
114pushd ../intel-gpu-tools-%{gputoolsdate}
115make install DESTDIR=$RPM_BUILD_ROOT
116popd
117
118
119find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
120
121%clean
122rm -rf $RPM_BUILD_ROOT
123
124%triggerpostun -- XOrg < 7.0
125if (grep -q i810 /etc/X11/xorg.conf)
126then
127  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
128  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
129fi ||:
130
131%files
132%defattr(-,root,root,-)
133%{driverdir}/intel_drv.so
134%{_datadir}/hwdata/videoaliases/intel.xinf
135%{_libdir}/libI810XvMC.so.*
136%{_libdir}/libIntelXvMC.so.*
137%{_mandir}/man4/i*
138
139%files devel
140%defattr(-,root,root,-)
141%{_libdir}/libI810XvMC.so
142%{_libdir}/libIntelXvMC.so
143
144%files -n intel-gpu-tools
145%defattr(-,root,root,-)
146%{_bindir}/intel_*
147%{_mandir}/man1/intel_*.1*
148
149
150%changelog
151* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
152- rebuild with xserver-1.9.2
153
154* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
155- new upstream release
156- add Patch40: fix uxa planemask (backported)
157- add Patch61: add support for backlight on macbooks
158- add Patch62: disable page flipping for stability
159
160* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
161- new upstream release
162- drop patch70
163
164* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
165- rebuild again with xserver-1.8rc
166
167* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
168- add intel-gpu-tools as sub-package
169- rebuild with libdrm-2.4.18
170
171* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
172- new upstream release
173- import Patch1,2,60,70 from fedora
174- add BR: kernel-headers >= 2.6.33 (new drm header required)
175- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
176- add BR; libudev-devel and autoreconf for Patch60
177
178* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
179- rebuild with libdrm-2.4.17
180
181* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
182- new upstream release
183
184* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
185- new upstream release (hopefully fixes severe issues w/ efifb)
186- drop all patches already upstreamed; import Patch20/21 from Fedora
187
188* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
189- import Patch121,122 from ubuntu
190- build with libdrm-2.4.12 which fixes vt switch crash
191
192* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
193- apply patch114 to fix Xv with non-GEM kernel
194
195* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
196- update to 2.6.3
197- add patch106,107,115,118,119,120 from ubuntu
198  - add Patch106: remove triple buffering
199  - add Patch107: remove page flipping
200  - add Patch115: fix crash Xv overlay
201  - add Patch118: drop legacy3d
202  - add Patch119: fix crashes in drm bo
203  - add Patch120: fix vt switch
204- add patch130-134 from upstream git
205  - add Patch130: fix another vt switch leak
206  - add Patch131: Create known output configuration at EnterVT time
207  - add Patch132: fix leak of some 965 render state on VT switch
208  - add Patch133: fix crash with fake bufmgr and UXA
209  - add Patch134: fix EnterVT/LeaveVT
210  - add Patch135: add new chip supoprt
211
212
213* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
214- revert to 2.6.1, add Epoch
215- add Patch103-121 from ubuntu
216
217* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
218- new upstream release
219
220* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
221- new upstream release
222
223* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
224- new upstream release
225
226* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
227- add Patch5 - Dont die on irq handler failure
228
229* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
230- new upstream release
231- add BR: libdrm-devel >= 2.4.0-3
232
233* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
234- import Patch10,11,12 from ubuntu
235
236* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
237- new upstream release
238- add triggerpostun script to replace i810 driver to intel driver
239
240* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
241- new upstream release
242
243* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
244- new upstream release
245- rename i810.xinf to intel.xinf
246- update intel.xinf (add Intel 4 series)
247
248* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
249- rebuild with new xserver
250
251* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
252- new upstream release
253
254* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
255- new upstream release
256
257* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
258- new upstream release
259
260* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
261- initial build for Vine Linux
262
263* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
264- Rebuild for new server ABI.
265- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
266
267* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
268- hook up ch7017 (bz#408471)
269
270* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
271- xf86-video-intel 2.2.0
272
273* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
274- xf86-video-intel 2.1.99.
275- Drop the i810 driver.  Time to move on.
276- Require xserver 1.4.99.1
277
278* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
279- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
280
281* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
282- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
283  for textured Xv to use as an offscreen pixmap so xv actually works under
284  compiz - granted it may be unusably slow but at least stuff shows up.
285
286* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
287- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
288- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
289
290* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
291- intel-2.1.1-quirk-update.patch - update quirks from master
292
293* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
294- i810.xinf: Flip everything over to -intel by default now.  Still install
295  i810 driver just in case.
296
297* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
298- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
299
300* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
301- xf86-video-intel 2.1.1.
302
303* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
304- xf86-video-intel 2.1.0.
305
306* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
307- Update Requires and BuildRequires.
308
309* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
310- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
311  965GME, G33, Q33, and Q35 chips.
312
313* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
314- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
315  DRI clients are active, for better battery life.
316
317* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
318- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
319
320* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
321- xf86-video-intel 2.0.0.  Change the version number to match, why not.
322- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
323  rename this at some point.
324
325* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
326- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
327  915GM.
328
329* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
330- i810.xinf: More intel whitelisting (#214011, #234877)
331
332* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
333- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
334- i810.xinf: Point 965GM support at the intel driver since it's not present
335  in old i810.
336
337* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
338- xf86-video-intel-1.9.93 (RC3).
339
340* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
341- fix typo with 945GM pci id from my laptop
342
343* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
344- xf86-video-intel 1.9.92 (RC2).
345
346* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
347- Updated modesetting driver to one that will actually work with a 1.3 server.
348
349* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
350- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
351- Remove ivch and ch7017 from the install since they aren't hooked up to the
352  code anywhere
353- Disown the module
354
355* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
356- update modesetting driver to git snapshot from today
357
358* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
359- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
360
361* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
362- rebuilt for unwind info generation, broken in gcc-4.1.1-21
363
364* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
365- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
366  actually require kudzu to run.
367
368* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
369- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
370
371* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
372- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
373- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
374  driver match the corresponding terrible heuristic in the server.
375
376* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
377- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
378  correctly distinguish between Mac Mini and Macbook Pro.
379
380* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
381- i810.xinf: PCI IDs for i965.
382
383* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
384- i810.xinf: Uppercase PCI IDs.
385
386* Fri Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
387- Update i810 to 1.6.5, should fix DRI.
388- Add kuzdu requires.
389- i810.xinf: Start whitelisting devices over to intel.
390
391* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
392- intel-driver-rename.patch: Fix the driver name in more places so it'll,
393  you know, load.
394
395* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
396- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
397  LFP special casing in favor of the blacklist.
398
399* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
400- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
401  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
402  and is selected with Driver "intel" in xorg.conf.  Individual devices will
403  whitelist over to "intel" until that branch gets merged into head.
404- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
405- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
406  the BIOS is known to lie.
407
408* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
409- Today's snapshot: I2C bus creation fix.
410
411* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
412- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
413  clock when computing the modes list.
414- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
415  in centimeters as the size of the display in pixels.
416
417* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
418- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
419  probing.
420
421* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
422- Update again for a mode comparison bugfix.
423
424* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
425- Update to today's git; crash fixes, better pre-915 support, slightly better
426  autoconfigurability.
427
428* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
429- rebuild
430
431* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
432- Fix Revision number to match naming policy.
433
434* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
435- Add back modesetting changes.
436
437* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
438- Roll back modesetting changes and build for fc5 aiglx repo.
439
440* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
441- Snapshot of the git modesetting branch.
442
443* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
444- Update i810.xinf to include entries for E7221 and 945GM.
445
446* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
447- Add with_dri macro to spec file, and conditionalize build time DRI support
448
449* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
450- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
451  to pick up proto-devel as well.
452
453* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
454- Rebuild for 7.1 ABI fix.
455
456* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
457- Bump for fc5-bling build.
458
459* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
460- Update to 1.6.0 from 7.1RC1.
461
462* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
463- Add patch to add missing #include's, specifically assert.h.
464
465* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
466- Update to CVS snapshot of 20060322.
467
468* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
469- rebuilt for new gcc4.1 snapshot and glibc changes
470
471* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
472- Added 8086:2772 mapping to i810.xinf for bug (#178451)
473
474* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
475- Added 8086:2592 mapping to i810.xinf for bug (#172884)
476
477* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
478- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
479
480* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
481- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
482- Removed 'x' suffix from manpage dirs to match RC4 upstream.
483
484* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
485- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
486
487* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
488- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
489- Fix *.la file removal.
490- Added 'devel' subpackage for XvMC .so
491- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
492
493* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
494- Update BuildRoot to use Fedora Packaging Guidelines.
495- Deglob file manifest.
496- Limit "ExclusiveArch" to x86, x86_64, ia64
497
498* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
499- Initial spec file for i810 video driver generated automatically
500  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.