source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 11500

Revision 11500, 23.8 KB checked in by tomop, 6 years ago (diff)

xorg-x11-drv-intel-2.99.917-5.20180218

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3
4%define gitdate 20180218
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8%define gputoolsdate 20180218
9%else
10%define accel sna
11%define gputoolsdate 20110817
12%endif
13
14Summary:   Xorg X11 Intel video driver
15Summary(ja):   Xorg X11 Intel ビデオドライバ
16Name:      xorg-x11-drv-intel
17Epoch:     1
18Version:   2.99.917
19Release:   5.%{gitdate}%{?_dist_release}
20URL:       http://intellinuxgraphics.org/
21License:   MIT
22Group:     User Interface/X Hardware Support
23
24#Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
25Source0:   xf86-video-intel-%{gitdate}.tar.bz2
26Source2:   intel.xinf
27Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
28
29Patch0:     intel-gcc-pr65873.patch
30Patch1:     igt-stat.patch
31# https://bugs.freedesktop.org/show_bug.cgi?id=96255#c11
32Patch4:     0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
33
34ExclusiveArch: %{ix86} x86_64 ia64
35BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
36BuildRequires: autoconf, automake, libtool
37BuildRequires: xorg-x11-server-sdk >= 1.7.99
38BuildRequires: libXvMC-devel
39BuildRequires: libXfont2-devel
40BuildRequires: libXrandr-devel
41BuildRequires: libXcursor-devel
42BuildRequires: libXScrnSaver-devel
43BuildRequires: libXdamage-devel
44BuildRequires: libXfixes-devel
45BuildRequires: libXtst-devel
46BuildRequires: libXext-devel
47BuildRequires: libXrender-devel
48BuildRequires: pixman-devel
49BuildRequires: libGL-devel >= 7.10
50BuildRequires: libdrm-devel >= 2.4.25
51BuildRequires: kernel-headers >= 2.6.33
52BuildRequires: eudev-libudev-devel
53BuildRequires: libxcb-devel >= 1.5
54BuildRequires: xcb-util-devel
55BuildRequires: cairo-devel
56BuildRequires: kmod-devel
57BuildRequires: procps-devel
58BuildRequires: libunwind-devel
59
60# for only autoreconf
61BuildRequires: gtk-doc
62
63Requires:  hwdata
64Requires:  xorg-x11-server-Xorg
65Requires:  xcb-util
66
67Obsoletes: xorg-x11-drv-i810
68Provides: xorg-x11-drv-i810
69
70#Conflicts:  kudzu < 1.2.42-1
71
72Vendor: Project Vine
73Distribution: Vine Linux
74Packager: daisuke
75
76%description
77X.Org X11 Intel video driver.
78
79%package devel
80Summary:   Xorg X11 Intel video driver XvMC development package
81Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
82Group:     Development/System
83Requires:  %{name} = %{epoch}:%{version}-%{release}
84Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
85
86%description devel
87X.Org X11 Intel video driver XvMC development package.
88
89%package -n intel-gpu-tools
90Summary:    Debugging tools for Intel graphics chips
91Group:      Development/Tools
92
93%description -n intel-gpu-tools
94Debugging tools for Intel graphics chips
95
96
97%prep
98%setup -q -n xf86-video-intel-%{gitdate} -b3
99
100%patch0 -p1 -b .gcc
101%patch4 -p1
102
103pushd ../intel-gpu-tools-%{gputoolsdate}
104%patch1 -p1 -b .stat
105touch lib/check-ndebug.h
106popd
107
108%build
109autoreconf -vi
110
111%if "%{?_dist_release}" < "vl7"
112export CFLAGS="-I/usr/include/X11/dri"
113%endif
114
115%configure \
116  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
117  --enable-tools \
118  --enable-dri --enable-xvmc \
119  --enable-sna --enable-uxa \
120  --with-default-accel=%{accel} \
121  --enable-xaa=no
122
123make %{_smp_mflags} V=1
124
125pushd ../intel-gpu-tools-%{gputoolsdate}
126mkdir -p m4
127cp /usr/share/gtk-doc/data/gtk-doc.make ./
128autoreconf -f -i -v
129%configure \
130        --disable-nouveau \
131        --disable-dumper \
132        --disable-gtkdoc
133
134export LANG=en_US.UTF-8
135make %{_smp_mflags} V=1
136popd
137
138
139%install
140rm -rf $RPM_BUILD_ROOT
141
142make install DESTDIR=$RPM_BUILD_ROOT
143mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
144install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
145
146pushd ../intel-gpu-tools-%{gputoolsdate}
147make install DESTDIR=$RPM_BUILD_ROOT
148popd
149
150rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
151
152find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
153
154
155%clean
156rm -rf $RPM_BUILD_ROOT
157
158%triggerpostun -- XOrg < 7.0
159if (grep -q i810 /etc/X11/xorg.conf)
160then
161  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
162  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
163fi ||:
164
165%files
166%defattr(-,root,root,-)
167%{driverdir}/intel_drv.so
168%{_datadir}/hwdata/videoaliases/intel.xinf
169%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
170%{_libdir}/libI810XvMC.so.*
171%{_libdir}/libIntelXvMC.so.*
172%{_libexecdir}/xf86-video-intel-backlight-helper
173%{_mandir}/man4/i*
174
175%files devel
176%defattr(-,root,root,-)
177%{_libdir}/libI810XvMC.so
178%{_libdir}/libIntelXvMC.so
179
180%files -n intel-gpu-tools
181%defattr(-,root,root,-)
182%{_bindir}/*
183%{_libdir}/intel_aubdump.so
184%{_libexecdir}/intel-gpu-tools/
185%{_datadir}/intel-gpu-tools/
186#{_mandir}/man1/intel_*.1*
187
188
189%changelog
190* Sun Feb 18 2018 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 2.99.917-5.20180218
191- updated Source0 and Source3 to git HEAD(2018-02-18).
192
193* Fri Feb 16 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.99.917-4
194- rebuild with xorg 1.19.6
195- update patch0 (based on fc28)
196- add patch10 (from fc28)
197
198* Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-3
199- update Source3 (intel-gpu-tools-1.14.tar.bz2)
200- update Patch0 (xf86-video-intel-2.99.917-git20160430.patch)
201- add BuildRequires: libXfont-devel
202
203* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
204- update Source3 (intel-gpu-tools-1.12.tar.bz2)
205- update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
206- remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
207- remove Source4 (intel-gpu-tools-20110817.tar.bz2)
208
209* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
210- update to 2.99.917
211- update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
212- update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
213- update Source3 (intel-gpu-tools-1.10.tar.bz2)
214
215* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
216- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
217- update Source3 (intel-gpu-tools-1.8.tar.bz2)
218
219* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
220- update to 2.99.916
221
222* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
223- update to 2.99.912
224
225* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
226- change BuildRequires: eudev-libudev-devel instead of libudev-devel
227
228* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
229- rebuild with VineSeed environment
230
231* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
232- new upstream release
233
234* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
235- new upstream release
236- change default accel method to sna.
237
238* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
239- new upstream release
240
241* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
242- new upstream release
243
244* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
245- new upstream release
246
247* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
248- new upstream release
249
250* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
251- new upstream release
252
253* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
254- new upstream release
255
256* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
257- new upstream release
258
259* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
260- new upstream release
261
262* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
263- new upstream release
264
265* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
266- new upstream release
267
268* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
269- rebuild with xcb-util-0.3.9
270
271* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
272- disable sna, enable uxa
273
274* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
275- new upstream release
276
277* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
278- rebuild with xserver-1.12.0
279
280* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
281- new upstream release
282- enable sna
283
284* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
285- disable sna/vmap
286
287* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
288- new upstram release
289- disable copy-fb patch
290
291* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
292- rebuild with xserver-1.11.1.902
293
294* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
295- add --enable-sna --enable-vmap
296
297* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
298- new upstream release
299
300* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
301- rebuild with xcb-util-0.3.8
302- drop Patch200
303
304* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
305- update to disable copy_fb on sandybridge/ivybridge
306
307* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
308- update intel.xinf
309- add patch10 from fedora
310  - Clamp VGA pixel clock to 250MHz,
311    anything higher's going to look awful anyway. (#559426)
312
313* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
314- drop patch1-3 and replaced with new patch1 from git master
315- add Patch200 to disable DRI on SandyBridge/IvyBridge
316- update intel-gpu-tools
317
318* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
319- add Patch1-3 from upstream
320
321* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
322- new upstream release
323- drop upstream patches: 107-115
324- temporary disabled patch101
325- BR: libdrm >= 2.4.25
326
327* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
328- add Patch101-115 from ubuntu/debian package
329  - Patch101: Plymouth integration patch
330  - Patch107: Check null return from uxa_acquire_solid()
331  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
332  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
333  - Patch110,114: Cherry picks to fix a large number of build warnings.
334  - Patch111: Fix clipped window plane offset
335  - Patch112: Fix issue where vertical green line and strange colors
336              shows up when playing gstreamer with certain videos,
337              when dragged.  (LP 460677)
338  - Patch113: Fixes GPU lockup during login with
339              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
340              error messages listed in the gpu dump text. (LP 710321)
341  - Patch115: Don't fill up Xorg.0.log with
342              "get vblank counter failed: Invalid argument" warnings.
343   
344* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
345- rebuild with xserver-1.10.0
346
347* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
348- new upstream release
349
350* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
351- new upstream release
352
353* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
354- rebuild with xserver-1.9.2
355
356* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
357- new upstream release
358- add Patch40: fix uxa planemask (backported)
359- add Patch61: add support for backlight on macbooks
360- add Patch62: disable page flipping for stability
361
362* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
363- new upstream release
364- drop patch70
365
366* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
367- rebuild again with xserver-1.8rc
368
369* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
370- add intel-gpu-tools as sub-package
371- rebuild with libdrm-2.4.18
372
373* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
374- new upstream release
375- import Patch1,2,60,70 from fedora
376- add BR: kernel-headers >= 2.6.33 (new drm header required)
377- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
378- add BR; libudev-devel and autoreconf for Patch60
379
380* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
381- rebuild with libdrm-2.4.17
382
383* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
384- new upstream release
385
386* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
387- new upstream release (hopefully fixes severe issues w/ efifb)
388- drop all patches already upstreamed; import Patch20/21 from Fedora
389
390* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
391- import Patch121,122 from ubuntu
392- build with libdrm-2.4.12 which fixes vt switch crash
393
394* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
395- apply patch114 to fix Xv with non-GEM kernel
396
397* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
398- update to 2.6.3
399- add patch106,107,115,118,119,120 from ubuntu
400  - add Patch106: remove triple buffering
401  - add Patch107: remove page flipping
402  - add Patch115: fix crash Xv overlay
403  - add Patch118: drop legacy3d
404  - add Patch119: fix crashes in drm bo
405  - add Patch120: fix vt switch
406- add patch130-134 from upstream git
407  - add Patch130: fix another vt switch leak
408  - add Patch131: Create known output configuration at EnterVT time
409  - add Patch132: fix leak of some 965 render state on VT switch
410  - add Patch133: fix crash with fake bufmgr and UXA
411  - add Patch134: fix EnterVT/LeaveVT
412  - add Patch135: add new chip supoprt
413
414
415* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
416- revert to 2.6.1, add Epoch
417- add Patch103-121 from ubuntu
418
419* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
420- new upstream release
421
422* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
423- new upstream release
424
425* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
426- new upstream release
427
428* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
429- add Patch5 - Dont die on irq handler failure
430
431* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
432- new upstream release
433- add BR: libdrm-devel >= 2.4.0-3
434
435* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
436- import Patch10,11,12 from ubuntu
437
438* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
439- new upstream release
440- add triggerpostun script to replace i810 driver to intel driver
441
442* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
443- new upstream release
444
445* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
446- new upstream release
447- rename i810.xinf to intel.xinf
448- update intel.xinf (add Intel 4 series)
449
450* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
451- rebuild with new xserver
452
453* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
454- new upstream release
455
456* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
457- new upstream release
458
459* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
460- new upstream release
461
462* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
463- initial build for Vine Linux
464
465* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
466- Rebuild for new server ABI.
467- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
468
469* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
470- hook up ch7017 (bz#408471)
471
472* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
473- xf86-video-intel 2.2.0
474
475* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
476- xf86-video-intel 2.1.99.
477- Drop the i810 driver.  Time to move on.
478- Require xserver 1.4.99.1
479
480* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
481- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
482
483* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
484- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
485  for textured Xv to use as an offscreen pixmap so xv actually works under
486  compiz - granted it may be unusably slow but at least stuff shows up.
487
488* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
489- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
490- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
491
492* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
493- intel-2.1.1-quirk-update.patch - update quirks from master
494
495* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
496- i810.xinf: Flip everything over to -intel by default now.  Still install
497  i810 driver just in case.
498
499* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
500- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
501
502* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
503- xf86-video-intel 2.1.1.
504
505* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
506- xf86-video-intel 2.1.0.
507
508* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
509- Update Requires and BuildRequires.
510
511* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
512- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
513  965GME, G33, Q33, and Q35 chips.
514
515* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
516- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
517  DRI clients are active, for better battery life.
518
519* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
520- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
521
522* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
523- xf86-video-intel 2.0.0.  Change the version number to match, why not.
524- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
525  rename this at some point.
526
527* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
528- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
529  915GM.
530
531* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
532- i810.xinf: More intel whitelisting (#214011, #234877)
533
534* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
535- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
536- i810.xinf: Point 965GM support at the intel driver since it's not present
537  in old i810.
538
539* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
540- xf86-video-intel-1.9.93 (RC3).
541
542* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
543- fix typo with 945GM pci id from my laptop
544
545* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
546- xf86-video-intel 1.9.92 (RC2).
547
548* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
549- Updated modesetting driver to one that will actually work with a 1.3 server.
550
551* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
552- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
553- Remove ivch and ch7017 from the install since they aren't hooked up to the
554  code anywhere
555- Disown the module
556
557* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
558- update modesetting driver to git snapshot from today
559
560* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
561- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
562
563* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
564- rebuilt for unwind info generation, broken in gcc-4.1.1-21
565
566* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
567- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
568  actually require kudzu to run.
569
570* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
571- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
572
573* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
574- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
575- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
576  driver match the corresponding terrible heuristic in the server.
577
578* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
579- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
580  correctly distinguish between Mac Mini and Macbook Pro.
581
582* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
583- i810.xinf: PCI IDs for i965.
584
585* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
586- i810.xinf: Uppercase PCI IDs.
587
588* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
589- Update i810 to 1.6.5, should fix DRI.
590- Add kuzdu requires.
591- i810.xinf: Start whitelisting devices over to intel.
592
593* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
594- intel-driver-rename.patch: Fix the driver name in more places so it'll,
595  you know, load.
596
597* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
598- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
599  LFP special casing in favor of the blacklist.
600
601* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
602- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
603  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
604  and is selected with Driver "intel" in xorg.conf.  Individual devices will
605  whitelist over to "intel" until that branch gets merged into head.
606- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
607- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
608  the BIOS is known to lie.
609
610* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
611- Today's snapshot: I2C bus creation fix.
612
613* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
614- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
615  clock when computing the modes list.
616- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
617  in centimeters as the size of the display in pixels.
618
619* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
620- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
621  probing.
622
623* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
624- Update again for a mode comparison bugfix.
625
626* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
627- Update to today's git; crash fixes, better pre-915 support, slightly better
628  autoconfigurability.
629
630* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
631- rebuild
632
633* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
634- Fix Revision number to match naming policy.
635
636* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
637- Add back modesetting changes.
638
639* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
640- Roll back modesetting changes and build for fc5 aiglx repo.
641
642* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
643- Snapshot of the git modesetting branch.
644
645* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
646- Update i810.xinf to include entries for E7221 and 945GM.
647
648* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
649- Add with_dri macro to spec file, and conditionalize build time DRI support
650
651* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
652- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
653  to pick up proto-devel as well.
654
655* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
656- Rebuild for 7.1 ABI fix.
657
658* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
659- Bump for fc5-bling build.
660
661* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
662- Update to 1.6.0 from 7.1RC1.
663
664* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
665- Add patch to add missing #include's, specifically assert.h.
666
667* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
668- Update to CVS snapshot of 20060322.
669
670* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
671- rebuilt for new gcc4.1 snapshot and glibc changes
672
673* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
674- Added 8086:2772 mapping to i810.xinf for bug (#178451)
675
676* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
677- Added 8086:2592 mapping to i810.xinf for bug (#172884)
678
679* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
680- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
681
682* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
683- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
684- Removed 'x' suffix from manpage dirs to match RC4 upstream.
685
686* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
687- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
688
689* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
690- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
691- Fix *.la file removal.
692- Added 'devel' subpackage for XvMC .so
693- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
694
695* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
696- Update BuildRoot to use Fedora Packaging Guidelines.
697- Deglob file manifest.
698- Limit "ExclusiveArch" to x86, x86_64, ia64
699
700* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
701- Initial spec file for i810 video driver generated automatically
702  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.