source: projects/specs/trunk/x/xorg-x11-drv-intel/xorg-x11-drv-intel-vl.spec @ 11492

Revision 11492, 23.0 KB checked in by iwamoto, 6 years ago (diff)

xorg-x11-drv-intel: rebuild with xorg 1.19.6

Line 
1%define moduledir %(pkg-config xorg-server --variable=moduledir )
2%define driverdir       %{moduledir}/drivers
3%define gputoolsdate1 20130611
4%define gputoolsdate2 20110817
5
6%if "%{?_dist_release}" >= "vl7"
7%define accel sna
8#%define gputoolsdate 20130611
9%define gputoolsdate 1.14
10%else
11%define accel sna
12%define gputoolsdate 20110817
13%endif
14
15Summary:   Xorg X11 Intel video driver
16Summary(ja):   Xorg X11 Intel ビデオドライバ
17Name:      xorg-x11-drv-intel
18Epoch:     1
19Version:   2.99.917
20Release:   4%{?_dist_release}
21URL:       http://intellinuxgraphics.org/
22License:   MIT
23Group:     User Interface/X Hardware Support
24
25Source0:   http://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
26Source2:   intel.xinf
27Source3:   intel-gpu-tools-%{gputoolsdate}.tar.bz2
28
29# vine patch
30Patch0:    xf86-video-intel-2.99.917-git20171025.patch.xz
31Patch10:   0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
32
33ExclusiveArch: %{ix86} x86_64 ia64
34BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
35BuildRequires: autoconf, automake, libtool
36BuildRequires: xorg-x11-server-sdk >= 1.7.99
37BuildRequires: libXvMC-devel
38BuildRequires: libXfont-devel
39BuildRequires: libGL-devel >= 7.10
40BuildRequires: libdrm-devel >= 2.4.25
41BuildRequires: kernel-headers >= 2.6.33
42BuildRequires: eudev-libudev-devel
43BuildRequires: libxcb-devel >= 1.5
44BuildRequires: xcb-util-devel
45BuildRequires: cairo-devel
46
47Requires:  hwdata
48Requires:  xorg-x11-server-Xorg
49Requires:  xcb-util
50
51Obsoletes: xorg-x11-drv-i810
52Provides: xorg-x11-drv-i810
53
54#Conflicts:  kudzu < 1.2.42-1
55
56Vendor: Project Vine
57Distribution: Vine Linux
58Packager: daisuke
59
60%description
61X.Org X11 Intel video driver.
62
63%package devel
64Summary:   Xorg X11 Intel video driver XvMC development package
65Summary(ja):   Xorg X11 Intel ビデオドライバ XvMC 開発パッケージ
66Group:     Development/System
67Requires:  %{name} = %{epoch}:%{version}-%{release}
68Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
69
70%description devel
71X.Org X11 Intel video driver XvMC development package.
72
73%package -n intel-gpu-tools
74Summary:    Debugging tools for Intel graphics chips
75Group:      Development/Tools
76
77%description -n intel-gpu-tools
78Debugging tools for Intel graphics chips
79
80
81%prep
82%setup -q -n xf86-video-intel-%{version} -b3
83%patch0 -p1
84%patch10 -p1
85
86%build
87autoreconf -vi
88
89%if "%{?_dist_release}" < "vl7"
90export CFLAGS="-I/usr/include/X11/dri"
91%endif
92
93%configure \
94  --disable-static --libdir=%{_libdir} --mandir=%{_mandir} \
95  --enable-dri --enable-xvmc \
96  --enable-sna --enable-uxa \
97  --with-default-accel=%{accel} \
98  --enable-xaa=no
99make
100
101pushd ../intel-gpu-tools-%{gputoolsdate}
102#autoreconf -v --install
103%configure \
104        --disable-nouveau \
105        --disable-dumper \
106        --disable-gtkdoc \
107        --without-libunwind
108make
109popd
110
111
112%install
113rm -rf $RPM_BUILD_ROOT
114
115make install DESTDIR=$RPM_BUILD_ROOT
116mkdir -p $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases
117install -m 0644 %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/hwdata/videoaliases/
118
119pushd ../intel-gpu-tools-%{gputoolsdate}
120make install DESTDIR=$RPM_BUILD_ROOT
121popd
122
123rm -rf $RPM_BUILD_ROOT%{_datadir}/gtk-doc/html/intel-gpu-tools
124
125find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
126
127
128%clean
129rm -rf $RPM_BUILD_ROOT
130
131%triggerpostun -- XOrg < 7.0
132if (grep -q i810 /etc/X11/xorg.conf)
133then
134  cp /etc/X11/xorg.conf /etc/X11/xorg.conf.rpmsave
135  sed -i -e 's/"i810"/"intel"/g' /etc/X11/xorg.conf
136fi ||:
137
138%files
139%defattr(-,root,root,-)
140%{driverdir}/intel_drv.so
141%{_datadir}/hwdata/videoaliases/intel.xinf
142%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
143%{_libdir}/libI810XvMC.so.*
144%{_libdir}/libIntelXvMC.so.*
145%{_libexecdir}/xf86-video-intel-backlight-helper
146%{_mandir}/man4/i*
147
148%files devel
149%defattr(-,root,root,-)
150%{_libdir}/libI810XvMC.so
151%{_libdir}/libIntelXvMC.so
152
153%files -n intel-gpu-tools
154%defattr(-,root,root,-)
155%{_bindir}/*
156%{_libdir}/intel_aubdump.so
157%{_libexecdir}/intel-gpu-tools/
158%{_datadir}/intel-gpu-tools/
159%{_mandir}/man1/intel_*.1*
160
161
162%changelog
163* Fri Feb 16 2018 Satoshi IWAMOTO <satoshi.iwamoto@nifty.ne.jp> 2.99.917-4
164- rebuild with xorg 1.19.6
165- update patch0 (based on fc28)
166- add patch10 (from fc28)
167
168* Thu May 05 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-3
169- update Source3 (intel-gpu-tools-1.14.tar.bz2)
170- update Patch0 (xf86-video-intel-2.99.917-git20160430.patch)
171- add BuildRequires: libXfont-devel
172
173* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-2
174- update Source3 (intel-gpu-tools-1.12.tar.bz2)
175- update Patch0 (xf86-video-intel-2.99.917-git20151019.patch)
176- remove Patch1 (intel-gpu-tools-1.10-git20150410.patch)
177- remove Source4 (intel-gpu-tools-20110817.tar.bz2)
178
179* Sun Apr 12 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.917-1
180- update to 2.99.917
181- update Patch0 (xf86-video-intel-2.99.917-git20150409.patch)
182- update Patch1 (intel-gpu-tools-1.10-git20150410.patch)
183- update Source3 (intel-gpu-tools-1.10.tar.bz2)
184
185* Sun Nov 23 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-2
186- add Patch0 (xf86-video-intel-2.99.916-git20141120.patch)
187- update Source3 (intel-gpu-tools-1.8.tar.bz2)
188
189* Sat Nov 22 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.916-1
190- update to 2.99.916
191
192* Thu Jul 10 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.99.912-1
193- update to 2.99.912
194
195* Tue Jun 17 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-3
196- change BuildRequires: eudev-libudev-devel instead of libudev-devel
197
198* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.15-2
199- rebuild with VineSeed environment
200
201* Thu Oct 10 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.15-1
202- new upstream release
203
204* Sat Jun 01 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.8-1
205- new upstream release
206- change default accel method to sna.
207
208* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.21.6-1
209- new upstream release
210
211* Fri Mar 22 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.5-1
212- new upstream release
213
214* Mon Feb 11 2013 Daisuke SUZUKI <daisuke@linux.or.jp> 2.21.1-1
215- new upstream release
216
217* Tue Dec 18 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.16-1
218- new upstream release
219
220* Mon Dec 03 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.15-1
221- new upstream release
222
223* Tue Oct 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.10-1
224- new upstream release
225
226* Sun Sep 16 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.8-1
227- new upstream release
228
229* Tue Sep 04 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.6-2
230- new upstream release
231
232* Fri Jul 27 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.2-2
233- new upstream release
234
235* Tue Jul 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.20.1-1
236- new upstream release
237
238* Wed Jun 06 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.19.0-3
239- rebuild with xcb-util-0.3.9
240
241* Tue May 08 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-2
242- disable sna, enable uxa
243
244* Wed May 02 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.19.0-1
245- new upstream release
246
247* Sun Mar 25 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.18.0-2
248- rebuild with xserver-1.12.0
249
250* Fri Feb 24 2012 Daisuke SUZUKI <daisuke@linux.or.jp> 2.18.0-1
251- new upstream release
252- enable sna
253
254* Sat Nov 26 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-2
255- disable sna/vmap
256
257* Fri Nov 18 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.17.0-1
258- new upstram release
259- disable copy-fb patch
260
261* Wed Nov 02 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.16.0-3
262- rebuild with xserver-1.11.1.902
263
264* Wed Aug 31 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-2
265- add --enable-sna --enable-vmap
266
267* Wed Aug 24 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.16.0-1
268- new upstream release
269
270* Sat Aug 20 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 2.15.0-6
271- rebuild with xcb-util-0.3.8
272- drop Patch200
273
274* Tue Jul 05 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-5
275- update to disable copy_fb on sandybridge/ivybridge
276
277* Mon Jun 27 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-4
278- update intel.xinf
279- add patch10 from fedora
280  - Clamp VGA pixel clock to 250MHz,
281    anything higher's going to look awful anyway. (#559426)
282
283* Tue May 17 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-3
284- drop patch1-3 and replaced with new patch1 from git master
285- add Patch200 to disable DRI on SandyBridge/IvyBridge
286- update intel-gpu-tools
287
288* Thu Apr 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-2
289- add Patch1-3 from upstream
290
291* Fri Apr 15 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 2.15.0-1
292- new upstream release
293- drop upstream patches: 107-115
294- temporary disabled patch101
295- BR: libdrm >= 2.4.25
296
297* Sun Mar 06 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-3
298- add Patch101-115 from ubuntu/debian package
299  - Patch101: Plymouth integration patch
300  - Patch107: Check null return from uxa_acquire_solid()
301  - Patch108: Cherry-pick fix from upstream git to fix graphics corruption
302  - Patch109: Fix font corruption (missing glyphs) on rotated screens.
303  - Patch110,114: Cherry picks to fix a large number of build warnings.
304  - Patch111: Fix clipped window plane offset
305  - Patch112: Fix issue where vertical green line and strange colors
306              shows up when playing gstreamer with certain videos,
307              when dragged.  (LP 460677)
308  - Patch113: Fixes GPU lockup during login with
309              "Bad length (4) in MI_DISPLAY_BUFFER_INFO, [3, 3]"
310              error messages listed in the gpu dump text. (LP 710321)
311  - Patch115: Don't fill up Xorg.0.log with
312              "get vblank counter failed: Invalid argument" warnings.
313   
314* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.14.0-2
315- rebuild with xserver-1.10.0
316
317* Fri Jan 28 2011 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.14.0-1
318- new upstream release
319
320* Wed Nov 24 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.13.0-1
321- new upstream release
322
323* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 1:2.12.0-2
324- rebuild with xserver-1.9.2
325
326* Tue Aug 17 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.12.0-1
327- new upstream release
328- add Patch40: fix uxa planemask (backported)
329- add Patch61: add support for backlight on macbooks
330- add Patch62: disable page flipping for stability
331
332* Tue Mar 30 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.11.0-1
333- new upstream release
334- drop patch70
335
336* Thu Mar 25 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-3
337- rebuild again with xserver-1.8rc
338
339* Thu Mar 11 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-2
340- add intel-gpu-tools as sub-package
341- rebuild with libdrm-2.4.18
342
343* Mon Mar 08 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.10.0-1
344- new upstream release
345- import Patch1,2,60,70 from fedora
346- add BR: kernel-headers >= 2.6.33 (new drm header required)
347- add BR: xcb-util-devel, libxcb-devel and R: xcb-util fot XvMC client
348- add BR; libudev-devel and autoreconf for Patch60
349
350* Mon Jan 04 2010 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-2
351- rebuild with libdrm-2.4.17
352
353* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.9.1-1
354- new upstream release
355
356* Sat Oct 10 2009 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 1:2.9.0-1
357- new upstream release (hopefully fixes severe issues w/ efifb)
358- drop all patches already upstreamed; import Patch20/21 from Fedora
359
360* Fri Jul 24 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-3
361- import Patch121,122 from ubuntu
362- build with libdrm-2.4.12 which fixes vt switch crash
363
364* Fri Jul 17 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-2
365- apply patch114 to fix Xv with non-GEM kernel
366
367* Mon May 11 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.3-1
368- update to 2.6.3
369- add patch106,107,115,118,119,120 from ubuntu
370  - add Patch106: remove triple buffering
371  - add Patch107: remove page flipping
372  - add Patch115: fix crash Xv overlay
373  - add Patch118: drop legacy3d
374  - add Patch119: fix crashes in drm bo
375  - add Patch120: fix vt switch
376- add patch130-134 from upstream git
377  - add Patch130: fix another vt switch leak
378  - add Patch131: Create known output configuration at EnterVT time
379  - add Patch132: fix leak of some 965 render state on VT switch
380  - add Patch133: fix crash with fake bufmgr and UXA
381  - add Patch134: fix EnterVT/LeaveVT
382  - add Patch135: add new chip supoprt
383
384
385* Sat May 02 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 1:2.6.1-2
386- revert to 2.6.1, add Epoch
387- add Patch103-121 from ubuntu
388
389* Fri May 01 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.7.0-1
390- new upstream release
391
392* Sun Mar 22 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 2.6.1-1
393- new upstream release
394
395* Sun Nov 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.1-1
396- new upstream release
397
398* Wed Oct 22 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-2
399- add Patch5 - Dont die on irq handler failure
400
401* Tue Oct 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.5.0-1
402- new upstream release
403- add BR: libdrm-devel >= 2.4.0-3
404
405* Sat Sep 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-2
406- import Patch10,11,12 from ubuntu
407
408* Wed Sep 03 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.2-1
409- new upstream release
410- add triggerpostun script to replace i810 driver to intel driver
411
412* Fri Aug 15 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.1-1
413- new upstream release
414
415* Wed Jul 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.4.0-1
416- new upstream release
417- rename i810.xinf to intel.xinf
418- update intel.xinf (add Intel 4 series)
419
420* Sun Jul 06 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-2
421- rebuild with new xserver
422
423* Sat Jun 21 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.2-1
424- new upstream release
425
426* Wed May 14 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.3.1-1
427- new upstream release
428
429* Mon May 12 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.1-1
430- new upstream release
431
432* Wed Jan 23 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 2.2.0-0vl1
433- initial build for Vine Linux
434
435* Wed Jan 09 2008 Adam Jackson <ajax@redhat.com> 2.2.0-3
436- Rebuild for new server ABI.
437- intel-2.2.0-alloca.patch: Fix use of {DE,}ALLOCATE_LOCAL.
438
439* Mon Dec 10 2007 Dave Airlie <airlied@redhat.com> 2.2.0-2
440- hook up ch7017 (bz#408471)
441
442* Tue Nov 27 2007 Adam Jackson <ajax@redhat.com> 2.2.0-1
443- xf86-video-intel 2.2.0
444
445* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 2.1.99-1
446- xf86-video-intel 2.1.99.
447- Drop the i810 driver.  Time to move on.
448- Require xserver 1.4.99.1
449
450* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-7
451- intel-2.1.1-fix-xv-compiz.patch - update to not crash is we can't get RAM
452
453* Wed Oct 17 2007 Dave Airlie <airlied@redhat.com> 2.1.1-6
454- intel-2.1.1-fix-xv-compiz.patch - Real dirty hack to allocate 4MB of RAM
455  for textured Xv to use as an offscreen pixmap so xv actually works under
456  compiz - granted it may be unusably slow but at least stuff shows up.
457
458* Mon Oct 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-5
459- intel-2.1.1-fix-vt-switch.patch - Only restore paletter regs on enabled pipes
460- intel-2.1.1-fix-xv-reset.patch - Reset XV after mode switch
461
462* Fri Oct 05 2007 Dave Airlie <airlied@redhat.com> 2.1.1-4
463- intel-2.1.1-quirk-update.patch - update quirks from master
464
465* Mon Aug 20 2007 Adam Jackson <ajax@redhat.com> 2.1.1-3
466- i810.xinf: Flip everything over to -intel by default now.  Still install
467  i810 driver just in case.
468
469* Wed Aug 15 2007 Dave Airlie <airlied@redhat.com> 2.1.1-2
470- intel-2.1.1-fix-texoffset-start.patch - shouldn't set texoffsetstart when not using EXA
471
472* Tue Aug 14 2007 Dave Airlie <airlied@redhat.com> 2.1.1-1
473- xf86-video-intel 2.1.1.
474
475* Tue Jul 03 2007 Adam Jackson <ajax@redhat.com> 2.1.0-1
476- xf86-video-intel 2.1.0.
477
478* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 2.0.0-5
479- Update Requires and BuildRequires.
480
481* Wed Jun 06 2007 Adam Jackson <ajax@redhat.com> 2.0.0-4
482- Update to git master.  Many Xv and DVO fixes.  Adds support for 945GME,
483  965GME, G33, Q33, and Q35 chips.
484
485* Mon May 14 2007 Adam Jackson <ajax@redhat.com> 2.0.0-3
486- intel-2.0-vblank-power-savings.patch: Disable vblank interrupts when no
487  DRI clients are active, for better battery life.
488
489* Tue May 01 2007 Adam Jackson <ajax@redhat.com> 2.0.0-2
490- Rebuild for final RANDR 1.2 ABI.  Fixes segfault at startup. (#238575)
491
492* Mon Apr 23 2007 Adam Jackson <ajax@redhat.com> 2.0.0-1
493- xf86-video-intel 2.0.0.  Change the version number to match, why not.
494- Add a Virtual provides for xorg-x11-drv-intel, since we should probably
495  rename this at some point.
496
497* Tue Apr 10 2007 Adam Jackson <ajax@redhat.com> 1.6.5-19
498- i810.xinf: Move all 965 and 945 chips onto the new driver, as well as
499  915GM.
500
501* Thu Apr 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-18
502- i810.xinf: More intel whitelisting (#214011, #234877)
503
504* Wed Apr 04 2007 Adam Jackson <ajax@redhat.com> 1.6.5-17
505- xf86-video-intel-1.9.94 (RC4).  Adds support for 965GM.
506- i810.xinf: Point 965GM support at the intel driver since it's not present
507  in old i810.
508
509* Fri Mar 30 2007 Adam Jackson <ajax@redhat.com> 1.6.5-16
510- xf86-video-intel-1.9.93 (RC3).
511
512* Tue Mar 27 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-15
513- fix typo with 945GM pci id from my laptop
514
515* Thu Mar 22 2007 Adam Jackson <ajax@redhat.com> 1.6.5-14
516- xf86-video-intel 1.9.92 (RC2).
517
518* Mon Mar 05 2007 Adam Jackson <ajax@redhat.com> 1.6.5-13
519- Updated modesetting driver to one that will actually work with a 1.3 server.
520
521* Tue Feb 27 2007 Adam Jackson <ajax@redhat.com> 1.6.5-12
522- Nuke %%with_dri, since the arch list exactly matched the ExclusiveArch list
523- Remove ivch and ch7017 from the install since they aren't hooked up to the
524  code anywhere
525- Disown the module
526
527* Tue Jan 30 2007 Jeremy Katz <katzj@redhat.com> - 1.6.5-11
528- update modesetting driver to git snapshot from today
529
530* Tue Nov 7 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-10
531- i965-xv-hang-fix.patch: Backport Xv hang fix for G965.
532
533* Sun Oct 01 2006 Jesse Keating <jkeating@redhat.com> - 1.6.5-9
534- rebuilt for unwind info generation, broken in gcc-4.1.1-21
535
536* Fri Sep 22 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-8.fc6
537- Change 'Requires: kudzu >= foo' to 'Conflicts: kudzu < foo' since we don't
538  actually require kudzu to run.
539
540* Fri Sep 15 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-7.fc6
541- i810.xinf: Whitelist Apple 945GM machines and Aopen Mini PC onto intel(4)
542
543* Tue Sep 12 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-6.fc6
544- i810-1.6.5-to-git-20060911.patch: Backport post-1.6.5 fixes from git.
545- i810-match-server-sync-ranges.patch: Make a terrible heuristic in the
546  driver match the corresponding terrible heuristic in the server.
547
548* Mon Aug 28 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-5.fc6
549- intel-945gm-lfp-blacklist.patch: Tweak the Apple blacklist to (hopefully)
550  correctly distinguish between Mac Mini and Macbook Pro.
551
552* Mon Aug 21 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-4.fc6
553- i810.xinf: PCI IDs for i965.
554
555* Thu Aug 17 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-3.fc6
556- i810.xinf: Uppercase PCI IDs.
557
558* Thu Aug 10 2006 Adam Jackson <ajackson@redhat.com> 1.6.5-2.fc6
559- Update i810 to 1.6.5, should fix DRI.
560- Add kuzdu requires.
561- i810.xinf: Start whitelisting devices over to intel.
562
563* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-3.fc6
564- intel-driver-rename.patch: Fix the driver name in more places so it'll,
565  you know, load.
566
567* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-2.fc6
568- intel-945gm-lfp-blacklist.patch: At anholt's suggestion, remove the other
569  LFP special casing in favor of the blacklist.
570
571* Wed Aug  9 2006 Adam Jackson <ajackson@redhat.com> 1.6.4-1.fc6
572- Admit defeat, kinda.  Package both i810 stable and modesetting drivers.
573  The modesetting driver is installed as intel_drv.so instead of i810_drv.so,
574  and is selected with Driver "intel" in xorg.conf.  Individual devices will
575  whitelist over to "intel" until that branch gets merged into head.
576- Update the stable branch driver to 1.6.4 from upstream, adds i965 support.
577- intel-945gm-lfp-blacklist.patch: Blacklist LFP detection on machines where
578  the BIOS is known to lie.
579
580* Tue Aug  8 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-14.20060808modeset.fc6
581- Today's snapshot: I2C bus creation fix.
582
583* Wed Aug  2 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-13.20060717modeset.fc6
584- intel-prune-by-edid-pixclock.patch: Honor the EDID-reported maximum pixel
585  clock when computing the modes list.
586- intel-virtual-sizing-bogon.patch: Don't interpret the size of the display
587  in centimeters as the size of the display in pixels.
588
589* Mon Jul 24 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-12.20060717modeset.fc6
590- Disable spread-spectrum LVDS, various crash and hang fixes, saner output
591  probing.
592
593* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-11.20060713modeset.fc6
594- Update again for a mode comparison bugfix.
595
596* Thu Jul 13 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-10.20060713modeset.fc6
597- Update to today's git; crash fixes, better pre-915 support, slightly better
598  autoconfigurability.
599
600* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 1.6.0-9.20060707modeset.1.fc6
601- rebuild
602
603* Tue Jul 11 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-9.20060707modeset
604- Fix Revision number to match naming policy.
605
606* Tue Jul 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-8.modeset20060707
607- Add back modesetting changes.
608
609* Mon Jul 10 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-7
610- Roll back modesetting changes and build for fc5 aiglx repo.
611
612* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6.modeset20060707
613- Snapshot of the git modesetting branch.
614
615* Fri Jul  7 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-6
616- Update i810.xinf to include entries for E7221 and 945GM.
617
618* Fri Jun 23 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-5
619- Add with_dri macro to spec file, and conditionalize build time DRI support
620
621* Fri May 26 2006 Mike A. Harris <mharris@redhat.com> 1.6.0-4
622- Added "BuildRequires: libdrm >= 2.0-1" for (#192334), and updated sdk dep
623  to pick up proto-devel as well.
624
625* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-3
626- Rebuild for 7.1 ABI fix.
627
628* Tue Apr 11 2006 Kristian H淡gsberg <krh@redhat.com> 1.6.0-2
629- Bump for fc5-bling build.
630
631* Sun Apr 09 2006 Adam Jackson <ajackson@redhat.com> 1.6.0-1
632- Update to 1.6.0 from 7.1RC1.
633
634* Tue Apr 04 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322.1
635- Add patch to add missing #include's, specifically assert.h.
636
637* Wed Mar 22 2006 Kristian H淡gsberg <krh@redhat.com> 1.4.1.3-4.cvs20060322
638- Update to CVS snapshot of 20060322.
639
640* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.4.1.3-3.1
641- rebuilt for new gcc4.1 snapshot and glibc changes
642
643* Sat Feb 04 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-3
644- Added 8086:2772 mapping to i810.xinf for bug (#178451)
645
646* Fri Feb 03 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-2
647- Added 8086:2592 mapping to i810.xinf for bug (#172884)
648
649* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.4.1.3-1
650- Updated xorg-x11-drv-i810 to version 1.4.1.3 from X11R7.0
651
652* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 1.4.1.2-1
653- Updated xorg-x11-drv-i810 to version 1.4.1.2 from X11R7 RC4
654- Removed 'x' suffix from manpage dirs to match RC4 upstream.
655
656* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 1.4.1-1
657- Updated xorg-x11-drv-i810 to version 1.4.1 from X11R7 RC2
658
659* Fri Nov 04 2005 Mike A. Harris <mharris@redhat.com> 1.4.0.1-1
660- Updated xorg-x11-drv-i810 to version 1.4.0.1 from X11R7 RC1
661- Fix *.la file removal.
662- Added 'devel' subpackage for XvMC .so
663- Added 'BuildRequires: libXvMC-devel' for XvMC drivers.
664
665* Mon Oct 03 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-1
666- Update BuildRoot to use Fedora Packaging Guidelines.
667- Deglob file manifest.
668- Limit "ExclusiveArch" to x86, x86_64, ia64
669
670* Fri Sep 02 2005 Mike A. Harris <mharris@redhat.com> 1.4.0-0
671- Initial spec file for i810 video driver generated automatically
672  by my xorg-driverspecgen script.
Note: See TracBrowser for help on using the repository browser.