source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 8064

Revision 8064, 11.4 KB checked in by Takemikaduchi, 10 years ago (diff)

freetype2: fix pkgconfig
xserver: update to 1.14.5
others: new upstream release or rebuild

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.7
9Release: 2%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.3.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.7.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.6.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.4.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.4.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.1.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.4.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.3.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.6.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.5.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.4.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.2.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.4.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.5.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.4.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.6.1.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.5.tar.bz2
36
37Patch1: luit-1.1.1-git20131203.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59BuildRequires: libXrandr-devel
60BuildRequires: libXinerama-devel
61
62Requires(pre): xorg-x11-filesystem
63
64Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
65Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
66
67# NOTE: xwd, xwud, luit used to be in these.
68Obsoletes: XFree86, XOrg
69# NOTE: x11perf, xclipboard used to be in these.
70Obsoletes: XFree86-tools, XOrg-tools
71
72Vendor: Project Vine
73Distribution: Vine Linux
74
75%description
76A collection of common X Window System applications.
77
78%prep
79%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
80
81pushd luit-1.1.1
82%patch1 -p1 -b .luit
83popd
84
85%build
86# Build all apps
87{
88   for app in * ; do
89      pushd $app
90
91      case $app in
92         x11perf*)
93            autoreconf -if
94         ;;
95         luit*)
96            autoreconf -if
97         ;;
98      esac
99
100      %configure --disable-xprint
101      make
102      popd
103   done
104}
105
106%install
107rm -rf $RPM_BUILD_ROOT
108# Install all apps
109{
110   for app in * ; do
111      pushd $app
112      make install DESTDIR=$RPM_BUILD_ROOT
113      popd
114   done
115}
116
117%clean
118rm -rf $RPM_BUILD_ROOT
119
120%files
121%defattr(-,root,root,-)
122#%doc
123%{_bindir}/luit
124%{_bindir}/oclock
125%{_bindir}/x11perf
126%{_bindir}/x11perfcomp
127%{_bindir}/xbiff
128%{_bindir}/xcalc
129%{_bindir}/xclipboard
130%{_bindir}/xclock
131%{_bindir}/xconsole
132%{_bindir}/xcursorgen
133%{_bindir}/xcutsel
134%{_bindir}/xdpr
135%{_bindir}/xeyes
136%{_bindir}/xinput
137%{_bindir}/xkill
138%{_bindir}/xload
139%{_bindir}/xlogo
140%{_bindir}/xmag
141%{_bindir}/xmessage
142%{_bindir}/xpr
143%{_bindir}/xwd
144%{_bindir}/xwud
145%dir %{_datadir}/X11
146%{_datadir}/X11/app-defaults/Clock-color
147%{_datadir}/X11/app-defaults/XCalc
148%{_datadir}/X11/app-defaults/XCalc-color
149%{_datadir}/X11/app-defaults/XClipboard
150%{_datadir}/X11/app-defaults/XClock
151%{_datadir}/X11/app-defaults/XClock-color
152%{_datadir}/X11/app-defaults/XConsole
153%{_datadir}/X11/app-defaults/XLoad
154%{_datadir}/X11/app-defaults/XLogo
155%{_datadir}/X11/app-defaults/XLogo-color
156%{_datadir}/X11/app-defaults/Xmag
157%{_datadir}/X11/app-defaults/Xmessage
158%{_datadir}/X11/app-defaults/Xmessage-color
159%dir %{_libdir}/X11/x11perfcomp
160%{_libdir}/X11/x11perfcomp/Xmark
161%{_libdir}/X11/x11perfcomp/fillblnk
162%{_libdir}/X11/x11perfcomp/perfboth
163%{_libdir}/X11/x11perfcomp/perfratio
164#%dir %{_mandir}/man1x
165%{_mandir}/man1/xcursorgen.1*
166%{_mandir}/man1/Xmark.1*
167%{_mandir}/man1/luit.1*
168%{_mandir}/man1/oclock.1*
169%{_mandir}/man1/x11perf.1*
170%{_mandir}/man1/x11perfcomp.1*
171%{_mandir}/man1/xbiff.1*
172%{_mandir}/man1/xcalc.1*
173%{_mandir}/man1/xclipboard.1*
174%{_mandir}/man1/xclock.1*
175%{_mandir}/man1/xconsole.1*
176%{_mandir}/man1/xcutsel.1*
177%{_mandir}/man1/xdpr.1*
178%{_mandir}/man1/xeyes.1*
179%{_mandir}/man1/xinput.1*
180%{_mandir}/man1/xkill.1*
181%{_mandir}/man1/xload.1*
182%{_mandir}/man1/xlogo.1*
183%{_mandir}/man1/xmag.1*
184%{_mandir}/man1/xmessage.1*
185%{_mandir}/man1/xpr.1*
186%{_mandir}/man1/xwd.1*
187%{_mandir}/man1/xwud.1*
188
189%changelog
190* Thu Dec 26 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-2
191- xclock-1.0.7
192- xwd-1.0.6
193- xclipboard-1.1.3
194- xconsole-1.0.6
195- xkill-1.0.4
196- xload-1.1.2
197- xinput-1.6.1
198- add Patch1 (luit-1.1.1-git20131203.patch)
199
200* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
201- xcalc-1.0.5
202- xconsole-1.0.5
203- xmag-1.0.5
204- xmessage-1.0.4
205
206* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-8
207- xinput-1.6.0
208- xpr-1.0.4
209- xwud-1.0.4
210- add BuildRequires: libXrandr-devel, libXinerama-devel
211
212* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
213- luit-1.1.1
214- xcursorgen-1.0.5
215- xload-1.1.1
216- xlogo-1.0.4
217
218* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
219- oclock-1.0.3
220- xclipboard-1.1.2
221- xclock-1.0.6
222- xwd-1.0.5
223
224* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
225- xinput-1.5.4
226
227* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
228- x11perf-1.5.4
229
230* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
231- xcalc-1.0.4.1
232
233* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
234- xbiff-1.0.3
235
236* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
237- x11perf-1.5.3
238
239* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
240- xwd-1.0.4
241- wud-1.0.3
242- xclipboard-1.1.1
243- xcursorgen-1.0.4
244- xeyes-1.1.1
245- xkill-1.0.3
246- xinput-1.5.3
247- xcalc-1.0.4
248
249* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
250- oclock-1.0.2
251- xlock-1.0.5
252- xconsole-1.0.4
253- luit-1.1.0
254- x11perf-1.5.2
255- xbiff-1.0.2
256- xlogo-1.0.3
257- xload-1.1.0
258- xmag-1.0.4
259- xinput-1.5.2
260- drop Patch2
261- add BuildRequires: libXi-devel
262
263* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
264- luit-1.0.5
265- xeyes-1.1.0
266- xlogo-1.0.2
267- xmessage-1.0.3
268- xinput-1.5.1
269- added xcalc-1.0.3 <wishes:161>
270
271* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
272- xclock-1.0.4
273- xwd-1.0.3
274- xwud-1.0.2
275- xpr-1.0.3
276- luit-1.0.4
277- x11perf-1.5.1
278- xclipboard-1.1.0
279- xcursorgen-1.0.3
280- xeyes-1.0.991
281- xkill-1.0.2
282- xmag-1.0.3
283- xinput-1.5.0
284
285* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
286- xinput-1.4.2
287
288* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
289- xinput-1.4.1
290
291* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
292- bump to 7.4 version
293- add xinput-1.3.0
294
295* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
296- xwd 1.0.2
297- luit 1.0.3
298- x11perf 1.5
299
300* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
301- new versioning policy
302
303* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
304- initial build for Vine Linux
305
306* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
307- xconsole 1.0.3
308- xmessage 1.0.2
309- Bump to 7.3-1
310
311* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
312- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
313- bump to 7.2 version
314
315* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
316- Fix man page globs and rebuild for FC7.
317
318* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
319- Fix race condition in luit (Bug 197165).
320
321* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
322- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
323- Add 'dist' tag to package release string.
324
325* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
326- rebuild
327
328* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
329- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
330- Artificially inflate package version-release to 7.1 to match the X11R7.1
331  release that all of the tarballs are taken from.
332- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
333- Add temporary dependency on autoconf, automake for brew builds.
334
335* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
336- Add more BuildRequires to fix mock builds.  (#191896)
337
338* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
339- Updated xclock and xconsole
340
341* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
342- Bump x11perf to 1.4.1 from upstream.
343
344* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
345- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
346
347* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
348- bump again for double-long bug on ppc(64)
349
350* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
351- rebuilt for new gcc4.1 snapshot and glibc changes
352
353* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
354- Upgraded all apps to version 1.0.1 from X11R7.0
355
356* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
357- Upgraded all apps to version 1.0.0 from X11R7 RC4.
358- Changed manpage dir from man1x to man1 to match upstream default now.
359- Dropped all of the datadir-cleanups patches added in the previous build.
360- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
361  to put the helper scripts in datadir.
362- Added --disable-xprint to configure, as a great symbolic jesture.
363
364* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
365- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
366  (#173384)
367- Added the following patches, and invoke aclocal/automake/autoconf on them
368  to force app-defaults and other datafiles into _datadir instead of _libdir:
369  - oclock-0.99.1-oclock-datadir-cleanups.patch
370  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
371  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
372  - xclock-0.99.1-xclock-datadir-cleanups.patch
373  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
374  - xload-0.99.1-xload-datadir-cleanups.patch
375  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
376  - xmag-0.99.1-xmag-datadir-cleanups.patch
377  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
378- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
379
380* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
381- add Requires(pre) on newer filesystem package (#172610)
382
383* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
384- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
385  various utils have moved here from there in monolithic X packaging.
386- Add "BuildRequires: xbitmaps-devel" for xbiff.
387- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
388
389* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
390- Initial build, with all apps taken from X11R7 RC2.
391- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
392  some packages.
393- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.