source: projects/specs/trunk/x/xorg-x11-apps/xorg-x11-apps-vl.spec @ 7648

Revision 7648, 11.2 KB checked in by Takemikaduchi, 11 years ago (diff)

xserver-1.14.1

Line 
1%define pkgname apps
2
3Summary: X.Org X11 applications
4Summary(ja): X.Org X11 アプリケーション
5Name: xorg-x11-%{pkgname}
6# NOTE: The package version should be set to the X11 major release from which
7# the OS release is based upon.
8Version: 7.7
9Release: 1%{?_dist_release}
10License: MIT/X11
11Group: User Interface/X
12URL: http://www.x.org
13
14# Clock apps
15Source0:  ftp://ftp.x.org/pub/individual/app/oclock-1.0.3.tar.bz2
16Source1:  ftp://ftp.x.org/pub/individual/app/xclock-1.0.6.tar.bz2
17# X Window Dump (xwd) utilities
18Source2:  ftp://ftp.x.org/pub/individual/app/xwd-1.0.5.tar.bz2
19Source3:  ftp://ftp.x.org/pub/individual/app/xwud-1.0.4.tar.bz2
20Source4:  ftp://ftp.x.org/pub/individual/app/xpr-1.0.4.tar.bz2
21# Miscellaneous other applications
22Source5:  ftp://ftp.x.org/pub/individual/app/luit-1.1.1.tar.bz2
23Source6:  ftp://ftp.x.org/pub/individual/app/x11perf-1.5.4.tar.bz2
24Source7:  ftp://ftp.x.org/pub/individual/app/xbiff-1.0.3.tar.bz2
25Source8:  ftp://ftp.x.org/pub/individual/app/xclipboard-1.1.2.tar.bz2
26Source9:  ftp://ftp.x.org/pub/individual/app/xconsole-1.0.5.tar.bz2
27Source10: ftp://ftp.x.org/pub/individual/app/xcursorgen-1.0.5.tar.bz2
28Source11: ftp://ftp.x.org/pub/individual/app/xeyes-1.1.1.tar.bz2
29Source12: ftp://ftp.x.org/pub/individual/app/xkill-1.0.3.tar.bz2
30Source13: ftp://ftp.x.org/pub/individual/app/xload-1.1.1.tar.bz2
31Source14: ftp://ftp.x.org/pub/individual/app/xlogo-1.0.4.tar.bz2
32Source15: ftp://ftp.x.org/pub/individual/app/xmag-1.0.5.tar.bz2
33Source16: ftp://ftp.x.org/pub/individual/app/xmessage-1.0.4.tar.bz2
34Source17: ftp://ftp.x.org/pub/individual/app/xinput-1.6.0.tar.bz2
35Source18: ftp://ftp.x.org/pub/individual/app/xcalc-1.0.5.tar.bz2
36
37Patch2: xconsole-1.0.3-streams-me-softer.patch
38
39BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
40BuildRequires: autoconf, automake
41BuildRequires: pkgconfig
42BuildRequires: xorg-x11-util-macros
43BuildRequires: xorg-x11-xbitmaps
44BuildRequires: zlib-devel
45BuildRequires: libfontenc-devel
46BuildRequires: libX11-devel
47BuildRequires: libXmu-devel
48BuildRequires: libXext-devel
49BuildRequires: libXt-devel
50BuildRequires: libXaw-devel
51BuildRequires: libXpm-devel
52BuildRequires: libXft-devel
53BuildRequires: libXrender-devel
54BuildRequires: libxkbfile-devel
55BuildRequires: libXcursor-devel
56BuildRequires: libpng-devel
57BuildRequires: libXfixes-devel
58BuildRequires: libXi-devel
59BuildRequires: libXrandr-devel
60BuildRequires: libXinerama-devel
61
62Requires(pre): xorg-x11-filesystem
63
64Provides: luit oclock x11perf xbiff xclipboard xclock xconsole xcursorgen
65Provides: xeyes xkill xload xlogo xmag xmessage xpr xwd xwud xinput xcalc
66
67# NOTE: xwd, xwud, luit used to be in these.
68Obsoletes: XFree86, XOrg
69# NOTE: x11perf, xclipboard used to be in these.
70Obsoletes: XFree86-tools, XOrg-tools
71
72Vendor: Project Vine
73Distribution: Vine Linux
74
75%description
76A collection of common X Window System applications.
77
78%prep
79%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18
80## %patch2 -p0 -b .streams-me-softer
81
82%build
83# Build all apps
84{
85   for app in * ; do
86      pushd $app
87
88      case $app in
89         x11perf*)
90            aclocal ; automake ; autoconf
91         ;;
92         luit*)
93            autoconf
94         ;;
95      esac
96
97      %configure --disable-xprint
98      make
99      popd
100   done
101}
102
103%install
104rm -rf $RPM_BUILD_ROOT
105# Install all apps
106{
107   for app in * ; do
108      pushd $app
109      make install DESTDIR=$RPM_BUILD_ROOT
110      popd
111   done
112}
113
114%clean
115rm -rf $RPM_BUILD_ROOT
116
117%files
118%defattr(-,root,root,-)
119#%doc
120%{_bindir}/luit
121%{_bindir}/oclock
122%{_bindir}/x11perf
123%{_bindir}/x11perfcomp
124%{_bindir}/xbiff
125%{_bindir}/xcalc
126%{_bindir}/xclipboard
127%{_bindir}/xclock
128%{_bindir}/xconsole
129%{_bindir}/xcursorgen
130%{_bindir}/xcutsel
131%{_bindir}/xdpr
132%{_bindir}/xeyes
133%{_bindir}/xinput
134%{_bindir}/xkill
135%{_bindir}/xload
136%{_bindir}/xlogo
137%{_bindir}/xmag
138%{_bindir}/xmessage
139%{_bindir}/xpr
140%{_bindir}/xwd
141%{_bindir}/xwud
142%dir %{_datadir}/X11
143%{_datadir}/X11/app-defaults/Clock-color
144%{_datadir}/X11/app-defaults/XCalc
145%{_datadir}/X11/app-defaults/XCalc-color
146%{_datadir}/X11/app-defaults/XClipboard
147%{_datadir}/X11/app-defaults/XClock
148%{_datadir}/X11/app-defaults/XClock-color
149%{_datadir}/X11/app-defaults/XConsole
150%{_datadir}/X11/app-defaults/XLoad
151%{_datadir}/X11/app-defaults/XLogo
152%{_datadir}/X11/app-defaults/XLogo-color
153%{_datadir}/X11/app-defaults/Xmag
154%{_datadir}/X11/app-defaults/Xmessage
155%{_datadir}/X11/app-defaults/Xmessage-color
156%dir %{_libdir}/X11/x11perfcomp
157%{_libdir}/X11/x11perfcomp/Xmark
158%{_libdir}/X11/x11perfcomp/fillblnk
159%{_libdir}/X11/x11perfcomp/perfboth
160%{_libdir}/X11/x11perfcomp/perfratio
161#%dir %{_mandir}/man1x
162%{_mandir}/man1/xcursorgen.1*
163%{_mandir}/man1/Xmark.1*
164%{_mandir}/man1/luit.1*
165%{_mandir}/man1/oclock.1*
166%{_mandir}/man1/x11perf.1*
167%{_mandir}/man1/x11perfcomp.1*
168%{_mandir}/man1/xbiff.1*
169%{_mandir}/man1/xcalc.1*
170%{_mandir}/man1/xclipboard.1*
171%{_mandir}/man1/xclock.1*
172%{_mandir}/man1/xconsole.1*
173%{_mandir}/man1/xcutsel.1*
174%{_mandir}/man1/xdpr.1*
175%{_mandir}/man1/xeyes.1*
176%{_mandir}/man1/xinput.1*
177%{_mandir}/man1/xkill.1*
178%{_mandir}/man1/xload.1*
179%{_mandir}/man1/xlogo.1*
180%{_mandir}/man1/xmag.1*
181%{_mandir}/man1/xmessage.1*
182%{_mandir}/man1/xpr.1*
183%{_mandir}/man1/xwd.1*
184%{_mandir}/man1/xwud.1*
185
186%changelog
187* Sun May 05 2013 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.7-1
188- xcalc-1.0.5
189- xconsole-1.0.5
190- xmag-1.0.5
191- xmessage-1.0.4
192
193* Wed May 30 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-8
194- xinput-1.6.0
195- xpr-1.0.4
196- xwud-1.0.4
197- add BuildRequires: libXrandr-devel, libXinerama-devel
198
199* Sat Mar 24 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-7
200- luit-1.1.1
201- xcursorgen-1.0.5
202- xload-1.1.1
203- xlogo-1.0.4
204
205* Sat Mar 03 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-6
206- oclock-1.0.3
207- xclipboard-1.1.2
208- xclock-1.0.6
209- xwd-1.0.5
210
211* Sun Jan 29 2012 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-5
212- xinput-1.5.4
213
214* Sun Aug 14 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-4
215- x11perf-1.5.4
216
217* Mon Feb 28 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-3
218- xcalc-1.0.4.1
219
220* Sat Feb 05 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-2
221- xbiff-1.0.3
222
223* Sat Jan 22 2011 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.6-1
224- x11perf-1.5.3
225
226* Sat Dec 18 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-4
227- xwd-1.0.4
228- wud-1.0.3
229- xclipboard-1.1.1
230- xcursorgen-1.0.4
231- xeyes-1.1.1
232- xkill-1.0.3
233- xinput-1.5.3
234- xcalc-1.0.4
235
236* Sun Nov 07 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 7.5-3
237- oclock-1.0.2
238- xlock-1.0.5
239- xconsole-1.0.4
240- luit-1.1.0
241- x11perf-1.5.2
242- xbiff-1.0.2
243- xlogo-1.0.3
244- xload-1.1.0
245- xmag-1.0.4
246- xinput-1.5.2
247- drop Patch2
248- add BuildRequires: libXi-devel
249
250* Fri Mar 26 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 7.5-2
251- luit-1.0.5
252- xeyes-1.1.0
253- xlogo-1.0.2
254- xmessage-1.0.3
255- xinput-1.5.1
256- added xcalc-1.0.3 <wishes:161>
257
258* Thu Nov 19 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.5-1
259- xclock-1.0.4
260- xwd-1.0.3
261- xwud-1.0.2
262- xpr-1.0.3
263- luit-1.0.4
264- x11perf-1.5.1
265- xclipboard-1.1.0
266- xcursorgen-1.0.3
267- xeyes-1.0.991
268- xkill-1.0.2
269- xmag-1.0.3
270- xinput-1.5.0
271
272* Wed May 20 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-3
273- xinput-1.4.2
274
275* Mon Apr 13 2009 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-2
276- xinput-1.4.1
277
278* Mon Nov 10 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.4-1
279- bump to 7.4 version
280- add xinput-1.3.0
281
282* Sat Jul 05 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-2
283- xwd 1.0.2
284- luit 1.0.3
285- x11perf 1.5
286
287* Sun May 18 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-1
288- new versioning policy
289
290* Thu Jan 17 2008 Daisuke SUZUKI <daisuke@linux.or.jp> 7.3-0vl1
291- initial build for Vine Linux
292
293* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 7.3-1
294- xconsole 1.0.3
295- xmessage 1.0.2
296- Bump to 7.3-1
297
298* Tue Aug 21 2007 Dave Airlie <airlied@redhat.com> 7.2-1
299- luit-1.0.2 xclock 1.0.3 xmag 1.0.2 xpr 1.0.2 xload 1.0.2 xcursorgen 1.0.2
300- bump to 7.2 version
301
302* Tue Jan 30 2007 Adam Jackson <ajax@redhat.com> 7.1-4
303- Fix man page globs and rebuild for FC7.
304
305* Mon Oct 2 2006 Soren Sandmann <sandmann@redhat.com> 7.1-3.fc6
306- Fix race condition in luit (Bug 197165).
307
308* Wed Jul 19 2006 Mike A. Harris <mharris@redhat.com> 7.1-2.fc6
309- Remove app-defaults dir from file manifest, as it is owned by libXt (#174021)
310- Add 'dist' tag to package release string.
311
312* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> 7.1-1.1
313- rebuild
314
315* Tue Jun 20 2006 Mike A. Harris <mharris@redhat.com> 7.1-1
316- Added xload-1.0.1-setuid.diff to fix potential security issue (#196094)
317- Artificially inflate package version-release to 7.1 to match the X11R7.1
318  release that all of the tarballs are taken from.
319- Update to xconsole-1.0.2, xcursorgen-1.0.1 from X11R7.1
320- Add temporary dependency on autoconf, automake for brew builds.
321
322* Fri May 26 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-2
323- Add more BuildRequires to fix mock builds.  (#191896)
324
325* Thu Apr 27 2006 Adam Jackson <ajackson@redhat.com> 1.0.3-1
326- Updated xclock and xconsole
327
328* Thu Mar 02 2006 Adam Jackson <ajackson@redhat.com> 1.0.2-1
329- Bump x11perf to 1.4.1 from upstream.
330
331* Fri Feb 24 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-2
332- Added luit-1.0.1-locale.alias-datadir.patch to fix bug (#181785)
333
334* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.2
335- bump again for double-long bug on ppc(64)
336
337* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> 1.0.1-1.1
338- rebuilt for new gcc4.1 snapshot and glibc changes
339
340* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 1.0.1-1
341- Upgraded all apps to version 1.0.1 from X11R7.0
342
343* Sat Dec 17 2005 Mike A. Harris <mharris@redhat.com> 1.0.0-1
344- Upgraded all apps to version 1.0.0 from X11R7 RC4.
345- Changed manpage dir from man1x to man1 to match upstream default now.
346- Dropped all of the datadir-cleanups patches added in the previous build.
347- Added x11perf-1.0.0-x11perf-datadir-cleanups.patch as it is still needed
348  to put the helper scripts in datadir.
349- Added --disable-xprint to configure, as a great symbolic jesture.
350
351* Tue Nov 22 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-4
352- Added "Requires(pre): xorg-x11-filesystem >= 0.99.2-3" to workaround
353  (#173384)
354- Added the following patches, and invoke aclocal/automake/autoconf on them
355  to force app-defaults and other datafiles into _datadir instead of _libdir:
356  - oclock-0.99.1-oclock-datadir-cleanups.patch
357  - x11perf-0.99.1-x11perf-datadir-cleanups.patch
358  - xclipboard-0.99.1-xclipboard-datadir-cleanups.patch
359  - xclock-0.99.1-xclock-datadir-cleanups.patch
360  - xconsole-0.99.2-xconsole-datadir-cleanups.patch
361  - xload-0.99.1-xload-datadir-cleanups.patch
362  - xlogo-0.99.1-xlogo-datadir-cleanups.patch
363  - xmag-0.99.1-xmag-datadir-cleanups.patch
364  - xmessage-0.99.1-xmessage-datadir-cleanups.patch
365- Added luit-0.99.1-luit-locale-dir-fix.patch to fix bug (#173702)
366
367* Mon Nov 14 2005 Jeremy Katz <katzj@redhat.com> 0.99.2-3
368- add Requires(pre) on newer filesystem package (#172610)
369
370* Sun Nov 13 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-2
371- Add "Obsoletes: XFree86, XFree86-tools, xorg-x11, xorg-x11-tools", as
372  various utils have moved here from there in monolithic X packaging.
373- Add "BuildRequires: xbitmaps-devel" for xbiff.
374- Rebuild against new libXaw 0.99.2-2, which has fixed DT_SONAME. (#173027)
375
376* Fri Nov 11 2005 Mike A. Harris <mharris@redhat.com> 0.99.2-1
377- Initial build, with all apps taken from X11R7 RC2.
378- Use "make install DESTDIR=$RPM_BUILD_ROOT" as the makeinstall macro fails on
379  some packages.
380- Temporary hack to move xcursorgen manpage to 'man1' dir.
Note: See TracBrowser for help on using the repository browser.