source: projects/specs/trunk/x/xnoise/xnoise-vl.spec @ 7638

Revision 7638, 6.8 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%define XNOISE_BIN %{_libexecdir}/%{name}
2
3Name: xnoise
4Version: 0.2.17
5Release: 1%{?_dist_release}
6Summary: Tracklist-centric Media Player
7Summary(ja): トラックリストを中心とするメディアプレーヤー
8
9Group: Applications/Multimedia
10License: GPLv2+ with exceptions
11URL: http://www.xnoise-media-player.com/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
16Source1: xnoise_ja.po
17Source10: xnoise.sh
18
19BuildRequires: pkgconfig
20BuildRequires: gettext
21BuildRequires: glib2-devel >= 2.30.0
22BuildRequires: gtk3-devel
23BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
24BuildRequires: intltool
25BuildRequires: libxml2-devel >= 2.6.32
26BuildRequires: libsoup-devel >= 2.26.0
27BuildRequires: libtaginfo-devel
28BuildRequires: perl-XML-Parser
29BuildRequires: sqlite3-devel >= 3.6
30BuildRequires: taglib-devel >= 1.6.0
31BuildRequires: unique-devel
32BuildRequires: vala-devel >= 0.16.0
33BuildRequires: desktop-file-utils gettext intltool
34Requires: hicolor-icon-theme
35Requires: libtaginfo
36# xnoise >= 0.1.14 bundles the plug-ins
37Provides: xnoise-plugins-core = %{version}-%{release}
38
39%description
40Xnoise is a Gtk+ media player with a tracklist-centric design. The
41tracklist is a list of video or music tracks that are played one by
42one without being removed (right side of window). This gives you the
43possibility to enqueue any track in any order, regardless if they are
44on the same album or not. The tracks can be reordered at any time by
45using drag and drop.
46
47
48%package devel
49Summary: Development files for %{name}
50Summary(ja): %{name} の開発ファイル
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description    devel
55The %{name}-devel package contains libraries and header files for
56developing applications that use %{name}.
57
58
59%prep
60%setup -q
61%{__cp} -f %{SOURCE1} po/ja.po
62#sed -i s/hu/hu\\nja/g po/LINGUAS
63
64%build
65%configure --enable-soundmenu2=no --disable-ubuntuone
66make %{?_smp_mflags}
67
68
69%install
70rm -rf $RPM_BUILD_ROOT
71make install DESTDIR=$RPM_BUILD_ROOT
72
73find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
74
75# remove invalid locale file
76rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
77
78## wrapper install
79%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
80%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
81%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
82
83%find_lang %{name}
84
85
86%check
87make check
88desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
89
90
91%post
92/sbin/ldconfig
93touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
94update-desktop-database &> /dev/null || :
95
96%postun
97/sbin/ldconfig
98if [ $1 -eq 0 ] ; then
99    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
100    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
101fi
102update-desktop-database &> /dev/null || :
103
104%posttrans
105gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
106
107
108%files -f %{name}.lang
109%defattr(-,root,root,-)
110%doc AUTHORS COPYING README
111%{XNOISE_BIN}
112%{_bindir}/xnoise
113%{_bindir}/xnoise_image_extractor_service
114# libxnoise.so *needs* to be in main package
115# otherwise plugins currently don't work
116%exclude %{_libdir}/xnoise/libxnoisetest.so
117%{_libdir}/xnoise
118%{_libdir}/libxnoise.so*
119%{_mandir}/man1/xnoise.1*
120%{_datadir}/xnoise
121%{_datadir}/applications/xnoise.desktop
122%{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
123%{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
124%{_datadir}/icons/hicolor/*
125%{_datadir}/icons/ubuntu-mono-*/*
126
127%files devel
128%defattr(-,root,root,-)
129%{_includedir}/xnoise
130%{_libdir}/xnoise/libxnoise*.so*
131%{_libdir}/pkgconfig/xnoise-1.0.pc
132# make package own the vala API dir:
133# xnoise plugins don't have to be written in vala
134%dir %{_datadir}/vala
135%dir %{_datadir}/vala/vapi
136%{_datadir}/vala/vapi/xnoise-1.0.*
137
138%changelog
139* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
140- new upstream release
141- updated Source1
142- changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
143  gstreamer1-plugins-base-devel >= 1.0.1
144- added BuildRequires: libtaginfo-devel
145- added Requires: libtaginfo
146- fixed Source10
147
148* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
149- new upstream release
150- updated Source1
151
152* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
153- new upstream release
154- updated Source1
155
156* Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
157- new upstream release
158- updated Source1
159
160* Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
161- new upstream release
162- updated Source1
163- deleted BuildRequires: libnotify-devel >= 0.7.0
164- changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
165
166* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
167- new upstream release
168- updated Source1
169- deleted %%configure option: --disable-magnatune
170
171* Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
172- new upstream release
173- updated Source1
174
175* Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
176- new upstream release
177- updated Source1
178- added %%configure option: --disable-magnatune
179
180* Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
181- new upstream release
182- updated Source1
183- added %%configure option: --disable-ubuntuone
184
185* Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
186- initial build for VineSeed
187
188* Wed Oct  5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
189- Update to 0.1.29
190
191* Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
192- Update to 0.1.28
193
194* Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
195- Update to 0.1.27
196
197* Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
198- Update to 0.1.26
199- Enable tests
200
201* Mon Apr  4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
202- Update to 0.1.18
203
204* Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
205- Update to 0.1.16
206- Now bundles the plugins, obsoleting xnoise-plugins-core
207
208* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
209- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
210
211* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
212- Own %%{_libdir}/xnoise for plugins
213
214* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
215- invoke ldconfig on (un)install
216- remove %%clean section; only targeting F-14+
217- re-enable deletion of invalid locale dir
218
219* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
220- Update to 0.1.12
221- Specify the correct location for Vala API files in *.pc
222
223* Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
224- Make xnoise-devel co-own Vala's VAPI dir
225- Remove invalid locale file
226
227* Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
228- Update to final 0.1.6 release
229
230* Sat Apr  3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
231- Initial package
232
Note: See TracBrowser for help on using the repository browser.