source: projects/specs/trunk/x/xnoise/xnoise-vl.spec @ 7671

Revision 7671, 7.1 KB checked in by kudoh, 11 years ago (diff)

--force-log

Line 
1%define XNOISE_BIN %{_libexecdir}/%{name}
2
3Name: xnoise
4Version: 0.2.18
5Release: 1%{?_dist_release}
6Summary: Tracklist-centric Media Player
7Summary(ja): トラックリストを中心とするメディアプレーヤー
8
9Group: Applications/Multimedia
10License: GPLv2+ with exceptions
11URL: http://www.xnoise-media-player.com/
12
13BuildRoot: %{_tmppath}/%{name}-%{version}-root
14
15Source0: http://xnoise.googlecode.com/files/xnoise-%{version}.tar.gz
16Source1: xnoise_ja.po
17Source10: xnoise.sh
18
19BuildRequires: pkgconfig
20BuildRequires: gettext
21BuildRequires: glib2-devel >= 2.30.0
22BuildRequires: gtk3-devel
23BuildRequires: gstreamer1-plugins-base-devel >= 1.0.1
24BuildRequires: intltool
25BuildRequires: libxml2-devel >= 2.6.32
26BuildRequires: libsoup-devel >= 2.26.0
27BuildRequires: libtaginfo-devel >= 0.1.6
28BuildRequires: perl-XML-Parser
29BuildRequires: sqlite3-devel >= 3.6
30BuildRequires: taglib-devel >= 1.6.0
31BuildRequires: unique-devel
32BuildRequires: vala-devel >= 0.16.0
33BuildRequires: desktop-file-utils gettext intltool
34Requires: hicolor-icon-theme
35Requires: libtaginfo >= 0.1.6
36# xnoise >= 0.1.14 bundles the plug-ins
37Provides: xnoise-plugins-core = %{version}-%{release}
38
39%description
40Xnoise is a Gtk+ media player with a tracklist-centric design. The
41tracklist is a list of video or music tracks that are played one by
42one without being removed (right side of window). This gives you the
43possibility to enqueue any track in any order, regardless if they are
44on the same album or not. The tracks can be reordered at any time by
45using drag and drop.
46
47
48%package devel
49Summary: Development files for %{name}
50Summary(ja): %{name} の開発ファイル
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
53
54%description    devel
55The %{name}-devel package contains libraries and header files for
56developing applications that use %{name}.
57
58
59%prep
60%setup -q
61%{__cp} -f %{SOURCE1} po/ja.po
62#sed -i s/hu/hu\\nja/g po/LINGUAS
63sed -i 's/Keywords=Media\;Audio\;Video\;Player\;Mediaplayer\;Movie\;MP3/&;/' \
64    data/misc/xnoise.desktop.in.in
65
66%build
67%configure --enable-soundmenu2=no
68make %{?_smp_mflags}
69
70
71%install
72rm -rf $RPM_BUILD_ROOT
73make install DESTDIR=$RPM_BUILD_ROOT
74
75find $RPM_BUILD_ROOT -name '*.la' -exec rm -f {} ';'
76
77# remove invalid locale file
78rm -rf $RPM_BUILD_ROOT%{_share}/locale/default
79
80## wrapper install
81%__mkdir_p $RPM_BUILD_ROOT%{_libexecdir}
82%__mv $RPM_BUILD_ROOT%{_bindir}/%{name} $RPM_BUILD_ROOT%{XNOISE_BIN}
83%{__install} -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/%{name}
84
85%find_lang %{name}
86
87
88%check
89make check
90desktop-file-validate $RPM_BUILD_ROOT/%{_datadir}/applications/xnoise.desktop
91
92
93%post
94/sbin/ldconfig
95touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
96update-desktop-database &> /dev/null || :
97
98%postun
99/sbin/ldconfig
100if [ $1 -eq 0 ] ; then
101    touch --no-create %{_datadir}/icons/hicolor &>/dev/null
102    gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
103fi
104update-desktop-database &> /dev/null || :
105
106%posttrans
107gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
108
109
110%files -f %{name}.lang
111%defattr(-,root,root,-)
112%doc AUTHORS COPYING README
113%{XNOISE_BIN}
114%{_bindir}/xnoise
115%{_bindir}/xnoise_image_extractor_service
116# libxnoise.so *needs* to be in main package
117# otherwise plugins currently don't work
118%exclude %{_libdir}/xnoise/libxnoisetest.so
119%{_libdir}/xnoise
120%{_libdir}/libxnoise.so*
121%{_mandir}/man1/xnoise.1*
122%{_datadir}/xnoise
123%{_datadir}/applications/xnoise.desktop
124%{_datadir}//dbus-1/services/org.gtk.xnoise.ImageExtractor.service
125%{_datadir}//dbus-1/services/org.gtk.xnoise.PlayerEngine.service
126%{_datadir}/icons/hicolor/*
127%{_datadir}/icons/ubuntu-mono-*/*
128
129%files devel
130%defattr(-,root,root,-)
131%{_includedir}/xnoise
132%{_libdir}/xnoise/libxnoise*.so*
133%{_libdir}/pkgconfig/xnoise-1.0.pc
134# make package own the vala API dir:
135# xnoise plugins don't have to be written in vala
136%dir %{_datadir}/vala
137%dir %{_datadir}/vala/vapi
138%{_datadir}/vala/vapi/xnoise-1.0.*
139
140%changelog
141* Sun May 12 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.18-1
142- new upstream release
143- updated Source1
144- changed BuildRequires: libtaginfo-devel >= 0.1.6
145- changed Rquires: libtaginfo >= 0.1.6
146- fixed desktop error
147- deleted unrecognize option: --disable-ubuntuone
148
149* Mon Apr 29 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.17-1
150- new upstream release
151- updated Source1
152- changed BuildRequires: gstreamer-plugins-base-devel >= 0.10.23 to
153  gstreamer1-plugins-base-devel >= 1.0.1
154- added BuildRequires: libtaginfo-devel
155- added Requires: libtaginfo
156- fixed Source10
157
158* Fri Feb 08 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.15-1
159- new upstream release
160- updated Source1
161
162* Fri Jan 11 2013 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.14-1
163- new upstream release
164- updated Source1
165
166* Sat Nov 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.13-1
167- new upstream release
168- updated Source1
169
170* Thu Oct 04 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.12-1
171- new upstream release
172- updated Source1
173- deleted BuildRequires: libnotify-devel >= 0.7.0
174- changed BuildRequires: vala-devel >= 0.15.0 to 0.16.0
175
176* Sat Sep 22 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.11-1
177- new upstream release
178- updated Source1
179- deleted %%configure option: --disable-magnatune
180
181* Sat Sep 08 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.9-1
182- new upstream release
183- updated Source1
184
185* Sat Aug 25 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.8-1
186- new upstream release
187- updated Source1
188- added %%configure option: --disable-magnatune
189
190* Fri Aug 10 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.5-1
191- new upstream release
192- updated Source1
193- added %%configure option: --disable-ubuntuone
194
195* Thu Aug 02 2012 Toshiharu Kudoh <toshi.kd2@gmail.com> - 0.2.4-1
196- initial build for VineSeed
197
198* Wed Oct  5 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.29-1
199- Update to 0.1.29
200
201* Wed Sep 21 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.28-1
202- Update to 0.1.28
203
204* Sat Sep 10 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.27-1
205- Update to 0.1.27
206
207* Thu Jul 28 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.26-1
208- Update to 0.1.26
209- Enable tests
210
211* Mon Apr  4 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.18-1
212- Update to 0.1.18
213
214* Sun Mar 13 2011 Michel Salim <salimma@fedoraproject.org> - 0.1.16-1
215- Update to 0.1.16
216- Now bundles the plugins, obsoleting xnoise-plugins-core
217
218* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.12-4
219- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
220
221* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-3
222- Own %%{_libdir}/xnoise for plugins
223
224* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-2
225- invoke ldconfig on (un)install
226- remove %%clean section; only targeting F-14+
227- re-enable deletion of invalid locale dir
228
229* Sat Nov  6 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.12-1
230- Update to 0.1.12
231- Specify the correct location for Vala API files in *.pc
232
233* Fri Jun 25 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-2
234- Make xnoise-devel co-own Vala's VAPI dir
235- Remove invalid locale file
236
237* Wed Jun 23 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.6-1
238- Update to final 0.1.6 release
239
240* Sat Apr  3 2010 Michel Salim <salimma@fedoraproject.org> - 0.1.2-0.1.331hg
241- Initial package
242
Note: See TracBrowser for help on using the repository browser.