source: projects/specs/trunk/x/xmoto/xmoto-vl.spec @ 10570

Revision 10570, 8.1 KB checked in by Takemikaduchi, 8 years ago (diff)

rebuild with gcc-5.4.0

Line 
1Name:           xmoto
2Version:        0.5.11
3Release:        2%{?_dist_release}
4Summary:        Challenging 2D Motocross Platform Game
5Summary(ja):    2D 画面のアクロバティックなモトクロスゲーム
6
7Group:          Applications/Games
8License:        GPLv2+
9URL:            http://xmoto.sourceforge.net/
10Source0:        http://download.tuxfamily.org/xmoto/xmoto/%{version}/xmoto-%{version}-src.tar.gz
11Source1:        xmoto.desktop
12Source2:        xmoto.png
13Source3:        xmoto-0.5.4-ja.po
14#Patch0:                xmoto-man.patch
15Patch1:         xmoto-0.3.4-Environment-cstlib.patch
16#Patch2:                xmoto-0.3.4-Scene-collisioninclude.patch
17Patch3:         xmoto-0.4.0-Environment-string.patch
18#Patch4:                xmoto-0.4.0-DrawLib-hashmap.patch
19#Patch5:                xmoto-0.4.2-initode.patch
20#Patch6:                xmoto-0.4.2-opengldepth.patch
21Patch7:         xmoto-0.5.0-xmargs-include.patch
22Patch8:         xmoto-0.5.0-helpers-text-includes.patch
23Patch9:         xmoto-0.5.0-helpers-log-include.patch
24#Patch10:       xmoto-0.5.2-x86-64.patch
25BuildRoot:      %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
26
27BuildRequires:  desktop-file-utils
28BuildRequires:  SDL_mixer-devel
29BuildRequires:  SDL_ttf-devel
30BuildRequires:  curl-devel
31BuildRequires:  ode-devel
32BuildRequires:  lua-devel
33BuildRequires:  libGL-devel
34BuildRequires:  libGLU-devel
35BuildRequires:  libjpeg-devel
36BuildRequires:  libpng-devel
37BuildRequires:  libxml2-devel
38BuildRequires:  bzip2-devel
39BuildRequires:  sqlite3-devel
40BuildRequires:  SDL_net-devel
41BuildRequires:  libxdg-basedir-devel
42Requires:       TrueType-vlgothic
43
44Packager:       kazutaka
45
46%description
47X-Moto is a challenging 2D motocross platform game, where physics play an all
48important role in the gameplay. You need to control your bike to its limit, if
49you want to have a chance finishing the more difficult of the challenges.
50
51First you'll try just to complete the levels, while later you'll compete with
52yourself and others, racing against the clock.
53
54%description -l ja
55X-Moto はアクロバティックな 2D 画面のモトクロスゲームです。
56このゲームでは重力を上手に利用することがとても重要になります。
57また、難易度の高い面を攻略するには、バイクの特性の限界ギリギリ
58までコントルールする必要があります。
59
60最初は各面を攻略するところから始まりますが、全ての面をクリア
61した後もタイムトライアルに挑戦できます。
62
63
64%prep
65%setup -q
66#%patch
67%patch1 -p0
68#%patch2 -p0
69%patch3 -p0
70#%patch4 -p0
71#%patch5 -p1
72#%patch6 -p0
73%patch7 -p0
74%patch8 -p0
75%patch9 -p0
76#%patch10 -p0
77
78#fix encoding
79sed -i 's/\r//' src/xmscene/Camera.cpp
80sed -i 's/\r//' src/xmscene/Camera.h
81
82#fix permissions
83chmod 644 src/xmscene/Camera.*
84chmod -x src/*.cpp
85chmod -x src/*.h
86chmod -x src/*/*.cpp
87chmod -x src/*/*.h
88chmod -x src/*/*/*.cpp
89chmod -x src/*/*/*.h
90
91%build
92%configure --with-enable-zoom=1
93make
94
95
96%install
97rm -rf $RPM_BUILD_ROOT
98make install DESTDIR=$RPM_BUILD_ROOT
99
100# Install icon and desktop file
101mkdir -p $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
102cp %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/icons/hicolor/48x48/apps
103
104desktop-file-install --vendor vine \
105                     --dir $RPM_BUILD_ROOT%{_datadir}/applications \
106                     --add-category X-Fedora %{SOURCE1}
107
108# use vlgothic as default font
109rm $RPM_BUILD_ROOT%{_datadir}/xmoto/Textures/Fonts/DejaVuSans.ttf
110ln -s ../../../fonts/TrueType-vlgothic/VL-PGothic-Regular.ttf $RPM_BUILD_ROOT%{_datadir}/xmoto/Textures/Fonts/DejaVuSans.ttf
111
112# install japanese translation
113%{__mkdir} -p ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES
114msgfmt %{SOURCE3} -o ${RPM_BUILD_ROOT}/%{_localedir}/ja/LC_MESSAGES/%{name}.mo
115
116# Locale files
117%find_lang %{name} %{name}.lang
118
119%clean
120rm -rf $RPM_BUILD_ROOT
121
122
123%post
124touch --no-create %{_datadir}/icons/hicolor || :
125if [ -x %{_bindir}/gtk-update-icon-cache ]; then
126 %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
127fi
128
129%postun
130touch --no-create %{_datadir}/icons/hicolor || :
131if [ -x %{_bindir}/gtk-update-icon-cache ]; then
132 %{_bindir}/gtk-update-icon-cache --quiet %{_datadir}/icons/hicolor || :
133fi
134
135%files -f %{name}.lang
136%defattr(-,root,root,-)
137%doc ChangeLog COPYING README
138%{_bindir}/xmoto
139%{_datadir}/xmoto
140%{_datadir}/applications/vine-xmoto.desktop
141%{_datadir}/icons/hicolor/48x48/apps/xmoto.png
142%{_mandir}/man6/xmoto.6.gz
143
144%changelog
145* Sat Jul 09 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-2
146- rebuild with gcc-5.4.0
147
148* Sun Dec 07 2014 Yoji TOYODA <bsyamato@sea.plala.or.jp> 0.5.11-1
149- update to 0.5.11
150- add BuildRequires: libxml2-devel
151
152* Fri Jan 07 2011 Kazutaka HARADA <kazutaka@vinelinux.org> 0.5.4-1
153- initial build for Vine Linux based on fedora development
154- add Source3: japanese translation
155
156* Mon Dec 13 2010 Jon Ciesla <limb@jcomserv.net> 0.5.4-1
157- New upstream.
158
159* Tue May 04 2010 Jon Ciesla <limb@jcomserv.net> 0.5.3-1
160- New upstream.
161- Dropped upstreamed x86-64 patch.
162
163* Mon Dec 07 2009 Jon Ciesla <limb@jcomserv.net> 0.5.2-1.1
164- EVR bump for fix CVS tagging snafu.
165
166* Sun Dec 06 2009 Howard Liberty <liberty@live.com> 0.5.2-1
167- New upstream.
168- Add x86-64 patch so it can be compiled in x86-64 enviroment.
169
170* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-1
171- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
172
173* Tue Apr 14 2009 Jon Ciesla <limb@jcomserv.net> 0.5.1-0
174- New upstream.
175- Dropped opengldepth patch, applied upstream.
176
177* Mon Feb 23 2009 Jon Ciesla <limb@jcomserv.net> 0.5.0-6
178- Patch for includes.
179
180* Mon Feb 02 2009 Jon Ciesla <limb@jcomserv.net> 0.5.0-5
181- Fix for ati crash, BZ 481485.
182
183* Tue Jan 20 2009 Jon Ciesla <limb@jcomserv.net> 0.5.0-4
184- Font requires change for BZ 480480, dejavu rename.
185
186* Tue Dec 30 2008 Jon Ciesla <limb@jcomserv.net> 0.5.0-3
187- Symlink to system font, BZ 477485.
188- Dropped extension from icon in .desktop.
189
190* Wed Dec 10 2008 Jon Ciesla <limb@jcomserv.net> 0.5.0-2
191- No remaining fuzzy patches, dropping patch fuzz workaround.
192
193* Mon Dec 01 2008 Jon Ciesla <limb@jcomserv.net> 0.5.0-1
194- Update to 0.5.0.
195
196* Wed Oct 15 2008 Hans de Goede <hdegoede@redhat.com> 0.4.2-4
197- Fix crash caused by using new ode (bz 466738)
198
199* Tue Sep 30 2008 Jon Ciesla <limb@jcomserv.net> 0.4.2-3
200- Patch for new ode version.
201
202* Fri Sep 12 2008 Jon Ciesla <limb@jcomserv.net> 0.4.2-2
203- Introducted patch fuzz workaround, will fix.
204
205* Tue Mar 18 2008 Jon Ciesla <limb@jcomserv.net> 0.4.2-1
206- Update to 0.4.2.
207- Dropping xmoto-man patch.
208
209* Wed Feb 13 2008 Jon Ciesla <limb@jcomserv.net> 0.4.1-1
210- Update to 0.4.1.
211- Dropped subversion BR.
212
213* Mon Feb 11 2008 Jon Ciesla <limb@jcomserv.net> 0.4.0-1
214- Update to 0.4.0.
215- Dropped unneeded patches.
216- Added string patch, hash_map, inline(jwrdegoede) patch.
217- BRed subversion.
218
219* Tue Jan 08 2008 Jon Ciesla <limb@jcomserv.net> 0.3.4-2
220- Added cstdlib, include extra tokens patches.
221- GCC 4.3 rebuild.
222
223* Thu Oct 25 2007 Jon Ciesla <limb@jcomserv.net> 0.3.4-1
224- Bumped to 0.3.4.
225
226* Mon Sep 24 2007 Jon Ciesla <limb@jcomserv.net> 0.3.3-2
227- Patches from upstream to correct BZ 295981.
228
229* Wed Aug 29 2007 Jon Ciesla <limb@jcomserv.net> 0.3.3-1
230- Bumped to upstream.
231- Fixed URL.
232
233* Thu Aug 16 2007 Jon Ciesla <limb@jcomserv.net> 0.3.1-2
234- License tag correction.
235
236* Mon Jul 09 2007 Jon Ciesla <limb@jcomserv.net> 0.3.1-1
237- Bumped to upstream, BZ 247445.
238
239* Wed Jun 20 2007 Jon Ciesla <limb@jcomserv.net> 0.3.0-1
240- Bumped to upstream.
241
242* Mon Mar 19 2007 Jon Ciesla <limb@jcomserv.net> 0.2.7-1
243- Bumped to upstream, fixed man issues.
244
245* Fri Mar 16 2007 Jon Ciesla <limb@jcomserv.net> 0.2.6-2
246- Bumped release, build mistake.
247
248* Fri Mar 16 2007 Jon Ciesla <limb@jcomserv.net> 0.2.6-1
249- New upstream release.
250- Removed Application from .desktop.
251- Spec cleanup.
252- Fixed man path with patch.
253- Removed X-Fedora.
254
255* Wed Feb 28 2007 Jon Ciesla <limb@jcomserv.net> 0.2.4-1
256- New upstream release
257- xmoto-edit now seperate from base xmoto
258
259* Mon Nov 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.2.2-2
260- Added again the debuginfo package (it's working)
261
262* Sun Nov 12 2006 Hugo Cisneiros <hugo@devin.com.br> 0.2.2-1
263- New upstream release
264
265* Mon Nov  6 2006 Jindrich Novy <jnovy@redhat.com> 0.2.0-2
266- Rebuild against the new curl
267
268* Wed Sep 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.2.0-1
269- New upstream release
270
271* Wed Sep 13 2006 Hugo Cisneiros <hugo@devin.com.br> 0.1.16-2
272- Rebuilt for FC6
273
274* Wed Jul  5 2006 Hugo Cisneiros <hugo@devin.com.br> 0.1.16-1
275- Initial RPM release
Note: See TracBrowser for help on using the repository browser.