source: projects/specs/trunk/x/xmonad-contrib/xmonad-contrib-vl.spec @ 11992

Revision 11992, 3.2 KB checked in by ara_t, 5 years ago (diff)

xmobar/xmonad: update/build with ghc-8.6.3

RevLine 
[10170]1%define pkg_name    xmonad-contrib
[11992]2%define pkg_version 0.15
3%define pkg_release 1%{?_dist_release}
[10170]4
5Summary:     Third party extensions for xmonad
6Summary(ja): サードパーティーによるxmonad拡張
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
[11632]15Source0: packages
[10170]16
[11763]17# # Patch for building ghc-8.4
18# Source1: xmonad-contrib-0.13_using_ghc-8.4.patch
[11632]19
[10916]20Source11: X11-xft-0.3.1.tar.gz
[11632]21Source12: X11-xft.cabal
22Source13: old-time-1.1.0.3.tar.gz
23Source14: old-time.cabal
[11992]24Source15: xmonad-contrib-0.15.tar.gz
25Source16: xmonad-contrib.cabal
[10170]26
27BuildRoot: %{_tmppath}/%{name}-%{version}-root
28
[10916]29BuildRequires: ghc haskell-platform
[10170]30BuildRequires: xmonad
31
32BuildRequires: libffi-devel gmp-devel zlib-devel
33BuildRequires: xorg-x11-devel
[11763]34BuildRequires: libXScrnSaver-devel
[10170]35BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
36
[11632]37Requires: haskell-platform-dep
[11763]38Requires: libXScrnSaver-devel
[10170]39Requires: xmonad
40
41Vendor: Project Vine
42Distribution: Vine Linux
[10916]43Packager: ara_t
[10170]44
[11632]45
[10170]46%description
47Third party tiling algorithms, configurations and scripts to xmonad,
48 a tiling window manager for X.
49
50%description -l ja
51サードパーティーによるxmonad拡張であり、
52タイル化のためのアルゴリズム、設定およびスクリプトを含みます。
53
54
55%prep
56%{__rm} -rf ${RPM_BUILD_ROOT}
57
58%build
[11632]59%ghc_pkg_init
[10170]60
61cd %{_builddir}
[11632]62for pkg in `cat %{SOURCE0}`; do
63    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
64    pushd ${pkg}
65        %ghc_fix_dependencies ${pkg}
66        %cabal_configure2 %{name} ${pkg}
67        %cabal_build
68        %cabal_haddock
69        %cabal_copy_resister %{name}_${pkg}
70    popd
[10170]71done
72
73
74%install
[11632]75# copy documents
76pushd %{_builddir}/%{name}-%{version}
77    %{__cp} CHANGES.md LICENSE README.md \
78     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
79popd
[10170]80
[11632]81
[10170]82%clean
83%{__rm} -rf ${RPM_BUILD_ROOT}
84
85%post
[11632]86%ghc_pkg_recache
[10170]87
88%postun
[11632]89%ghc_pkg_recache
[10170]90
91
92%files
93%defattr(-, root, root)
94%{_libdir}/ghc-%{ghc_version}/
95%{_libdir}/ghc-lib/
[10236]96%{_docdir}/%{name}/
[10170]97
98
99%changelog
[11992]100* Mon Dec 17 2018 Toshiaki Ara <ara_t@384.jp> 0.15-1
101- update to 0.15
102- build using ghc-8.6.3
103
[11763]104* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-2
105- add BuildRequires: and Requires: libXScrnSaver-devel
106
107* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-1
108- update to 0.14
109- build using ghc-8.4.3-2
110- drop Source1
111
[11746]112* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.13-4
113- build using ghc-8.4.3
114
[11632]115* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.13-3
116- rebuild using ghc-8.4.2
117- add Patch for building with ghc-8.4 (Source1)
118- rewrite using macro
119
120* Thu May 10 2018 Toshiaki Ara <ara_t@384.jp> 0.13-2
121- rebuild using ghc-8.4.2
122
[11384]123* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.13-1
124- update to 0.13
125- rebuild using ghc-8.0.2
126
[10916]127* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.12-6
128- rebuild using ghc-8.0.1
129
[10236]130* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.12-5
131- rebuilt
132
[10170]133* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.12-4
134- rebuild under xmonad-0.12-3
135- correct SPEC file
136
137* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.12-3
138- rebuild under xmonad-0.12-2
139
140* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-2
141- recompile
142
143* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-1
144- new package
Note: See TracBrowser for help on using the repository browser.