source: projects/specs/trunk/x/xmonad-contrib/xmonad-contrib-vl.spec @ 11763

Revision 11763, 3.2 KB checked in by ara_t, 6 years ago (diff)

xmonad-*/xmobar: rebuild with ghc-8.4.3-2

Line 
1%define pkg_name    xmonad-contrib
2%define pkg_version 0.14
3%define pkg_release 2%{?_dist_release}
4
5Summary:     Third party extensions for xmonad
6Summary(ja): サードパーティーによるxmonad拡張
7Name:    %{pkg_name}
8Version: %{pkg_version}
9Release: %{pkg_release}
10
11License: BSD3
12Group:   User Interface/Desktops
13URL:     http://hackage.haskell.org
14
15Source0: packages
16
17# # Patch for building ghc-8.4
18# Source1: xmonad-contrib-0.13_using_ghc-8.4.patch
19
20Source11: X11-xft-0.3.1.tar.gz
21Source12: X11-xft.cabal
22Source13: old-time-1.1.0.3.tar.gz
23Source14: old-time.cabal
24Source15: random-1.1.tar.gz
25Source16: random.cabal
26Source17: xmonad-contrib-0.14.tar.gz
27Source18: xmonad-contrib.cabal
28
29BuildRoot: %{_tmppath}/%{name}-%{version}-root
30
31BuildRequires: ghc haskell-platform
32BuildRequires: xmonad
33
34BuildRequires: libffi-devel gmp-devel zlib-devel
35BuildRequires: xorg-x11-devel
36BuildRequires: libXScrnSaver-devel
37BuildRequires: docbook-utils docbook-utils-pdf docbook-style-xsl
38
39Requires: haskell-platform-dep
40Requires: libXScrnSaver-devel
41Requires: xmonad
42
43Vendor: Project Vine
44Distribution: Vine Linux
45Packager: ara_t
46
47
48%description
49Third party tiling algorithms, configurations and scripts to xmonad,
50 a tiling window manager for X.
51
52%description -l ja
53サードパーティーによるxmonad拡張であり、
54タイル化のためのアルゴリズム、設定およびスクリプトを含みます。
55
56
57%prep
58%{__rm} -rf ${RPM_BUILD_ROOT}
59
60%build
61%ghc_pkg_init
62
63cd %{_builddir}
64for pkg in `cat %{SOURCE0}`; do
65    %{__tar} xzf %{_sourcedir}/${pkg}.tar.gz
66    pushd ${pkg}
67        %ghc_fix_dependencies ${pkg}
68        %cabal_configure2 %{name} ${pkg}
69        %cabal_build
70        %cabal_haddock
71        %cabal_copy_resister %{name}_${pkg}
72    popd
73done
74
75
76%install
77# copy documents
78pushd %{_builddir}/%{name}-%{version}
79    %{__cp} CHANGES.md LICENSE README.md \
80     ${RPM_BUILD_ROOT}%{_docdir}/%{name}/%{name}-%{version}
81popd
82
83
84%clean
85%{__rm} -rf ${RPM_BUILD_ROOT}
86
87%post
88%ghc_pkg_recache
89
90%postun
91%ghc_pkg_recache
92
93
94%files
95%defattr(-, root, root)
96%{_libdir}/ghc-%{ghc_version}/
97%{_libdir}/ghc-lib/
98%{_docdir}/%{name}/
99
100
101%changelog
102* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-2
103- add BuildRequires: and Requires: libXScrnSaver-devel
104
105* Wed Aug 08 2018 Toshiaki Ara <ara_t@384.jp> 0.14-1
106- update to 0.14
107- build using ghc-8.4.3-2
108- drop Source1
109
110* Fri Jul 20 2018 Toshiaki Ara <ara_t@384.jp> 0.13-4
111- build using ghc-8.4.3
112
113* Fri May 18 2018 Toshiaki Ara <ara_t@384.jp> 0.13-3
114- rebuild using ghc-8.4.2
115- add Patch for building with ghc-8.4 (Source1)
116- rewrite using macro
117
118* Thu May 10 2018 Toshiaki Ara <ara_t@384.jp> 0.13-2
119- rebuild using ghc-8.4.2
120
121* Tue Jan 09 2018 Toshiaki Ara <ara_t@384.jp> 0.13-1
122- update to 0.13
123- rebuild using ghc-8.0.2
124
125* Fri Feb 03 2017 Toshiaki Ara <ara_t@384.jp> 0.12-6
126- rebuild using ghc-8.0.1
127
128* Wed May 04 2016 Toshiaki Ara <ara_t@384.jp> 0.12-5
129- rebuilt
130
131* Tue Apr 12 2016 Toshiaki Ara <ara_t@384.jp> 0.12-4
132- rebuild under xmonad-0.12-3
133- correct SPEC file
134
135* Tue Mar 01 2016 Toshiaki Ara <ara_t@384.jp> 0.12-3
136- rebuild under xmonad-0.12-2
137
138* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-2
139- recompile
140
141* Sat Feb 27 2016 Toshiaki Ara <ara_t@384.jp> 0.12-1
142- new package
Note: See TracBrowser for help on using the repository browser.