source: projects/specs/trunk/x/xlockmore/xlockmore-vl.spec @ 521

Revision 521, 7.4 KB checked in by daisuke, 14 years ago (diff)

import VineSeed package specs

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.29.1
9%define release 2%{?_dist_release}
10
11Summary: An X terminal locking program.
12Name: %{name}
13Version: %{version}
14Release: %{release}
15License: MIT
16Group: Amusements/Graphics
17Url: http://www.tux.org/~bagleyd/xlockmore.html
18Source0: ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/xlockmore-%{version}.tar.bz2
19Source1: m-redhat.xpm
20Source2: m-redhat.xbm
21Source3: s-redhat.xpm
22Source4: s-redhat.xbm
23Source5: xlock.pamd
24Patch0: xlockmore-5.02-sounddir.patch
25BuildPrereq: esound-devel, audiofile-devel
26Requires: pam >= 0.59, esound, audiofile, fortune-mod
27BuildRequires: flex
28BuildRequires: pam-devel
29BuildRequires: libX11-devel
30BuildRequires: libXt-devel
31BuildRequires: libXinerama-devel
32BuildRequires: libXext-devel
33%{?withgl:Requires: Mesa, gle}
34%{?withgl:BuildPreReq: Mesa-devel, gle-devel}
35%{?withgl:Provides: xlockmore}
36Conflicts: %{orgname}%{!?withgl:_gl}
37Buildroot: %{_tmppath}/%{name}-%{version}-root
38
39Vendor: Project Vine
40Distribution: Vine Linux
41
42%define gldesc %{?withgl:This package has MesaGL feature.}
43
44%define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
45
46%description
47The xlockmore utility is an enhanced version of the standard xlock
48program, which allows you to lock an X session so that other users
49can't access it.  Xlockmore runs a provided screensaver until you type
50in your password.
51
52Install the xlockmore package if you need a locking program to secure
53X sessions.
54
55%{gldesc}
56
57%description
58xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
59X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
60セスできないようにします.
61
62%{gldescja}
63
64%prep
65%setup -q -n %{orgname}-%{version}
66%patch0 -p1 -b .sounddir
67
68cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
69cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
70cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
71cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
72cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
73cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
74
75%build
76#autoconf-2.13
77
78%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
79%define glflag %{?withgl:--with-mesa --with-gltt}
80
81#%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
82#    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
83#    --with-esound %{glflag} %{nglflag}
84%configure --without-motif --without-gtk --without-gtk2 --enable-pam --with-esound %{glflag} %{nglflag}
85
86make
87
88# recompile xlockgen for each architecture
89make -C etc/genlauncher xlockgen
90
91%install
92rm -rf %{buildroot}
93mkdir -p %{buildroot}/etc/pam.d
94#%%makeinstall \
95#       exec_prefix=%{buildroot}/usr/X11R6/ \
96#       bindir=%{buildroot}/usr/X11R6/bin \
97#       mandir=%{buildroot}/usr/X11R6/man/man1 \
98#       xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  \
99#       INSTPGMFLAGS="-m 755"
100
101%makeinstall \
102        mandir=%{buildroot}%{_mandir}/man1 \
103        xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/  \
104        INSTPGMFLAGS="-m 755"
105
106install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
107
108mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
109install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
110
111(cd etc
112sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
113mv xlock.tcl.new xlock.tcl
114# chmod +x xlock.tcl
115)
116
117# eliminate executable bit in %doc
118find etc/ -type f -perm +111 | xargs -r chmod -x
119
120%clean
121rm -rf %{buildroot}
122
123%files
124%defattr(-,root,root)
125%doc README docs/ etc/
126%attr(4111,root,root)%{_bindir}/xlock
127%config %{_sysconfdir}/pam.d/xlock
128%config %{_datadir}/X11/app-defaults/XLock
129%{_datadir}/sounds/xlockmore/
130%{_mandir}/man1/xlock.*
131
132%changelog
133* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
134- add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
135- fix xlock.pamd (required pam_unix.so -> include system-auth)
136
137* Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
138- new upstream release
139- add configure option: --without-gtk2
140- add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
141- fixed xlock.pamd (pam_stack.so -> pam_unix.so)
142- comment out: autoconf-2.13
143
144* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
145- applied new versioning policy, spec in utf-8
146- fixed autoconf version
147- modified install directories
148
149* Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
150- updated to current stable release 5.03
151- use %%configure, %%makeinstall
152- added patch for DEFALUT_SOUND_DIR
153
154* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
155- typo fixed: --without-mesagl -> --without-mesa
156
157* Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
158- add Conflicts tag
159
160* Fri Aug 17 2001 <sagami@vinelinux.org>
161- 5.01.2-0vl1: bump up release
162
163* Wed Jul 18 2001 <sagami@vinelinux.org>
164- 5.01.2-0vl0: updated to current stable release 5.01.2
165
166* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
167- bug fix for withgl option
168
169* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
170- bug fix in Provides for withgl
171- build with gle
172
173* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
174- added switch withgl
175
176* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
177- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
178  for each architecture (to resolve unmet dependency)
179
180* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
181- 4.17.2-0vl4
182- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
183
184* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
185- build on gcc-2.95.3
186- partialy used rpmmacros
187
188* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
189- change filedepend to package name depend
190
191* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
192- 4.17.2-0vl1
193
194* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
195- 4.17.1-0vl1
196- upgrade and build without GL
197- added docs etc
198
199* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
200- wmconfig gone.
201
202* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
203- handle compressed man pages
204
205* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
206- fun with GL
207
208* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
209- update to 4.15
210
211* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
212- update to 4.13.1
213
214* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
215- auto rebuild in the new build environment (release 2)
216
217* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
218- update to 4.12
219
220* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
221- take out some modules to avoid TMv
222
223* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
224- turned PAM support on in ./configure
225
226* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
227- Upgraded to 4.11
228
229* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
230- translations modified for de, fr, tr
231
232* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
233- upgraded to 4.09
234- removed Michael's PAM patch (it's now available in the sources)
235
236* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
237- upgrade to 4.05
238- add wmconfig
239
240* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
241- Upgraded to 4.04
242- Changed pam to new conventions
243- Use configure instead of imake
244- buildroot
245
246* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
247- built against glibc
248
249* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
250- moved from pam.conf to pam.d
251
Note: See TracBrowser for help on using the repository browser.