source: projects/specs/trunk/x/xlockmore/xlockmore-vl.spec @ 10581

Revision 10581, 8.3 KB checked in by Takemikaduchi, 8 years ago (diff)

xlockmore: new upstream release
others: rebuild with gcc-5.4.0

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.47
9%define release 1%{?_dist_release}
10
11Summary: An X terminal locking program.
12Summary(ja): X 端末をロックするためのプログラム
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: MIT
17Group: User Interface/X
18URL: http://www.tux.org/~bagleyd/xlockmore.html
19Source0: http://www.tux.org/~bagleyd/xlock/xlockmore-%{version}/xlockmore-%{version}.tar.xz
20Source1: m-redhat.xpm
21Source2: m-redhat.xbm
22Source3: s-redhat.xpm
23Source4: s-redhat.xbm
24Source5: xlock.pamd
25Patch0: xlockmore-5.02-sounddir.patch
26BuildRequires: audiofile-devel
27Requires: pam >= 0.59, audiofile, fortune-mod
28Requires: xorg-x11-jpfonts
29BuildRequires: flex
30BuildRequires: pam-devel
31BuildRequires: libX11-devel
32BuildRequires: libXt-devel
33BuildRequires: libXinerama-devel
34BuildRequires: libXext-devel
35%{?withgl:BuildRequires: libGLU-devel}
36%{?withgl:Provides: xlockmore}
37BuildRequires: gtk2-devel
38
39Conflicts: %{orgname}%{!?withgl:_gl}
40Buildroot: %{_tmppath}/%{name}-%{version}-root
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%define gldesc %{?withgl:This package has MesaGL feature.}
46
47%define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
48
49%description
50The xlockmore utility is an enhanced version of the standard xlock
51program, which allows you to lock an X session so that other users
52can't access it.  Xlockmore runs a provided screensaver until you type
53in your password.
54
55Install the xlockmore package if you need a locking program to secure
56X sessions.
57
58%{gldesc}
59
60%description -l ja
61xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
62X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
63セスできないようにします.
64
65%{gldescja}
66
67%prep
68%setup -q -n %{orgname}-%{version}
69%patch0 -p1 -b .sounddir
70
71cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
72cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
73cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
74cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
75cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
76cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
77
78sed -i 's|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG)|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG) -laudiofile|' modes/Makefile.in
79
80%build
81#autoconf-2.13
82
83%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
84%define glflag %{?withgl:--with-mesa --with-gltt}
85
86#%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
87#    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
88#    --with-esound %{glflag} %{nglflag}
89
90%configure --without-motif --without-gtk --without-gtk2 --enable-pam --without-esound %{glflag} %{nglflag}
91
92make
93
94# recompile xlockgen for each architecture
95make -C etc/genlauncher xlockgen
96
97%install
98rm -rf %{buildroot}
99mkdir -p %{buildroot}/etc/pam.d
100#%%makeinstall \
101#       exec_prefix=%{buildroot}/usr/X11R6/ \
102#       bindir=%{buildroot}/usr/X11R6/bin \
103#       mandir=%{buildroot}/usr/X11R6/man/man1 \
104#       xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  \
105#       INSTPGMFLAGS="-m 755"
106
107%makeinstall \
108        mandir=%{buildroot}%{_mandir}/man1 \
109        xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/  \
110        INSTPGMFLAGS="-m 755"
111
112install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
113
114mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
115install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
116
117(cd etc
118sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
119mv xlock.tcl.new xlock.tcl
120# chmod +x xlock.tcl
121)
122
123# eliminate executable bit in %doc
124find etc/ -type f -perm +111 | xargs -r chmod -x
125
126%clean
127rm -rf %{buildroot}
128
129%files
130%defattr(-,root,root)
131%doc README docs/ etc/
132%attr(4111,root,root)%{_bindir}/xlock
133%config %{_sysconfdir}/pam.d/xlock
134%config %{_datadir}/X11/app-defaults/XLock
135%{_datadir}/sounds/xlockmore/
136%{_mandir}/man1/xlock.*
137
138%changelog
139* Sun Jul 10 2016 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.47-1
140- new upstream release
141- remove BuildRequires: esound-devel
142
143* Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.45-1
144- new upstream release
145
146* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.32-1
147- new upstream release
148- add Requires: xorg-x11-jpfonts
149- add BuildRequires: gtk2-devel
150
151* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.31-2
152- changed Group to User Interface/X
153- added Japanese summary
154
155* Sat Jul 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.31-1
156- new upstream release
157
158* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.29.1-3
159- rebuilt with ftgl-2.1.3-1.rc5
160
161* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
162- add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
163- fix xlock.pamd (required pam_unix.so -> include system-auth)
164
165* Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
166- new upstream release
167- add configure option: --without-gtk2
168- add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
169- fixed xlock.pamd (pam_stack.so -> pam_unix.so)
170- comment out: autoconf-2.13
171
172* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
173- applied new versioning policy, spec in utf-8
174- fixed autoconf version
175- modified install directories
176
177* Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
178- updated to current stable release 5.03
179- use %%configure, %%makeinstall
180- added patch for DEFALUT_SOUND_DIR
181
182* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
183- typo fixed: --without-mesagl -> --without-mesa
184
185* Sat Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
186- add Conflicts tag
187
188* Fri Aug 17 2001 <sagami@vinelinux.org>
189- 5.01.2-0vl1: bump up release
190
191* Wed Jul 18 2001 <sagami@vinelinux.org>
192- 5.01.2-0vl0: updated to current stable release 5.01.2
193
194* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
195- bug fix for withgl option
196
197* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
198- bug fix in Provides for withgl
199- build with gle
200
201* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
202- added switch withgl
203
204* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
205- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
206  for each architecture (to resolve unmet dependency)
207
208* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
209- 4.17.2-0vl4
210- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
211
212* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
213- build on gcc-2.95.3
214- partialy used rpmmacros
215
216* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
217- change filedepend to package name depend
218
219* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
220- 4.17.2-0vl1
221
222* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
223- 4.17.1-0vl1
224- upgrade and build without GL
225- added docs etc
226
227* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
228- wmconfig gone.
229
230* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
231- handle compressed man pages
232
233* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
234- fun with GL
235
236* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
237- update to 4.15
238
239* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
240- update to 4.13.1
241
242* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
243- auto rebuild in the new build environment (release 2)
244
245* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
246- update to 4.12
247
248* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
249- take out some modules to avoid TMv
250
251* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
252- turned PAM support on in ./configure
253
254* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
255- Upgraded to 4.11
256
257* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
258- translations modified for de, fr, tr
259
260* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
261- upgraded to 4.09
262- removed Michael's PAM patch (it's now available in the sources)
263
264* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
265- upgrade to 4.05
266- add wmconfig
267
268* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
269- Upgraded to 4.04
270- Changed pam to new conventions
271- Use configure instead of imake
272- buildroot
273
274* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
275- built against glibc
276
277* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
278- moved from pam.conf to pam.d
279
Note: See TracBrowser for help on using the repository browser.