source: projects/specs/trunk/x/xlockmore/xlockmore-vl.spec @ 2415

Revision 2415, 7.9 KB checked in by Takemikaduchi, 13 years ago (diff)

new upstream release

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.32
9%define release 1%{?_dist_release}
10
11Summary: An X terminal locking program.
12Summary(ja): X 端末をロックするためのプログラム
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: MIT
17Group: User Interface/X
18URL: http://www.tux.org/~bagleyd/xlockmore.html
19Source0: http://www.tux.org/~bagleyd/xlock/xlockmore-%{version}/xlockmore-%{version}.tar.bz2
20Source1: m-redhat.xpm
21Source2: m-redhat.xbm
22Source3: s-redhat.xpm
23Source4: s-redhat.xbm
24Source5: xlock.pamd
25Patch0: xlockmore-5.02-sounddir.patch
26BuildRequires: esound-devel, audiofile-devel
27Requires: pam >= 0.59, esound, audiofile, fortune-mod
28Requires: xorg-x11-jpfonts
29BuildRequires: flex
30BuildRequires: pam-devel
31BuildRequires: libX11-devel
32BuildRequires: libXt-devel
33BuildRequires: libXinerama-devel
34BuildRequires: libXext-devel
35%{?withgl:BuildRequires: libGLU-devel}
36%{?withgl:Provides: xlockmore}
37BuildRequires: gtk2-devel
38
39Conflicts: %{orgname}%{!?withgl:_gl}
40Buildroot: %{_tmppath}/%{name}-%{version}-root
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%define gldesc %{?withgl:This package has MesaGL feature.}
46
47%define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
48
49%description
50The xlockmore utility is an enhanced version of the standard xlock
51program, which allows you to lock an X session so that other users
52can't access it.  Xlockmore runs a provided screensaver until you type
53in your password.
54
55Install the xlockmore package if you need a locking program to secure
56X sessions.
57
58%{gldesc}
59
60%description
61xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
62X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
63セスできないようにします.
64
65%{gldescja}
66
67%prep
68%setup -q -n %{orgname}-%{version}
69%patch0 -p1 -b .sounddir
70
71cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
72cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
73cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
74cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
75cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
76cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
77
78%build
79#autoconf-2.13
80
81%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
82%define glflag %{?withgl:--with-mesa --with-gltt}
83
84#%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
85#    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
86#    --with-esound %{glflag} %{nglflag}
87
88%configure --without-motif --without-gtk --without-gtk2 --enable-pam --with-esound %{glflag} %{nglflag}
89
90make
91
92# recompile xlockgen for each architecture
93make -C etc/genlauncher xlockgen
94
95%install
96rm -rf %{buildroot}
97mkdir -p %{buildroot}/etc/pam.d
98#%%makeinstall \
99#       exec_prefix=%{buildroot}/usr/X11R6/ \
100#       bindir=%{buildroot}/usr/X11R6/bin \
101#       mandir=%{buildroot}/usr/X11R6/man/man1 \
102#       xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  \
103#       INSTPGMFLAGS="-m 755"
104
105%makeinstall \
106        mandir=%{buildroot}%{_mandir}/man1 \
107        xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/  \
108        INSTPGMFLAGS="-m 755"
109
110install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
111
112mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
113install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
114
115(cd etc
116sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
117mv xlock.tcl.new xlock.tcl
118# chmod +x xlock.tcl
119)
120
121# eliminate executable bit in %doc
122find etc/ -type f -perm +111 | xargs -r chmod -x
123
124%clean
125rm -rf %{buildroot}
126
127%files
128%defattr(-,root,root)
129%doc README docs/ etc/
130%attr(4111,root,root)%{_bindir}/xlock
131%config %{_sysconfdir}/pam.d/xlock
132%config %{_datadir}/X11/app-defaults/XLock
133%{_datadir}/sounds/xlockmore/
134%{_mandir}/man1/xlock.*
135
136%changelog
137* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.32-1
138- new upstream release
139- add Requires: xorg-x11-jpfonts
140- add BuildRequires: gtk2-devel
141
142* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.31-2
143- changed Group to User Interface/X
144- added Japanese summary
145
146* Sun Jul 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.31-1
147- new upstream release
148
149* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.29.1-3
150- rebuilt with ftgl-2.1.3-1.rc5
151
152* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
153- add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
154- fix xlock.pamd (required pam_unix.so -> include system-auth)
155
156* Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
157- new upstream release
158- add configure option: --without-gtk2
159- add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
160- fixed xlock.pamd (pam_stack.so -> pam_unix.so)
161- comment out: autoconf-2.13
162
163* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
164- applied new versioning policy, spec in utf-8
165- fixed autoconf version
166- modified install directories
167
168* Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
169- updated to current stable release 5.03
170- use %%configure, %%makeinstall
171- added patch for DEFALUT_SOUND_DIR
172
173* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
174- typo fixed: --without-mesagl -> --without-mesa
175
176* Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
177- add Conflicts tag
178
179* Fri Aug 17 2001 <sagami@vinelinux.org>
180- 5.01.2-0vl1: bump up release
181
182* Wed Jul 18 2001 <sagami@vinelinux.org>
183- 5.01.2-0vl0: updated to current stable release 5.01.2
184
185* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
186- bug fix for withgl option
187
188* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
189- bug fix in Provides for withgl
190- build with gle
191
192* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
193- added switch withgl
194
195* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
196- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
197  for each architecture (to resolve unmet dependency)
198
199* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
200- 4.17.2-0vl4
201- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
202
203* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
204- build on gcc-2.95.3
205- partialy used rpmmacros
206
207* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
208- change filedepend to package name depend
209
210* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
211- 4.17.2-0vl1
212
213* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
214- 4.17.1-0vl1
215- upgrade and build without GL
216- added docs etc
217
218* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
219- wmconfig gone.
220
221* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
222- handle compressed man pages
223
224* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
225- fun with GL
226
227* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
228- update to 4.15
229
230* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
231- update to 4.13.1
232
233* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
234- auto rebuild in the new build environment (release 2)
235
236* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
237- update to 4.12
238
239* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
240- take out some modules to avoid TMv
241
242* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
243- turned PAM support on in ./configure
244
245* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
246- Upgraded to 4.11
247
248* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
249- translations modified for de, fr, tr
250
251* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
252- upgraded to 4.09
253- removed Michael's PAM patch (it's now available in the sources)
254
255* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
256- upgrade to 4.05
257- add wmconfig
258
259* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
260- Upgraded to 4.04
261- Changed pam to new conventions
262- Use configure instead of imake
263- buildroot
264
265* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
266- built against glibc
267
268* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
269- moved from pam.conf to pam.d
270
Note: See TracBrowser for help on using the repository browser.