source: projects/specs/trunk/x/xlockmore/xlockmore-vl.spec @ 9340

Revision 9340, 8.2 KB checked in by Takemikaduchi, 9 years ago (diff)

atkmm,pangomm,automake112: rebuild
others: new upstream release

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.45
9%define release 1%{?_dist_release}
10
11Summary: An X terminal locking program.
12Summary(ja): X 端末をロックするためのプログラム
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: MIT
17Group: User Interface/X
18URL: http://www.tux.org/~bagleyd/xlockmore.html
19Source0: http://www.tux.org/~bagleyd/xlock/xlockmore-%{version}/xlockmore-%{version}.tar.bz2
20Source1: m-redhat.xpm
21Source2: m-redhat.xbm
22Source3: s-redhat.xpm
23Source4: s-redhat.xbm
24Source5: xlock.pamd
25Patch0: xlockmore-5.02-sounddir.patch
26BuildRequires: esound-devel, audiofile-devel
27Requires: pam >= 0.59, esound, audiofile, fortune-mod
28Requires: xorg-x11-jpfonts
29BuildRequires: flex
30BuildRequires: pam-devel
31BuildRequires: libX11-devel
32BuildRequires: libXt-devel
33BuildRequires: libXinerama-devel
34BuildRequires: libXext-devel
35%{?withgl:BuildRequires: libGLU-devel}
36%{?withgl:Provides: xlockmore}
37BuildRequires: gtk2-devel
38
39Conflicts: %{orgname}%{!?withgl:_gl}
40Buildroot: %{_tmppath}/%{name}-%{version}-root
41
42Vendor: Project Vine
43Distribution: Vine Linux
44
45%define gldesc %{?withgl:This package has MesaGL feature.}
46
47%define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
48
49%description
50The xlockmore utility is an enhanced version of the standard xlock
51program, which allows you to lock an X session so that other users
52can't access it.  Xlockmore runs a provided screensaver until you type
53in your password.
54
55Install the xlockmore package if you need a locking program to secure
56X sessions.
57
58%{gldesc}
59
60%description
61xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
62X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
63セスできないようにします.
64
65%{gldescja}
66
67%prep
68%setup -q -n %{orgname}-%{version}
69%patch0 -p1 -b .sounddir
70
71cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
72cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
73cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
74cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
75cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
76cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
77
78sed -i 's|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG)|XLOCKLDFLAGS = @XLOCKLDFLAGS@ $(CHECKLDFLAG) -laudiofile|' modes/Makefile.in
79
80%build
81#autoconf-2.13
82
83%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
84%define glflag %{?withgl:--with-mesa --with-gltt}
85
86#%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
87#    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
88#    --with-esound %{glflag} %{nglflag}
89
90%configure --without-motif --without-gtk --without-gtk2 --enable-pam --with-esound %{glflag} %{nglflag}
91
92make
93
94# recompile xlockgen for each architecture
95make -C etc/genlauncher xlockgen
96
97%install
98rm -rf %{buildroot}
99mkdir -p %{buildroot}/etc/pam.d
100#%%makeinstall \
101#       exec_prefix=%{buildroot}/usr/X11R6/ \
102#       bindir=%{buildroot}/usr/X11R6/bin \
103#       mandir=%{buildroot}/usr/X11R6/man/man1 \
104#       xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  \
105#       INSTPGMFLAGS="-m 755"
106
107%makeinstall \
108        mandir=%{buildroot}%{_mandir}/man1 \
109        xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/  \
110        INSTPGMFLAGS="-m 755"
111
112install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
113
114mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
115install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
116
117(cd etc
118sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
119mv xlock.tcl.new xlock.tcl
120# chmod +x xlock.tcl
121)
122
123# eliminate executable bit in %doc
124find etc/ -type f -perm +111 | xargs -r chmod -x
125
126%clean
127rm -rf %{buildroot}
128
129%files
130%defattr(-,root,root)
131%doc README docs/ etc/
132%attr(4111,root,root)%{_bindir}/xlock
133%config %{_sysconfdir}/pam.d/xlock
134%config %{_datadir}/X11/app-defaults/XLock
135%{_datadir}/sounds/xlockmore/
136%{_mandir}/man1/xlock.*
137
138%changelog
139* Sun Feb 08 2015 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.45-1
140- new upstream release
141
142* Thu Dec 30 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.32-1
143- new upstream release
144- add Requires: xorg-x11-jpfonts
145- add BuildRequires: gtk2-devel
146
147* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.31-2
148- changed Group to User Interface/X
149- added Japanese summary
150
151* Sat Jul 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.31-1
152- new upstream release
153
154* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.29.1-3
155- rebuilt with ftgl-2.1.3-1.rc5
156
157* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
158- add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
159- fix xlock.pamd (required pam_unix.so -> include system-auth)
160
161* Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
162- new upstream release
163- add configure option: --without-gtk2
164- add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
165- fixed xlock.pamd (pam_stack.so -> pam_unix.so)
166- comment out: autoconf-2.13
167
168* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
169- applied new versioning policy, spec in utf-8
170- fixed autoconf version
171- modified install directories
172
173* Wed Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
174- updated to current stable release 5.03
175- use %%configure, %%makeinstall
176- added patch for DEFALUT_SOUND_DIR
177
178* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
179- typo fixed: --without-mesagl -> --without-mesa
180
181* Sat Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
182- add Conflicts tag
183
184* Fri Aug 17 2001 <sagami@vinelinux.org>
185- 5.01.2-0vl1: bump up release
186
187* Wed Jul 18 2001 <sagami@vinelinux.org>
188- 5.01.2-0vl0: updated to current stable release 5.01.2
189
190* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
191- bug fix for withgl option
192
193* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
194- bug fix in Provides for withgl
195- build with gle
196
197* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
198- added switch withgl
199
200* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
201- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
202  for each architecture (to resolve unmet dependency)
203
204* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
205- 4.17.2-0vl4
206- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
207
208* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
209- build on gcc-2.95.3
210- partialy used rpmmacros
211
212* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
213- change filedepend to package name depend
214
215* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
216- 4.17.2-0vl1
217
218* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
219- 4.17.1-0vl1
220- upgrade and build without GL
221- added docs etc
222
223* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
224- wmconfig gone.
225
226* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
227- handle compressed man pages
228
229* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
230- fun with GL
231
232* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
233- update to 4.15
234
235* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
236- update to 4.13.1
237
238* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
239- auto rebuild in the new build environment (release 2)
240
241* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
242- update to 4.12
243
244* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
245- take out some modules to avoid TMv
246
247* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
248- turned PAM support on in ./configure
249
250* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
251- Upgraded to 4.11
252
253* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
254- translations modified for de, fr, tr
255
256* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
257- upgraded to 4.09
258- removed Michael's PAM patch (it's now available in the sources)
259
260* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
261- upgrade to 4.05
262- add wmconfig
263
264* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
265- Upgraded to 4.04
266- Changed pam to new conventions
267- Use configure instead of imake
268- buildroot
269
270* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
271- built against glibc
272
273* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
274- moved from pam.conf to pam.d
275
Note: See TracBrowser for help on using the repository browser.