source: projects/specs/trunk/x/xlockmore/xlockmore-vl.spec @ 1713

Revision 1713, 7.8 KB checked in by inagaki, 14 years ago (diff)

update: libflashsupport, libmediainfo, libzen, nspluginswrapper, xlockmore

Line 
1%define orgname xlockmore
2
3# if you want to make kterm_plus version,
4# uncomment below line, or rpm --define withgl:1
5# % define withgl 1
6
7%define name %{orgname}%{?withgl:_gl}
8%define version 5.31
9%define release 2%{?_dist_release}
10
11Summary: An X terminal locking program.
12Summary(ja): X 端末をロックするためのプログラム
13Name: %{name}
14Version: %{version}
15Release: %{release}
16License: MIT
17Group: User Interface/X
18URL: http://www.tux.org/~bagleyd/xlockmore.html
19Source0: ftp://ftp.tux.org/pub/tux/bagleyd/xlockmore/xlockmore-%{version}.tar.bz2
20Source1: m-redhat.xpm
21Source2: m-redhat.xbm
22Source3: s-redhat.xpm
23Source4: s-redhat.xbm
24Source5: xlock.pamd
25Patch0: xlockmore-5.02-sounddir.patch
26BuildRequires: esound-devel, audiofile-devel
27Requires: pam >= 0.59, esound, audiofile, fortune-mod
28BuildRequires: flex
29BuildRequires: pam-devel
30BuildRequires: libX11-devel
31BuildRequires: libXt-devel
32BuildRequires: libXinerama-devel
33BuildRequires: libXext-devel
34%{?withgl:Requires: Mesa, gle}
35%{?withgl:BuildPreReq: Mesa-devel, gle-devel}
36%{?withgl:Provides: xlockmore}
37Conflicts: %{orgname}%{!?withgl:_gl}
38Buildroot: %{_tmppath}/%{name}-%{version}-root
39
40Vendor: Project Vine
41Distribution: Vine Linux
42
43%define gldesc %{?withgl:This package has MesaGL feature.}
44
45%define gldescja %{?withgl:このパッケージは MesaGL 対応になっています.}
46
47%description
48The xlockmore utility is an enhanced version of the standard xlock
49program, which allows you to lock an X session so that other users
50can't access it.  Xlockmore runs a provided screensaver until you type
51in your password.
52
53Install the xlockmore package if you need a locking program to secure
54X sessions.
55
56%{gldesc}
57
58%description
59xlockmore は 標準的な xlock の機能拡張版です.あなたが席をはずすときに
60X セッションをロックし,あなたがパスワードを入力するまで他の人がアク
61セスできないようにします.
62
63%{gldescja}
64
65%prep
66%setup -q -n %{orgname}-%{version}
67%patch0 -p1 -b .sounddir
68
69cp %{_sourcedir}/m-redhat.xpm pixmaps/m-redhat.xpm
70cp %{_sourcedir}/m-redhat.xbm bitmaps/m-redhat.xbm
71cp %{_sourcedir}/m-redhat.xpm pixmaps/l-redhat.xpm
72cp %{_sourcedir}/m-redhat.xbm bitmaps/l-redhat.xbm
73cp %{_sourcedir}/s-redhat.xpm pixmaps/s-redhat.xpm
74cp %{_sourcedir}/s-redhat.xbm bitmaps/s-redhat.xbm
75
76%build
77#autoconf-2.13
78
79%define nglflag %{!?withgl:--without-opengl --without-mesa --without-gltt}
80%define glflag %{?withgl:--with-mesa --with-gltt}
81
82#%configure --prefix=/usr --exec-prefix=/usr/X11R6/ --bindir=/usr/X11R6/bin \
83#    --mandir=/usr/X11R6/man/man1  --without-motif --without-gtk --enable-pam \
84#    --with-esound %{glflag} %{nglflag}
85%configure --without-motif --without-gtk --without-gtk2 --enable-pam --with-esound %{glflag} %{nglflag}
86
87make
88
89# recompile xlockgen for each architecture
90make -C etc/genlauncher xlockgen
91
92%install
93rm -rf %{buildroot}
94mkdir -p %{buildroot}/etc/pam.d
95#%%makeinstall \
96#       exec_prefix=%{buildroot}/usr/X11R6/ \
97#       bindir=%{buildroot}/usr/X11R6/bin \
98#       mandir=%{buildroot}/usr/X11R6/man/man1 \
99#       xapploaddir=%{buildroot}/usr/X11R6/lib/X11/app-defaults/  \
100#       INSTPGMFLAGS="-m 755"
101
102%makeinstall \
103        mandir=%{buildroot}%{_mandir}/man1 \
104        xapploaddir=%{buildroot}%{_datadir}/X11/app-defaults/  \
105        INSTPGMFLAGS="-m 755"
106
107install -m 644 %{_sourcedir}/xlock.pamd %{buildroot}/etc/pam.d/xlock
108
109mkdir -p %{buildroot}%{_datadir}/sounds/xlockmore/
110install -m 644 -p sounds/*.au %{buildroot}%{_datadir}/sounds/xlockmore/
111
112(cd etc
113sed -e 's|/usr/X11/bin/wish|/usr/bin/wish|g' xlock.tcl > xlock.tcl.new
114mv xlock.tcl.new xlock.tcl
115# chmod +x xlock.tcl
116)
117
118# eliminate executable bit in %doc
119find etc/ -type f -perm +111 | xargs -r chmod -x
120
121%clean
122rm -rf %{buildroot}
123
124%files
125%defattr(-,root,root)
126%doc README docs/ etc/
127%attr(4111,root,root)%{_bindir}/xlock
128%config %{_sysconfdir}/pam.d/xlock
129%config %{_datadir}/X11/app-defaults/XLock
130%{_datadir}/sounds/xlockmore/
131%{_mandir}/man1/xlock.*
132
133%changelog
134* Sun Aug 29 2010 Ryoichi INAGAKI <ryo1@bc.wakwak.com> 5.31-2
135- changed Group to User Interface/X
136- added Japanese summary
137
138* Sun Jul 31 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.31-1
139- new upstream release
140
141* Sat May 29 2010 MATSUBAYASHI Kohji <shaolin@vinelinux.org> - 5.29.1-3
142- rebuilt with ftgl-2.1.3-1.rc5
143
144* Mon Jan 11 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-2
145- add BuildRequires: libXinerama-devel, libXext-devel (for Vine Linux 5.0)
146- fix xlock.pamd (required pam_unix.so -> include system-auth)
147
148* Sat Jan 02 2010 Yoji TOYODA <bsyamato@sea.plala.or.jp> 5.29.1-1
149- new upstream release
150- add configure option: --without-gtk2
151- add BuildRequires: flex, pam-devel, libX11-devel, libXt-devel
152- fixed xlock.pamd (pam_stack.so -> pam_unix.so)
153- comment out: autoconf-2.13
154
155* Wed Oct 15 2008 Shu KONNO <owa@bg.wakwak.com> 5.03-1vl5
156- applied new versioning policy, spec in utf-8
157- fixed autoconf version
158- modified install directories
159
160* Tue Jan 30 2002 Toru Sagami <sagami@vinelinux.org> 5.03-0vl1
161- updated to current stable release 5.03
162- use %%configure, %%makeinstall
163- added patch for DEFALUT_SOUND_DIR
164
165* Tue Sep 04 2001 MATSUBAYASHI Kohji <shaolin@vinelinux.org> 5.01.2-0vl3
166- typo fixed: --without-mesagl -> --without-mesa
167
168* Sun Aug 18 2001 MATSUBAYASHI 'Shaolin' Kohji <shaolin@vinelinux.org>
169- add Conflicts tag
170
171* Fri Aug 17 2001 <sagami@vinelinux.org>
172- 5.01.2-0vl1: bump up release
173
174* Wed Jul 18 2001 <sagami@vinelinux.org>
175- 5.01.2-0vl0: updated to current stable release 5.01.2
176
177* Mon Apr  2 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl8
178- bug fix for withgl option
179
180* Wed Mar 28 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl7
181- bug fix in Provides for withgl
182- build with gle
183
184* Tue Mar 27 2001 Jun Nishii <jun@vinelinux.org> 4.17.2-0vl6
185- added switch withgl
186
187* Mon Jan 22 2001 Tomoya TAKA <tomoya@olive.plala.or.jp> 4.17.2-0vl5
188- recompile %%{_docdir}/xlockmore-%{version}/etc/genlauncher/xlockgen
189  for each architecture (to resolve unmet dependency)
190
191* Sat Jan 20 2001 Toru Sagami <czs14350@mb.infoweb.ne.jp>
192- 4.17.2-0vl4
193- eliminate executable bit in %doc (requierment for /bin/ksh etc.)
194
195* Sun Nov 12 2000 MACHINO, Satoshi <machino@vinelinux.org> 4.17.2-0vl3
196- build on gcc-2.95.3
197- partialy used rpmmacros
198
199* Tue Nov  7 2000 Kazuhisa TAKEI <takei@vinelinux.org> 4.17.2-0vl2
200- change filedepend to package name depend
201
202* Sat Sep  2 2000 Jun Nishii <jun@vinelinux.org>
203- 4.17.2-0vl1
204
205* Fri Sep  1 2000 Jun Nishii <jun@vinelinux.org>
206- 4.17.1-0vl1
207- upgrade and build without GL
208- added docs etc
209
210* Wed Feb 09 2000 Preston Brown <pbrown@redhat.com>
211- wmconfig gone.
212
213* Thu Feb  3 2000 Bill Nottingham <notting@redhat.com>
214- handle compressed man pages
215
216* Fri Jan 14 2000 Bill Nottingham <notting@redhat.com>
217- fun with GL
218
219* Tue Nov  9 1999 Bill Nottingham <notting@redhat.com>
220- update to 4.15
221
222* Mon Jun 14 1999 Bill Nottingham <notting@redhat.com>
223- update to 4.13.1
224
225* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
226- auto rebuild in the new build environment (release 2)
227
228* Fri Dec 18 1998 Bill Nottingham <notting@redhat.com>
229- update to 4.12
230
231* Tue Oct 13 1998 Cristian Gafton <gafton@redhat.com>
232- take out some modules to avoid TMv
233
234* Fri Sep 18 1998 Bill Nottingham <notting@redhat.com>
235- turned PAM support on in ./configure
236
237* Fri Sep 11 1998 Preston Brown <pbrown@redhat.com>
238- Upgraded to 4.11
239
240* Fri Apr 24 1998 Prospector System <bugs@redhat.com>
241- translations modified for de, fr, tr
242
243* Sat Apr 11 1998 Donnie Barnes <djb@redhat.com>
244- upgraded to 4.09
245- removed Michael's PAM patch (it's now available in the sources)
246
247* Thu Oct 23 1997 Marc Ewing <marc@redhat.com>
248- upgrade to 4.05
249- add wmconfig
250
251* Mon Oct 13 1997 Michael K. Johnson <johnsonm@redhat.com>
252- Upgraded to 4.04
253- Changed pam to new conventions
254- Use configure instead of imake
255- buildroot
256
257* Mon Jul 21 1997 Erik Troan <ewt@redhat.com>
258- built against glibc
259
260* Mon Mar 03 1997 Michael K. Johnson <johnsonm@redhat.com>
261- moved from pam.conf to pam.d
262
Note: See TracBrowser for help on using the repository browser.