source: projects/specs/trunk/x/xl2tpd/xl2tpd-vl.spec @ 8331

Revision 8331, 14.3 KB checked in by tomop, 10 years ago (diff)

xl2tpd-1.3.6-1

Line 
1%define src_dir_name xl2tpd-%{version}
2
3Summary: Layer 2 Tunnelling Protocol Daemon (RFC 2661)
4Name: xl2tpd
5Version: 1.3.6
6Release: 1%{?_dist_release}
7# No version specified.
8License: GPL+
9Url: http://www.xelerance.com/software/xl2tpd/
10Group: System Environment/Daemons
11# https://github.com/xelerance/xl2tpd/archive/v%{version}.tar.gz
12Source0: xl2tpd-%{version}.tar.gz
13BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
14Requires: ppp
15BuildRequires: libpcap-devel
16BuildRequires: openssl-devel
17Requires(post): /sbin/chkconfig
18Requires(preun): /sbin/chkconfig
19Requires(preun): /sbin/service
20
21Vendor: Project Vine
22Distribution: Vine Linux
23Packager: tomop
24
25%description
26xl2tpd is an implementation of the Layer 2 Tunnelling Protocol (RFC 2661).
27L2TP allows you to tunnel PPP over UDP. Some ISPs use L2TP to tunnel user
28sessions from dial-in servers (modem banks, ADSL DSLAMs) to back-end PPP
29servers. Another important application is Virtual Private Networks where
30the IPsec protocol is used to secure the L2TP connection (L2TP/IPsec,
31RFC 3193). The L2TP/IPsec protocol is mainly used by Windows and
32Mac OS X clients. On Linux, xl2tpd can be used in combination with IPsec
33implementations such as Openswan.
34Example configuration files for such a setup are included in this RPM.
35
36xl2tpd works by opening a pseudo-tty for communicating with pppd.
37It runs completely in userspace.
38
39xl2tpd supports IPsec SA Reference tracking to enable overlapping internak
40NAT'ed IP's by different clients (eg all clients connecting from their
41linksys internal IP 192.168.1.101) as well as multiple clients behind
42the same NAT router.
43
44xl2tpd supports the pppol2tp kernel mode operations on 2.6.23 or higher,
45or via a patch in contrib for 2.4.x kernels.
46
47Xl2tpd is based on the 0.69 L2TP by Jeff McAdams <jeffm@iglou.com>
48It was de-facto maintained by Jacco de Leeuw <jacco2@dds.nl> in 2002 and 2003.
49
50%prep
51%setup -q -n %{src_dir_name}
52
53%build
54make DFLAGS="$RPM_OPT_FLAGS -g -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_FLOW -DDEBUG_PAYLOAD -DDEBUG_CONTROL -DDEBUG_CONTROL_XMIT -DDEBUG_FLOW_MORE -DDEBUG_MAGIC -DDEBUG_ENTROPY -DDEBUG_HIDDEN -DDEBUG_PPPD -DDEBUG_AAA -DDEBUG_FILE -DDEBUG_FLOW -DDEBUG_HELLO -DDEBUG_CLOSE -DDEBUG_ZLB -DDEBUG_AUTH"
55
56%install
57rm -rf %{buildroot}
58make DESTDIR=%{buildroot} PREFIX=%{_prefix} install
59install -p -D -m644 examples/xl2tpd.conf %{buildroot}%{_sysconfdir}/xl2tpd/xl2tpd.conf
60install -p -D -m644 examples/ppp-options.xl2tpd %{buildroot}%{_sysconfdir}/ppp/options.xl2tpd
61install -p -D -m600 doc/l2tp-secrets.sample %{buildroot}%{_sysconfdir}/xl2tpd/l2tp-secrets
62install -p -D -m600 examples/chapsecrets.sample %{buildroot}%{_sysconfdir}/ppp/chap-secrets.sample
63install -p -D -m755 packaging/fedora/xl2tpd.init %{buildroot}%{_initrddir}/xl2tpd
64install -p -D -m755 -d %{buildroot}%{_localstatedir}/run/xl2tpd
65
66
67%clean
68rm -rf %{buildroot}
69
70%post
71/sbin/chkconfig --add xl2tpd
72
73%preun
74if [ $1 -eq 0 ]; then
75  /sbin/service xl2tpd stop > /dev/null 2>&1
76  /sbin/chkconfig --del xl2tpd
77fi
78
79%postun
80if [ $1 -ge 1 ]; then
81  /sbin/service xl2tpd condrestart 2>&1 >/dev/null
82fi
83
84%files
85%defattr(-,root,root)
86%doc BUGS CHANGES CREDITS LICENSE README.* TODO doc/rfc2661.txt
87%doc doc/README.patents examples/chapsecrets.sample
88%{_sbindir}/xl2tpd
89%{_sbindir}/xl2tpd-control
90%{_bindir}/pfc
91%{_mandir}/*/*
92%dir %{_sysconfdir}/xl2tpd
93%config(noreplace) %{_sysconfdir}/xl2tpd/*
94%config(noreplace) %{_sysconfdir}/ppp/*
95%attr(0755,root,root)  %{_initrddir}/xl2tpd
96%dir %{_localstatedir}/run/xl2tpd
97%ghost %attr(0600,root,root) %{_localstatedir}/run/xl2tpd/l2tp-control
98
99%changelog
100* Wed Apr  2 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.6-1
101- new upstream release.
102
103* Sun Jan 05 2014 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.3-1
104- new upstream release.
105
106* Sat Sep 29 2012 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.1-1
107- new upstream release.
108
109* Fri Sep 16 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.3.0-1
110- new upstream release.
111
112* Fri Apr 22 2011 Tomohiro "Tomo-p" KATO <tomop@teamgedoh.net> 1.2.8-2
113- built for Vine Linux.
114
115* Wed Feb 23 2011 Paul Wouters <paul@xelerance.com> - 1.2.8-1
116- Updated to 1.2.8
117- Add ghosting for l2tp pipe (bz#656725)
118
119* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.7-3
120- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
121
122* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-2
123- fix md5 of init script in sources
124
125* Tue Nov 30 2010 Paul Wouters <paul@xelerance.com> - 1.2.7-1
126- Updated to 1.2.7
127- Added more DEBUG build options to the make command
128- Minor cleanups
129
130* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-2
131- Bump for EVR
132
133* Sat Jan 09 2010 Paul Wouters <paul@xelerance.com> - 1.2.5-1
134- Upgraded to 1.2.5. (fixes interop with two Windows machines behind same NAT)
135- Fix mix space/tab in spec file
136- Added missing keyword Default-Stop
137
138* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.4-4
139- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
140
141* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-3
142- Bump version for tagging mistake
143
144* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-2
145-Fix initscript for https://bugzilla.redhat.com/show_bug.cgi?id=247100
146
147* Sun Mar 08 2009 Paul Wouters <paul@xelerance.com> - 1.2.4-1
148- Upgraded to 1.2.4
149- Merged spec file with upstream
150
151* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2.0-2
152- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
153
154* Thu Oct  9 2008 Paul Wouters <paul@xelerance.com> - 1.2.0-1
155- Updated to new upstream release
156
157* Sat Sep  6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.1.12-3
158- fix license tag
159
160* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.1.12-2
161- Autorebuild for GCC 4.3
162
163* Fri Oct 26 2007 Paul Wouters <paul@xelerance.com> 1.1.12-1
164- Upgraded to new release upstream
165- Removed l2tpd to xl2tpd migration in post
166
167* Wed Aug 29 2007 Fedora Release Engineering <rel-eng at fedoraproject dot org> - 1.1.11-3
168- Rebuild for selinux ppc32 issue.
169
170* Sat Jul 28 2007 Paul Wouters <paul@xelerance.com> 1.1.11-2
171- Upgraded to 1.1.11
172- Include new split README.*
173
174* Mon Mar 19 2007 Paul Wouters <paul@xelerance.com> 1.1.09-1
175- Upgraded to 1.1.09
176
177* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-2
178- Bump for EVR
179
180* Fri Feb 23 2007 Paul Wouters <paul@xelerance.com> 1.1.08-1
181- Upgraded to 1.1.08
182- This works around the ppp-2.4.2-6.4 issue of not dying on SIGTERM
183
184* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-2
185- Fixed version usage in source macro
186
187* Tue Feb 20 2007 Paul Wouters <paul@xelerance.com> 1.1.07-1
188- Upgraded to 1.1.07
189- Added /var/run/xl2tpd to the spec file so this pacakge
190  owns /var/run/xl2tpd
191 
192* Thu Dec  7 2006 Paul Wouters <paul@xelerance.com> 1.1.06-5
193- Changed space/tab replacing method
194
195* Wed Dec  6 2006 Paul Wouters <paul@xelerance.com> 1.1.06-4
196- Added -p to keep original timestamps
197- Added temporary hack to change space/tab in init file.
198- Added /sbin/service dependancy
199
200* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-3
201- Added Requires(post) / Requires(preun)
202- changed init file to create /var/run/xl2tpd fixed a tab/space
203- changed control file to be within /var/run/xl2tpd/
204
205* Tue Dec  5 2006 Paul Wouters <paul@xelerance.com> 1.1.06-2
206- Changed Mr. Karlsen's name to not be a utf8 problem
207- Fixed Obosoletes/Provides to be more specific wrt l2tpd.
208- Added dist tag which accidentally got deleted.
209
210* Mon Dec  4 2006 Paul Wouters <paul@xelerance.com> 1.1.06-1
211- Rebased spec file on Fedora Extras copy, but using xl2tpd as package name
212
213* Sun Nov 27 2005 Paul Wouters <paul@xelerance.com> 0.69.20051030
214- Pulled up sourceforget.net CVS fixes.
215- various debugging added, but debugging should not be on by default.
216- async/sync conversion routines must be ready for possibility that the read
217  will block due to routing loops.
218- refactor control socket handling.
219- move all logic about pty usage to pty.c. Try ptmx first, if it fails try
220  legacy ptys
221- rename log() to l2tp_log(), as "log" is a math function.
222- if we aren't deamonized, then log to stderr.
223- added install: and DESTDIR support.
224
225* Thu Oct 20 2005 Paul Wouters <paul@xelerance.com> 0.69-13
226- Removed suse/mandrake specifics. Comply for Fedora Extras guidelines
227
228* Tue Jun 21 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-12jdl
229- Added log() patch by Paul Wouters so that l2tpd compiles on FC4.
230
231* Sat Jun 4 2005 Jacco de Leeuw <jacco2@dds.nl>
232- l2tpd.org has been hijacked. Project moved back to SourceForge:
233  http://l2tpd.sourceforge.net
234
235* Tue May 3 2005 Jacco de Leeuw <jacco2@dds.nl>
236- Small Makefile fixes. Explicitly use gcc instead of cc.
237  Network services library was not linked on Solaris due to typo.
238
239* Thu Mar 17 2005 Jacco de Leeuw <jacco2@dds.nl> 0.69-11jdl
240- Choosing between SysV or BSD style ptys is now configurable through
241  a compile-time boolean "unix98pty".
242
243* Fri Feb 4 2005 Jacco de Leeuw <jacco2@dds.nl>
244- Added code from Roaring Penguin (rp-l2tp) to support SysV-style ptys.
245  Requires the N_HDLC kernel module.
246
247* Fri Nov 26 2004 Jacco de Leeuw <jacco2@dds.nl>
248- Updated the README.
249
250* Wed Nov 10 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
251- Patch by Marald Klein and Roger Luethi. Fixes writing PID file.
252  (http://l2tpd.graffl.net/msg01790.html)
253  Long overdue. Rereleasing 10jdl.
254
255* Tue Nov 9 2004 Jacco de Leeuw <jacco2@dds.nl> 0.69-10jdl
256- [SECURITY FIX] Added fix from Debian because of a bss-based
257  buffer overflow.
258  (http://www.mail-archive.com/l2tpd-devel@l2tpd.org/msg01071.html)
259- Mandrake's FreeS/WAN, Openswan and Strongswan RPMS use configuration
260  directories /etc/{freeswan,openswan,strongswan}. Install our
261  configuration files to /etc/ipsec.d and create symbolic links in
262  those directories.
263
264* Wed Aug 18 2004 Jacco de Leeuw <jacco2@dds.nl>
265- Removed 'leftnexthop=' lines. Not relevant for recent versions
266  of FreeS/WAN and derivates.
267
268* Tue Jan 20 2004 Jacco de Leeuw <jacco2@dds.nl>  0.69-9jdl
269- Added "noccp" because of too much MPPE/CCP messages sometimes.
270
271* Wed Dec 31 2003 Jacco de Leeuw <jacco2@dds.nl>
272- Added patch in order to prevent StopCCN messages.
273
274* Sat Aug 23 2003 Jacco de Leeuw <jacco2@dds.nl>
275- MTU/MRU 1410 seems to be the lowest possible for MSL2TP.
276  For Windows 2000/XP it doesn't seem to matter.
277- Typo in l2tpd.conf (192.168.128/25).
278
279* Fri Aug 8 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-8jdl
280- Added MTU/MRU 1400 to options.l2tpd. I don't know the optimal
281  value but some apps had problems with the default value.
282
283* Fri Aug 1 2003 Jacco de Leeuw <jacco2@dds.nl>
284- Added workaround for the missing hostname bug in the MSL2TP client
285  ('Specify your hostname', error 629: "You have been disconnected
286  from the computer you are dialing").
287
288* Sun Jul 20 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-7jdl
289- Added the "listen-addr" global parameter for l2tpd.conf. By
290  default, the daemon listens on *all* interfaces. Use
291  "listen-addr" if you want it to bind to one specific
292  IP address (interface), for security reasons. (See also:
293  http://www.jacco2.dds.nl/networking/freeswan-l2tp.html#Firewallwarning)
294- Explained in l2tpd.conf that two different IP addresses should be
295  used for 'listen-addr' and 'local ip'.
296- Modified init script. Upgrades should work better now. You
297  still need to start/chkconfig l2tpd manually.
298- Renamed the example Openswan .conf files to better reflect
299  the situation. There are two variants using different portselectors.
300  Previously I thought Windows 2000/XP used portselector 17/0
301  and the rest used 17/1701. But with the release of an updated
302  IPsec client by Microsoft, it turns out that 17/0 must have
303  been a mistake: the updated client now also uses 17/1701.
304
305* Thu Apr 10 2003 Jacco de Leeuw <jacco2@dds.nl>  0.69-6jdl
306- Changed sample chap-secrets to be valid only for specific
307  IP addresses.
308
309* Thu Mar 13 2003 Bernhard Thoni <tech-role@tronicplanet.de>
310- Adjustments for SuSE8.x (thanks, Bernhard!)
311- Added sample chap-secrets.
312
313* Thu Mar 6 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-5jdl
314- Replaced Dominique's patch by Damion de Soto's, which does not
315  depend on the N_HDLC kernel module.
316
317* Wed Feb 26 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-4jdl
318- Seperate example config files for Win9x (MSL2TP) and Win2K/XP
319  due to left/rightprotoport differences.
320  Fixing preun for Red Hat.
321
322* Mon Feb 3 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
323- Mandrake uses /etc/freeswan/ instead of /etc/ipsec.d/
324  Error fixed: source6 was used for both PSK and CERT.
325
326* Wed Jan 29 2003 Jacco de Leeuw <jacco2@dds.nl> 0.69-3jdl
327- Added Dominique Cressatti's pty patch in another attempt to
328  prevent the Windows 2000 Professional "loopback detected" error.
329  Seems to work!
330
331* Wed Dec 25 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-2jdl
332- Added 'connect-delay' to PPP parameters in an attempt to
333  prevent the Windows 2000 Professional "loopback detected" error.
334  Didn't seem to work.
335
336* Fri Dec 13 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
337- Did not build on Red Hat 8.0. Solved by adding comments(?!).
338  Bug detected in spec file: chkconfig --list l2tpd does not work
339  on Red Hat 8.0. Not important enough to look into yet.
340
341* Sun Nov 17 2002 Jacco de Leeuw <jacco2@dds.nl> 0.69-1jdl
342- Tested on Red Hat, required some changes. No gprintf. Used different
343  pty patch, otherwise wouldn't run. Added buildroot sanity check.
344
345* Sun Nov 10 2002 Jacco de Leeuw <jacco2@dds.nl>
346- Specfile adapted from Mandrake Cooker. The original RPM can be
347  retrieved through:
348  http://www.rpmfind.net/linux/rpm2html/search.php?query=l2tpd
349- Config path changed from /etc/l2tp/ to /etc/l2tpd/
350  (Seems more logical and rp-l2tp already uses /etc/l2tp/).
351- Do not run at boot or install. The original RPM uses a config file
352  which is completely commented out, but it still starts l2tpd on all
353  interfaces. Could be a security risk. This RPM does not start l2tpd,
354  the sysadmin has to edit the config file and start l2tpd explicitly.
355- Renamed patches to start with l2tpd-
356- Added dependencies for pppd, glibc-devel.
357- Use %%{name} as much as possible.
358- l2tp-secrets contains passwords, thus should not be world readable.
359- Removed dependency on rpm-helper.
360
361* Mon Oct 21 2002 Lenny Cartier <lenny@mandrakesoft.com> 0.69-3mdk
362- from Per 0yvind Karlsen <peroyvind@delonic.no> :
363 - PreReq and Requires
364 - Fix preun_service
365
366* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-2mdk
367- Move l2tpd from /usr/bin to /usr/sbin
368- Added SysV initscript
369- Patch0
370- Patch1
371
372* Thu Oct 17 2002 Per 0yvind Karlsen <peroyvind@delonic.no> 0.69-1mdk
373- Initial release
Note: See TracBrowser for help on using the repository browser.